
mGovern – Your Mobile
Solution

Release 6.0 Version 1.0
Last Revision Update:  5/7/18



Harris Govern

mGovern – Your Mobile Solution

Version: 1.0

June 2016 - Release 6.0

Copyright © Harris Govern 1997 - 2016

All rights reserved



© 2016 Harris Govern Page iii



mGovern – Your Mobile Solution
Disclaimer

Harris Govern has taken due care in preparing this manual. However, nothing 
contained herein modifies or alters in any way the standard terms and 
conditions of the purchase, lease, or license agreement by which the product 
was acquired, nor increases in any way the liability of Harris Govern to the 
customer.
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Preface
Preface
Welcome to Govern for Windows, a comprehensive and fully integrated 
transaction-driven system written exclusively for local governments. Govern 
includes a wide variety of database modules:

Computer-Assisted Mass Appraisal (CAMA)
• Appraisals / Property Valuations 
• Comparable Sales Management

Financial Management
• Account Receivable
• Cash Collection 

Land Management
• Appeals & Grievances
• Business & Individual Licenses
• Complaint Tracking
• Leasing
• Permit Tracking & Inspection Scheduling
• Planning
• Violations

Revenue Management
• Aircraft & Boat Excise Tax
• Miscellaneous Billing
• Personal Property Tax Billing
• Real Property Tax Billing
• Self-Reported Tax Billing
• Special Assessments
• Tax Title / Tax Lien / Tax Sales
• Utility Billing

Since 1980, MS Govern, formerly PG Govern, has worked hand-in-hand with 
local and state governments to simplify the implementation of software 
solutions that automate the flow of information related to their properties.
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Chapter 1: Setting Up an mGovern 
Deployment

This section describes how to set up a deployment for the mGovern 
application. In order to do this, you need access to the Govern database on 
the office server, a second server where you can create a temporary 
database, and a mobile device.

The procedures in this section only need to be performed when you are first 
setting up an mGovern deployment. Once the setup is complete, you can 
easily install the mGovern application on any appropriate device, by clicking 
the shortcut created by Deploy EZ.

The procedures in this section are required to be performed in the order they 
are written:

1. Creating the Required Databases on page 1

2. Deploying mGovern on page 3

3. Creating a Connection Key for the Temporary Deployment on page 11

4. Initializing the Temporary Database on page 12

5. Installing the Deployment on page 14

Creating the Required Databases

The following are required for the deployment:

1. A Govern database is required to be running on a server. Typically this is 
the office server. This database is referred to as the Source Database. A 
source database can be either Oracle or Microsoft SQL 2008 or greater.

2. A database will be created on each mobile device that will be acting as a 
mGovern client. The mGovern application will be installed on each of 

Overview

WARNING: Prior to performing any installation, it is essential to perform 
a full backup of all source databases that are involved in the 
overall configuration process.
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mGovern – Your Mobile Solution
these devices. This is required because the Govern database structure is 
copied to the mobile devices when the application is installed.

3. A Temporary Database will be created on a server. The temporary 
database is required for the initial deployment and initialization processes 
and for updating the deployments. It will not be used for maintaining 
property records.

The Temporary Database can be Microsoft SQL 2008 or greater or SQL 
Express.

During the deployment, the Govern database is copied from the source 
database to the temporary database. 

Property records are copied from the source database to the Mobile database 
when you are logged in to mGovern and are performing a data transfer. Once 
records are transferred, you can perform es on the Mobile database and load, 
create, and modify records as you would on the main Govern database. When 
you have updated records, you can transfer them from the Mobile database to 
the main Govern database during the synchronization process.

Set Up Databases on the Mobile Devices

To set up the databases on the Mobile devices:

1. Log in to a Mobile device.

2. Launch SQL Server or SQL Express.

3. Create a new database and give it a name.

4. Create a new user name for the database.

5. Assign a login name and password for this user name. 

6. Select db_owner for the Default Schema and Database Role 
Membership.

7. Click Save.

8. Repeat this procedure on each Mobile device.

Note: It is important that the databases on all the mobile devices have 
the same name, for example Govern_Mobile. This name must be 
the same as the temporary database name.
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Setting Up the Temporary Database

There are multiple options for creating the temporary database. Some options 
are described in the Appendix section of this document. See Temporary 
Database Options on page 35 

To set up the temporary database:

1. Log in to the server where you are creating the temporary database.

2. Launch SQL.

3. Create a new database and give it a name.

4. Create a new user name for the temporary database. 

5. Assign a login name and password for this user.

6. Select db_owner for the Default Schema and Database Role 
Membership. 

7. Click Save.

Oracle Environment - Setting Up mGovern

The tns_admin parameter is not supported while the mGovern application is 
offline. 

This parameter determines the location of the tns administration files 

Deploying mGovern

The next step is to launch Govern Deploy EZ and create the mGovern 
Deployment.

Note: It is important that the temporary database and the databases on 
the mobile devices have the same name, for example 
Govern_Mobile.

Note: This section applies to Oracle users only.
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To create the mGovern Deployment:

1. Launch Govern Deploy EZ.

2. Select Manage Deployments and click Next.

3. Enter a name for the deployment; typically, the deployment name 
describes the deployment and includes the server name and server type. 

4. Enter the deployment name in the Deployment text box.

5. Click Next.
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6. Select SQL Server 2005 or greater from the Server Type options.

7. Enter localhost in the Server drop-down list.

This name is referenced when you install the database on each mobile 
device.

8. Enter the database name in the Database text box.

Alternatively, you can select the database from the drop-down list or click 

the ellipsis button to perform a  and select the database from the  

results.

9. Enter the credentials for the Mobile database in the User ID and 
Password text boxes.

Note: Users that are using the LocalDB method should specify 
(localdb)\serverNAME as the server. Where serverNAME is the 
name of the server specified in the LocalDB instance.

TIP: User should note that at times refresh issues may occur between 
DeployEZ and SQL Server. This may arise as a result of DeployEZ 
being out of synch with SQL Server. As a result the correct Server or 
Database is not listed in the combo box when the Create a New 
Connection Key option is selected. In such instances a restart of the 
DeployEZ is recommended.
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10. Click Next.

11. Enter the name of your organization in the Organization text box.

12. Enter the serial number for your product license.

13. Click Next.

14. Select the authentication type in the Deployment Authentication text 
box. Available types are:
• Microsoft Active Directory (MSAD): Authentication is performed using 

your Windows credentials.
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• The Govern Authentication type will require a Govern user name and 
password be entered in the .

15. Click Next.

16. Select a culture to define the language and regional settings for the 
mGovern interface from the Default Culture text box.

17. Click Next.
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18. Select the Set as mobile deployment check box.

19. Click the ellipsis button and create a folder for the Mobile 
deployment.

The folder must be created on the server where the deployment is run.

20. Select the connection key to the source database on the server.
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21. Click Next.

22. Select the release version for the packages that you want to install from 
the Filter text box.

23. Select the following packages:
• Govern
• Resource Files
• System Files
• Govern Custom Control

24. Click Next.

The Progress bar indicates the progress of the installation. Each step is 
written as it is performed.
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25. Click Next when the button is enabled.

26. Click Exit to close DeployEZ.
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Creating a Connection Key for the Temporary 
Deployment

The next step is to run Govern New Administration (GNA) and create a 
connection key for the temporary deployment,

To create a connection key for the temporary deployment:

1. Launch GNA on the computer used for the temporary deployment. 

2. Select Utilities > Connection Key Management.

3. Click the New icon  to create a new connection key for the temporary 
deployment.

4. Define a name for the connection key and enter it in the Database 
Connection Key text box.

Typically, the connection key name is made up of the database name, the 
server name, and the server type, separated by underscores:

All characters in the connection key name will be forced to upper case.

DatabaseName_ServerName_DatabaseType
For example, GOVERNMOBILE_CMSDEMO_SQL
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5. Select Microsoft SQL 2005 under the Server Type options.

6. Enter the credentials for the database created for the mobile deployment 
in the User ID and Password text boxes. 

7. Leave the default settings in the Default Connection Time Out and 
Default Command Time Out text boxes.

8. Click Save . 

The connection is automatically tested. A message will 
appear to confirm that the connection was successful.

About Alternate Connection Keys

In environments where there are multiple databases, the Govern New 
Administration (GNA) can access alternate databases by creating secondary 
and tertiary connection keys. Users should note that Govern Mobile does NOT 
support the use of Alternate Connection Keys. Unlike the GNA, Govern mobile 
was designed to function with a single connection key.

Initializing the Temporary Database

The next step is to initialize the temporary database for the mGovern 
deployment. This process copies settings from the source database to the 
temporary database.

To initialize the temporary database:

1. Launch GNA on the computer used for the temporary deployment. 

2. Select Utilities > Database Utilities > Initialize Mobile Database.

This opens the Mobile Database Initialization window.
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3. In the Mobile Database Initialization > Connection Key group, select the 
connection keys that correspond with the following:

4. Select the name of the mobile deployment from the Mobile Deployment 
Name drop-down list.

5. Select the connection key to the temporary SQL database from the 
Temporary SQL Database Connection Key drop-down list.

This is the database that you created when you set up the Mobile 
Deployment. See Creating the Required Databases on page 1.

The following parameters are automatically populated based on these two 
selections:
• Mobile Deployment Connection Key
• Shared Folder for Database Files
• Source Database Connection Key

6. Select the tables to process. By default the following three tables are 
selected:

• Mass Appraisal (MA_PARM)
• Permit (PM_TYPE) 
• Tax 

7. Select the starting and ending years for the process or leave the Starting 
Year and Ending Year fields blank to process all years. When a Year 
range is specified, the tables for the selected years are copied from the 
source database to the temporary database. 
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8. Click Start .

Installing the Deployment

Running mGovern for the First Time 

When you are ready to run mGovern for the first time, connect the mobile to a 
secure Local Area Network (LAN) or high speed network. Ensure that the 
network connection is constant so that files are transferred without 
interruptions.

An automatic synchronization is performed when you launch the application.

Note: The constant LAN or high speed connection is required only the first 
time that the application is run on the mobile client. 
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Chapter 2: Using mGovern

The mGovern application has the same look and feel as the Govern 
OpenForms data entry application. The user forms are the same and you can 
update records and work in both applications in the same manner. What 
differentiates the mGovern interface from Govern is the additional features for 
transferring property records and ensuring that the data in the mobile 
database are synchronized and consistent with the data in the main Govern 
database on the office server.

The information that is specific to mGovern is displayed under the Mobile tab 
in the Ribbon, additional visual cues on the Status bar.

The following table provides an overview of the icons that are specific to 
mGovern:

Overview

Description Icon Description Icon

Connected (Ribbon) Connected (Status bar)
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This section describes the following tasks in the order that they are typically 
performed:

• Viewing Connection Status on page 17
• Viewing Error and Informational Messages on page 18
• Performing es on ing for and Loading Parcels on page 21
• Saving a Dataset and Appending Data on page 22
• Checking Out Property Records on page 26
• Transferring Parcels on Transferring Property Records on page 27
• Synchronizing Data on page 29
• Checking In Data onChecking In Data on page 32

Viewing Connection Status

The Connection Status of the mGovern application is displayed on both the 
Govern Ribbon, under Options, and on the Status Bar.

Disconnected (Ribbon) Disconnected (Status bar)

Messages (Ribbon) Messages (Status bar)

Automatic Synchronization Manual Synchronization

Get Latest (server updates on 
parcels not checked out)

Check In

Description Icon Description Icon
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• On the Options menu on the Govern Ribbon:
The Connected icon is displayed in the Options menu of the 
ribbon when mGovern is successfully connected to the office 
server. 

The Disconnected icon is displayed in the Options menu of 
the ribbon when mGovern is disconnected from the office 
server.

• On the Status Bar beside the datasource connection key:
The status indicator is white when the application is 
successfully connected to the office server.

The status indicator is red when the application is 
disconnected from the office server.

Viewing Error and Informational Messages

Icons are displayed in the Options menu of the Govern Ribbon and on the 
status bar when errors and warnings occur or when there is new information 
about the synchronization.
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mGovern Ribbon

To access the error messages from the Govern Ribbon:

1. Launch mGovern.

2. Select the Options menu on the Govern Ribbon.

3. Select the Messages icon 

The Options menu displays an icon for each type of message that currently 
exists for the application and has not been read. From most to least severe, 
messages can be error, warning, or informational.

 Error Message icon

 Warning message con

 Informational Message icon
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mGovern Status Bar

To view the error and informational messages from the Status bar:

1. Launch mGovern.

An icon is displayed for each type of message that currently exists for the 
application and has not been read. This means that a maximum of three 
icons can be displayed on the Status bar.

For example, if all message types have been generated and none read, all 
three icons are displayed.

if informational and warning messages have been generated, but not error 
messages, or if the error messages have been read, the informational and 
warning message icons are displayed:

if informational messages have been generated, but not error or warning 
messages, or if the latter messages types have been read, only the 
informational message icons are displayed:

If no new, unread messages have been generated, no icons are displayed.

Reading Error Messages

To read the error and informational messages:

1. Launch mGovern.

2. Click on a message icon in the Govern Ribbon or on the status bar.

The Message screen opens to the type of message that corresponds to 
the icon that you selected:
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The number of messages generated for each type are displayed on the 
tab next to the message type.

3. Click Copy to copy the messages to the Windows clipboard. You can then 
forward the message by e-mail or save it is as required.

4. Click Exit to close the message screen.

ing for and Loading Parcels

You can perform a , using the Predefined  screen as you would in Govern. The 
mGovern version has extra features and icons for transferring parcels 
between the main Govern database on the office server and the database on 
the mGovern. 

These icons are used for performing the following tasks:

Option Description

 on Server: Select the  on Server option to perform a  
on the office server, in order to retrieve the parcels 
you require. This is the same as performing a  in 
Govern.
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Saving a Dataset and Appending Data

As in Govern, if you are using the same records multiple times, you can create 
a Saved DataSet. This can include records from multiple types of es and can 
be accessed at any time.

The procedures to save a dataset and append data to it are the same as those 
used in Govern OpenForms. 

Once you create and save a dataset, you can perform a  by that dataset and 
quickly retrieve the parcels you require from the office server.

Creating a Saved Dataset

To save a dataset:

1. Launch mGovern.

2. Open a Profile that includes the user forms you want to access.

3. Open the Predefined es pane and perform a .

Check Out: Check out property records on the office 
server in order to lock them. When parcels are in 
Check Out, other users are unable to make 
modifications to them.

Clear Local Data: Select this option to delete the 
data currently on the Mobile device.

Tip: You can select this option at the same time that 
you transfer the data to the mobile database. 

Transfer Parcels: Download parcels from the 
Govern database on the office server to the database 
on the mGovern.

Load Parcels: Load the parcels that you require for 
your Model, as you would in Govern. This adds the 
parcels to the Dataset Treeview.

Option Description
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4. Select the records to include in the dataset.

5. Load the records to the Treeview.

6. Open the View menu on the mGovern Ribbon.

7. Enter a name for your saved dataset in the Datasources section of the 
menu.

8. Click the Save Dataset icon .
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Appending Records to a Saved Dataset

You can add records to a dataset from one or multiple  types.

To append records to a dataset:

1. Perform a new .

2. Load your records to the TreeView.

3. Open the View menu on the Govern Ribbon.

4. Select your dataset in the Datasources section.

5. Select the Append checkbox.

6. Click the Save Dataset icon .
Page 24 © 2016 Harris Govern



Deleting a Saved Dataset

You can remove one or all of your datasets using the icons in the Options 
menu.

To delete one or more saved datasets:

1. Launch mGovern.

2. Open a Profile and model.

3. Open the View menu on the Govern Ribbon.

4. Select your dataset in the Datasources section.

5. Classic the arrow beside Saved Dataset to expand the menu.

6. Do one of the following:
• Click Delete Selected to delete the selected dataset.
• Click Delete All to delete all saved datasets.

Performing a  by a Saved Dataset

You can perform a  by Dataset in order to retrieve parcels using a previously 
saved dataset. 

To perform a  by saved dataset:

1. Launch mGovern.

2. Open a Profile that contains the required user form.

3. Open the Predefined  screen.
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4. Click on the Dynamic  Group and select the  group, such as Property .

5. Select By Saved Dataset .

6. Select your saved dataset from the Dataset drop-down list.

7. Click the  icon 

The retrieved parcels are displayed under the  Results.

8. If you do not require all the parcels, deselect the ones you do not want to 
load.

9. Click the Load icon to load your dataset to the Dataset Treeview.

Checking Out Property Records

The purpose of Checking Out property records is to lock them on the main 
Govern database on the office server. When they are locked, the records can 
only be modified from the mGovern application.

This ensures that two people are not working on the same parcels in two 
different locations at the same time. 

By default, the Check Out parameter is selected on the Predefined es 
window. The Check Out occurs when you transfer the parcels from the main 
Govern database to the mGovern database. See Transferring Property 
Records on page 27.
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To perform a Check Out:

1. Launch mGovern.

2. Open the Predefined  screen.

3. Select the Dynamic  Group for the type of  you want to perform, such as 
Property Location.

4. Enter your  criteria.

5. Click the  icon 

The retrieved parcels are displayed under the  Results.

Transferring Property Records

The transfer makes a copy of selected property records on the Govern 
database located on the office server and adds them to the database on the 
mGovern device.

When you Check Out the transferred records, they are locked on the main 
Govern database on the office server. Other users are unable to make 
modifications to them.

To transfer property records:

1. Launch mGovern.

2. Ensure that the mobile device is connected to the Govern database on the 
office server.
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The Connected icon is displayed in the Govern Ribbon under Options 
when mGovern is connected to the office server. See mGovern Status 
Bar on page 20.

3. Open the Predefined es.

4. Select the  on office server check box .

5. Select the Check Out option  if you want to lock the parcels on 
the main Govern database on the office server.

6. Perform a  for the required records.

7. Click the Transfer Parcels icon 

A progress bar indicates the progress of the transfer.

If the Check Out option is selected, property records are checked out, or 
locked, when the transfer to the mGovern database is performed.

Loading Property Records

Once property records are transferred to the mGovern device, you can load 
them to the Dataset treeview for the selected Profile.
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To load property records:

1. Launch mGovern.

2. Transfer property records to the Mobile device as described under 
Transferring Property Records on page 27.

3. Open the required Profile, Model, and user form.

4. Open the Predefined es.

5. Deselect the  on office server check box .

6. Perform a  to retrieve records from the records that you transferred to the 
mGovern database.

7. Select the property records that you want to load in the  results.

8. Click the Load icon.

Synchronizing Data

When you synchronize the data, the changes that you make to the property 
records on the mobile device are transferred back to the main Govern 
database on the office server.

At the same time, running Data Synchronization ensures that the data in the 
mGovern database are consistent with the data in the main Govern database 
on the office server. 

Data synchronization does not transfer changes made on the main Govern 
database to the mGovern database.

If there are conflicts; for example, if there are differences in a property record, 
three level of messages are displayed in the messages window. 

• Error: Error messages indicate that an error has occurred and that the 
data were not synchronized. The following is an example:
2/22/2012 10:10:13 AM The synchronization completed 
successfully on the server, but an error occurred when 
updating your local database. You will need to re-
download the data from the server... 

• Warning: Warning messages identify the records where the conflicts 
occurred. The following is an example:
2/22/2012 10:10:13 AM  The record could not be updated 
on the server because it has already been modified by 
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someone else OR it doesn't exist anymore. Table: 
PC_PARCEL, Id: P_ID=7000064

• Information: Informational messages provide additional details. The 
following is an example:
IMPORTANT: The records that were not updated will stay 
out of sync until you re-download the data from the 
server. Then you will need to redo this changes. 2/22/
2012 10:10:13 AM  Synchronization started.

If an error, warning, or informational message is generated, the icons on the 
mGovern status bar and Options menu change to show this information: See 
Viewing Error and Informational Messages on page 18.

Errors could occur if, for example, you did not Check Out the data on the main 
Govern database. Checking Out the data is the best practice. It locks the 
records so that no else can make modifications to them. If you did not Check 
Out the data, changes could be made to the records on the main Govern 
database. Any changes that you made to the property records on mGovern 
would be transferred to the main Govern Database; however, changes made 
on the main Govern database would not be transferred to the mGovern 
database.

For example, if you changed the Effective Year Built on a Miscellaneous 
Structures record and at the same time, some one else updated the 
Condition Code for the same record, the Effective Year Built would be 
updated on the main Govern database when you synchronized the data. 
However, the Condition Code would not be updated on the mGovern 
database. You would need to download the record from the main Govern 
database again in order to be up to date. When you download the record 
again, both changes;i.e, the new Effective Year Built and the new Condition 
Code, would be transferred to the database for the mGovern application.

Synchronization Options

Synchronization options and information are displayed on the Options menu 
on the mGovern Ribbon in the Mobile section. 

They include the following:
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• Automatic Synchronization
• Manual Synchronization
• Is Synchronizing
• Check In

Automatic Synchronization

Automatic Synchronization ensures that the main Govern database and the 
mGovern database are kept consistent as long as the mobile device is 
connected to the Govern server. If there are conflicts; for example, if there are 
changes to a property record on the office server, error messages are 
displayed in the message window. See Viewing Error and Informational 
Messages on page 18. 

It is recommended to keep Automatic Synchronization running when you are 
running mGovern and are connected to the main Govern database on the 
office server. This ensures that your modifications are updated.

To run Automatic Synchronization:

1. Launch mGovern.

2. Ensure that the connection between databases is successful.

3. Open the Options menu on the mGovern Ribbon.

4. Select the Automatic Synchronization option.

Manual Synchronization

You can run the Manual Synchronization at any time that you connect the 
mobile device to the main Govern database. Running the manual 
synchronization ensures that the data in both databases are up-to-date and 
that you are aware of any conflicts.

If there is a conflict; for example, if there are differences in a property record, 
error messages are displayed in the message window. See Viewing Error and 
Informational Messages on page 18. 
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When you are running mGovern and are connected to the main Govern 
database on the office server, it is recommended to keep Automatic 
Synchronization running. This ensures that you are aware of any conflicts.

To run the Synchronization manually:

1. Launch mGovern.

2. Ensure that the connection between databases is successful.

3. Open the Options menu on the mGovern Ribbon.

4. Deselect the Automatic Synchronization option.

5. Select Synchronize.

The Is Synchronizing icon is activated during the process.

Checking In Data

When the data are synchronized, you can perform the Check In. This removes 
the lock on the property records that was put in place when you performed the 
Check Out.

To perform a Check In:

1. Launch mGovern.

2. Ensure that mGovern is successfully connected to the main Govern 
Database.

3. Run an Automatic or Manual Synchronization.

4. Open the Options menu on the Govern Ribbon.

5.  Click the Check In  icon.
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The following screen is displayed.

6. Select the property records that you want to Check In to the main Govern 
database. 

7. Click the Check In Selected Records icon .

Once the Check In is performed, the property records are no longer locked on 
the main Govern database on the office server. You can continue to work on 
the property records on mGovern. You can also continue to run Data 
Synchronization. The modifications that you make to property records are 
transferred to the main Govern database when they are synchronized. 
However, errors are generated if modifications are made to the records on the 
main Govern database. Records on the mGovern are not updated.

Typical Workflow

When working with the mGovern application, you would normally proceed as 
follows:

In the Office

1. Connect the mobile device to the main Govern database.

2. Launch the mGovern application.

3. Verify the application is successfully connected.

4. Open the Predefined  screen on the mGovern.

5. Select the  on Server option.
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6. Perform a  to retrieve the required parcels.

7. Select the Check Out option.

8. Transfer the parcels to the mGovern database.

9. Select the Automatic Synchronization option until you are ready to 
disconnect the device.

In the Field

1. Open the user form you require in mGovern.

2. Update the records as required. 

3. Continue to run the Automatic Synchronization if you are connected to the 
Govern database. This ensures that your modifications are backed up on 
the server and that you are aware of any conflicts.

Back in the Office

1. Launch mGovern.

2. Run the Automatic or Manual Synchronization to transfer your record 
updates to the main Govern database on the office server. 

3. Check In the records to unlock them; so, that you can work on them in 
Govern.
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APPENDIX A:Temporary Database 
Options

SQL Express LocalDB

The purpose of the SQL Express LocalDB is to provide a local environment 
that is easy to install and manage. Users should note that the LocalDB 
environment does not require the installation of a service or any security 
configuration. When installed an instance of the LocalDB runtime can be 
started as needed. SQL Express LocalDB can be downloaded from the 
Microsoft Website. Follow the instructions to install, then start an instance of 
the database server. For our example the LocalDB server instance will be 
mySERVER, and the temporary database is called mGOVERN.

After installing the SQL Express LocalDB open a command prompt...

Starting the LocalDB server

1. At the command prompt, type the following: rootDRIVE:\> SqlLocalDb 
start "mySERVER" or
rootDRIVE:\> SqlLocalDb create "mySERVER" -s

Result: LocalDB instance "mySERVER" started.

Stopping the LocalDB server

To stop and delete an instance, you can issue the following two commands:

1. C:\> SqlLocalDb stop   "mySERVER"

2. C:\> SqlLocalDb delete "mySERVER"

As there is no graphical user interface to connect to the LocalDB, a freely 
downloadable application like Microsoft SQL Management Studio Express can 
be installed on the mobile unit. Likewise the full Microsoft SQL Server 
Management Studio may also be used for the “front end”.
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To Connect to the server using 
the Management Studio:

1. Click connect.

2. At the Connect to Server 
prompt, enter the server 
name as follows:
(localdb)\mySERVER
mySERVER is the name of 
our server instance.

3. When connected to the 
database, create the 
temporary database.

Advantage of using SQL Express LocalDB

This alternate method of managing the temporary database has the 
advantage of having the same instance for the source and the mobile 
database. It is unlikely that all users will configure SQL Server in the same 
manner. Issues can arise as a result of differing instances between the server 
hosting the source database and the mobile client.
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Troubleshooting
APPENDIX B:Troubleshooting

Introduction

As indicated earlier in this manual the usual issues that are encountered with 
installing and configuring the mGovern application are often related to 
permissions or access rights. The following are known issues with a “work-
around” for commonly encountered issues.

Installations on Microsoft Surface Pro Tablet

SQL & Firewall Setups for Mobile Surface Access

1. Launch SQL Server Configuration Manager

2. Go to “SQL Server Network Configuration”

3. Go To “Protocols for MSSQLSERVER”

4. Ensure that TCP/IP is Enabled as indicated below: 

5. Go to “SQL Server Services”

6. Double Click on “SQL Server (MSSQLSERVER)
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7. Go to “Service” Tab

8. Note the VALUE of the Binary Path as 
indicated here.

9. Launch Control Panel

10. Select Administrative Tools

11. Select “Windows Firewall with 
Advanced Security”

12. Right Click on “Inbound Rules” and 
Select “New Rule”

13. Keep “Rule Type” as Default – Click 
Next

14. Type the Path identified in STEP 5 
ABOVE “C:\Program Files\Microsoft 
SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn” and click Next.

15. Maintain Defaults in ALL other windows when you click Next.
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A Note about Permissions

In Windows, access to a folder on a file server is determined through two sets 
of permissions, the share permissions set on a folder and the permissions set 
by NTFS (which can also be set on files). What is relevant here is that Share 
permissions and NTFS permissions are independent, i.e. neither one changes 
the other. The final access permissions on a shared folder are determined by 
taking into consideration both the share permission and the NTFS permission 
entries. The more restrictive permissions are then applied. Knowing all this 
then, it is critical to. Therefore, when a message like the following is displayed, 
it is possible that the issue is related to a shared folder.

Empty Search Combo Boxes on Remote Deployments

When a Mobile deployment is remote in the field, i.e. away from local the 
home database that it synchronizes with, combo boxes that are populated by 
(Table: NA_NAMES) or (Table: PC_ADDRESS) search queries could result in 
empty combo boxes. This behavior has been observed with queries that may 
use the SQL SELECT DISTINCT statement:

Ex.: SELECT DISTINCT <columnName> FROM NA_NAMES; or SELECT 
DISTINCT <columnName> FROM PC_ADDRESS;

These types of queries are valid, the queries are by design intended to search 
on the Parent or Local Database. The understanding is that the Local but 
should be executed when the mobile deployment is connected to the home/
main database.
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Explanation: The combos should be populated by selecting the Search on 
Server option to search the Parent/Home database while the Mobile 
deployment is docked at the office, and the Search on Server option is 
available. When the deployment is on the road, the child/remote database 
becomes the Local database. The search combo boxes will now be populated 
with the required data records.

Tip: As a Best Practice for successful use of mGovern while in Remote 
Mode, i.e. away from the office, users should include as a part of their 
planning schedule, a process to pre-load searches with the names and 
addresses of locations that will be visited. This should be done while at 
the office. When a search is performed with the Search on Server 
option selected, the combo's will be populated by pre-fetching the 
parcels from the LOCAL/Home database.As a result of this process 
when you are remote your search results for the parcels will   
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