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Disclaimer

MS Govern has taken due care in preparing this manual. However, nothing 
contained herein modifies or alters in any way the standard terms and 
conditions of the purchase, lease, or license agreement by which the product 
was acquired, nor increases in any way the liability of MS Govern to the 
customer.
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Preface
Welcome to Govern for Windows, a comprehensive and fully integrated 
transaction-driven system written exclusively for local governments. Govern 
includes a wide variety of database modules:

Computer-Assisted Mass Appraisal (CAMA)
• Appeals & Grievances
• Appraisals / Property Valuations 
• Comparables Sales Management

Financial Management
• Account Receivable
• Cash Collection 

Land Management
• Business & Individual Licenses
• Complaint Tracking
• Leasing
• Permit Tracking & Inspection Scheduling
• Planing
• Violations

Revenue Management
• Aircraft & Boat Excise Tax
• Miscellaneous Billing
• Personal Property Tax Billing
• Real Property Tax Billing
• Self-Reported Tax Billing
• Special Assessments
• Tax Title / Tax Lien / Tax Sales
• Utility Billing

Since 1980, MS Govern has worked hand-in-hand with State and Local 
Governments to simplify the implementation of software solutions that 
automate the flow of information related to their properties.
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Introduction: Super User

The Super User guide is intended for users with Super User privileges, often 
these individuals are designated as Administrators. It describes all the 
procedures which are normally performed by the Super User after completing 
the installation and setup as described in the Getting Started guide. 

This guide is divided into three (3) chapters:

• Govern Admin, describing the administrative procedures and setup.
• Govern, describing how to customize the Govern User Interface.
• Govern Batch Processing, describing the batch processes which are 

normally performed by a Super User or system administrator.

Overview
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What’s New
This section lists the new features in Govern for Windows™, 10.7. 
Throughout the online manuals and the Help files, the new features 
are indicated by the New symbol.

Govern Admin

.NET Installer for Component Integration Interfaces

There is a new .NET component installer for Govern’s component integration 
interfaces. All individual installers are now consolidated within one installer. 
See .NET Installer for Govern for Windows Interfaces on page 4.

Support for USPS Intelligent Mail Barcodes

Configuration parameters have been added to the System Registry 
Maintenence formthat supports USPS Intelligent Mail barcodes. The barcode 
formats that are supported are IMB_31 and IMB_65. See Support for USPS 
Intelligent Mail Barcodes on page 38.

Govern Batch

MS Govern Batch (.NET) can be called from GovBatch

The MS Govern Batch .NET application can be called fromGovBatch release 
10.7. This will allow for users of GovBatch to access the new Govern.NET 
batch processes. See MS Govern Batch (.NET) can be called from GovBatch 
(Govern for Windows Batch) on page 275

Improved User Menu Access 

In Release 10.7 a new enhancement offers greater control over user menu 
access. Administrators are able to give access to individual menu items; 
previously menu access was “all or none”. For example, an Administrator or 
Super User can now give access to a specific menu item under a Govern 

Note: This functionality is only available to users that have obtained licenses 
for Govern.NET and have the required applications installed.

NEW
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Batch Processing (GovBatch) menu, as opposed to giving access to all menu 
items. See Assigning User Permissions to Batch Processes on page 292.
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.NET Installer for Govern for Windows Interfaces

There is a new .NET component installer with version 10.7. The 
goal of this installer is to consolidate the installation of all previous 
.NET installers under one common Interface.

At the beginning of the installation process, a validation for the version 2.0 and 
4.0 of the .NET Framework is performed. Version 2.0 is required as some 
components are compiled with FrameWork2.0. 

Who should run the Installer?

Users of the following integration interfaces should run the installer.

• Credit Card Helper – Users of IC Verify for Credit Card processing
• Crystal Helper – For users of the Utility Billing eBilling module which 

generates .PDF bills.
• Email Helper – Used in systems that may have reported issues with email 

integration; this component was a workaround.
• FMS Integration – Users that are using the MS Govern FMS G/L interface
• Great Plains Integration – For users of the Great Plains G/L interface
• iNovah Integration – This is for Govern users with the iNovah payment 

collection and processing interface.
• OneCode Integration – For users of the Intelligent Postal Barcode 

Generator called OneCode.
• Rhode Island DMV Integration – Users of the Integration interface for the 

Rhode Island Department of Motor  Vehicles (DMV)
• Sonrai Systems Integration – Designed for users of the Sonrai Systems 

waste and recycling system management system. 
• SIRE Integration – Any users of the Govern for Windows SIRE Integration 

that allows exchange of multimedia files with the SIRE Document 
Management System.

Note: If an upgrade is required, you will be presented presented with an error 
requesting that you upgrade to the necessary version of the .NET 
Framework.

Note: This installer must be run on each individual system that will be 
accessing the any of the above listed interfaces.

NEW
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Running the Installer

To run the installer, obtain the NET107Setup.exe form MS Govern technical 
support:

1. Double-click the NET107Setup.exe file.

2. At the first screen, you will see the list of integration packages that the 
installer will check for and replace; click OK to continue.

 

Note: Since the installer was previously run, the screen will be different; click 
OK to continue. Running the installer multiple times will in no way 
affect your system.
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3.  At the Welcome screen of the first component to uninstall, click Next.

4. When the component has been removed, i.e. uninstalled, click Finish.

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 7

You will repeatedly uninstall any of the interfaces that were discovered by the 
installer. When all components have been completely uninstalled, you will be 
presented with the .NET Component for Govern for Windows Setup screen. 

5. At the installation Welcome screen, click Install.

During the installation process, all integration interface components will be 
installed.
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6. At the completion screen, click Finish.

At the completion of this process, the target system will be updated with the 
latest version of all Govern integration components.

Note:  It will be necessary to have the proper licenses to access these 
interfaces. Contact MS Govern Technical Support for any licensing 
requirements.
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CHAPTER 1: ADMINISTRATOR

This section provides the information you need for configuring the Govern 
application. This includes setting up users, groups and departments; defining 
default parameters; configuring external applications and the GIS component 
and creating SQL queries and definitions, logical expressions, formulas and 
constant values.

Administrative Forms for Govern Setup

System Registry Maintenance

Set the default parameters for the organization on the System Registry 
Maintenance form. These include the default path for the Help files, reports, 
query definitions and multimedia documents; the G/L interface type; 
encryption of Social Security Numbers and Federal IDs; the link type and P_ID 
column name for the GIS and general parameters; such as support of multiple 
jurisdictions, user name and date stamp and legal index format. These 
parameters are saved to the SY_REGISTRY table.

See System Registry Maintenance on page 16.

User Registry Maintenance

Define default parameters at the user-level on the User Registry Maintenance 
form. These parameters include user identification and the default language 
for the computer; default paths to Help files, bitmaps, reports and query 
definitions; GIS definitions; such as GIS link type, project, view and theme, 
P_ID column name; Melissa data and the Document Locator External folder. 
These parameters are saved to the SY_REGISTRY and USR_REGISTRY 
tables. See User Registry Maintenance on page 53.

Overview

Note: Certain parameters; such as, the paths to Help files, reports, custom 
reports, bitmaps, the image editor and query definitions, the GIS Link 
Type and P_ID column name can also be set on the User Registry 
Maintenance form. Those set for the user have precedence over those 
set at the system level.

FI
N

AL
 D

R
AF

T



Page 10 © 2013 MS Govern

Super User

User Maintenance

Maintain user data on the User Maintenance form. Create new users, set 
access rights or remove the user profiles that are no longer active. See User 
Maintenance on page 60.

Menu Security Setup

Grant and restrict user access, for administrators, on the Menu Security Setup 
form. Access rights can be set for each menu item in Govern Admin. See 
Menu Security Setup on page 72.

User Groups

Define User Groups and set access rights on the Group of Users form. 
Enhance security by setting permissions by jurisdiction. See Groups of Users 
on page 74.

Global Field Validation Mask

Define patterns or masks for data entry on the Global Field Validation Mask 
form. See Global Field Validation Mask on page 78.

Validation Tables and Codes

Maintain the System and User Validation Tables on the Validation Tables form. 
These tables are used to validate the information entered in the various fields. 
Create and maintain the elements of the tables on the Validation Codes form. 
See Validation Tables on page 85.

Property Control Validation Tables

Use the Property Control Validation Tables form to maintain the tables that are 
linked to the Property Area function in Govern. These tables are saved by year 
and by jurisdiction, if applicable. See Property Control Validation Tables on 
page 97.

Dataset Source Setup

Grant and restrict user access to the Dataset Sources on the Dataset Source 
Setup form. See Dataset Source Setup on page 98.

Note: This is not required for administrators or super users.FI
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Department Setup

Define the profile for each department on the Department Setup form. This 
includes the fiscal year used by the department, access to the Govern User 
functions and access to Accounts / Receivable data. See Department Setup 
on page 101.

Functions Setup

Grant and restrict access to the Govern functions on the Functions Setup 
form. Access is set by department, group and user. You can also add your 
own business rules to the Add, Save and Delete buttons of any Govern 
function, from this form. See Functions Setup on page 123.

Audit Trail and Data Duplication Setup

Track modifications to selected Govern tables, by function, using the Audit 
Trail form. Define the data that can be duplicated from an existing property to a 
new one, using the Data Duplication Setup form. See Audit Trail and Data 
Duplication Setup on page 131.

Govern Admin Audit Trail

You can now create an audit trail to track modifications made in Govern 
Admin. You need to select the forms on which you want to set the audit trail. 
Modifications are saved to USR_AUDIT_ADM. See Govern Admin Audit Trail 
on page 134.

Bill Messages Setup

Add a message to your next billing run using the Bill Messages Setup form. 
This message is valid for one billing only. See Bill Messages Setup on 
page 137.

Lists and Crystal Reports Setup

Use the List and Reports Setup form to define the Govern functions and 
Govern batch processes, from which the reports can be launched. Set access 
permissions by department, user and group. Then, define your Report Tree 
View for Govern. See Lists & Crystal Reports Setup on page 140.

FI
N

AL
 D

R
AF

T



Page 12 © 2013 MS Govern

Super User

SQL Server Reporting Services

SQL Reporting Services (SSRS) is a database reporting solution that is 

available with Microsoft® SQL Server® (Version 2005 and later). Govern 
Version 9.5 and higher offers support for SQL RS and the ability to set the 
parameters of a report datasource at run-time. See “Enable SQL Reporting 
Services” on page 43.

User Text Maintenance

With the new User Text Maintenance form, you can now modify all the text 
from the SY_TEXT table. This includes the entries on the Govern CoolBar, 
messages and labels on functions. The text is modified on the user interface 
but remains unchanged in the database. See User Text Maintenance on 
page 160.

Process Flow Wizard

Governs Batch Processing application now includes a Batch Process Flow 
Wizard. You can define the processes that you need to run, in the order they 
need to run. Details are saved and displayed for tracking information. See 
Process Flow Wizard Setup on page 161

Scanner Parameters Setup

Define your scanner settings on the Scanner Parameters Setup form. Any 
TWAIN-compatible scanner can be used to copy images to disk for the 
Multimedia functions. See User Text Maintenance on page 160.

IC Verify Setup

Use the ICVerify Setup form to integrate the ICVerify package, for credit card 
transaction processing. See ICVerify Setup on page 168.

External Application Setup

Launch an external application directly from Govern, after setting it up through 
the External Application Setup form. See External Application Setup on 
page 178.

Formula Editor

Create customized formulas, using the Formula Editor form. Formulas can be 
used in Mass Appraisal calculations, permit fee calculations, added to a 
logical expression, created through the Logical Expression Block Editor and 
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added to a customized database field. See Formula Editor on page 183.

Logical Expression Block Editor

Create customized logical expressions, using the Logical Expression Block 
Editor form. Logical expressions can be used in Mass Appraisal calculations, 
permit fee calculations and added to a customized database fields. See 
Logical Expression Block Editor on page 191.

Constant Editor

Define and maintain constant values using the Constant Editor form. 
Constants can be used in formulas and logical expressions for values that 
change on a yearly basis. As constants are saved by year, you only need to 
edit the constant definition in order to update your formulas and logical 
expressions. See Constant Value Editor on page 208.

SQL Definition Setup

Create customized SQL queries, on the SQL Definition Setup form. SQL 
Queries can be linked to command buttons, used for displaying information on 
the toolbar or used in Formulas and Logical Expressions. See SQL Queries on 
page 211.

Queries by SQL Setup

Create customized SQL queries on the Queries by SQL Setup form. These 
queries can be selected from a drop-down list and executed for the Query by 
SQL search. They can also be saved by jurisdiction to be used by authorized 
users only. See “Queries by SQL Setup” on page 212.
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Govern Admin Interface

This section lists the modifications made to the Govern Admin interface for 
version 10.7 and describes how to modify the background.

Overview
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Govern Admin Interface

Toolbar Icons

You can launch Govern, Govern Batch Processing 
and the Payment Lockbox applications by clicking 
the icons displayed on the main menu of the Govern 
Admin interface, as well as from the Tools menu. 

Govern for Windows Background

Several images are included in the Govern\Bitmap directory for the 
background of the Govern for Windows interfaces. By default, an image is 
automatically selected based on your screen resolution. 

To replace this image:

1. Name your customized image background_800.bmp, background_ 
1024.bmp, background_ 1152.bmp, background_1280.bmp or 
background_1600.bmp, according to your screen resolution setting.   If 
you have a non-standard setting, the next highest resolution is used.

2. Scroll to the Govern\Bitmaps directory.

3. Paste your image to this directory to override the existing image.

You can replace this with an image of your choice.

Note: If you have Govern Admin, Govern and Govern Batch Processing on 
your computer, the background images of all these applications are 
replaced.
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System Registry Maintenance

Set the default parameters for the organization on the System Registry 
Maintenance form and it’s associated tabs. These include the default paths for 
help files, reports, query definitions and multimedia documents; the G/L 
interface type; encryption of confidential information; GIS information and 
general parameters; such as support of multiple jurisdictions, the user name 
and date stamp and the legal index format. The parameters under these tabs 
are saved to the SY_REGISTRY table.

The display of configuration tabs in the System Registry Maintenance form are 
conditional upon user serial numbers. Some serial numbers enable the display 
of the tabs used to configure the eComponents, i.e. eProfile, eComponents. 
Parameters in these tabs will only configure eComponent applications that are 
before release 4.0. 

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Parameters > Edit the System Registry...

Overview

Note: Certain parameters; such as, the paths to Help files, reports, custom 
reports, bitmaps, the image editor and query definitions, the GIS Link 
Type and P_ID column name can also be set on the User Registry 
Maintenance form. Those set for the user have precedence over those 
set at the system level.

Note: If you are using eComponents release 4.0 or greater, you must use the 
Govern NetAdmin (GNA) release 4.7 or greater for your Web site 
configurations.
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System Registry Maintenance Command 
Buttons

Saving the System Registry Setup: Once the fields have been filled in, 
click the Save button to save the information in the SY_REGISTRY table. 

Exit: Click Exit to close the form. A confirmation message appears if there 
are any unsaved modifications.

General Tab

Paths to Govern directories are displayed on the General tab, the other 
Govern options are now distributed on the second tab. In order to provide 
more configuration options to Govern users, additional configuration 
parameters have been added to the Connections tab and the Login Setup tab.
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General Tab Parameters

Path Information group

You can select the drive and directory to define the required paths for 
the System Registry Maintenance information.

Bitmap Folder: Enter the path to the Bitmaps folder.

Help Files Folder: Enter the path for the On-Line Help folder.

Reports Folder: Enter the path to the Reports folder. These are the 
standard reports included in the Govern package.

Custom Reports Folder: Enter the path for the Custom Reports folder. 
Custom Reports are created specifically for a client or by the client.

GIS Query Definition Folder: Enter the path to GIS Queries folder. 

Query Definition Folder: Enter the path for the Queries folder.

Inspection Templates: Enter a path to a directory containing an Adobe 
Acrobat .PDF file or Microsoft Word.DOC templates; these are documents or 
forms that may be required to accompany certain inspection types. Refer to 
Inspection Templates in the Inspections guide.

Note: You can enter Universal Naming Convention (UNC) commands for the 
path information instead of entering a map to the drive. Enter double 
backslashes for the server name and single backslashes to identify 
the directories; i.e., \\servername\path.

Note: Before setting up your directory paths to the standard reports, on the 
System Registry Maintenance and User Registry Maintenance forms, 
ensure that you open the directory for your state and copy the reports 
to the Standard Reports directory. See Appendix A: Standard 
Reports on page 320 for details.
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Specify Lockbox Temp File and Log File 
Locations

For better system management, you can specify the locations of 
your Govern Lockbox Temp file, and Log files. By default these 
directories are located in the bin folder in the Lockbox install 

directory for the Lockbox Temp files, and the local systems Temp folder for the 
Log files. Locations can be local, or specified with the Uniform Naming 
Convention (UNC). When the locations for these files are selected by the user, 
the selected locations will override the system default.

Lockbox Temp Folder Network Locations

When a network file location, i.e. a UNC network path is specified for the 
Lockbox temp file, unless the location is exclusive to the user, issues may 
arisein the form of the temp file being “locked” by another user. Ideally, when 
selecting a network location, ensure that the location is exclusive to each user.

Log File Folder Network Locations

The Log file is a dynamic file that is used for logging error messages. When its 
location has been specified as a shared location, issues may arise when the 
file is being written to by multiple users. Therefore, ideally, when selecting a 
network location, ensure that the location for the log file is exclusive to each 
user.

To specify an alternate location for your Lockbox temp file or Log files, in 
Govern Admin...

1. Select Parameters > Edit the System Registry...

Note: Due to virtualization features, a Windows Terminal Services network 
environments may not experience the issues that are associated with 
a shared network path. For further configuration details, consult with 
your network administrator.

Note: Windows Terminal Services network environments may not 
experience the issues that are associated with a shared network path 
as a result of its virtualization features. Consult your network 
administrator for further configuration details..
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2. Click to select the Govern tab.

3. Look for the parameters labelled LockBox File Folder (A), and Log Files 
Folder (B).

4. Click “...” (C) to navigate to the target directory (D).
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5. Navigate to the folder that you would like to designate as the Lockbox 
Temp File folder, or the Log File folder; alternatively, you can enter a UNC 
path to the network drive or folder.

LockBox File Folder: You can specify a location for the Lockbox 
temp files by entering a path to a local directory, or enter a UNC 
network location. See Lockbox Temp Folder Network Locations on 

page 19 for additional details.

Log Files Folder: To specify a location that will be used for 
storing log files, enter a path to a local directory, or enter a UNC 
network location. See Log File Folder Network Locations on 

page 19 for additional details.

Windows Imaging Editor Folder: Enter the full path to the Imaging editor, 
you are using.

AutoCAD Viewer: Enter the full path and executable (.exe file) for your 
AutoCAD Viewer, in order to display AutoCAD files, directly from the 
Multimedia Information and Multimedia by Name functions, in the specified 
viewer. This can also be defined on the User Registry Maintenance form.

PDF Viewer: Enter the full path and executable (.exe file) for your PDF 
Viewer, in order to display PDF files, directly from the Multimedia Information 
and Multimedia by Name functions, in the specified viewer. This path can also 
be defined on the User Registry Maintenance form.

Note: Issues may exist with a shared network path for a Lockbox Temp file. 
Consult your network administrator for further configuration details..

Note: Issues may exist with a shared network path for a log file. Consult your 
network administrator for further configuration details..

Note: Once a valid path is entered, the Imaging Editor option is enabled on 
the Tools menu in Govern.

NEW
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Option to Use iAddress for Address Verification

Melissa / iAddress Data Folder: Enter the path to the 
MelissaDATA or iAddress address verification application.

If you are including MelissaDATA’s Residential Business Delivery Indicator 
(RBDI) add-on with your existing Melissa Address Verification service, place 
this in the same directory. Refer to the Property Control guide for details.

Should you wish to use the iAddress address verification application, you must 
select the iAddress option in the User Registry Maintenance form. See Option 
to Use iAddress for Address Verification on page 59 for details.

Multimedia Document Path

Level I Multimedia Document Path: This path will contain all the 
multimedia documents. The system creates a new directory in this path each 
time you save a multimedia document. The directory name is the date you 

have saved a document, for example, 20080530: May 30th 2008. All the 
documents you save during the course of a day will be saved in the same 
directory.

Level II Multimedia Document Path: This path will contain all the 
archived multimedia documents from Level I after running the Archive 
Multimedia Batch Process. 

Level III Multimedia Document Path: This path will contain all the 
archived multimedia documents from Level II after running the Archive 
Multimedia Batch Process.

Note: If you are running Govern offline, it is important to enter this path in the 
User Registry Maintenance form. When offline, Govern will default to 
the paths specified in the User Registry Maintenance form.

Note: A user license for the iAddress application is required.

Note: If you manually modify the multimedia paths for the three levels, the 
IMAGING section of the SY_REGISTRY table is automatically 
updated. The batch process will use these paths, in the Imaging 
section to archive the multimedia documents.
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Multimedia Levels by Year: Select this option to create an additional 
folder for archiving your multimedia images. A directory named according to 
the current year will be added to the end of the multimedia image paths at 
each level.

Country Format: Select a country code from the drop-down list (Table: VT_ 
SY_MAILFMT). The country code formats the mailing information, according 
to the standards of the country from which the mail is sent. On the System 
Registry Maintenance form, this code sets the default. The user can override 
the default, for the current record, on the Name and Address Maintenance 
function in Govern.

Case Sensitivity: Select one of the following options, from the drop-down 
list:

• 1st Letter (N&A) - Saves the first letter of each field in upper case
• No - Select to save the data as entered
• Ucase - This saves the Name & Address, Property Location, and forms 

from the NA_NAMES and PC_ADDRESS tables, and any data that is 
masked in other tables, in upper case. 

• Ucase (N&A) - This will save the Name & Address data (from the 
NA_NAMES and PC_ADDRESS tables) in upper case

Crystal Report Sleep Time (ms): Select this option to set a delay, 
between the time a report is created and can be opened. Then, enter the 
length of the delay in milliseconds. The delay ensures that the report is 
completely copied to your Temp directory before it can be opened. Otherwise, 
you may get an error message indicating that Govern could not find the report 
or could not open it. This type of error is more frequent with longer reports 
since more time is needed to copy the file to the Temp directory.

Note:  If you change the path (for the Levels I, II or III), after saving 
multimedia documents, you will not be able to display these images.
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Geographic Information System (GIS) Parameters

GIS Link Type: Select the GIS Link from the drop-down list.

GIS Link Definition

ArcView 8.x ArcView 8.x, or higher, application

ArcView 8.x Tax Map # ArcView 8.x, or higher, application with search by Tax 
Map Number

Horus Kheops application

JMap Kheops application

MapInfo MapInfo application

No None

Test Test

Yes ArcView 3.3 Application
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If you are using Arcview 8.x, Arcview 8.x with Tax Map Number, or higher, 
enter the path as in the following example:

Otherwise, enter the path as follows:

P_ID Column Name: After entering the GIS View and Theme, enter the 
P_ID column name, associated with the shape file to be used with the GIS 
application. When the application is loaded, the records in this column, 
matching those in the current recordset are highlighted.

Tax Map Column Name:  After entering the GIS View and Theme, enter 
the Tax_Map column name, associated with the shape file to be used with the 
GIS application, if you are using ArcView 8.x, or higher, with Tax Map Number. 
When the application is loaded, the records in this column, matching those in 
the current recordset are highlighted.

General Ledger

G/L Interface: Select a General Ledger Interface from the drop-down list. 
(Table: VT_SY_GL_INTER). The selection will be used during the batch 
process. For example, selecting Govern Unix will enable the Govern G/L V4.5 
Import / Export process.

c:\Govern\gis\gis\govern31.mxd

GIS=C:\ESRI\AV_GIS30\ARCVIEW\BIN32\arcview.exe c:\Govern\ 
gis\gis\govern.apr govern,govern

Note: This field option will be displayed when the ArcView 8.x Tax Map # 
option is selected from the GIS Link Type drop-down menu.

G/L Interface Option Description

ACS G/L Interface Select this option to interface with the ACS G/L 
Interface.

BudgetSense G/L Interface Option to interface with the BudgetSense G/L 
Interface.

Cayenta G/L Interface Select to use the Cayenta G/L Interface.
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CBJ Cayenta G/L Interface Use this option to use the CBJ Cayenta G/L 
Interface.

FMS G/L Interface Select this option to use the MS Govern FMS 
G/L Interface.

Govern Generic G/L Interface This is the option for the Govern G/L Interface.

Govern Unix G/L Interface Option for the Govern Unix G/L Interface.

Great Plains G/L Interface If you are using Great Plains as you G/L 
application, select this option.

Great Plains G/L Interface Web Select this option for the Great Plains G/L Web 
interface.

Lawson G/L Interface Choose this option to use the Lawson G/L 
Interface.

Munis G/L Interface This is the option to use the Munis G/L 
Interface.

New World System Select this option if you are using New World 
System.

S.F.G. G/L Interface Use this option if you are using S.F.G. as your 
G/L interface.

Savannah G/L Interface Choose this option is you are using the 
Savannah G/L solution.

Sungard HTE G/L Interface Select this option if you are using Sungard HTE 
as your G/L solution.

Note: When a G/L Interface is selected, there may be additional options 
associated with the selection. When the option for “Use Integrated 
G/L” appears, this is an indication that information is fetch from the 
G/L system; additional configuration may be required. For detailed G/L 
interface instructions, contact your G/L interface supplier. 

G/L Interface Option Description
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Options Tab

System Registry Maintenance Parameters

Multilingual: Select this option if you are supporting two or more languages, 
for Govern functions, in your setup; for example, if you are supporting English 
and French, or English and Spanish. You will also need to set this option for 
each user on the User Registry Maintenance.

Formula “rpt_range” Separator: Using the procedure described under 
Creating User Prompts on page 147, you can define prompts to be displayed 
when a Crystal report is run, in Govern. The user enters the parameters, such 
as a range of parcel numbers or tax map numbers, as in the following screen 
shot, in order to view specific information on the report.

You can define a default separator to be used for displaying these prompts. 
Enter a maximum of two characters for the separator, such as a comma (,) or 
a semi-colon (;) and a space.
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Do not use clob: Select this option to use varchar2 instead of blob and clob 
types. 

Encrypt the Social Security No. in the Database: If selected, this will 
encrypt the Social Security Number in the database.

Encrypt the Federal ID No. in the Database: If selected, the Federal ID 
numbers will be encrypted in the database.

Generate Account Number for Name: Select this option to associate a 
system-generated account number with a name when you create new name 
and address records.

Support of Multiple Jurisdictions: ISelect this option if you are 
maintaining data by jurisdiction. See Jurisdiction on page 68 for details about 
jurisdictions.

Support Billing Address Forwarding: Select this option to 
enable the Address Forwarding parameters on the Utility Billing 
(UB), Self Reported (ST), Personal Property (PP), and Real Estate 

(RE) tax Mailing Indexes. Billing address forwarding can be set up for your 
clients who spend part of the year at one or more alternate locations. Refer to 
the respective UB, ST, PP, and RE Tax Assessment & Billing guides for 
details.

Note: This option is visible only on Oracle connections.
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Add User Name and Current Date in Notes (Memo): Select this option 
to add the user name and date automatically to each entry in the Notes and 
Comments text boxes in Govern.

Fill Tax Map Number for External Recordset: If selected (Value = -1), 
the Tax Map Number will be loaded into the PC_EXTERNAL table when you 
load data using the Load Recordset to External Recordset option from the 
File menu in Govern. Refer to the File section of the General Information 
guide for details.

Legal Index Multi Format: Select this option to add a legal index to the 
Parcel Information form in Govern. This index can be entered when you 
search for a parcel. The Parcel Index text box appears on this form if this 
option is selected; otherwise, it is invisible.

Parcel Records Can Be Locked When Exported

During an Export to an Inspector / Export to an Appraiser Database process, 
prior to Release 10.5 only the Inspection records were locked. In Release 10.5 
and later, locking can be applied to the parcel record. This means that all Mass 
Appraisal (MA) related functions, and certain Land Management (LM) 
functions, will also be locked. Exported parcels are flagged as exported 
(Table: PC_PARCEL) during the Microsoft Access database export process.

Note: You can now specify the functions to which you want to apply this 
feature, through the Auto Trail and Data Duplication Setup form, rather 
than applying it universally throughout Govern. See Audit Trail and 
Data Duplication Setup on page 131.
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Checkin/Checkout for Inspections: Select this option to enable the 
locking of exported parcel records during an Export to an Inspector Database 
process. 

Checkin/Checkout for Appraisers: Select this option to enable the 
locking of exported parcel records during an Export to an Appraisers Database 
process. 

Select “Keep Parcel Active” as 
default in Split/Merge Func-
tion: Select this option to set the 
“Keep Parcels Active” option as the 
selected default in the Parcel Split / 
Merge / Remap function in Govern 
for Windows.

Select “The Parcels are Vir-
tual” as default in Split/Merge 
Function: Click this option to set 
the option of “The Parcels are 
Virtual” as the selected default in 
the Parcel Split / Merge / Remap 
function in Govern for Windows.

Refer to the Split / Merge / Remap section of the Property Control guide for 
details on the Split / Merge process.

Full Audit Trail: Govern has an audit feature that allows the user to track 
basic modifications to selected Govern tables, by function. Should a full 
exhaustive audit be required that includes creation and deletion information, 
select the Full Audit Trail option. Before enabling this option, it will be 

Note: If these options are not selected, the behavior of the Checkin/
Checkout feature will remain unchanged, i.e. pre Release 10.5.
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necessary to enable the Audit Trail option for the tables you want to audit. See 
“Audit Trail and Data Duplication Setup” on page 131. 

Process Card on Load: If selected, this will process the Summary Card 
when the User opens it, otherwise the Options screen is displayed and the 
User will have to press the Refresh button after the card is loaded.

Deed Process: Select this option to link the Deed Information and Sales 
Information functions in Govern. Refer to the Deed Information section in the 
Mass Appraisal Sales guide or in the Property Control guide for further details.

Deed Transfer Owner / Mailing: Select this option to automatically update 
the Mailing Index with new owner information from the Deed Information 
function.

Assign Permit During Split / Merge: Select this option to allow Govern 
users to re-assign permits to a new tax map number when performing a parcel 
split, merge or remapping. Refer to the Split / Merge / Remap section of the 
Property Control guide for details.

Note: Due to the fact that complete details are kept of all fields, a lot of data 
may be generated; enabling this option may have storage 
implications.
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Assign Multimedia During Split / Merge (All Department): Select this 
option to allow Govern users to re-assign multimedia files to a new tax map 
number when performing a parcel split, merge or remapping. Refer to the Split 
/ Merge / Remap section of the Property Control guide for details.

Assign Misc. Structure During Split/Merge: Select this option to 
automatically move a misc. structure with a building during a Split/Merge 
process. Refer to the Mass Appraisal Miscellaneous Structures guide for 
details.

Warning on PGM Version Error: Select this option to prompt users when 
a more recent version of Govern Software is currently available. If this option 
is not selected and the Database version does not match the Application 
version, Govern applications will not start. If this happens the Administrator 
can launch Govern Updata and activate the option from there.
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FAQ Buttons by Department: Select this option to save your Frequently 
Asked Questions (FAQ) by department. Deselect this option to use the same 
FAQ throughout the organization. See New Command Buttons on page 257 
for details on the FAQ feature.

Creating Jurisdictions

Jurisdictions are set up through the VT_USR_ JURISD validation table. See 
Validation Tables on page 85.

 

Spell Checking Features

Use Word Spell Checker: Select this option to use the spell checking 
feature throughout Govern. This feature uses the spell checker that is installed 

with Microsoft® Word or the Microsoft® Office suite.

There are four (4) steps required to configure spell checking:

STEP 1 - Verify Installation of MS Word or Office

1. Ensure that Microsoft Office® Word® or the Microsoft Office Suite with the 
Spell Checker is set up on each computer. The default language selected 
in Word is used in Govern; for example, American English, Canadian 
English or Canadian French.

STEP 2 - Govern Admin Configuration

1. In Govern Admin, select Parameters > System Registry Maintenance. 

Note:  If you are using jurisdictions with the Mass Appraisal module, the 
code must be a number between two (2) and 32,760.

Note: You can increase the security of the system by applying user 
permissions by jurisdictions. See Groups of Users on page 74.

Note: The following steps must be performed by someone with system 
administrator right.
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2. In the System Registry Maintenance form, under the Options tab, select 
the Use Word Spell Checker option; click Save to save your changes.

It is now necessary to enable the checking process on a field by field basis in 
Govern for Windows.

STEP 3 - Govern for Windows Configuration

Spell Checking by Fields

The spell checker is used on specific memo or text fields. When the spell 
checking option is activated in the Govern Admin, the individual fields can be 
specified using Field Setup Mode in Govern for Windows. See “Validation 
Type group” on page 241.These steps must be performed by a system 
administrator.

3. In Govern for Windows, Use the Field Setup Mode to enable spell 
checking for individual fields. See Field Setup Mode on page 237, and 
Validation Type group on page 241 for details.

4. Exit Field Setup Mode; select Setup > Cancel Field Setup Mode.

STEP 4 - Spell Checking in 
Govern for Windows

Now, only the memo and text fields with 
spellchecking enabled will be reviewed 
by the spell checker when the form is 
saved.

To perform a spell check, in Govern for 
Windows:

5. Select Options > Spellcheck, to 
enable spell checking; a check mark 
will appear beside the option in the menu.

Note: “Spell checking” is now enabled, and will appear as a menu option in 
Govern for Windows, but until you specify which fields in which forms 
are to be checked, spelling verification will not occur.

Note: If Govern for Windows was open during your modifications in Govern 
Admin, you will need to close down and re-open Govern for Windows.FI
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6. Select a function that has Spell Check enabled on text and memo fields.

7. Make any required text entries; click Save.

Prior to saving the form, the spell check Spelling form will appear highlighting 
suspect words. As with traditional spelling checkers, you will be prompted with 
recommended changes, or the option to ignore. When no longer required, the 
option to spell check can be turned off by the user.

To turn off spell checking:

1. Select Options > Spell Check; the check mark will disappear from the 
menu option.

Track Emails sent by Activities: Emails may be sent as a result of an 
activity step. Select this option to enable the system to track these messages. 
See Messgaing System in the Permits & Licenses guide for details. 

Daemon Server group

The Daemon Server can be used for Tax Assessment and posting to Accounts 
Receivable, as well as Mass Appraisal computations.

Online Start After (Seconds): Enter a delay (in seconds) for starting the 
Daemon Server This feature is used for Mass Appraisal calculations launched 
from a Govern function. If there is no delay, the Daemon Server starts as soon 
as the user clicks the Save button. This presents a problem if the user saves a 
modification, then revises and clicks Save again immediately afterwards. To 
prevent a lock being placed on the server, enter a delay.

Batch Max Records: Enter the maximum number of records to be sent to 
each server for batch processing.

See Sending Computations to the Daemon Server on page 297, for details on 
the Daemon Server.

SMTP Setup group

The parameters in this section are used to provide both e-mail service for the 
eComponents, and for e-mail notifications for batch processes. Refer to the 
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eProfile guide and to Setting up E-mail Notification for Batch Processes on 
page 310 for details. 

Host Name: Enter the host name of the server.

User ID: Enter the user identification for the e-mail account, from which 
messages are sent.

Password: Enter the password for the e-mail account.

Port: Enter the port for the e-mail service. By default, this is set to 25.

Test (button): Click Test (A) to verify functioning of your email connection.

 When you click send, you may encounter the following notification message. 

Click Allow to enable the test to proceed. If successful, a confirmation 
message will be printed in Red near the botton of the test screen.
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If you encounter a failure in the test, refer to the link indicated below for a 
possible workaround.

Issues with sending emails in Activities

There is a known issue that can occur within the Activities function. When an 
activity step involves the sending of an email via Microsoft’s Messaging 
Application Programming Interface (MAPI). See Issues with sending emails in 
Activities in the Troubleshooting section of the Getting Started guide, for 
possible workarounds.

When an activity step triggers the sending of an email message, the following 
screen has been observed:

Resolution - Option 1

This issue can be resolved with a Hotfix that is available by request at the 
following link:

http://support.microsoft.com/kb/980681

Note: The Hotfix package is by request only; an email contact will have to be 
provided in order to receive it.
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Resolution - Option 2

An alternative resolution is to request from MS Govern Technical Support the 
NetEmailerSetup.exe patch. Installation of this patch will resolve the 
issue.

Support for USPS Intelligent Mail Barcodes

The Intelligent Mail Barcode (formerly known as the 4-State 
Customer Barcode) is used to sort and track letters. Intelligent Mail 
barcode technology, combines the capabilities of the POSTNET™ 

barcode and the PLANET Code® barcode into one unique barcode.

For support of the Intelligent Mail barcode, configuration parameters have 
been added to the System Registry Maintenence form. Barcode formats that 
are supported are IMB_31 and IMB_65. 

Note: Users of the MelissaDATA address verification service should note 
that Melissa Mail +4 is NOT required for the Intelligent Barcode 
process. Melissa + 4 is a service for zip code validation and sort order. 
Although the MelissaDATA service performs a zip code validation, it 
does not perform the sort order. The sort order is not required because 
the intelligent Barcode has its own sort order encoded within the code.
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Intelligent Barcode group

Barcode ID: This information identifies the presort information. The Barcode 
ID field should be "00" (zero-zero) with the exception of automation-price 
eligible flat-sized mail bearing a printed optional endorsement line (OEL). 
Enter the ID of the Barcode (2 digits, the 2nd digit must be 0-4)

Service ID: This parameter identifies the class of mail; type the Service ID in 
this field (3 digits). Users should refer to the USPS Website for information 
related to the 

Mailer ID: This is the number that uniquely identifies the mail owner or 
mailing agent; enter a 6 or 9 digit Mailer Identifier number.

Serial Number: Specify a serial number. This is a 9 digit code when used 
with a 6 digit Mailer ID, or a 6 digit code when used with a 9 digit Mailer ID.

Generate Barcode when update name: Select this option to 
automatically generate a barcode when a new name is created or an update is 
made in the Name & Address Maintenance function.

System Tables Changes

To implement this feature, the following system changes have been made to 
format Name and Address (in GovBatch), and perform Name and Address 
verification with MelissaDATA service if installed.

• The IMB_31 and IMB_65 barcode information are generated in the 
NA_NAMES.IMB_31 and NA_NAMES.IMB_65 tables, respectively.

• Addresses are corrected and formatted in (Table: 
NA_LK_NAME_ADDRESS)

• IMB_31 and IMB_65 barcodes are generated in other addresses (Table: 
NA_LK_NAME_ADDRESS).

• Fields added in (Table: NA_NAMES and NA_LK_NAME_ADDRESS).

Note: The information for the following fields will be provided by the USPS 
provider when an application is made. Configuration information can 
be found on the USPS user gateway at https://gateway.usps.com/
bcg/login.htm
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Barcode Setup for OCR and PostNet Billing

Previously, modifications to barcode fonts required special assistance for 
configuration. With this option, configuration of Barcode, OCR, and PostNet 
fonts, is now accessible to users with administrator-level access.

Bill Fonts group

OCR / PostNet barcodes can be generated and included in Govern generated 
reports such as tax bills, invoices, etc.

Bill Fonts and Crystal Reports

The configuration of Bill Fonts option does not apply to Crystal Reports. 
Crystal reports are self contained, i.e. their fonts are embedded within the 
report, and therefore external to Governs administration.

To configure Bill Fonts in Govern Admin...

1. Select Parameters > System Registry Maintenance.

2. In the System Registry Maintenance form, select the Options tab.

3. Look for the Bill Fonts group.
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4. In the Bill Fonts group, configure the parameters as per your requirements.

Configuring the USPS Barcode

To configure the USPS Barcode refer to the Getting Started release 10.7 user 
guide.

CCR Setup group

Use the following parameters to 
configure Centralized Cash 
Receipting (CCR). See CCR 
Setup on page 176 for more 
information.

Payment Method: Select a 
payment method that was 
created specifically for CCR 
transactions. See Validation 
Tables on page 85 to learn how 
to create a CCR Payment 
Method. (Table: 
VT_USR_CCTYPE)

User ID: Select a user ID that 
has been defined for CCR from 
the drop down menu. See User 
Maintenance on page 60 for 
details on creating a User ID; 
you might choose an ID called 
CCR Transaction Type. (Table: USR_USERFILE)

AR ID (for MCR): Enter an AR_ID that will be used for MCR (Misc. Cash 
Receipts)

MB ID (for MCR): Type in the MB_ID for MCR (Misc. Cash Receipts)

Note: Barcodes and barcode readers are specialized in that users cannot  
use any barcode font. Refer to the information supplied with your 
reader or scanning system, to find out what fonts are compatible with 
your system.
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NA ID (for MCR): Enter the NA_ID that will be used for MCR (Misc. Cash 
Receipts)

Connections Tab

Database Connections for Crystal Reports

Database Server: Enter the name of the database server that will be 
accessed.

Database Name: Type in the name of the database that you are connecting 
to.

User ID: Enter your user ID to access the database.

Password: Type your password to access the database.
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Enable SQL Reporting Services

SQL Server Reporting Services (SSRS) is a database reporting solution that 

is available with Microsoft® SQL Server® (Version 2005 and later). Govern 
Version 9.5 and above offers support for SSRS.

Server Connection for SQL Reporting group

Server Path: Enter the full path to the SQL report server.

Note: Users intending to use SQL Server Reporting Services (SSRS) must 
ensure that the.NET Framework 2.0 or higher is installed on their PC.

Note: For full details on Govern for WindowsTM implementation of SQL 
Server Reporting Services (SSRS), refer to the “Documentation & 
Standards for SQL Server Reporting Services” document.
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Authentication Type

There are two (2) methods of authentication available when connecting to the 
report server. 

Windows Integrated Security: The Windows Integrated Security option is 
typically used when the Kerberos authentication protocol is enabled, or when 
the servers are all located on the same computer with Kerberos disabled. It 
will pass the login of the current user accessing the report on the server. While 
using this option, the windows account must exist on the SQL Server machine 
in order to be able to access the database.

Click this option to use the Windows Integrated Security.

Predefine Credentials: Predefine Credentials should be selected when 
additional access credentials are required for the server.

When the Predefine Credentials option is selected, fields to be completed 
are...:

• Username - Type in a username
• Password - Enter a password
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• Domain - Specify the domain that the aforementioned Username and 
Password belong to.

Report Folder

Specify a report folder.

Custom Folder

Specify a custom report folder.

Database Connection for SQL Reporting Service

Datasource Type: Choose the datasource from the drop down menu; 
options are:

• Oracle

• SQL Server

Database Server:  Indicate the name of the database server.

Database Name: : Specify the name of the database that will be used.

User ID: : Type in a username.

Password:  Enter a password.
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Configuration Parameters for iNovah Integration

New administrative parameters have been added to the Connection 
tab of the System Registry Maintenance form. This allows entry of 
parameters required for configuring iNovah integration. There are 

new parameters to enable and enter the Web Service URL, User ID, and 
Password used to access the iNovah system.

To use the iNovah parameters...

1. Select Parameters > Edit the System Registry...

2. Click to select the Connection tab.

3. Click to select the Use iNovah Web Service URL option to enable the 
fields.
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MS Govern Batch (.NET) can be called from 
GovBatch

The MS Govern Batch .NET application can be called from 
GovBatch release 10.7. This will allow for users of GovBatch to 
access Govern.NET batch processes.

Where to Find...: In Govern Admin.

1. Select Parameters > Edit the System Registry...

2. In the System Registry Maintenance form, click the Connections tab (A).

3. Locate the DeplyEZ (ClickOnce) Application Batch Shortcut (B) 
parameter.

Note: This functionality is only available to users that have obtained licenses 
for Govern.NET and have the required applications installed.
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Login Setup tab

Login Setup tab parameters

Active Directory Configuration group

Use Active Directory: Click this option to use Active Directory.

Note: It is critical that Active Directory is properly configured and 
synchronized with Govern before selecting this option; failure to do so 
can result in an inability to access your database. Refer to the Govern 
Integration with Active Directory guide

Note: When this option is not selected, the parameter to enter Users Inactive 
Date will be inactive, i.e. this option is disabled when Active Directory 
is not being used.
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Request password double check: Select this option if you would like to 
enable password confirmation.

SQL Administration group

User ID: Enter your SQL Administrator user ID.

Password: Type in your password.

Re-Enter Password: Re-enter your password for confirmation.

Use this Connection for all Users: Click this option to indicate that all 
users will be using this connection.

Govern Login Settings group

Number of Attempts to Access Govern

It is possible to set a maximum number of user access attempts in Govern. As 
an administrator, it is possible to:

• View details of all successful and unsuccessful logins

• Clear the log files

• Create a custom error message for that will be displayed to the user.

Limit Login Attempts: Click this option to limit the number of login 
attempts allowed by the user. If not selected the user will have an unlimited 
number of attempts.

Note: In order to use this function, it will be necessary to be logged in with a 
valid SQL Administrator account password.
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Number of Attempts: When Limit Login Attempts is selected, enter the 
desired number of attempts that will be given to the user to access Govern.

To set Number of Attempts:

1. In the Govern System Administration window Select Parameters > Edit 
the System Registry... 

2. Select the Login setup tab.

3. In the Govern Login Settings frame, click Limit Login Attempts to activate 
the fields.

4. In the Number of Attempts field, enter the number of attempts that the user 
will be allowed.
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Time before reset (in minutes): When Number of attempts has been 
specified, and the user has failed to login successfully, this is the mandatory 
wait time before the user can make another login attempt. 

To set the Time before reset (in minutes):

1. In the Govern System Administration window Select Parameters > Edit 
the System Registry... 

2. Select the Login setup tab.

3. In the Govern Login Settings frame, if not already selected, click Limit 
Login Attempts to activate the fields.

4. In the Time before reset (in minutes) field, enter the amount of minutes 
before reset.

Customize Attempts Reached Message: Type in this field the message 
that the user will see in the event of a failed login attempt.

To create a Custom Error Message:

1. Select Customize Attempts Reached Message,

2. Type a message of up to 256 characters in length, including spaces.

3. Click Save.

Manage User Login

As part of the enhanced security features of Govern, the Manage User Login 
feature allows the Super User to administrate the Govern Login settings. 
When a user has exceeded the maximum number of login attempts permitted 
they will have to wait for the set number of minutes before the system allows 
another attempt. Only an administrator is able to override the Time before 
reset option. 

The Manage User Login feature allows an administrator to reset any user 
that has exceeded the system allowed number of tries.

Sample Message:
 Maximum login attempts reached; contact your System Administrator.

Note: There is a maximum of 256 characters including spaces allowed in this 
field.
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To access the User Login Management screen:

1. In Govern Admin select Parameters > Manage User Login…

2. Locate the user that has exceeded the maximum number of attempts in 
the list.

3. Select the checkbox in the last column, click Remove to reset the user.

4. A confirmation screen will appear, click Yes to reset the user.

After the user has been removed from the list, they will once again be able to 
attempt to access Govern with their same preset number of attempts.
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User Registry Maintenance

Define default parameters at the user-level on the User Registry Maintenance 
form. These parameters include user identification and the default language 
by computer; default paths to the Help files, bitmaps, reports and query 
definitions; GIS definitions; such as GIS link type, project, view and theme, 
P_ID column name; Melissa data and the Document Locator External folder. 
These parameters are saved to the SY_REGISTRY and USR_REGISTRY 
tables. 

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Parameters > Edit the User Registry

Overview

Note: Certain parameters are also set on the System Registry Maintenance 
form. Those set for the user have precedence over those set at the 
system level.
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User ID: This field displays the current User ID.

Language: This field displays the default language defined for the current 
user. To change the default language, select an alternate from the drop-down 
list. 

Multilingual: Select this option if you are supporting two or more languages, 
for Govern functions; for example, if you are supporting English and French or 
English and Spanish. You also need to set this option on the System Registry 
Maintenance form.

Saving Parameters by User ID

Click Save to save the selected language for the displayed User ID. These 
parameters are saved in the USR_REGISTRY table (KEY_TYPE = 1).

 

Saving Parameters by Computer Name

Click Save to save a new User Registry Maintenance setup, or modifications 
to an existing one, for the current Computer Name to the USR_REGISTRY 
table (KEY_TYPE = 2).
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Computer Name: This field displays the current Computer Name.

Address validation: Select an Address validation application 
option from the drop down menu. Available options are Melissa or 
iAddress. To specify no verification application, leave blank this 

parameter blank.

Terminal Server PC: Select this option if you are running Govern through a 
Terminal Server on a network. An identification label is automatically assigned 
to each terminal. This is made up of the user ID appended to the terminal 
server name. Four digits are reserved for the user identification and 11 for the 
server name.

Use Melissa Data: Select this option if you are using Melissa address 
verification.

Entering User Registry Maintenance Paths

You can now select the drive and directory to define the required 
paths for the User Registry Maintenance information
.

Bitmap Folder: Enter the path for the Bitmaps folder. To select the path, 

click  Then, select the drive and directory. The full path is displayed 

along the bottom of the form. Click OK

Note: You can enter Universal Naming Convention (UNC) commands for the 
path information instead of entering a map to the drive. Enter double 
backslashes for the server name and single backslashes to identify 
the directories; i.e., \\servername\path.
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Imaging Editor Folder : Enter the full path to the Image Editor.

GIS Folder & Scripts (or ArcView 8 Project (*.mxd)): 

If you are using Arcview 8.x or Arcview 8.x with Tax Map #, enter the path as in 
the following example:

Otherwise, enter the path as follows:

Note: Once a valid path is entered, the Imaging Editor option will be 
enabled on the Tools menu in Govern.

c:\Govern\gis\gis\govern31.mxd

GIS=C:\ESRI\AV_GIS30\ARCVIEW\BIN32\arcview.exe c:\Govern\ 
gis\gis\govern.apr govern,govern
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Reports Folder: Enter the path for the Reports folder. These are the 
standard reports included in the Govern package.

Query Definition Folder: Enter the path for the Queries folder.

Online Help Folder: Enter the path for the On-Line Help folder.

PDF Viewer: Enter the full path and executable (.exe file) for your PDF 
Viewer, in order to display PDF files, directly from the Multimedia Information 
and Multimedia by Name functions, in the specified viewer. This path can also 
be defined on the System Registry Maintenance form.

AutoCAD Viewer: Enter the full path and executable (.exe file) for your 
AutoCAD Viewer, in order to display AutoCAD files, directly from the 
Multimedia Information and Multimedia by Name functions, in the specified 
viewer. This can also be defined on the System Registry Maintenance form.

Melissa / iAddress Data Folder: Depending upon your choice 
for an address verification application, enter the path to the Melissa 
DATA or iAddress folder. This is important if you are running 

Govern offline. SeeOption to Use iAddress for Address Verification on 
page 59.

If you are including MelissaDATA’s Residential Business Delivery Indicator 
(RBDI) add-on with your existing Melissa Address Verification service, place 
this in the same directory. Refer to the Property Control guide for details.

Note: Before setting up your directory paths to the standard reports, on the 
System Registry Maintenance and User Registry Maintenance forms, 
ensure that you open the directory for your state and copy the reports 
to the Standard Reports directory. See Appendix A: Standard 
Reports on page 320 for details.

Note: You should enter the path to the data folder in  the System Registry 
Maintenance form.

NEW

FI
N

AL
 D

R
AF

T



Page 58 © 2013 MS Govern

Super User

GIS Link Type: Select the GIS Link from the drop-down list or leave this 
field blank to use the default GIS link type set on the System Registry 
Maintenance form.

P_ID Column Name: After entering the GIS View and Theme, enter the 
P_ID column name, associated with the shape file to be used with the GIS 
application. When the application is loaded, the records in this column, 
matching those in the current recordset are highlighted.

Tax Map Column Name:  After entering the GIS View and Theme, enter 
the Tax_Map column name associated with the shape file to be used with the 
GIS application, if you are using ArcView 8.x with Tax Map Number. When the 
application is loaded, the records in this column, matching those in the current 
recordset are highlighted.

Default GIS View: If you have selected ArcView 8.x GIS link type, then you 
must enter the GIS View to be used as the default.

Default GIS Theme: If you have selected ArcView 8.x GIS link type, then 
you must enter the GIS Theme to be used as the default.

Bitmap Folder: Enter the path for the Bitmaps folder.

Custom Reports Folder: Enter the path for the Custom Reports folder. 
Custom Reports are created specifically for a client or by the client.

GIS Link Definition

ArcView 8.x ArcView 8.x application

ArcView 8.x Tax Map # ArcView 8.x application with search by Tax Map 
Number

JMap Kheops application

MapInfo MapInfo application

Horus Kheops application

No None

Test Test

Yes ArcView 3.3 Application
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Document Locator External Folder: Specify the path for the external 
multimedia directory. 

Option to Use iAddress for Address Verification

If you wish to use the iAddress address verification application, you 
must select the iAddress option under Address Validation in the 
User Registry Maintenance form.

To specify iAddress as an address verification application in Govern Admin...

1. Select Parameters > Edit the User Registry...; in the User Registry 
maintenance form, click the Computer Name option (A).

2. Select the iAddress option from the drop down menu; click Save.

3. From the menu, select Parameters > Edit the System Registry...

4. In the System Registry Maintenance form, manually enter the path to the 
iAddress data folder (B) or click “...” to navigate to the target directory.

Note: A user license for the iAddress application is required.
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User Maintenance

The User Maintenance form is used to maintain user data. In this form form, 
you can create new users, set access rights, or remove user profiles that are 
no longer active. 

This form also includes a tab for setting access rights to the Mass Appraisal 
Validation Tables. Refer to the Mass Appraisal General Information guide for 
details.

To access this form, from Govern’s main screen, select Tools > System 
Administration (Govadm32.exe)

OR

Click Applications in the Side Navigation Bar to display Govern applications

5. In Govern Admin select Setup > User Maintenance

Overview
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User Maintenance Command Buttons

Creating a User: Click New to clear the form and create a new user profile.

Saving a User Record: Click Save to save a new user profile or 
modifications to an existing one.

Deleting a User: Click Delete to remove the current user record.

Browsing User Records: Click Browse to view a list of the existing user 
profiles.

Exit: Click Exit to close the form. A confirmation message appears if there 
are any unsaved modifications. 

User Maintenance Parameters

User ID: Enter the user identification required for login.

Password: When Govern is installed as client/server, the user ID and 
password from the server are used and a password is not mandatory. If a 
password is to be used, it is encrypted in the database and is not displayed on 
the screen.

Name: Enter the full name of the user.

Group of Users: Select a group for the user, if required. 

Creating a Group of Users

1. Click the  button to the right of the Group of Users list box. This opens 
the Group Validation Table Header form.

Note: A user can be a member of a single group only. If a user is already a 
member of one group and you add the user to a second group, the 
user is automatically removed from the first group. 

Note: User access rights override group access rights.
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2. Create the group as defined under Creating a Group on page 75.

3. Add users to the group by selecting them from the drop-down list.

Primary Department: Select the Primary or default department for the 
current user. The primary department is important for the following reasons:

• This department is automatically selected when the user launches Govern.

• The default fiscal year of this department is used by default in Govern 
Admin and Govern Batch Processing. 

Creating a New Department

Open the Department Setup form, in order to create a new department or 

make a modification, click the  button. See Department Setup on page 101 
for details on this form.

E-Mail Address: Enter the user’s e-mail address. This e-mail address is 
used in the Messaging System function within the Permits & Inspections sub-
system.

Language: Select the default language for the current user.

Inactive Date: Enter an expiration date for the account; i.e. the date after 
which the account is no longer active.

Initials: Enter the initials of the user; use a maximum of three (3) letters.

Note: A user can be a member of a single group only. If a user is already a 
member of one group and you add the user to the selected group, the 
user is automatically removed from the first group. 

Note: If you are using ArcView® with Govern, users need to be assigned a 
Primary Department, in order to launch Govern directly from the GIS 
application.

Note: Once the default year is changed, using the Set Default Year option in 
the File menu in Govern Admin or Govern Batch Processing, the 
application uses this year instead of the default.
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Enable Outlook Scheduling: Select this option to link Microsoft® 

Outlook® to the Inspection function for scheduling. Inspections can be 
automatically added to the Outlook Calendar or Task List. Refer to the Permits 
& Inspections guide for details.

Lite User : Select this option to designate the user as a Lite User and limit 
access to options on the Property Control Search screen. The following 
screen is used in place of the screen.

Disable Editing on Query by SQL: Select this option to restrict the 
selected user from modifying or deleting SQL queries on the Query by SQL 
function in Govern. The user will be able to select and execute stored queries 
but unable to make changes, to create new queries or to select queries from 
another file. The Edit box, Retrieve SQL and Save SQL buttons are disabled:
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Access to Inspector Web Services: Select this option to allow the 
selected user to have access to the Mobile Inspections web services.

Access Types

There are four (4) user access types in Govern: (Table: VT_SY_USR_TYPE)

• Super User: giving the user access to all functions, all forms and all 
features, including the system tables. 

Note: User with Super User or administrator rights can run Action or 
Selection queries, from this function. Other users can run Selection 
queries only. See Selection Queries and Action Queries on page 216 
for details on queries.

Note: Super User Access must be used with caution. Improper use may 
harm the integrity of the software. For security reasons, User 
accessibility should be limited.
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• Administrator: giving the user access to all menu options with the 
exception of the system tables. This type is recommended for the System 
Administrator.

• User: gives the user access to the functions and forms assigned by an 
administrator or Super User. 

• Inquiry Only: offers the user view-only access to the functions and forms 
defined by an administrator with Super User rights. See Inquiry Only User 
Access on page 65.

Inquiry Only User Access 

You can set Inquiry Only access for users or clients who need to view, but not 
modify data.

A different license can be purchased for these users. This information is 
displayed on the Govern Admin About box, available through the Help menu.

See the following sections for more information on user access:

• Department Setup on page 101
• Functions Setup on page 123
• Menu Security Setup on page 72
• Groups of Users on page 74
• Dataset Source Setup on page 98
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• Providing Access to a Jurisdiction on page 76

Super User and Full Access Rights

When you set user access rights to the functions, there are also four levels of 
Access Types:

• Full Access Rights
• Create Modify and Delete
• Create and Modify
• Inquiry Only

The following table lists the permissions, by function, that are available only to 
Super Users and to those assigned Full Access Rights to the specified 
function.

See Functions Setup on page 123 for more information on assigning user 
access to the functions.

Note: Super Users are automatically assigned Full Access Rights to all 
functions.

Function Full Access and Super User Rights

A/R Inquiry Add notes and payment plan information

Modify Due Dates with removal of a protest flag

Reapply Payment Plan Distribution records and 
recompute Summary Record Card data

Recalculate penalties and interest

Modify ACH Information

ACH Information Modify the Prenoted option, on the ACH Information 
by Name function, that indicates the account was 
included in the Prenotification batch process.

Modify the ACH Information selected for the Real 
Estate and Utility Billing Mailing Indexes or Personal 
Property, Motor Vehicle, Boat and Aircraft Excise Tax 
Maintenance functions. The ACH Information 
selection option is visible only to users with Full 
Access Rights to these functions.
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Allow Creation of... group

Select the following options, as applicable, to provide security for property and 
name and address records. See Privacy / Restrictions for Names group on 
page 105 for full details on protecting name and address records:

• Parcels: Select this option to permit the user to create new parcels. 
Otherwise, deselect the option.

• Names: Select this option to permit the user to create new name and 
address records. Otherwise, deselect the option.

• Flags: Select this option to permit the user to add and remove messages 
to and from property records. Messages can be set up for the department 
or for the organization, using the Department Flag and Global Flag 

Historical Year Modify data in Historical Mode

Inspections Modify an Inspection record with Completed status.

Name and Address 
Maintenance

See Department Setup on page 101 for information on 
access rights for name and address records.

Payment Data Entry Modify or override interest charges.

Permit, Workflow and 
Offense functions

Modify the Permit, Workflow or Offense Number 
even after the permit is completed.

Delete the Historical flag, after it has been set.

Property Location Delete all property location records, even sequence 0 
records

Query by SQL Execute Action Queries. Other users can execute 
Selection Queries only.

Real Estate and Utility 
Billing Mailing Indexes

Modify the Mortgage company record.

System Activities Delete an Activity.

System Tables Delete System Tables (Super Users only)

Function Full Access and Super User Rights
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options in Govern. The message is then viewed by all members of the 
department or organization, when accessing the record.

Jurisdiction

A Jurisdiction is a defined area that a user has power or authority to apply the 
law; to grant the user access to a jurisdiction, select the jurisdictions, from the 
lower drop-down list. This list box contains the jurisdictions created in the user 
validation table, VT_ USR_JURISD.

.

You can also set user access rights by jurisdiction. For example, you can grant 
Full Access Rights to some jurisdictions and Inquiry Only access to others. 
Previously, you could only grant or deny access. Now, you have four levels of 
access rights:

• Full Access Rights: The user can view, create, modify and delete data 
including the historical data for the specified jurisdiction.

• Create, Modify, Delete: The user can view, create, modify and delete data 
for the specified jurisdiction.

• Create and Modify: The user can view, create and modify data for the 
specified jurisdiction.

• Inquiry Only: The user is only able to view the data in the specified 
jurisdiction.

To grant access rights to a jurisdiction:

1. Select the user record you want to modify.

2. Select the jurisdiction from the Jurisdiction drop-down list.

Note: Messages can also be added to a property through the Accounts 
Receivable Inquiry function. Refer to the Accounts Receivable guide 
for details.

Note: This feature is enabled only if the Support of Multiple Jurisdictions 
option is selected on the System Registry Maintenance form.

Note: Only a Super User has automatic access to all jurisdictions.
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3. Highlight the jurisdiction in the list box.

4. Click S to open the Access Rights screen.

5. Select the applicable Access Type from the list.

6. Click OK.

7. Repeat steps 3 to 6 for each jurisdiction the user can access.

To remove all access rights to a jurisdiction:

1. Select the user record that you want to modify.

2. Highlight the jurisdiction in the list box.

3. Click R.

You can also set up group access rights to the jurisdiction using the Group of 
Users form. See Groups of Users on page 74.
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Dataset Source

This list box displays the Dataset Sources the user can access in order to 
retrieve records. Select additional Dataset Sources, from the drop-down list, 
(Table: VT_SY_APPL). Click Save after you have made your selection(s).

For more information on Dataset Sources, see Dataset Source Setup on 
page 98.

Removing a Dataset Source: To remove a Dataset Source, highlight it in 
the list and click R.

Dataset Source Access by User and Group: Highlight a Dataset 
Source in the list box and click S, to view lists of the users and groups who 
have access rights.

The selected Dataset Source is displayed in the list box on the left.

Users: This list box displays the users with access permission to the current 
record.

Selecting Users: To provide additional users access to the selected 
Dataset Source, select them.

Groups: This list box displays the groups with access to the Dataset Source.

Selecting Groups: Select the groups from the drop-down list or click  to 
open the Group validation table and create a new group. See Group Validation 
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Table on page 75. 

Removing User or Group Access to the Dataset Source: Select the 
users or groups in the applicable list and click Remove.

Note: User access rights override group access rights.
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Menu Security Setup

Launch the Menu Security Setup form to set access rights to the forms and 
features in Govern Admin.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Menu Security Setup

Overview

Note: You need to set access rights for users assigned User Access Type 
rights. By default Super Users and Administrators have access to all 
Govern Admin forms. See Access Types on page 64 for full details.FI
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Granting and Restricting Access to the Batch Forms

To grant or restrict access to a Govern Admin form:

1. Select the user or users from the list box.

2. Select the menu, where the form is listed.

3. Select the form to grant access. Deselect it to restrict access.

4. Click Save.

5. Click Exit to close the form.

Click Grant Access to all Menu 
Items to grant the selected users 
access to all features and processes 
in Govern Admin.

Click Remove Access to all Menu 
Items to block the selected users 
from all forms and features in Govern 
Admin.

Tip: You can select as many users as you like at the same time. To select a 
number of users that are listed consecutively, select the first user, then 
hold down the Shift key and select the last in the list. If the users are not 
listed consecutively, hold down the Ctrl key while selecting them. To 
deselect a selected user, hold down the Ctrl key and reselect the user.

The user has access to all forms and features that are selected on 
the menu.

Tip: To restrict access to specific forms, you can open the menus and 
deselect the forms.

Tip: To grant access to specific processes, you can open the menus and 
select the forms.
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 Groups of Users

Define groups of users and set access rights on the Groups of Users form. 
Enhance security by setting permissions by jurisdiction. 

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Group of Users

Group: The Group list box displays all the groups that have been defined in 
the system. When you select a group in this box, the group members are 
displayed in the Users list box. 

Users: The Users list box displays all the users who are members of the 
selected group. To add a user to this list, select the user name from the drop-
down list. To remove a user from the list, select the user and click R.

Overview

Note: In Govern, a user can be a member of a single group only.
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Jurisdiction: The Jurisdiction list box displays the jurisdictions that the 
selected group can access. To provide access rights to a jurisdiction, highlight 
the group, then select the jurisdiction from the drop-down list.

Creating a Group

Click the  button to open the Group Validation Table Header form and 
create a group. 

Group Validation Table: From the User Maintenance function, Group of 

Users field, click the  button to open the Group Validation Table and create 
a new group.

Table Name: This field displays the Validation Table Name Group.

Year: N/A

Note: The Jurisdiction list box appears only if the Support of Multiple 
Jurisdictions option is selected under the Options tab of the System 
Registry Maintenance form. See System Registry Maintenance on 
page 16.

Note: Individual user access rights will override group access rights.
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Code: Enter a code to identify the group in the database.

Short Description: Enter a short description. This is used for fast data entry 
and look-ups where space is limited on forms.

Long Description: Enter a long description. This is displayed for look-ups, 
on forms and normally used for reporting.

Full Description: N/A

Providing Access to a Jurisdiction

To provide access to a jurisdiction for a group:

1. Highlight the group in the Group list box.

2. Select the jurisdiction from the drop-down list in the Jurisdiction list box.

3. Click Exit.

For details on granting access to a user, see User Maintenance on page 60.

Setting Security Access Rights to a Jurisdiction

You can set specific access rights to each jurisdiction for the group. For 
example, you can grant Full Access Rights to some jurisdictions and Inquiry 
Only access to others. Previously, you could only grant or deny access. Now, 
you have four levels of access rights:

• Full Access Rights: The group can view, create, modify and delete data 
including the historical data for the specified jurisdiction.

• Create, Modify, Delete: The group can view, create, modify and delete 
data for the specified jurisdiction.

• Create and Modify: The group can view, create and modify data for the 
specified jurisdiction.

• Inquiry Only: The group can only view the data in the specified 
jurisdiction.

To grant access rights:

1. Select the group in the Group list box.

2. Select the jurisdiction from the Jurisdiction drop-down list.
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3. Highlight the jurisdiction in the list box.

4. Click S to open the Access Rights screen.

5. Select the applicable Access Type from the list.

6. Click OK.

7. Repeat steps 3 to 6 for each jurisdiction the group can access.

To remove all access rights to a jurisdiction for the group:

1. Highlight the jurisdiction you want to remove in the Jurisdiction list box.

2. Click R.

You can set access rights to the jurisdiction for an individual user on the User 
Maintenance form. See User Maintenance on page 60.

Note: If you select a user from the Users drop-down list, the user is added to 
the selected group and removed from the group in which the user was 
previously a member.
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Global Field Validation Mask

With the Global Field Validation Mask function, you can define a set of Field 
Masks that can then be applied to fields in Govern for Windows functions. 
Applying a field mask automatically formats the data entered in the field 
according to your pre-set pattern. For example, you can define a pattern for 
phone numbers and apply it to the Telephone fields in Govern. Then, if the 
user enters 18005618168, this is automatically formatted as 1-800-561-8168.

Use this function for phone numbers, postal or ZIP codes, Tax Map Numbers, 
Social Security Numbers, etc.

To apply a field mask, follow the instructions under Field Setup Mode on 
page 217.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Global Field Validation Mask

Creating a Field Mask: To create a new field mask, click New.

Saving a Field Mask: Click Save to save a new field mask or modifications 
to an existing one to the USR_FIELDS_MASK table.

Deleting a Field Mask: Click Delete to delete the current record.

Overview
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Browsing Field Mask Records: Click Browse to view a list of the existing 
field masks.

Name: Enter a name for the field mask. This appears in the drop-down list 
that is displayed when you apply the mask. See Field Setup Mode on 
page 217 for details.

Field Mask: In this parameter, enter the text string that will be used for your 
field mask.

The following tables list the symbols that can be used in field masks. The 
second table lists symbols that can be used for Tax Map Numbers only:

Valid Masks for all Types of Fields

Note: You can enter a maximum of 64 characters in this parameter.

Symbol Description

# Numeric value. Exact number of digits must be entered as 
defined in the “New Database Field Creation”.

 You can use the “-” (Dash) to separate the values.

9 Numeric value left justified compressed with trailing zeroes.

0 Numeric value right justified compressed with leading zeroes.

> Alpha & Numeric values. Alphabetic characters must be in 
uppercase. If only ONE “>” is entered, then the number of digits 
entered can be LESS than defined in the “New Database Field 
Creation” Size. 

Otherwise, the exact number of characters must be entered as 
defined.

You can use the “-” (Dash) to separate the values.

< Alpha & Numeric values. Alpha in lowercase. If only ONE “<” is 
entered, then the number of digits entered can be LESS than 
defined in the “New Database Field Creation” Size. Otherwise, 
the exact number of characters must be entered as defined. You 
can use the “-” (Dash) to separate the values.
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Valid Masks for Tax Map and Lot Number Fields Only

Tax Map and Lot Numbers are special fields that are identified with the 
following names respectively, *parcel and *lot. These are default system 
reserved names that are used for searches. The field mask pattern can be 
modified, but the names cannot.

A Alpha character in Uppercase. Number of characters entered 
must be as defined in “New Database Field Creation” Size. 

You can use the “-” (Dash) to separate the values.

^ Used to separate different possible masks in the same pattern 
also used as an OR clause. Note that this character is not valid 
for Tax Maps and Lot Numbers.

! Alpha and numeric values as entered, both uppercase and 
lowercase. You can use the dash, — to separate values.

“ “ Leaves a blank space before the next series of characters, in the 
same text box.

EXAMPLE:
A zip code can take two (2) formats, five (5) digits, or the extended “ZIP + 
4” format. A pattern for these formats could be presented as: 
#####^#####-####
Valid entries for this pattern would be 90210 OR 20037-8001. Note the 
use of the caret “^” for the logical OR.

Symbol Definition

d Numeric value left justified compressed without trailing 
zeroes.
The “d” is not to be confused with the “9” mask used for all 
types of fields. The trailing zeroes are not saved within the 
database.

Symbol Description
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Validation Masks and the Database

To better understand how the Govern system processes Tax Map and Lot 
Numbers, we can look at the following example. If we look at the setup of the 
following field mask, we see the following in Govern Admin.

 The *parcel mask has a pattern of...

###-999-000-ddd-ZZZ-###-00

Z Numeric value right justified compressed without leading 
zeroes.
The “Z” is not to be confused with the “0” mask used for all 
types of fields. The trailing zeroes are not saved within the 
database.

. Displays the next series of characters in another text box 
with the period in between. This character is used as a 
separator.

: Displays a single “.” Inside the series of characters, within 
the same text field. This character is used as a separator.

“” Displays the next series of characters in another text field. 
This character is used as a separator.

- Displays a “-” (Dash) inside the series of characters, within 
the same text field. This character is used as a separator.

Note: If you are applying the Tax Map Number type field mask to added 
fields, and those added fields appear on a secondary tab or divider, 
you will need to reposition the text boxes using the Object Dragging 
Mode feature. See Object Dragging Mode on page 215.

Symbol Definition
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• ### - This indicates that exactly three (3) numeric characters must be 
entered

• 999 - The “9” indicates that a numeric entry must be made, up to three (3) 
characters. If three characters are not entered, any entry will be "padded" 
with leading zero’s; i.e. a user entry of 7 will result in 700 being entered, or 
12 will result in 120.

• 000 - The “0” indicates that a numeric entry must be made, up to three (3) 
characters. If three characters are not entered, the entry made will have 
zero’s added to it or "padded" with trailing zero’s. i.e. a user entry of 5 will 
result in 005 being entered, or 14 will result in 014.

• ddd - As indicated earlier, the “d” denotes that a numeric entry of a 
maximum of three (3) characters, must be made. If less than three (3) 
characters are entered, any existing entry will be “padded” with trailing 
zero’s. What differs this character from the use of “9” is that when it is 
stored in the database, the trailing zero’s are stripped out; i.e. 100 will be 
stored as 1, or 450 will be stored as 45.

• ZZZ - These characters indicate that a numeric entry of a maximum of 
three (3) characters must be made, if less than three (3) characters are 
entered, any existing entry will be "padded" with leading zero’s. What 
differs this character from the use of “0” is that when it is stored in the 
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database, the leading zero’s are stripped out; i.e. 009 will be stored as 9, 
or 073 will be stored as 73.

• ### - Exactly three (3) numeric characters must be entered; there will be 
no padding with leading or trailing zero’s.

• 00 - A numeric entry of up to three (3) characters must be made. 
• - - Dashes act as separators.

Note: If look at the entry of the P_ID in the database, we see that the Tax 
Map is stored in two (2) columns in the database, TAX_MAP and  
TAX_MAP_UFMT. The d and Z mask entries are saved with the dash 
“-” separator in the TAX_MAP column, but the trailing and leading 
zeros are removed.  In the TAX_MAP_UFMT column, the d and Z 
mask entries are saved with the trailing and leading zeros, but the 
dash “-” separators are not saved for the entire entered sequence.
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The shortened format for the “d” and the “Z” characters are used when 
indicating Tax Map and Lot numbers in, Reports, the Summary Record Card 
function, Labels, and Formatted Tax Map fields.
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Validation Tables

Maintain the System and User Validation Tables on the Validation Tables form. 
These tables are used to validate the information entered in the various fields. 
Create and maintain the elements of the tables on the Validation Codes form.

The Property Control Validation Tables used in the Property Area function, are 
maintained from a separate form. These tables are all saved by year and 
where applicable, by jurisdiction. See Property Control Validation Tables on 
page 97.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Validation Table or Property Control 
Validation Table

Overview
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Validation Table Header Fields

System: Select this option to view the System validation tables. Deselect it 
for the user tables. Users with Super User or administrator rights can view, 
modify and create the user tables from this form and any user has been 
granted access rights to the Validation Table Header form can view existing 
data and create new columns. See Menu Security Setup on page 72.

Table Name: This field displays the name of the table. Use a descriptive 
name such as state for State or strdir for street direction. The table name can 
be a maximum of eight characters.

Description: This field displays a brief description or title for the table.

Forms: This field displays all the forms that are related to the current table. 
The list of forms is used for information purposes only and cannot be modified.

Table Type: The Table Type is system-generated and is used, as follows:

• R: Regular
• A: Accounts / Receivable
• C: Property Control (for multimedia and zoning information)
• B: Property Control (for the Property Area function)
• M: Mass Appraisal
• P: Permits and Inspections
• S: Super User
• T: Tax: Aircraft, Boat, Motor Vehicle, Personal Property and Real Property
• U: Utility Billing

If you create a table through the Validation Table Header form in Govern 
Admin, it is automatically assigned the Regular table type.

Note: Govern Software Inc. maintains the system tables. Only the 
description may be modified by the user.

Note: The Table Type is used for informational purposes only and cannot be 
modified.
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Use Full Description: Select this option when you create a new table to 
enable the Full Description field on the Validation Table Header form. The full 
description can be used for reports.

Reserved User Validation Tables

The following Validation User Tables must be present and must contain the 
following codes

Table Name Description Code Description

Areatype Area Type e Effective

Brand Meter Brand b Badger

r Rockwell

Inspter Inspection territory * All

MAfrate Municipal 
Adjustment Factor 
Rate

1 Seasonal Residence

2 Single Family 
Residence

3 Multi Unit Residence

4 Mobile Home

5 Travel Trailer

6 Commercial

Messbill Messages Bill 1 General

2 Information Only

3 Third Party

4 Owner w/Mortgage

5 TSO/Mortgage

6 Second Half Bill

7 Duplicate Bill

Messtat Departmental 
Message Status

c Closed
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f Forwarded

s Scheduled

Mistype critical Critical

insp Inspection

reminder Reminder

Pmactaw Permit Activity 
Answers

1 Yes

2 No

3 Special 1

4 Special 2

Pmfeld_A Customized Fields Same as Pmfield

Pmfeld_AL Customized Fields Same as Pmfield

Pmfeld_B Customized Fields Same as Pmfield

Pmfeld_BL Customized Fields Same as Pmfield

Pmfeld_BN Customized Fields Same as Pmfield

Pmfeld_CO Customized Fields Same as Pmfield

Pmfeld_D Customized Fields Same as Pmfield

Pmfeld_E Customized Fields Same as Pmfield

Pmfeld_G Customized Fields Same as Pmfield

Pmfeld_L Customized Fields Same as Pmfield

Pmfeld_OF Customized Fields Same as Pmfield

Pmfeld_P Customized Fields Same as Pmfield

Pmfeld_PA Customized Fields Same as Pmfield

Pmfeld_PN Customized Fields Same as Pmfield

Pmfield Customized Fields basement_size Basement Size

estimated_cost Estimated Cost

first_floor First Floor

last_fee Last Fee

Table Name Description Code Description
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last_fee_date Last Fee Date

mezzanine_size Mezzanine Size

nb_of_items Number of Items

second_floor Second Floor

total_dimension Total dimension

total_fee Total Fee

User_amount User Defined Amount

Pmname Name Types appl Applicant

contact Primary Contact

owner Owner

Insp Primary Inspector

PMINTYST Inspection Types Failed Failed Inspection

Incomplete Incomplete Inspection

Passed Successful Inspection

Proptype Property Type 0 Mixed Use

1 Residential

2 Open Space

3 Commercial

4 Industrial

8 Mineral

9 Exempt

Qual Sale Qualification n Not qualified

q Qualified

u Unverified sale

Timecost Time Cost cont Contributions

time Time Cost Recovery

Cctype rf * Refund

Table Name Description Code Description
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New Reserved User Validation Tables 

The following table names are system reserved, but there are no reserved 
code names for them, i.e. the user is free to create names that conform to the 
restrictions of the parameter.

Validation Table Header Command Buttons

Viewing Validation Tables: Each validation table is saved as a separate 
record. Select the System option to view the system tables or deselect it to 
view the user tables. Then, use the right / left navigation arrows to scroll to a 

rev* Reversal

Note: You can change the description but not the codes for these tables.

Note: The codes rf & rev are not defined in the CCTYPE table but are used 
internally by Govern. They are unavailable to the user.

Note: Multiple Property Type Codes can be defined with the initial digits, 0-4 
and 9. For example, 01, 02 and 03 are mixed-use tables.

Table Name Description Codes

pmdivision Division Code User definable

pmcond Condition Code User definable

pmcondca Category Code User definable

pmcondst Condition Status User definable

pmcondty Condition Type User definable

pmevent Event Code User definable

pmeventc Category Code User definable

pmeventd Disposition Code User definable

Table Name Description Code Description
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record or click Browse to view a list of the existing validation tables. The table 
name, table description and table type are displayed in the list.

Creating a New Validation Table: Click New to clear the form and create 
a new validation table.

Exit / Cancel: When you click New the Exit button changes to Cancel so 
that you can clear unsaved data without closing the form. If there is any 
unsaved data, a confirmation message appears when you click Cancel. Click 
Yes to continue or No to clear the new data and return to the previous screen. 
Similarly, when you click Exit, a confirmation message if there is any unsaved 
data. Click Yes to continue, No to clear the new data and close the form or 
Cancel to close the confirmation message and leave the screen unchanged.

Saving a New Validation Table: Click Save to save a new validation table 
or any modifications to an existing one.

Deleting Validation Tables: Click Delete to delete the current validation 
table.

Creating Codes for the Current Validation Table: Click Codes to open 
the Validation Table screen and create new codes for the current validation 
table. See Validation Codes on page 92.

Adding Columns: Select Add Columns to open the New Database Field 
Creation form and create new columns or fields for the selected validation 
table. These can be used for maintaining data related to the validated list, 
such as, neighborhood characteristics, rate data, or contact information for an 
organization.

Formulas or logical expressions are linked to a column type. See New 
Database Field Creation on page 251 for more information.

The new field is added to the Additional Information tab. It cannot be 
modified or deleted from this form.

Note: Do not change the validation codes if the table type is different from 
Regular. Make the modifications through the module used to create 
the table, as indicated by the Table Type.

Note: Only the Regular Table Types may be deleted from the system, if the 
User has this privilege. The system tables may be deleted or modified 
ONLY by a User with Super User privileges.
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Since Microsoft® Office Access imposes a limit of 256 columns per table and 
six are used by the form, you can add to 250 additional columns or fields.

Validation Codes 

The Validation Table Codes form is used for creating and updating the 
elements and values in each table. This form is used for both System and 
User Validation Tables.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Validation Table > Codes

Note: You cannot delete or modify the new columns once they are created.

Note: Any user who has been given access to the Validation Table Header 
form can create new columns and view existing data for the user 
validation tables. However, only a Super User or Administrator can 
create, delete or modify the user validation tables.
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Validation Table Code Command Buttons

Creating a Code: You can create a new code by clicking the New button.

Saving a Code: Clicking the Save button allows you to save a new code, or 
any modifications to an existing one.

Deleting a Code: Clicking the Delete button allows you to delete the current 
code from the table name displayed.

Browsing Code Records: Clicking the Browse button allows you to 
browse all codes for the current table.

Validation Table Code Parameters

Department: This field is visible for Land Management and Property Control 
codes only. It displays the department where the codes were created.

Table Name: This field displays the table name.

Year: This field is enabled for Mass Appraisal and Tax Assessment tables 
only. It displays the year in which the codes were created.

Code: This field displays the table code.
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Short Description: Enter a short description to identify the department. 
This is useful for fast data entry and look-ups if space is limited on the forms.

Only Apply To: Select one of the listed options to filter the name type code 
according to the selected permit type. This parameter is available when the 
PMNAMES validation table in Land Management is selected. See Permit Type 
Validation on page 94 for details.

Long Description: Enter a long description to identify the department. This 
will be displayed for look-ups on forms and will be normally used for reporting.

Full Description: You can add a full description to all new tables and have 
them displayed on reports. Note, for the existing tables, you can enter a full 
description on only the OFFENSE and FIREPREV (fire prevention) tables. 
These descriptions are displayed on the Offense function when a user double-
clicks on the Violation/Offense or Fire Prevention Description fields.

Do Not Show this Code: This option is displayed for System Validation 
Codes only. Select to hide the selected code so that it cannot be used for data 
entry. For example, if you have two setups, you can enable this code in one 
setup and disable it in another.

Permit Type Validation

In the Validation Table form, it is possible to configure the system to apply a 
name type validation. This validation or filter is based upon the permit type 
that is being created. By default, in Govern for Windows when linking a name 
type, regardless of what permit type is being selected the system displays all 
name types. This applies to linking a name to a Complaint/Greivance/Request 
For Service/Workflow, Offence/Violation, or Permit/License/Certificate permit 
type in Govern.NET.  When there are many name types in the list, the 
searching process for the name type can be tedious. When the validation filter 
is used, only the name types that apply to the permit type is displayed.

Permit Types that can be filtered are as follows:

• Complaints/Workflows/Grievance/Request for Services
• Offences/Violations

Note: To use the Full Description field when you are reporting with other 
tables, create a field called FULL_DESC as a memo type in the 
desired table.
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• Permits/Licenses/Certificates

To apply a filter to a name type, in Govern Admin...

1. SelectSetup > Validation Table...

2. In the Validation Table Header form, click Browse; look for the table called 
PMNAME, double click to select it.

3. Back in the Validation Table Header form, click Codes, to display the 
Validation Table form.

4. In the Validation Table form, select the code that you would like to apply 
the filter to.

5. Look for the Only Apply To parameter and click the drop-down menu to 
select the required filter.
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6. Click Save to save the modification.

Now, when making a link to a permit type that matches the filter in Govern for 
Windows, only filtered name types appear in the list. For example, if you had 
selected the Permits/Licenses/Certificates option for a name type, it will only 
be displaye when creating a a Permit, License, or Certificate. The name type 
will not be present at any other time.

Note: When no Permit Type filter is applied in Govern Admin, the name type 
will always be displayed for all Permit Types.
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Property Control Validation Tables

Use the Property Control Validation Tables form to maintain the tables that are 
linked to the Property Area function in Govern. These tables are saved by year 
and by jurisdiction, if applicable. 

These tables are linked to the Property Area function in Govern. They are 
saved by year and by jurisdiction, if your setup includes Support of Multiple 
Jurisdictions. See System Registry Maintenance on page 16 for more 
information.

Overview

Table Name Description

VT_USR_AREAID Area Identification

VT_USR_CITYDS City District

VT_USR_FIREDS Fire District

VT_USR_FLDZONE Flood Zone

VT_USR_NEIGHBOR Neighborhood Code

VT_USR_NEIGHSUB Sub-neighborhood Code

VT_USR_PARKDS Park District

VT_USR_POLLING Polling

VT_USR_PRECINCT Precinct

VT_USR_SDIST School District

VT_USR_SPECDS Special District

VT_USR_WARD Ward

VT_USR_ZONING Zoning Codes
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Dataset Source Setup

Grant and restrict user access to the Dataset Sources or search screens on 
the Dataset Source Setup form. Permissions can be granted by user or by 
group. A default Dataset Source is assigned to the department on the 
Department Setup form. By default, this is highlighted on the Open menu in 
Govern or launched from the Quick Open button.  

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Dataset Source Setup

About Dataset Source Screens

Govern provides the following Dataset Source or search screens for retrieving 
records. This list provides some of the search options for each screen. For 
complete details, refer to the Property Control guide:

• General
• External System: by property control, name and address or permit, 

from an external source, loaded to PC_ EXTERNAL, NA_EXTERNAL 
or PM_EXTERNAL. PC_EXTERNAL can also be loaded from Govern.

• None: to reset the form

Overview
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• Property Control: by parcel ID, Tax Map Number, subdivision, lot, 
project, linked parcels or effective year

• Name & Address: by account number, Federal ID Number, Social 
Security Number, drivers license or date of birth

• Query by SQL: by SQL query. Queries can be stored or composed 
and executed from this screen. See SQL Queries on page 211 for 
details on the setup of this screen. 

• Function
• Utility Billing: by account number, utility billing ID, meter serial 

number, route number, cycle code, name or address
• Personal Property: by account number, personal property ID or 

business address
• Public Hearing: by application number, status, title or date
• GIS: by tax map number, subdivision, split / merge or virtual parcel
• Offenses: by offense number, date, type or name
• Workflow: by reference number, date, type or date
• Inspections: by inspection number, date, type, inspector’s name, 

status or result
• Permit / License / Certificate by Property: by permit, license, 

certificate or application number, tax map number or address
• Permit / License by Name: by permit, license or application number, 

date, type or name

To access these screens:

1. In Govern, select File > Open.
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2. By default, your primary department and default Dataset Source are 
highlighted. You can select alternate options, if required.

3. Click OK.

Dataset Source Command Buttons

Viewing Dataset Source Records: Each Dataset Source is saved as a 

separate record. Use the right / left navigational arrows to view 
individual records or click Browse to view a list of the records, by query name 
and definition.

Removing User / Group Access to the Dataset: Select the user or 
group from the list box and click Remove.

Exit: Click Exit to your modifications and to close the form.

Dataset Source Parameters

Dataset Source: This field displays the Dataset Source for the current 
record.

Users: This list box displays the users with access permission to the current 
record.

Selecting Users: Select the users from the drop-down list or click  to 
open the User Maintenance Setup screen and create a new user. See User 
Maintenance on page 60.

Groups: This list box displays the groups with access permission to the 
current record.

Selecting Groups: Select the groups from the drop-down list or click  to 
open the Group validation table and create a new group. See Group Validation 
Table on page 75. 

Note: User access rights override group access rights.
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Department Setup

Define the profile for each department on the Department Setup form. This 
includes the fiscal year used by the department, access to the Govern data 
entry functions and access to Accounts / Receivable data. 

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Department Setup.

Overview
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Department Setup Parameters

Department Code: Identify the department by a code. All links to this 
department will use this code. All alphanumeric characters are valid.

Short Desc. Enter a short description to identify the department. This is used 
for fast data entry and look-ups if space is limited on forms.

Long Desc. Enter a long description to identify the department. This is used 
for look-ups, on forms and typically on reports.

Fiscal Year: Specify the fiscal year that the department is working in. 

This year is displayed on the toolbar of the Govern Admin, Govern and 
Govern Batch Processing applications. 

To change the year:

1. Click on the Year field on the toolbar.

2. Enter the new year in the text box.

3. Click OK.

Note: This field must be modified manually when the department changes to 
a new fiscal year.
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Owner as of Month / Plus (+) or Minus (-) Years

The Owner as of Month feature allows you to specify the month that the 
system will register new owners.

For example, the assessors office might use the date of March 1 as their 
annual registration date. This means that if a sale of a parcel occurs after 
March 1 plus a day, i.e. March 2, 3 etc., the previous owner is still considered 
as the Owner because they were in possession as of March 1.

Owner as of Month: Specify the (as of) month to be used when creating 
new property owners.

+ or – Years: Specify the number of years added, or subtracted, from the 
fiscal year, relative to the last assessment.

For example, if the last assessment was performed in the year 2007, and the 
current year is 2009, we would enter –2, i.e. (2007-2009 = -2), in the + or - 
Years parameter.

Approved Subdivision: If checked, this department will only work with 
approved subdivisions.

Use Departmental Calendar: The Departmental Calendar is used only for 
scheduling and maintaining inspections, within the department. Inspection 
calendars can also be set up at the organizational level or for individual 
inspectors. Refer to the Permits & Inspections guide for further details.

Note: You can leave the Owner as of Month field blank to consider the 
current owner immediately on possession.

Tip: You can use the Holiday Calendar to define statutory holidays, for billing 
purposes. Refer to the Accounts / Receivable guide for details.
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Default Search Form: Select the default Dataset Source or search screen, 
for the department, from the drop-down list. By default, this Dataset Source is 
highlighted on the Open menu in Govern or launched from the Quick Open 
button.  

For example, in the following screen shot, the Assessors Department is 
assigned the Property Control Dataset Source. Search options from this 
screen include: parcel ID, tax map number, subdivision, lot, project and linked 
parcels. For more information on Dataset Source screens, see Dataset 
Source Setup on page 98.

Nb records affected before warning : When an action query is initiated, 
the system will first perform a record count to determine the number of records 
that will be affected by the query. Enter the minimum number of records that 
need to be affected, before a warning is displayed to the user.

Delay before query rollback (minutes): Enter the number of minutes for 
the delay before the rollback occurs. Once this amount of time has elapsed, 
the rollback will occur automatically

If an action query is used; for example, to add, update or delete records in the 
database, when you perform this action, within the department, a warning 
screen appears

For example, the following warning screen is displayed if the P_ID is less than 
10,000.
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No: Click No to stop the deletion process and the roll back from occurring.

Yes: Click Yes to allow the deletion process to continue.

Privacy / Restrictions for Names group

To set up access rights, for name and address records, you need to define the 
following:

1. Assign a Name Sharing Group to the Department, as described below 
under Name Sharing Group on page 106.

2. Provide access to the Name and Address Maintenance function to the 
applicable departments.

3. Select the Allow Creation of Names option on the User Maintenance 
form for users who need to create names and deselect it for all others.

4. Set the Access Type Permissions to the Name and Address Maintenance 
for all users, as described under Name & Address Maintenance Security 
on page 109.
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5. Set permissions to the batch processes affecting name records, including 
the Format Names and Address, Export and Import Names in Mail 4+ 
Format and especially the Name Merge Utility, as described under 
Assigning User Permissions to Batch Processes on page 292. 

For details on all restrictions and accesses, refer to the Restriction Level: 
Private Names on page 111

Name Sharing Group

Name Group Code: You can create a Name Sharing Group in order to 
extend access rights to the name and address records, created by your 
department, to one or more of the other departments, within your organization.

To create a Name Sharing Group, enter a code of one or two characters in this 
field. Then, enter the same code when you set up the other departments in 
this group.

Next, select one of the following options to define the access rights for the 
departments included in the Name Sharing Group and for those outside of it.

The code of the Name Sharing Group and the type of security permissions are 
displayed on the Name and Address Maintenance function in Govern, unless 
the records are private to another department. If the name is restricted, it is 
grayed out and cannot be modified. Similarly, if the address is restricted, it is 
also grayed out and cannot be modified.

There are four levels of security for name and address records.

• Private Names - Name and Address records, are private to the 
department or Name Sharing Group, where they were created. Other 
users can’t search, modify, or delete these names. They can only view 
them if they are already link to other Govern functions

• Restricted Names - Names in the Name and Address records are 
restricted to the department or Name Sharing Group, where they were 
created. Other users can view the names can’t modify or delete them. 
They are still able to search for the records and modify the addresses.

• Restricted Names and Addresses - Both the name and address 
portions, of the Name and Address records, are restricted to the 
department or Name Sharing Group where they were created. Other users 
can perform a search for these records but cannot modify or delete them.
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• No Restrictions - There are no restrictions to the Name and Address 
portions of the records, they can be searched, modified, or deleted. Other 
users are equally unrestricted.

2008

Refer to the Property Control guide for more information on this function.

Name & Address Security Grid

The two (2) grids below 
should serve as a guide 
to the users level of 
access when they are 
Within a Department in 
a group, or Outside of 
the Name Group. For 
example in the Name & 
Address form, a user 
that is in the Building 
Department , and is a 
member of the Create/Modify/Delete group, within their department, for 
Names that are designated as Private, will be able to Search for the name, 
Link to the name, Modify Addresses, and Delete Names. Although note that 
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according to the system rule, this user is not able to Modify (A) the name. 
Outside of their name group they have no access (B). Refer to the grids below 
for details.

The following grid should serve as a guide to system imposed user restrictions 
for Name Sharing groups. 

Department in the Same Group
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Name & Address Maintenance Security

In addition to creating a Name Sharing Group, you can further refine name 
and address maintenance by setting access permissions for each user. 

Security for the Name & Address Maintenance function is more complex than 
for the other functions due to the important and sensitive nature of the data. 
For details on defining user access on the other functions, see Functions 
Setup on page 123. Also, see Super User and Full Access Rights on page 66. 

There are four levels of user access that can be set for each Govern function 
that typically provide the following rights:

• Inquiry Only: The user is only able to view the data for the specified 
function.

• Create and Modify: The user can view, create and modify data for the 
specified function.

• Create, Modify, Delete: The user can view, create, modify and delete data 
for the specified function.

Outside the Name Group
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• Full Access Rights: The user can view, create, modify and delete data 
and could also modify and delete historical data for the specified function.

However, in order to grant the permission to create names to any user, 
including a Super User or a user with Full Access Rights to the Name & 
Address Maintenance function, the Allow Creation of Names option must be 
selected on the User Maintenance form in Govern Admin. See User 
Maintenance on page 60 for more information.

The following tables display the different levels of access security for the 
Name & Address Maintenance function, according to the following tasks:

• Search: the right to search for a name and address record through the 
various search screens; for example the Name Search or the Name & 
Address Search. Refer to the Property Control guide for further details.

• Link: the right to link a name and address record to another function; for 
example, a Permit function, the Owner Information, Occupant / Business, 
Related Lien Names, ACH Information by Name or the Real Estate or 
Utility Billing Mailing Index, provided the user has access rights to these 
functions.

• Create: the right to create a new name and address record.
• Modify Name: the right to change name data: i.e., first name, last name, 

company name or formatted line_1.
• Modify Address: the right to change the address part of the record.
• Delete Name and Address: the right to delete name and address records.

The following conventions are used in these tables:

Note: Super Users are automatically given Full Access Rights to all 
functions.

Symbol Definition

 The user has permission to perform the task.

 The user does not have permission to perform the task.
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Restriction Level: Private Names

* The permission to create names is granted if the Allow Creation of Names 
option is selected on the User Maintenance form, in Govern Admin. Users can 
then create names within their primary department and within the Name 
Sharing Group, selected for the department. Otherwise, users do not have 
permission to create names, regardless of their department, regardless of the 
Name Sharing Group in which the department is a member and regardless of 
User Access Type.

Restriction Level: Restricted Names & Addresses

Permission Levels Ability to Perform Name & Address Maintenance Tasks

Access Type
Name Sharing 

Group
Search Link Create

Modify
Delete

Name Address

Super User or 
Full Access 
Rights

Member   *   

Non-Member     

Create, Modify 
and Delete

Member     

Non-Member     

Create, Modify Member     

Non-Member     

Inquiry Only Member     

Non-Member     

Permission Levels Ability to Perform Name & Address Maintenance Tasks

Access Type
Name Sharing 

Group
Search Link Create

Modify
Delete

Name Address

Super User or 
Full Access 
Rights

Member   *   

Non-Member     
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Restriction Level: Restricted Names

Create, Modify 
and Delete

Member     

Non-Member     

Create, Modify Member     

Non-Member     

Inquiry Only Member     

Non-Member     

Permission Levels Ability to Perform Name & Address Maintenance Tasks

Access Type
Name Sharing 

Group
Search Link Create

Modify
Delete

Name Address

Super User or 
Full Access 
Rights

Member   *   

Non-Member     

Create, Modify 
and Delete

Member     

Non-Member     

Create, Modify Member     

Non-Member     

Inquiry Only Member     

Non-Member     

Permission Levels Ability to Perform Name & Address Maintenance Tasks

Access Type
Name Sharing 

Group
Search Link Create

Modify
Delete

Name Address
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Restriction Level: No Restrictions

Summary

1. Only users with Full Access Rights on the Name and Address 
Maintenance function can modify a name even within their Name Sharing 
Group.

2. Even with Full Access Rights, users can modify a name, outside of their 
Name Sharing Group, only if the No Restrictions option is selected on the 
Department Setup form.

3. Users with Full Access Rights, Create, Modify, Delete or Create, Modify 
rights can always modify an address within their name sharing group.

4. These users can modify an address created outside their Name Sharing 
Group only if the Restricted Name or No Restrictions option is selected 
on the Department Setup form.

5. Users with Full Access or Create, Modify, Delete rights can delete name 
and address records even though they may not be granted permission to 
create or modify them.

Permission Levels Ability to Perform Name & Address Maintenance Tasks

Access Type
Name Sharing 

Group
Search Link Create

Modify
Delete

Name Address

Super User or 
Full Access 
Rights

Member   *   

Non-Member     

Create, Modify 
and Delete

Member     

Non-Member     

Create, Modify Member     

Non-Member     

Inquiry Only Member     

Non-Member     
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6. All users can view and search for a name and address records unless 
Private names is set for the department and the department is outside 
their Name Sharing Group.

7. Users can create names if the Allow Creation of Names option is 
selected on the User Maintenance form, regardless of whether or not the 
user’s department is a member of the Name Sharing Group and 
regardless of the user ‘s Access Type.

If this option is selected users can create names within their primary 
department and within the Name Sharing Group, selected for the 
department. 

Access to Accounts / Receivable Information

A/R Sub Systems Allowed: The department has access to the Accounts 
Receivable (A/R) data of each selected subsystem. Users can view, update 
and process these data through the Accounts / Receivable functions, including 
A/R Inquiry, Payment Data Entry and Cash Collection Posting.

Access to the Govern Functions

Functions group

In Govern, users will access functions by first logging into a department. Only 
the functions that are selected for the department, on this form, will be 
accessible to those users. 
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Adding a Function to the 
Accessible Functions List

To add a function to the Accessible 
Functions  list ...

1. Select a department.

2. Click the drop down menu below 
the Accessible Functions list for 
the department

3. Select the desired function.

Removing a Function from 
the Accessible Functions 
List

To remove a function from the Acessible Functions list

1. Click to select the function to be removed from the Accessible Functions 
list; multiple selections may be made by selecting Ctrl + Click.

2. Click R. 

Function Security

When you select a single function, or perform an extended selection, i.e. 
select multiple functions at once, you are granting specific access rights to the 
selected functions for users and groups within the department.

Single Function selection

Security configuration for a single function will establish  security configuration 
is required for a single function 

WARNING: When modifications are made to user and group access rights 
for a department and function in the Department Setup form, all previously 
defined rights are deleted and replaced with the newly defined rights.

Note: Before setting up the Security for each function, you need to create all 
the users. See User Maintenance on page 60.
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To set security for a single function...

1. Select the function and click S.

2. The Function Security Setup screen will be displayed.

The setup of this form is described in the Functions Setup section of this 
guide. See Functions Setup on page 123.

Multiple Function selections

Should you be required to establish access rights for multiple functions, an 
extended selection can be performed using the Shift + Click or Ctrl + Click key 
combinations. This will allow you to configure user or group access to multiple 
functions at once. When using this extended selection technique it is important 
to note that the first function selected is the function that will determine the 
access rights to all selected functions.

For example, we want to establish security for the Assessor’s Office, and set 
the right for the following functions:

• Activities

Note: The information displayed in this form are the access rights for this 
function; these are the rights that will be saved.
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• Building Drawing
• Building Information
• Building Miscellaneous Structures
• Building Structural Elements & Features

The Activities function is selected first. Using the extended selection technique 
of Ctrl + Click, the other Building functions were selected. As Activities was the 
first function selected, the rights that have been established for it will be the 
ones to be used for the group. This will be displayed when you click S. In 
addition, when the rights are saved, any previous rights that were established 
for any of the selected functions are deleted and replaced with the new rights 
associated with the Activities function.

Note: When selecting multiple functions, select the first function and click S. 
This will allow you to see the rights associated with the function. If an 
extended selection of other functions are made, they will have the 
same security rights.
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CoolBar Queries Setup

Govern CoolBar

The Govern CoolBar runs along the lower section of the Govern toolbar and 
displays data on the current record. By default, this includes the tax map 
number, owner name and address, occupant name, mailing index and 
property location, as well as data from the open functions, such as permit and 
license certification, registration or application numbers, inspection date and 
time and the utility billing account number. You can modify the background 
and foreground colors of each item and also reposition them on the CoolBar. 
Refer to the General Information guide for details.

CoolBar Queries Setup

Use the CoolBar Queries Setup form to add customized SQL queries to the 
Govern CoolBar. These queries are used to retrieve other data; such as the 
appraised value, building value, neighborhood or property class. 

The query is displayed on the CoolBar Customization screen in Govern, by 
description and result, as follows:

The result of each query is displayed as a separate item on the CoolBar. You 
can modify it and reposition it, as any other item.

To include a pre-defined SQL query, select the CoolBar Queries button on 
the Department Setup form. This displays the CoolBar Queries Setup form.
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Key Name: Select the record set key name to use with this query.

Query List: Select the query you want to use from the list.

Typically, CoolBar Queries return a single result and this is displayed as a 
single item on the CoolBar. In the following example, however, the sales date, 
deed book and page number have been concatenated so that they are 
displayed as single item.

SQL Query Example

Result

Note: The queries must be created beforehand using the SQL Definition 
Setup form. See SQL Queries on page 211 for details.

Note: Only Selection Queries can be added to the CoolBar. 

SELECT 'Date: ' + CAST(SALE_DATE AS VARCHAR) + ' / Book: ' + CAST(DEED_BOOK AS 
  VARCHAR) + ' / Page: ' + CAST(DEED_PAGE AS VARCHAR)AS RESULT
FROM MA_SALES 
   WHERE SALE_ID IN (SELECT TOP 1 SALE_ID 
     FROM PC_LK_PARCEL_SALE 
WHERE P_ID = parcel id
       ORDER BY SALE_ID DESC)
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You can also format the query result, by adding characters to the beginning of 
the query name. See Query Name (Code) on page 214 for details.

Coolbar Queries and Exported Databases

Inspector or Appraiser databases are extracts of Oracle or SQL databases. 
These extracted databases are in Microsoft Access format which supports 
only the most basic SQL query syntax. Issues occurred when Coolbar Queries 
used SQL functions that were not recognized by the extracted Microsoft 
Access database. As a result prior to version 10.0, Coolbar Queries were not 
copied to extracted Inspector or Appraiser databases. Since you are now able 
to direct your Coolbar queries to connect through the Access attach table, they 
are now copied with the extracted database.

Communicating with the Database

When users are connected to the main database, they can communicate in 
two (2) ways:

• Directly with the database
• Through an Access attach table

By default, users query the database directly using SQL. You can now choose 
how your query will connect to the database.

To direct a query to access the database through the Microsoft Access attach 
table...

1. In Govern Admin, select Setup > SQL Definition Setup

2. On the SQL Definition Setup form, create your query then select Query 
Access Format
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When this option is selected, the system will know that when this particular 
query is executed, it will be through the Access attach table.

Department Setup Command Buttons

Creating a New Department: Click New to clear the form and enter a new 
department setup.

Saving a Department: Click Save to save a new department setup, or any 
modifications made to an existing one.

Deleting a Department: Click Delete to remove the current department 
record.

Browsing Department Records: Click Browse to view a list of all the 
department records.

CoolBar Queries : Click CoolBar Queries to select a user-defined query 
that will retrieve additional data from the current record and display the result 
on the Govern CoolBar. The queries need to be created through the SQL 

Note: It is recommended that Coolbar queries, or queries used in formula 
calculations, be written in Access syntax particularly if they will be 
used in extracted Inspector or Appraiser databases.
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Definition Setup form. For example, you could set up a query to retrieve the 
value of the buildings that are linked to the parcel. See CoolBar Queries Setup 
on page 118 for details.

Exit: Click Exit to close the form. A confirmation message is displayed if there 
are any unsaved modifications.
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Functions Setup

Grant and restrict access to the Govern functions on the Functions Setup 
form. Access is set by department, group and user. You can also add your 
own business rules to the Add, Save and Delete buttons of any Govern 
function, from this form.

It is possible to add selection queries for validation in functions, for example, 
you could create a validation for the Planning Department when a General 
Permit is requested. The query could verify that there are no amounts owed to 
the municipality as a condition to allowing the Permit to be issued. 

Validations are performed with preexisting selection queries, or queries can be 
created by selecting a button on the form.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Functions Setup

Overview
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Function Setup Command Buttons

Access: To view or modify the access rights of a user or group, highlight the 
user or group name and select Access. See Assigning User and Group 
Access Rights to a Function on page 125 

Remove: To remove user or group access rights to a function, highlight the 
user or group name and select Remove. Similarly, to remove a query from the 
Add, Save or Delete button, highlight it in the list and select Remove. 

Validation Rule: Click Validation Rule to specify validation rules for the 
Function, Users, and Groups. See Validation Rule Setup for a Function on 
page 128 for details.

Browse: To view a list of the functions, by code, short and long description, 
select Browse.

Exit: Select Exit to close the form and save any modifications.

Functions Setup Parameters

Department: This field displays the name of the department for the access 
rights records.

Function: This field displays the name of the function for the record.

Users: This list box displays the names of the users with access rights to the 
function.

Creating a User Account: Click to open the User Maintenance form 
and enter the information for a new user account, as described under User 
Maintenance on page 60. The new user is added to the drop-down list when 
you click Save on the User Maintenance form.

Groups: This list box displays the names of the groups with access rights to 
the function.

Creating a Group: Click  to open the Group Validation Table form and 
enter the information for a new group. The group is added to the drop-down 
list when you click Save on the Validation Table Header form. See Group 
Validation Table on page 75, for more information. 
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Business Rules: These list boxes display the user-defined queries linked to 
the Add, Save or Delete button of the function.

Creating a Query: Click  to open the User Defined SQL Definition form 
where you can create a new query. This is added to the drop-down list. See 
SQL Queries on page 211, for more information.

Assigning User and Group Access Rights to a 
Function

To set user and group access rights, by function.

1. In Govern Admin, select Setup > Functions Setup... to launch the 
Functions Setup form.

2. Select the function for which you want to set access rights.

3. Select the user or group from the drop-down list to add them to the list box. 

4. Highlight the user or group in the Users or Groups list box.

5. Select Access to open the Access Type screen.

Note: In the Functions Setup form, you are configuring access rights to a 
single function for a single department. Any changes made here are 
related to access to the individual function. Access rights that are 
established here may be overwritten when access rights are set in the 
Department Setup form. It is therefore recommended that department 
access rights are configured first prior to setting access rights.for 
individual functions.

Note: When assigning user rights and group rights, individual user rights will 
always take precedence over group rights.
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6. Select the Access Type.

7. Click OK.

There are four Access Types:

• Create, Modify, Delete: The user can view, create, modify and delete data 
for the specified function.

• Full Access Rights: The user can view, create, modify and delete data 
and could also modify and delete historical data for the specified function.

• Inquiry Only: The user is only able to view the data for the specified 
function.

• Create and Modify: The user can view, create and modify data for the 
specified function.

See User Maintenance on page 60 for more information on Access Types.

Removing Access Rights from a User or Group

To remove access rights, select the user or group in the Users or Groups list 
box and click Remove.

Adding Business Rules to a Function

You can link one or more Business Rules or queries to the New, Save and 
Delete buttons of a function. These queries need to be pre-defined through 
the User Defined Queries Setup form in Govern Admin. In addition, they must 
be Selection Queries. They can be applied to both existing and user-defined 
parameters. See SQL Queries on page 211.
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To link queries to a command button:

1. In Govern Admin, launch the Functions Setup form.

2. Select the function to which you want to link the queries.

3. Select queries from the drop-down list to add to the list box for the New, 
Save and Delete buttons, as applicable.

4. Highlight the query in the list box and select U to move it towards the top of 
the list or D to move it towards the bottom.

Queries are executed as follows: 

• Queries in the Query List for Add Record are executed when you save a 
new record; i.e., when you click New, enter your data; then, click Save.

• Queries in the Query List for Save Record are normally executed when 
you click Save.

• Queries in the Query List for Delete Record are executed when you click 
Delete.

• Queries in each list are executed in the order they are displayed.

See Linking Queries to a New Command Button on page 262 for details on 
executing a query from a customized command button.

Modifying Functions

Changing the Function Name

You can change the name of any function, to a name of your choice, using the 
Validation Table Header form. 

To access this form:

1. In Govern Admin, click Setup > Validation Table.

Note: Only Selection Queries appear in the drop-down lists.

Note: If you have queries in both the Add Record and Save Record lists, 
the queries in the Add Record list are executed for a new record but 
not those in the Save Record list.

FI
N

AL
 D

R
AF

T



Page 128 © 2013 MS Govern

Super User

2. Select the System option.

3. Select Browse.

4. In the Browsing screen highlight funct and click Select.

5. Modify the Short and Long Description.

6. Click Save.

See Validation Tables on page 85 for more information on this form.

Changing the Function Icon

You can also change the icon of any function to an icon of your choice:

To change a function icon.

1. Rename your icon to functxxx.ico, where xxx is the value from the 
Code field in VT_SY_FUNCT, of the function, as displayed on the 
Browsing screen of the Function Setup form.

2. Copy your icon to the Govern bitmap directory, typically this is 
\Govern\bitmap. 

Validation Rule Setup for a Function

The Validation Rule Setup form allows you to configure existing SQL selection 
queries, or create new queries that will be used for a validation. The result of 
this validation is a Yes or No (1 or 0).

For example, in the Legal Description function, a rule could be set up to 
validate Property Type with a specific Levy Code. With validation in place, If a 
property type does not match a selected levy code, you could say that the 
user would not be able to save the entry and an error message would be 
displayed.

Note: DO NOT to modify the Code.

Note: Whenever you install a new version of Govern, the Govern bitmap 
directory is overwritten. Ensure that you have a backup of your icons 
so that you can recopy them, when the upgrade is complete.

Your modified function names are not overwritten.
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To setup a Validation Rule in Govern Admin:

1. Click Validation Rule on the Right Hand Side (RHS) of the Functions 
Setup form.

2. In the Validation Rule Setup form, select an existing query, or click New to 
create a new record.

3. Select a query from the Select Query Name parameter or click  to 
open the SQL Definition Setup form.

As stated, the queries used are selection queries, when executed they will 
return a value of 0, if false, or 1, if true. As in Business Rules, you can specify 
when the rule is valid.

4. Select the Rule is valid when return value = 0 option if the query returns 
with a zero. 

5. Enter a message string in the Message Display When Rule Invalid 
parameter.

Note: To make your validation user friendly, include a message that is to be 
displayed when the rule is invalid.
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Multiple Validation Queries

To have multiple validation queries:

1. Click New in the Validation Rule Setup form and select or create a new 
query. With each click on New, the sequence order (Seq. Order) number 
increments by one.

To change the sequence that the validation 
queries are executed, change the value that 
appears in the Seq. Order parameter.

Note: Ensure that you do not have duplicate sequence order (Seq. Order) 
numbers.
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Audit Trail and Data Duplication Setup

Track modifications to selected Govern tables, by function, using the Audit 
Trail form. When you set up the audit trail, an entry is created in the USR_ 
AUDIT_TRAIL table, for each modification.

You can set up an audit trail from modifications made to Govern Admin forms 
and for processes run through Govern Batch Processing. See Govern Admin 
Audit Trail on page 134 for details.

For a complete and exhaustive tracking of a record and its fields, you must 
select the Full Audit Trail option in Govern Admin. All audit information is 
updated to the USR_AUDIT_TRAIL table. See Full Audit Trail on page 30. 

Modifications made to Govern Admin forms are saved to USR_AUDIT_ADM, 
while audited information on Govern Batch processes is saved to USR_ 
AUDIT_ ATCH.

Define the data that can be duplicated from an existing property to a new one, 
using the Data Duplication Setup form. When you create a new property, or 
perform a Split / Merge, a confirmation message appears asking you to 
confirm that you want to duplicate all the items selected on the screen.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Audit Trail and Data Duplication Setup

Overview
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Setting the Audit Trail and Duplicate Data Parameters: To change 
the default setting for these functions, select a table from the list, then check or 
deselect audit trail and duplicate data accordingly.

Browsing the Govern Functions: Click Browse to view a list of the 
functions, by code and long description.

Function: This field displays the icon of the function.

Code: This field displays the code for the function.

Name: This field displays the name of the function.

Tables: This field displays a list of the tables associated with the function.

Audit Trail: If this option is selected, then it allows you to keep track of all 
modifications (Create / Update / Delete) made to the selected tables.

Duplicate Data: Select this option to duplicate the data from the selected 
table to a new property.

Note: For a full exhaustive audit trail, it will be necessary to select the Full 
Audit Trail option. See “Full Audit Trail” on page 30. for details

Note: Only tables that have a P_ID field can be duplicated.
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When you create a new property, or perform a Property Split, Merge or 
Remap, you are prompted to duplicate all the selections you have made.

Auto Comments on Memo Fields: Select this option to enable the Name 
and Time Stamp feature for the selected function. This adds the user name, 
along with the date and time of the entry, to any text added to the Notes & 
Comments field of the function. 

Note: If the Add User Name and Current Date in Notes (Memo) field is 
selected on the System Registry Maintenance form, the user name 
and time stamp are added to all memo functions and this is option is 
disabled. Otherwise, you can select or deselect it for each function.FI
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Govern Admin Audit Trail

You can create an audit trail to track modifications made in Govern Admin. 
You need to select the forms on which you want to set the audit trail. 
Modifications are saved to USR_AUDIT_ADM. 

Setting up an audit trail is similar to granting access to menu items through the 
Menu Security Setup form.

To set an audit trail to a menu item:

1. In Govern Admin, select Setup > Audit Trail ADMIN Setup...

2. In the Audit Trail Setup form, select Parameters or Setup, depending on 
where the item is located.

Overview
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3. Select the menu option to grant access. Deselect it to restrict access.

4. Click Save to save modifications to USR_AUDIT_ADM. Changes are 
saved by User ID and date. The type of action, such as create, modify, 
insert or delete is recorded as is the field name that was changed, with the 
previous and new values. 

5. Click Exit to close the form.

Click Set Audit Trail on all Menu 
Items to set the audit trail for all 
forms in Govern Admin.

Click Remove Audit Trail to all 
Menu Items to remove the audit trail 
from all Govern Admin forms.

The audit trail is set on all forms and features that are selected on 
the menus.

Tip: If you are setting an audit trails for all but a few forms, select this option, 
then remove the audit trail from the specific forms, by deselecting the 
applicable options.

Tip: To set the audit trail on only a few forms, you can select this option, then 
select the forms on which you want to set the trail.
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Audit Track Global ID

This feature allows you to track the access and length of time of selected ID’s 
(Table: USR_TRACK). This is an administrative feature that should be used 
with some caution as the table can be quickly populated.

When selected, the information tracked are as follows:

This information can be obtained through a custom report.

Parameter Name Description

TRACK_ID The sequence number.

USR_ID ID of the user that generated the record.

ID_NAME ID name that is was selected to be tracked.

ID_VALUE Value of the ID.

START_TIME Date and time that the event ID was generated.

END_TIME Date and time that the event ended.

DURATION Elapsed time in seconds.
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Bill Messages Setup

Add a message to your next billing run using the Bill Messages Setup form. 
This message is valid for one billing only. The message is defined by Message 
Type and by subsystem. For example, you can define a message to be printed 
on duplicate bills created for Real Property tax.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Bill Messages Setup

Bill Messages Setup Parameters

Subsystem: Select a Sub-system (Land Management, Real Property Tax, 
Special Assessment, and Utility Billing) from the drop-down list. 

Message Type: Select a Message Type from the drop-down list (Table: VT_ 
USR_MESSBILL). 

Message on Bill: Enter the message that will appear on the bill.

Overview

Note: This message is valid for one billing only.FI
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Message Types

The following table provides a list of Message Types with associated criteria:

Attaching a Message to a Bill

When you run the bill printing process, only the bills linked to the selected 
message are printed. If you do not select a message type, only the bills with 
no linked message are printed.

Bill Messages Setup Command Buttons

Creating a New Bill Message: Click New to clear the form and create a 
new message.

Saving a Bill Message: Click Save to save a new message setup or any 
modifications to an existing one.

Deleting a Bill Message: Click Delete to remove the current message 
setup.

Code Message Type Criteria

1 General Message Primary Index is the Owner (active), no 
Mortgage OR

Primary Index is the Owner (inactive) and 
temporary owner 

[Code x]

2 Information Only Primary Index is the Owner (active) and 
Additional Owner

3 Third Party Third Party

4 Owner with Mortgage Primary Index is the Owner with Mortgage

5 TSO / Mortgage TSO / Mortgage

Note: It is important to keep these codes intact. You can, however, define 
other codes for use with additional message types, through the 
Validation Table Header form. See Validation Tables on page 85.
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Browsing Bill Messages: Click Browse to view a list of the messages for 
all sub-systems.
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Lists & Crystal Reports Setup

Use the Crystal Reports Setup form to define the properties for Govern’s 
reports. Set user access permissions, link functions and batch processes and 
associate a fee. In addition, you can create prompts, to have the user 
dynamically set the selection criteria.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Lists & Crystal Reports Setup...

Overview

Tip: To make it easier for users to find and select the reports they need, 
create a Tree View for displaying reports in Govern.

Note: The paths to Govern’s standard and customized reports are defined on 
the System Registry Maintenance and User Registry Maintenance 
form in Govern Admin. See System Registry Maintenance on page 16.

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 141

Lists & Crystal Reports 
Setup

Standard reports have been removed from Govern Admin. All reports are 
launched from Govern or Govern Batch Processing and need to be linked to a 
data entry function or batch process or added to the Report Tree View, in 
Govern for Windows. See Linking Functions and Batch Processes on 
page 143 and Creating a Report Tree View on page 144. For a list of the 
standard reports, see Appendix A: Standard Reports on page 320.

To access the Lists & SQL Reports form from Govern’s main screen, select 
Tools > System Administration (Govadm32.exe) 

OR 

Click  then select Setup > Lists & SQL Reporting Setup...
 

Lists and Reports Command Buttons

The following are the command buttons that appear on both the Crystal 
Report Functions Setup form and the SQL Reporting Functions Setup form. 
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Browsing Reports: Each report is saved as a separate record. Use the 

right  and left  navigational buttons to display each record or 
select Browse to view a list of the existing reports. Reports are displayed on 
the Browsing screen, by code and long description.

Creating a New Report: Click New to create a new report setup.

Saving a Report: Click Save to save a new report setup or any 
modifications to an existing one. This report must be saved to the directory 
specified on the System Registry Maintenance or User Registry Maintenance 
form. See User Registry Maintenance on page 53 and System Registry 
Maintenance on page 16 for more information.

Deleting a Report: Click Delete to remove the current report setup from the 
database.

Lists and Reports Fields 

Report File Name: Enter the report file name.

Description: Enter a description of the report. 

Audit Trail: Select this option to create an entry in the USR_AUDIT_RPT 
table, each time the report is generated.

Defining User Access Permissions

You can define user access permissions by user, group or department.

Users: To grant user access to the report, select the users from the drop-

down list. To create a new user account, click the  button. This opens the 
User Maintenance form. See User Maintenance on page 60 for details.

Note: You need to enter a name for the report and click Save before 
selecting the Govern function or Batch Processing form or granting 
user access rights.

Note: The report must be saved in either the Report Folder or the Custom 
Reports Folder defined on the System Registry Maintenance or the 
User Registry Maintenance forms.
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To remove access to the report from a specific user, highlight the user in the 
list and click R.

Groups: To grant group access to the report, select the groups, from the 

drop-down list. To create a new group, click the  button. This opens the 
Group Validation Table screen, where you can create the new group. See 
Creating a Group on page 75.

To remove access to the report from a specific group, highlight the group in the 
list and click R.

Departments: To grant access to the report for one or more department, 
select the departments from the drop-down list.

To create a new department, click . This opens the Department Setup 
form, where you can define a new department. See Department Setup on 
page 101 for details.

To remove access to the report from a specific department, highlight the 
department in the list and click R.

Linking Functions and Batch Processes

Use the procedures in this section to open and run one or more reports 
directly from a function or on completion of certain batch processes.

Functions: To generate reports directly from a Govern function, you need to 
complete two procedures:

1. Select the function, from the drop-down list on this Report Functions Setup 
form.

2. Launch Govern, open the function and use the New Command Button 
form to link the report or reports, as described under New Command 
Buttons on page 257. 

There are now two ways to launch a report, from a new command button:
• Directly from the command button, In Quick Access Mode

• From a list of reports, launched from the command button.

Note: You need to repeat this procedure, for each function, from which the 
report is to be generated.
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To remove a function from the list, highlight the function and click R.

Process: To generate the report automatically, on completion of a batch 
process, in Govern Batch Processing, select the process from the drop-down 
list. When the user runs the process, a confirmation message, Do you want to 
run the Crystal Report?, appears.

To remove a batch process from the list box, associated with the report, 
highlight the process and click R.

Associating a Fee with a Report

A/R Class: To link an A/R Class code to the report, highlight a department; in 
the Departments list box; then, select the A/R Class code from the drop-down 
list (Table: VT_USR_AR_ CLASS). 

Fee: Enter a fee to associate with the report. This field is linked to the A/R 
subsystem.

Creating a Report Tree View

To make it easier for users to find and select the reports they need, organize 
your department’s reports under two levels of headings and display them in a 
tree view in Govern, For example, you can use the names of the subsystems 
as the top-level headings: Accounts Receivable, Tax Assessment and Billing, 
Utility Billing, etc. Then, create secondary headings, according to the 
information in the report, Credits, Debits, Payments, Real Property Tax or 
Personal Property Tax.

The user displays the Report Tree View, by selecting File > Open or Ctrl + R. 
Refer to the General Information guide for further details on this screen.

Note: Only the batch processes displayed in the drop-down list can be 
associated with a report.FI
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In order to create the tree view, you need to define the headings, then, select 
both the top-level heading, the Upper Node, and the secondary level, the 
Lower Node, for each report.

Creating the Headings

To create the Upper Node:

1. Click to open the validation table, VT_USR_RPT_LEV1.
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2. Enter a code, short description and long description.

3. Click Save.

4. Click New and repeat steps 2 and 3 until you have all your first level 
headings.

To create the Lower Node:

1. Click to open the validation table, VT_USR_RPT_LEV2.

2. Enter a code, short description and long description.

3. Click Save.

4. Click New and repeat steps 2 and 3 until you have all your second level 
headings.

Selecting the Headings

You need to select both the Upper and the Lower Nodes, for each report.

1. Scroll to the report.

2. Select the top-level heading, from the Upper Node drop-down list.

3. Select the secondary heading, from the Lower Node drop-down list.

Note: You can create a new heading, by clicking the  button.
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Creating User Prompts

To create a prompt:

1. Select a report on the General tab.

2. Select the Prompts tab.

3. Click New and complete the following fields as described in this section:

Prompt: Enter a label for the prompt.

Field Name: Click Field Selection to select a field for the prompt. The 
following screen is displayed:
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Report Field Selection: Select the table, from the left, and the field, from 
the right, to display when generating the report. Then, click OK.

Sequence: Enter a sequence number. This defines the order the field 
appears on the report.

Validation Table: If the field has to be validated, choose the validation table 
from the list box.

Ask for a Range: Select this option to prompt the user to enter a range for 
the selected criteria; such as range of dates or values, when the report is 
generated.

System Table: Select this option if the validation table is a system table.

Sample Report Generation Prompts

The following screen shot displays the report with user-defined fields:
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Govern Standard Reports

Crystal Reports are generated based upon data that is obtained from Govern. 
In some instances user action in the form of a prompt is required to filter the 
data, e.g. entering a date range. In other instances the data must first be 
extracted and then go through a “preprocess” step.

Currently there are six (6) Govern standard reports that require data pre-
processing. These reports are specific to the Govern Land Management 
module. Should you wish to use any of these reports, you must first configure 
the preprocessing for them. This can be done by configuring prompts in the 
Crystal Report Functions Setup form.

• PM_APPLIST.rpt
• PM_CERTLIST.rpt
• PM_EXPAPLST.rpt
• PM_EXPCTLST.rpt
• PM_EXPPMLST.rpt
• PM_PMLIST.rpt

If you try to run any of the aforementioned reports in Govern for Windows, it 
will look for the configured prompts. If they have not been created, an error will 
be displayed.

To configure the prompts for 
these reports in Govern 
Admin:

1. Select Setup > Lists & 
Crystal Reports Setup...

2. In the Crystal Report 
Functions Setup form, 
click Browse.

Note: Prompts must be configured for each of these reports.
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3. From the Browsing screen, select one of the six (6) Govern standard 
reports listed above, in this example we are selecting the Permits 
Application Listing report.

4. Under the General tab, configure any additional parameters required for 
the report, e.g. what departments, which users, etc.

5. Select the Prompts tab; click New to set up a new prompt for the report.

6. Enter Start Date in the Prompt parameter
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7. Click Field Selection to display a list of the fields that are within the report; 
in this case we require the APPLICATION_DATE within the PM_MASTER 
field.

8. Click OK; the field name is now copied into the Field Name parameter.

9. Enter a sequence number; for our example we will enter 1 to correspond 
with the first prompt.

10. Click Save.
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A grid now appears just below the Prompts tab, each line will correspond to a 
prompt that the user will see before the report is run. We now need a second 
prompt for the End Date.

11. Click New to make entries to add a second prompt.

12. We need to repeat Steps 6 to 9 in this procedure to complete the fields for 
a second prompt. At step 6, enter End Date in the Prompt parameter, at 
step 9, enter a 2 for the Sequence Number.

13. Click Save.

14.  A second line corresponding to the second prompt will appear in the grid.

Note: This procedure of creating prompts must be repeated for each of the 
six (6) standard reports.
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Report Function Setup: Formulas

This section lists the recommended, general, read-only and conditional 
formulas to include when creating reports through Crystal Reports.

Recommended Formulas

Include the following formulas when you create Crystal Reports:

General Formulas

Govern populates the following Crystal Reports formulas automatically, if they 
are included in your reports:

Overview

Formula Definition

@rpt_date (totext (currentdate)) Date & Time

@rpt_name Report Name

@rpt_Username Town or Company Name

Formula Definition

@dept Department (code)

@dept_label Department label

@language Language

@rpt_county County

@rpt_default_date Default Date

@rpt_login User name

@rpt_range Range Text

@rpt_state State

@rpt_title Report Title

@rpt_uid User identification code (UserID)
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Read-Only Formulas

The following Crystal Reports formulas are read-only; i.e., they must contain a 
nonblank value in the report. These formulas trigger specific actions or 
populate specific formulas:

@uniform Assessment Equalization Rate

@year Fiscal year in use by current user in 
Govern

Formula Action

@acbill Refreshes the AC_POST_MASTER table 
with the current Aircraft ID or the current 
Name ID (in duplicate bill printing).

@all_ar_needed_ac Populates the value of several formulas 
for the current NA_ID and for the all Tax 
sub-systems. See Conditional Formulas 
on page 158.

@all_int Updates the following fields in the AR_ 
SUMMARY table for all installments with 
positive balance, for all Taxation and 
Assessment sub-systems and for the 
current NA_ID. (All updated installment 
records within a sub-system will contain 
the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total balance 
due, exclusive of late charges)

@btbill Refreshes the BT_POST_MASTER table 
with the current Boat ID or the current 
Name ID (in duplicate bill printing).

@drilldown Enables Crystal Reports Drill Down 
feature

Formula Definition
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@govern_tx_interest

*This formula is used when calling a Web 
Crystal Report

Updates the LATE_CHARGES column in 
the AR_SUMMARY table.

Use when calling a Web Crystal Report in 
the Real Property Tax Subsystem.

@govern_ub_interest

*This formula is used when calling a Web 
Crystal Report

Updates the LATE_CHARGES column in 
the AR_SUMMARY table.

Use when calling a Web Crystal Report in 
the Utility Billing Subsystem.

@mv_ar_needed_ac Populates the value of several formulas 
for the current NA_ID and for the Motor 
Vehicle Excise Tax sub-system. See 
Conditional Formulas on page 158.

@mvbill Refreshes the MV_POST_MASTER table 
with current Motor Vehicle ID or the 
current Name ID (in duplicate bill printing).

@mv_int Updates the following fields in the AR_ 
SUMMARY table with motor vehicle 
excise tax information, for all installments 
having a positive balance for the current 
MV_ID. (All updated installment records 
will contain the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total Balance 
Due, excluding late charges.)

@pp_ar_needed Populates the value of several formulas 
for the current PP_ID and for the Personal 
Property Tax sub-system. See Conditional 
Formulas on page 158.

@pp_ar_needed_ac Populates the value of several formulas 
for the current NA_ID and for the Personal 
Property Tax sub-system. See Conditional 
Formulas on page 158.

Formula Action
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@ppbill Refreshes the PP_POST_MASTER table 
with the current Personal Property ID or 
the current Name ID (in duplicate bill 
printing).

@pp_int Updates the following fields in the AR_ 
SUMMARY table, for the current PP_ID, 
with Personal Property Tax information, 
for all installments having a positive 
balance. (All updated installment records 
will contain the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total Balance 
Due, excluding late charges)

@re_ar_needed Populates the value of several formulas 
for the current P_ID and for the Real 
Estate Tax sub-system. See Conditional 
Formulas on page 158.

@re_ar_needed_ac Populates the value of several formulas 
for the current NA_ID and for the Real 
Estate Tax sub-system. See Conditional 
Formulas on page 158.

@re_int Updates the following columns in the 
AR_SUMMARY table, for the current 
P_ID, with Real Estate Tax information, for 
all installments having a positive balance. 
(All updated installment records will 
contain the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total Balance 
Due, excluding late charges)

Formula Action

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 157

Report Function Setup: 
Formulas

@td_ar_needed Populates the value of several formulas 
for the current P_ID and for the Tax 
Deferral sub-system. See Conditional 
Formulas on page 158.

@td_int Updates the following fields in the 
AR_SUMMARY table for all installments 
having a positive balance, with Tax 
Deferral information for the current P_ID. 
(All updated installment records will 
contain the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total Balance 
Due, excluding late charges)

@tt_ar_needed Populates the value of several formulas 
for the current P_ID and for the Real 
Property Tax Title sub-system. See 
Conditional Formulas on page 158.

@tt_int Updates the following fields in the 
AR_SUMMARY table, for the current 
P_ID, with Tax Title/Lien information, for 
all installments having a positive balance. 
(All updated installment records will 
contain the same information).

LATE_CHARGES (Accrued Penalty or 
Interest)

CHARGE_DATE (Current date as defined 
in Govern)

BALANCE_AS_OF_DATE (Total Balance 
Due, excluding late charges)

@txbill Refreshes the TX_POST_MASTER table 
with the current Property ID or the current 
Name ID (in duplicate bill printing).

Formula Action
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Conditional Formulas

The Crystal Reports formulas listed in this table are populated by Govern 
conditionally, on the presence of the following read-only formulas: 

• @all_ar_needed_ac
• @mv_ar_needed_ac
• @pp_ar_needed
• @pp_ar_needed_ac
• @re_ar_needed
• @re_ar_needed_ac
• @td_ar_needed
• @tt_ar_needed

Formula Action

@ar_interest_1

@ar_interest_2

@ar_interest_3

@ar_interest_4

Calculates the interest and penalties 
committed for the current fiscal year and 
the specified installment.

@current_due Calculates the total balance due for the 
current fiscal year, including late charges.

@daily_interest Calculates the daily interest and penalties.

@prior_ar_fee_1

@prior_ar_fee_2

@prior_ar_fee_3

@prior_ar_fee_4

Calculates the demands, charges and 
fees committed for prior fiscal years and 
the specified installment.

@prior_ar_interest_1

@prior_ar_interest_2

@prior_ar_interest_3

@prior_ar_interest_4

Calculates the interest and penalties 
committed for the prior fiscal years and for 
the specified installment.
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@prior_due Calculates the total balance due for the 
prior fiscal years, including late charges.

Formula Action
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User Text Maintenance

With the User Text Maintenance form, you can modify all the text from the 
SY_TEXT table. This includes the entries on the Govern CoolBar, messages 
and labels on functions. The text is modified on the user interface but remains 
unchanged in the database.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > User text Maintenance

To modify text:

1. Select an item from the Select Form drop-down list. For example, in the 
preceding screen shot, the Mass Appraisal Information function, 
frm_ma14 is selected.

2. Highlight the text you want to modify from the System Text column, on the 
left. The text is copied to the User Text column, on the right.

3. Modify the text, in the right column.

4. Click Save.

Overview
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Process Flow Wizard Setup

Use the Process Flow Wizard Setup form to define a workflow for any work 
process, from printing bills to completing end-of-year procedures. You can 
include batch processes, administrative procedures and reports. Add them to 
the queue in the order they need to be completed and define the users that 
need access permissions. 

The Process Flow Wizard is run in Govern Batch Processing. This keeps track 
of each task, displaying the starting and completion date and times, with the 
name of the user and maintains an error log. See Process Flow Wizard on 
page 303, for details.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Process Flow Wizard Setup

Overview
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Creating a Workflow

To create a workflow with the Process Flow Wizard Setup:

1. Launch Govern Admin.

2. Select Setup > Process Flow Wizard Setup.

3. Click New to reset the form.

4. Enter a Workflow Code. This is saved to VT_USR_WORKFLOW and 
identifies the workflow.

5. Enter a Short Description and Long Description. The Long Description 
is used to populate the Workflow Description on the Process Flow 
Wizard in Govern Batch Processing.

6. Select the users, from the Users drop-down list, who need to access the 
current workflow in Govern Batch Processing.

Select the to open the User Maintenance form, if required.

7. Click Save to save the workflow to VT_USR_WORKFLOW. 

Defining Steps in the Workflow

To define each step in the workflow, or each task that needs to be completed 
in the work process:

1. Modify the Step Sequence, if required. Step Sequence Numbers are 
automatically generated, in increments of ten and used to order the steps, 
in the queue.

2. Select the Govern Batch Process, Govern Admin Process and / or 
Report Name for the step. 

3. Select Not Allow Restart to prevent a user from relaunching the process 
or regenerating the report if there are errors. You need to select this option 
if a previous step needs to be performed before the current step. For 
example, if a calculation needs to be performed before the current step 
can be executed.

4. Enter the step number from which the workflow needs to be restarted. For 
example, the step with the calculation that needs to be performed.

Tip: Enter the first letter of the item, rather than scrolling through the 
complete list.
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5. Click Add to add the step to the queue.

6. Repeat this procedure to complete the workflow.

7. Click Save.

Modifying a Step

To modify a step in the workflow:

1. Highlight the step in the grid.

2. Modify the fields as required.

3. Click Update.

4. Click Save.

Removing a Step

To remove a step from the workflow:

1. Highlight the step in the grid.

2. Click Remove.

3. Click Save.
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Define your scanner settings on the Scanner Parameters Setup form. Any 
TWAIN-compliant scanner can be used to copy images to disk for the 
Multimedia functions.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Scanner Parameters Setup

Overview
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Scanner Parameters Maintenance Command 
buttons

Test Parameters: Click Test Parameters to test the parameters that you 
have selected. If a parameter is not set properly, an error message will be 
displayed.

Save: Click Save to save the current Scanner Parameters Setup in the 
USR_REGISTRY table.

Scanning Parameters

Select Scanner group

Select Scanner: Select a scanner from the drop-down list. 

Default Scanner in Govern: When selected, this option can set the 
current Scanner as the default.

Interface to Use When Scanning group

Manufacturer User Interface: Select this option to default to the scanner 
manufacturers interface. When selected, all options in this form will be 
disabled.

Govern Direct Scan: If selected,  this option will enable the parameters in 
this form. Scanning results will be based upon the settings entered in this 
form.

Type of Image and Resolution group

Black / White, Gray scale, Palette Color, RGB Color: Select one of 
the image color options.

Bits Per Pixel: Select how many Bits per Pixel you want to use for the 
scanner resolution. The list of items varies depending on the color option 
selected.
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Resolution: Select the resolution that you want to use for the scanner. The 
list of items varies depending on the color option selected.

PAPER SIZE: Select the paper size to use when scanning. Available sizes 
include A4, A5, B5, Letter (81\2 x 11), (81\2 x 14), (11 x 17) 

Image Information group

Brightness: The values entered in this field is the default Brightness. The 
values required for optimum results from the selected scanner will have to be 
obtained by exprimentation or the manufacturer.

Gamma: This is the default Brightness value. The values required for 
optimum results from the selected scanner will have to be obtained by 
exprimentation or the manufacturer.

Shadow: The Shadow field displays the default Shadow value. The values 
required for optimum results from the selected scanner will have to be 
obtained by exprimentation or the manufacturer.

Contrast: This is the default Contrast value.  The values required for 
optimum results from the selected scanner will have to be obtained by 
exprimentation or the manufacturer.

Highlight: The value entered in this field is the default Highlight value. The 
values required for optimum results from the selected scanner will have to be 
obtained by exprimentation or the manufacturer.

Threshold: This field displays the default Threshold value. The values 
required for optimum results from the selected scanner will have to be 
obtained by exprimentation or the manufacturer.

Scan Feed group

Document Plate: If selected, this option directs the scanner to accept input 
one page at a time.

Note: The following options will need to be configured to the requirements of 
the document scanner that is being used. Each parameter value will 
need to be  verified for the sc anner from the manufacturer.FI
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ADF: When selected, this option allows you to feed the scanner using an 
Automatic Document Feeder (ADF).

Scan Units group

Inches: Select this option to set the scan units to Inches.

Centimeters: If selected  scanner unit will be set to centimeters.
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ICVerify Setup

Use the ICVerify Setup form to integrate the ICVerify package, for credit card 
transaction processing. The setup must be performed on every workstation 
accepting credit cards. This is used to verify security options for this type of 
transaction.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > IC Verify Setup

 

Saving the ICVerify Parameters Setup: Click Save to save the 
parameters setup for the current workstation. 

Overview
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Workstation ICVerify Install Directory: Enter the path of the ICVerify 

installation directory. You can also click the  button. This action opens a 
screen displaying a tree of the current working drive to help you to find the 
install directory. If the path is incorrect, or if the system cannot find any 
application installed, then a warning message is displayed. 

Master Request Shared Directory: Enter the path of the ICVerify master 
workstation shared directory that will receive the file used to send the requests 

for transaction approvals. To find the directory path, you can also click the  
button to find the install directory.

Merchant Code: Enter the Merchant Code. It corresponds to the four last 
characters of the setup file name of the merchant (that the transaction is being 
processed for). For example, if you use the default ICVERIFY.SET, this 
property should then be set to RIFY.   

Number of Licenses Purchased: Enter the exact number of ICVerify 
licenses purchased.

Transaction Time-out (in ms): This is the length of time in milliseconds 
that a transaction will wait for a license to process before it times out. The 
default value is 10000.

Minimum Transaction Amount Allowed: Enter the minimum transaction 
amount allowed. This value cannot be less than one.

Validate Credit Card Exp. Date: If this option is selected, the card 
expiration date is checked automatically by the system. If it is not valid, the 
process will not be completed. If it is not checked off, validation will not be 
performed by the system. 

Type of Processing Transaction

If you select, Authorization Only, you must enter a Batch File Directory. This 
file will store the pre-authorized transactions until the settlement process has 
been completed. In this mode, the system will prompt for an approval number 
when entering a credit card payment.

Authorization Only: If selected, you must enter a Batch File Directory. This 
file will store the pre-authorized transactions until the settlement process has 
been completed. In this mode, the system will prompt for an approval number 
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when entering a credit card payment. This is to allow balancing A/R by 
Cashier, Operator, Deposit Number or Date in the Batch Process.

Normal Sale: If selected, this option will tell ICVerify to process the 
transaction as a normal sale and settlement will occur as the option selected 
in the Type of Processing Network section.

Practice Mode: If selected, this option allows the User to test the function. 
The value returned will be 99999.

Type of Processing Network

Terminal-based: If selected, it indicates to Govern that you are using a 
processing network that will proceed in two steps: the approval followed by the 
settlement.

Host-based: If selected, it indicates to Govern that you are using a 
processing network that will proceed in one step: Approval & Settlement.

Address Verification Mode (AVS Mode): Select one of the AVS modes. 
The most complicated mode appears at the top of the list with the list at the 
bottom. The merchant-processing fee is usually less for the less complicated 
modes.

Navigate to a directory for the batch file. To return to the parameter setup click 

.
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PayPal Configuration

PayPal is an online payment transaction service that also offers credit card 
payment settlement services. With Govern version 10.0 PayPal was offered 
as an option for credit card transactions. Previously the only option available 
for processing credit card payments was ICVerify.

PayPal Parameters

Run Mode group

Live Mode: Select this option to run in a live environment.

Test Mode: Select this option to run in test mode.

Overview

FI
N

AL
 D

R
AF

T



Page 172 © 2013 MS Govern

Super User

PayPal Parameter group

PayPal Partner: Enter you PayPal partner name.

PayPal Password: Enter your password.

PayPal Port: Specify the port that PayPal will use.

PayPal Tender: Enter a method of payment:

• A - ACH (Automated Clearing House)
• C - Credit Card
• D - Pinless Debit
• E - Electronic Check
• K - Telecheck
• P - PayPal

PayPal Time Out: Specify a time-out value in seconds; a value of 30 - 300 
secs is the usual.

PayPal User: Enter the name of the PayPal user.

PayPal Vendor: Enter the PayPal vendor.

Minimum Transaction Amount Allowed: Enter the minimum amount 
that is allowed for a transaction.

To configure for PayPal transactions, in Govern Admin:

1. Select Parameters > System Registry Maintenance.

2. Click on the Credit Card tab.

3. On the Credit Card Processor Company drop-down menu option, select 
Pay Pal as the option.

Note: All PayPal configuration parameters will be provided by your PayPal 
partner.

Note: The following setup must be performed on every workstation accepting 
credit cards.

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 173

PayPal Configuration

4. Enter the required parameters.
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Barcode Setup for OCR and PostNet 
Billing

Previously, modifications to barcode fonts required special assistance for 
configuration. The parameters that were required to be set were not readily 
accessible to users. With this option, configuration of Barcode, OCR, and 
PostNet fonts, and dimensions, is  accessible to users with administrator-level 
access.

Using the Bill Fonts group, OCR / PostNet barcodes can be generated and 
included in Govern generated reports such as tax bills, invoices, etc.

Bill Fonts and Crystal Reports

The configuration of Bill Fonts options does not apply to Crystal Reports. 
Crystal reports are self contained, i.e. their fonts are embedded within the 
report itself, and therefore external to Govern’s control.

To configure Bill Fonts in Govern Admin...

1. Select Parameters > System Registry Maintenance.

2. In the System Registry Maintenance form, select the Options tab.

Overview
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3. Look for the Bill Fonts group.

The additional parameters that are required for the configuration, i.e. Barcode, 
Print Size, Pict Size, and Height are set based upon each user individual 
requirements.

Note: Barcodes and barcode readers are specialized in that users cannot  
use any barcode font. Refer to the information supplied with your 
reader or scanning system, to find out what fonts are compatible with 
your system.
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MS Govern's Centralized Cash Receipting (CCR) Module is a web based 
transaction system that integrates to the Govern System. Govern’s CCR 
module provides centralized cash collection on any cash receipt, including 
utility, building permits, property taxes and accounts receivables. Transactions 
made through CCR are sent to Govern via web services, and stored as a 
transaction in Govern's A/R table.

In order for Govern to be able to store a CCR transaction, it is necessary to 
include additional information that is not provided by CCR. This appending 
procedure ensures that CCR data will conform with Govern's database 
structure. Required settings are defined in the CCR Setup group in Govern 
Admin.

To configure CCR in Govern Admin:

1. Select Parameters > Edit the System Registry...
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2. In the System Registry Maintenance form, look for the CCR Setup group.

3. Configure the parameters as required.

For details on CCR Setup parameters, see CCR Setup group on page 41. 
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Launch an external application directly from Govern, after setting it up through 
the External Application Setup form. You can enter parameters, such as user 
ID and password or directory path in order to open the application directly. You 
can also enter the ODBC connection. The application name is added to the 
Tools menu in Govern.

You can create a command button for the application and launch it directly 
from a Govern function. See New Command Buttons on page 257, for details.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > External Application Setup

External Application Setup Parameters

Application Path: Enter the path to the application you are linking.

Overview
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Selecting an Application Path: Click  to open the selection screen. 

Then, navigate to the drive and directory where the application you are linking 
is located.

Selecting an External Application: Select the drive and directories 
where the application is located. Then, select the application from the list box 
on the right and click OK.

Menu Name: Enter a name to identify the external application you are 
linking. This will appear on the Tools menu in Govern.

Parameters 1, 2 and 3: Enter application parameters in these three fields. 
For example, you could set the keywords: %USERID%, for the current user 
name and %PASSWORD%, for the current password as parameters.

Note: You can enter more than one parameter per line. Separate each with a 
space.When you enter information on each line separately for 
Parameters 1, 2, and 3, the system automatically inserts a space.
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You can also set the ODBC connection in order to connect directly to the 
Govern database from the external application. To set the ODBC connection 
enter %ODBC%.

You can also enter any keyword from the validation table VT_SY_BRULE as a 
parameter; for example, enter the tax map number, parcel identification and 
name identification in order to open the application to a specific record:

The following table lists the available keywords.

The system replaces the semi-colon (;) in the connection string with a caret (^) 
and replaces the space with an at-sign (@); for example, the following string
ODBC;DSN=nfr75sp1;DATABASE=NFR75SP1;DBQ=NFR75SP1;UID=montreal
;USER ID= montre al;PWD=montreal
is replaced by:
ODBC^DSN=nfr75sp1^DATABASE=NFR75SP1^DBQ=NFR75SP1^UID=montre
al^USER@ID= montr eal^PWD=montreal
The external application needs to reconvert these characters to the original 
semi-colon and space.

Code Keyword Description

*date current date Current Date

ac_id aircraft id Unique identification number of the 
current Aircraft Excise Tax record
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bldg_id building id Unique identification number of the 
current building

bldg_seq building sequence Unique identification Sequence 
Number of the current building

bt_id boat id Identification number of the current 
Boat Excise Tax account 

co_id complaint id Unique identification number of the 
current Complaint, Grievance, 
Request of Services or Workflow 
record

dept department Department Code

frozen_id frozen id Unique identification number of the 
current Frozen record

in_id inspection id Unique identification number of the 
current inspection

land_id land id Unique identification number of the 
current land

misc_id miscellaneous id Identification number of the current 
Miscellaneous Billing account

mv_id motor vehicle id Identification number of the current 
Motor Vehicle Account 

na_id name id Unique identification number of the 
current Name

of_id offence id Unique identification number of the 
current Offense record

p_id parcel id Unique identification number of the 
current parcel 

pm_id permit id Unique identification number of the 
current Building Permit, Electrical 
Permit, General Permit, Plumbing 
Permit, Permit to Name, Animal 
License, Business License, License 
to Name, Approval, Bond, Decision, 
Prosecution or Appeal record

pp_det_id pp detail id Unique identification number of the 
current Personal Property Item

Code Keyword Description
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Users: Select the users who will have access to the external application, 

from the drop-down list. Click  to open the User Maintenance form. See 
User Maintenance on page 60.

Groups: Select the groups that will have access to the external application, 

from the drop-down list. Click  to open the Group Validation form. See 
Creating a Group on page 75, for details. 

External Application Setup Command Buttons

Creating a New External Application Setup Record: Click New to 
clear the form.

Saving an External Application Setup Record: Click Save to save a 
new External Application Setup record or any modifications to an existing one 
(Table: USR_EXT_AP).

Deleting an External Application Setup Record: Click Delete to 
remove the current record from the database.

Browsing External Application Setup Records: Click Browse to view 
a list of the existing External Application Setup records.

pp_id personal property id Identification number of the current 
Personal Property account 

tax_map tax map no Tax Map Number of the current 
record

ub_id utility billing id Unique identification number of the 
current Utility Billing account

usr_id user id Unique identification number of the 
current user

year_id year id Year identification of the current 
record

Note: Leave the Users and / or Groups fields blank to grant access to all.

Code Keyword Description
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Formula Editor

Create customized formulas, using the Formula Editor form. Formulas can be 
used in Mass Appraisal calculations, permit fee calculations, added to a 
logical expression, created through the Logical Expression Block Editor and 
added to a customized database field or linked to any field, whether created 
by Govern or user-defined.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Formula Editor

Overview
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Formula Editor Command Buttons

Creating a New Formula: Click New to clear the form so that you can 
enter new data. 

Saving a Formula: Click Save to save a new record or any modifications to 
an existing one. Formulas are saved to VT_USR_FORMULA.

Deleting a Formula: Click Delete to remove the current record from the 
database.

Browsing Formula Records: Click Browse to view a list of the existing 
formulas.

Formula Editor Fields

Functions: The following functions can be used to create formulas:

 Digits and Operators: The following digits and operators can be used:


Absolute Value Function


Arc Tangent Function


Cosine Function

Exponential of e 
Function (e= 2.718282)

Integer part of a number 
(not rounded)

Integer part of a number 
(rounded)

Natural Logarithm 
Function

Base 10 Logarithm 
Function

Sign Function (results to 
1 or –1)


Sinus Function


Square Root Function


Tangent Function

Rounded to 0 decimal 
places

Rounded to 2 decimal 
places

Rounded to 6 decimal 
places


Back Space


Clears Last Entry

Clears the Algebraic 
Formula Text box


Inserts the Digit 7


Inserts the Digit 8


Inserts the Digit 9
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Algebraic Formula: The Algebraic formula is created as the information is 
entered. This formula can also be modified in this space.

Name of Formula: Enter a name for the new formula.

Short Description: Enter a short description for the formula.

Long Description: Enter a long description for the formula.


Inserts the Digit 4


Inserts the Digit 5


Inserts the Digit 6


Inserts the Digit 1


Inserts the Digit 2


Inserts the Digit 3


Inserts a zero


Inserts a decimal point

Integer Division 
Operator


Division Operator


Multiplication Operator


Subtraction Operator


Addition Operator


Exponential Operator

Insert an Opening 
Parenthesis

Insert a Closing 
Parenthesis

Insert an Opening 
Bracket

The Brackets are used 
for enclosing database 
tables and fields.


Insert a Closing Bracket

Note: These definitions are displayed, as a tool tip, when you run the mouse 
over the button.
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Adding Database Fields, Queries, Keywords and 
Constants

To include a value from a database field, query, keyword or constant, in a 
formula, select the item from the drop-down list. You can include as many of 
these values as needed, by making multiple selections. The item is added 
where the cursor is placed in the Algebraic Formula edit box. For example, 
you could retrieve two values from the database, using Selection Queries, and 
add these values together.

The following restriction applies:

You can also create a new query or constant, from the Formula Editor by 
clicking the beside the drop-down list, for the item. 

Tables: To include a database field in a formula, you need to select the table 
first, from the Tables drop-down list.

Fields: After selecting the table, select the field from the Fields drop-down 
list. The value of this field for the current record is included in the formula. 
These selected table and field are displayed in uppercase, between square 
brackets; for example, [AC_ EXEMPTIONS.FROZEN_ID].

Consider Null as 0: Select this option to consider Null as 0 during the 
calculation process. Null represents the absence of a value and normally if 
one operand within the formula is Null, the result of the formula is Null. When 
this option is selected, Null is recognized as 0 and the formula returns a 
numeric value.

Select Queries: You can include one or more queries in a formula. These 
queries must be Selection queries; i.e., used to retrieve data from one or more 
fields.

All fields, selected from the Fields list, must be associated with the same 
function.
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The queries need to be defined through the User-Defined Queries Setup form. 
To include a query, select it from the list. The query name is displayed in the 
Algebraic Formula edit box between braces, { }. To create a new query, click 

. See SQL Queries on page 211 for more information.

Keywords: Select a keyword from the drop-down list to include it in the 
formula. Keywords are used to retrieve a value currently in memory; such as ~ 
parcel id ~ to retrieve the parcel id of the current record. Keywords are 
displayed in lowercase, between tildes, ~ ~.

The following table lists the available keywords for the formulas.

For example, in the following formula:

{depr_year}-[MA_BUILDINGS.EYB]

The Effective Year Built (EYB) of the current building record is subtracted from 
the Depreciation Year, the year used in calculating the depreciation (depr_year).

The Depreciation Year query {depr_year} retrieves the depreciation year from 
the SY_REGISTRY table, by specifying values for the SECTION_ NAME and 
KEY_NAME fields:

Select KEY_VALUE From SY_REGISTRY Where SECTION_NAME=str(Year 
Id,4) and KEY_NAME='depreciation year'

For example, to include the building sequence for the current building record, in 
the formula, select the ~building sequence~ keyword.

Code Keyword Description

*date current date Current Date

ac_id aircraft id Identification number of the current 
Aircraft Excise Tax record

ar_id accounts receivable id Identification number of the current 
Account Receivable record

bldg_id building id Identification number of the current 
building

bldg_seq building sequence Identification Sequence Number of 
the current building
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br_id bankruptcy id Identification number of the current 
Bankruptcy record

bt_id boat id Identification number of the current 
Boat Excise Tax account 

cc_id cash collection id Identification number of the current 
Cash Collection record

co_id complaint id Identification number of the current 
Complaint, Grievance, Request of 
Services or Workflow record

dept department Department Code

folio_id project folio id Identification number of the current 
Project Folio record

frozen_id frozen id Identification number of the current 
Frozen record

h_id hearing id Identification number of the current 
Hearing record

haz_id hazard id Identification number of the current 
Hazard record

in_id inspection id Identification number of the current 
inspection

key_counter activity id Identification number of the current 
Activity record

land_id land id Identification number of the current 
land

mb_id misc. billing id Identification number of the current 
Miscellaneous Billing record

misc_id miscellaneous id Identification number of the current 
Miscellaneous Billing account

mv_id motor vehicle id Identification number of the current 
Motor Vehicle Account 

na_id name id Identification number of the current 
Name

of_id offence id Identification number of the current 
Offense record

Code Keyword Description
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Constants: Select a constant from the drop-down list, to include it in the 

formula or click  to create a new constant. Constants are displayed between 

p_id parcel id Identification number of the current 
parcel 

pm_id permit id Identification number of the current 
Building Permit, Electrical Permit, 
General Permit, Plumbing Permit, 
Permit to Name, Animal License, 
Business License, License to Name, 
Approval, Bond, Decision, 
Prosecution or Appeal record

pp_det_id pp detail id Identification number of the current 
Personal Property Item

pp_id personal property id Identification number of the current 
Personal Property account 

prj_id project id Identification number of the current 
Project record

sa_id special assessment id Identification number of the current 
Special Assessment record

sale_id sale id Identification number of the current 
Sale record

si_id site id Identification number of the current 
Site record

st_acct_id self reported tax account 
id

Identification number of the current 
Self Reported Tax Account record

st_id self reported tax id Identification number of the current 
Self Reported Tax record

tax_map tax map no Tax Map Number of the current 
record

ub_id utility billing id Identification number of the current 
Utility Billing account

usr_id user id Identification number of the current 
user

year_id year id Year identification of the current 
record

Code Keyword Description
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ampersands (& &). See Constant Value Editor on page 208 for more 
information.

Executing Formulas and Logical Expressions

Note: When formulas and logical expressions that include keywords or 
database columns, are executed, all the applicable functions need to 
be open.

Alternately, you can add a Selection Query to the formula or logical 
expression, in order to retrieve values from database fields. 
SeeSelection Queries on page 216.FI
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Logical Expression Block Editor 

Create customized logical expressions, using the Logical Expression Block 
Editor form. Logical expressions can be used in Mass Appraisal calculations, 
permit fee calculations and linked to any field, whether it is created by Govern 
or user-defined.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Logical Expression Editor

You can include a Temporary Field, in your logical expressions. This can hold 
any value, for example, one generated from a query, a database field or from 
user input. See Using a Temporary Field on page 206.

Overview
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Logical Expression Block Editor Command Buttons

Creating a Logical Expression: Click New to clear the form so that you 
can create a new logical expression.

Saving a Logical Expression: Click Save to save a new Logical 
Expression or any modifications to an existing one. Logical expressions are 
saved to VT_USR_LOGEXP.
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Deleting a Logical Expression Record: Click Delete to remove the 
current record from the database.

Browsing Logical Expression Records: Click Browse to view a list of 
the existing Logical Expressions.

Logical Expression Block Editor Parameters

Logical Expression Block: Compose your logical expressions in this edit 
box. There is no limit to the number of statements you can add.

The following operators can used:

Expression Name: Enter a name or code for the logical expression.

Short Description: Enter a short description. This is used for fast data entry 
and look-ups if space is limited on forms.

Long Description: Enter a long description. This is displayed during look-
ups and on forms and reports.

Operator Definition

= Equal to

> Greater than

< Less than

<> Different from

<= Less than or Equal to

>= Greater than or Equal to

IN Value represented by the first expression as present in the second

AND (xxxx) AND (xxxx)

OR (xxxx) OR (xxxx)
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Building Logical Expressions 

You can compose your logical expressions in the Logical Expression Block 
edit box or copy and paste one from another file. Your logical expression can 
comprise an unlimited number of statements, constants, formulas, keywords, 
queries, database fields, numeric values and strings.

Statements

The logical expression can be built from the following types of statements: IF... 
THEN... ELSE, DO, RETURN and IN.

IF… THEN… ELSE…

This type of statement executes a group of statements, conditionally, 
depending on the value of the logical expression.

The following rules apply:

1. IF, THEN and ELSE must be written in uppercase.

2. A space must be entered between the statement and the action.

3. Only Select Queries can be used with the IF statement. For more 
information on queries, see SQL Queries on page 211.

The syntax is as follows:

DO

This type of statement executes an action. 

The following rules apply:

1. DO must be written in uppercase.

2. A space must be entered between the statement and the action.

3. It must be followed by an action.

IF condition THEN
statement
ELSEIF elseifcondition THEN
elseifstatement
ELSE elsestatement
ENDIF
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4. The action must be followed by a ; (semi-colon).

5. Only Action Queries can be used with the DO statement. For more 
information on queries, see SQL Queries on page 211.

The syntax is as follows:

RETURN

This type of statement returns a value.

1. RETURN must be written in uppercase.

2. A space must be entered between the statement and the action.

3. The action must be followed by a ; (semi-colon).

The syntax is as follows:

You can enter any of the following, after the RETURN: 

• Select Query: from the Select Queries drop down list. The query name 
must be entered between braces, {  }

• Formula: from the Formulas drop down list. A formula must be entered 
between bar delimiters, |   |.

• String: ‘text’. A string is entered between single quotation marks, ‘ ‘.
• Date: #2004#
• Value: 999
• Keyword: from the Keywords drop down list. A keyword must be placed 

between tildes, ~ ~.

IF condition THEN
DO action;
ELSEIF elseifcondition THEN
DO action;
ELSE
DO action;
ENDIF

IF condition THEN
RETURN value;
ELSEIF elseifcondition THEN
RETURN value;
ELSE
RETURN value;
ENDIF
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• TRUE: in uppercase
• FALSE: in uppercase
• A database field name must be entered, with the table, between square 

brackets, [TABLE.FIELD].

IN Statement

The following rules apply to the IN Statement:

1. An item list separated with a comma (,) must be placed after the IN 
operator.

2. The item list must be delimited with quotation marks (“)

3. The item list must contain at least two items.

4. The items in the list must be of the same type; i.e., numeric or string
OR

If the list contains items of different types, the items must be delimited with 
single quotation marks:

Logical Expression Comparison Operators

Statement Correct / Incorrect

IN “A,B,C,D”  Correct

IN “10,20,30,40”  Correct

IN”10,A,B,C”  Incorrect

IN”’10’,’A’,’C’,’D’”  Correct

INA,B,C,D  Incorrect

IN”A”  Incorrect

IN “A,B”  Correct

Operator Description How to use…

= Is the value represented by the first 
expression is equal to the value 
represented by the second?

0 = 0  True   

0 = 1  False

A = A  True

A = B  False
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Logical Operators

<> Is the value represented by the first 
expression not equal to the value 
represented by the second?

0 <> 1  True

0 <> 0  False

A <> B  True

A <> A  False

> Is the value represented by the first 
expression greater than the value 
represented by the second?

1 > 0  True

2 > 2  False

1 > 3  False 

>= Is the value represented by the first 
expression less than or equal to the 
value represented by the second?

1 >= 0  True 

2 >= 2  True

1 >= 3  False

< Is the value represented by the first 
expression less than the value 
represented by the second?

0 < 1  True

2 < 2  False

3 < 1  False 

<= Is the value represented by the first 
expression greater than or equal to 
the value represented by the second?

0 <= 1  True 

2 <= 2  True

3 <= 1  False

IN Is the value represented by the first 
expression found in the second?

1 IN “1,2,3,4,5”  
TrueA IN “A,B,C,D,E” 
 True

9 IN “1,2,3,4,5”  
FalseZ IN 
“A,B,C,D,E”  False

Operator Description How to use…

Operator Description How to use…
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RETURN_MAX_1

The RETURN_MAX_1 expression will compare two (2) values, and return the 
greater, i.e. the maximum, of the two.

Syntax for the use of the RETURN_MAX_1 expression is as follows:

RETURN_MAX_2

The RETURN_MAX_2 expression will compare three (3) values, and return 
the greater, i.e. the maximum, of the three.

AND The And operator performs logical conjunction on two 
Boolean expressions. That is, if both expressions 
evaluate to True, then the And operator returns True. 
If either or both expressions evaluate to False, then 
And returns False.

True AND True   True

True AND False  False

False AND True   False

False AND False  False

OR

The Or operator performs logical disjunction on two 
Boolean expressions. If either expression evaluates to 
True, Or returns True. If neither expression evaluates 
to True, Or returns False.

True OR True   True
True OR False  True
False OR True   True
False OR False  False

IF (ATTRIB_1 >= PARAM_1) THEN
 RETURN ATTRIB_1;
ELSE
   RETURN PARAM_1;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1 is the value of the parameter.

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 199

Logical Expression Block 
Editor

Syntax for the use of the RETURN_MAX_2 expression is as follows:

RETURN_MAX_3

The RETURN_MAX_3 expression will compare four (4) values, and return the 
greater, i.e. the maximum, of the four.

Syntax for the use of the RETURN_MAX_3 expression is as follows:

RETURN_MIN_1

The RETURN_MIN_1 expression will compare two (2) values, and return the 
lowest, i.e. the minimum, of the two.

IF (ATTRIB_1 >= PARAM_1) AND (ATTRIB_1 >= PARAM_2) THEN
   RETURN ATTRIB_1;
ELSEIF (PARAM_1 >= ATTRIB_1) AND (PARAM_1 >= PARAM_2) THEN
   RETURN PARAM_1;
ELSE
   RETURN PARAM_2;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1, and PARAM_2 are the values of the parameters.

IF (ATTRIB_1 >= PARAM_1) AND (ATTRIB_1 >= PARAM_2) AND 
(ATTRIB_1 >= PARAM_3) THEN
   RETURN ATTRIB_1;
ELSEIF (PARAM_1 >= ATTRIB_1) AND (PARAM_1 >= PARAM_2) AND 
(PARAM_1 >= PARAM_3) THEN
   RETURN PARAM_1;
ELSEIF (PARAM_2 >= ATTRIB_1) AND (PARAM_2 >= PARAM_1) AND 
(PARAM_2 >= PARAM_3) THEN
   RETURN PARAM_2;
ELSE
   RETURN PARAM_3;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1, PARAM_2 and PARAM_3 are the values of the parameters.
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Syntax for the use of the RETURN_MIN_1 expression is as follows:

RETURN_MIN_2

The RETURN_MIN_2 expression will compare three (3) values, and return the 
lowest, i.e. the minimum, of the three.

Syntax for the use of the RETURN_MIN_2 expression is as follows:

RETURN_MIN_3

The RETURN_MIN_3 expression will compare four (4) values, and return the 
lowest, i.e. the minimum, of the four.

IF (ATTRIB_1 <= PARAM_1) THEN
   RETURN ATTRIB_1;
ELSE
   RETURN PARAM_1;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1 is the value of the parameter.

IF (ATTRIB_1 <= PARAM_1) AND (ATTRIB_1 <= PARAM_2) THEN
   RETURN ATTRIB_1;
ELSEIF (PARAM_1 <= ATTRIB_1) AND (PARAM_1 <= PARAM_2) THEN
   RETURN PARAM_1;
ELSE
   RETURN PARAM_2;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1 and PARAM_2 are the values of the parameters.

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 201

Logical Expression Block 
Editor

Syntax for the use of the RETURN_MIN_3 expression is as follows:

Adding Formulas, Database Fields, Queries, 
Keywords and Constants

To include a value from a formula, database field, query, keyword or constant, 
in a logical expression, select the item from the drop-down list. You can 
include as many of these values as needed, by making multiple selections. 
The item is added where the cursor is placed in the Logical Expression 
Block edit box. For example, you could make a comparison of two values, 
retrieved through Selection Queries.

The following restriction applies:

To create a new formula, query or constant, from the Logical Expression Block 

Editor, click  in the drop-down list for the item. 

IF (ATTRIB_1 <= PARAM_1) AND (ATTRIB_1 <= PARAM_2) AND 
(ATTRIB_1 <= PARAM_3) THEN
   RETURN ATTRIB_1;
ELSEIF (PARAM_1 <= ATTRIB_1) AND (PARAM_1 <= PARAM_2) AND 
(PARAM_1 <= PARAM_3) THEN
   RETURN PARAM_1;
ELSEIF (PARAM_2 <= ATTRIB_1) AND (PARAM_2 <= PARAM_1) AND 
(PARAM_2 <= PARAM_3) THEN
   RETURN PARAM_2;
ELSE
   RETURN PARAM_3;
ENDIF

Where...
ATTRIB_1 is the value that is entered by the user.
PARAM_1, PARAM_2 and PARAM_3 are the values of the parameters.

All fields, selected in the Fields list, must be associated with the same function.
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Formulas: To include a value calculated through a formula, select the 
formula from the drop-down list. Formulas are displayed between bar 
delimiters, |FORMULA_NAME|. 

To create a new formula, click to open Formula Editor. See Formula Editor 

on page 183 for more information.

Keywords: Select a keyword from the drop-down list to include it in the 
logical expression. Keywords are used to retrieve a value currently in memory; 
such as parcel id  to retrieve the parcel id of the current record. Keywords are 
displayed in lowercase. 

The following table lists and describes the available keywords.

IF |IMP_VALUE| > 0 THEN
 RETURN |IMP_VALUE|;
ELSE
 RETURN 0;
ENDIF

Note: When the logical expression is run, the functions, associated with the 
formula must be open.

For example, to include the building sequence for the current building record, in 
the logical expression, select the building sequence keyword.

For example, 
IF parcel id > 0 THEN
RETURN ~parcel id~;
ELSE
RETURN 0;
ENDIF

Code Keyword Description

*date current date Current Date

ac_id aircraft id Identification number of the current 
Aircraft Excise Tax record

ar_id accounts receivable id Identification number of the current 
Account Receivable record
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bldg_id building id Identification number of the current 
building

bldg_seq building sequence Identification Sequence Number of 
the current building

br_id bankruptcy id Identification number of the current 
Bankruptcy record

bt_id boat id Identification number of the current 
Boat Excise Tax account 

cc_id cash collection id Identification number of the current 
Cash Collection record

co_id complaint id Identification number of the current 
Complaint, Grievance, Request of 
Services or Workflow record

dept department Department Code

folio_id project folio id Identification number of the current 
Project Folio record

frozen_id frozen id Identification number of the current 
Frozen record

h_id hearing id Identification number of the current 
Hearing record

haz_id hazard id Identification number of the current 
Hazard record

in_id inspection id Identification number of the current 
inspection

key_counter activity id Identification number of the current 
Activity record

land_id land id Identification number of the current 
land

mb_id misc. billing id Identification number of the current 
Miscellaneous Billing record

misc_id miscellaneous id Identification number of the current 
Miscellaneous Billing account

mv_id motor vehicle id Identification number of the current 
Motor Vehicle Account 

Code Keyword Description
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Validate Data Entry in a Logical Expression

To validate data entry in a Logical Expression, you can use the keyword 
~textbox value~ note the use of tildes “~”

Tables: To include a database field in a logical expression, you need to select 
the table first, from the Tables drop-down list.

Fields: After selecting the table, select the field from the Fields drop-down 
list. The value of this field for the current record is included in the logical 

na_id name id Identification number of the current 
Name

of_id offence id Identification number of the current 
Offense record

p_id parcel id Identification number of the current 
parcel 

pm_id permit id Identification number of the current 
Building Permit, Electrical Permit, 
General Permit, Plumbing Permit, 
Permit to Name, Animal License, 
Business License, License to Name, 
Approval, Bond, Decision, 
Prosecution or Appeal record

pp_det_id pp detail id Identification number of the current 
Personal Property Item

pp_id personal property id Identification number of the current 
Personal Property account 

For example, 
IF ~textbox value~ > 100000 THEN
RETURN False;
ELSE
RETURN TRUE;
ENDIF

Code Keyword Description
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expression. These selected table and field are displayed in uppercase, 
between square brackets; for example [AC_ EXEMPTIONS.FROZEN_ID].

Action / Select Queries: You can include either Action Queries, i.e., 
queries that perform some action, such as updating records in one or more 
tables, adding records to a table or deleting records from a table, or Selection 
queries; i.e., used to retrieve data from one or more fields, in a logical 
expression.

The queries need to be defined through the User-Defined Queries Setup form. 
To include a query, select it from the list. The query name is displayed in the 
Logical Expression Block edit box between braces, { }. For example, {AG_ 
VALUE}.

To create a new query, click . This opens the SQL Definition Setup form. 
See SQL Queries on page 211 for more information.

The following conditions apply:

• Only Select Queries can be used with the IF statement.
• Only Action Queries can be used with the ACTION statement.

Constants: Select a constant from the drop-down list, to include it in the 

formula or click  to create a new constant. Constants are displayed between 
ampersands (& &). See Constant Value Editor on page 208 for more 

IF [PC_PARCEL.P_ID] > 0 THEN
   RETURN [PC_PARCEL.P_ID];
ELSE
   RETURN 0;
ENDIF

For example, in the following logical expression:

IF {APP_VALUE} > 0 THEN
   RETURN |APP_VALUE|;
ELSE
   RETURN 0;
ENDIF

The Appraised Value of the current record is retrieved, through the 
{APP_VALUE} Selection query, and if the value is positive it is returned by the 
logical expression.
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information.

Message: Enter a message to be displayed if the validation fails.

Dates, Numeric Values and Strings: You can also include dates, 
numeric values and strings, as follows:

• Dates are displayed between crosshatches: IF A = #2004111# THEN
• Numeric values are displayed: IF A = 999 THEN
• Strings are displayed between single quotation marks: IF A = ‘text’ THEN

Using a Temporary Field

You can include a temporary field in a logical expression. This field can hold 
any value, such as one generated from a query, database field or user input.

To include a temporary field, add the following to the beginning of the logical 
expression:

To include multiple temporary fields, enter each value separately:

IF &TAX_RATE& > 0 THEN
   RETURN &TAX_RATE&;
ELSE
   RETURN 0;
ENDIF

SET ?TMP1? = <value>, where <value> is the value you are using

SET ?TMP1? = <value1>
SET ?TMP2? = <value2>
 where <value1> and <value2> represent the values you enter
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For example, the following logical expression is based on a keyword and 
database field:

This logical expression can be written using temporary fields, as follows:

Executing Formulas and Logical Expressions

IF (year id - [MA_BUILDINGS.YEAR_BUILT]) <= 10 THEN
   RETURN 6;
ELSEIF (year id - [MA_BUILDINGS.YEAR_BUILT]) <= 20 THEN
   RETURN 5;
ELSEIF (year id - [MA_BUILDINGS.YEAR_BUILT]) <= 30 THEN
   RETURN 4;
ELSE
   RETURN 3;
ENDIF

SET ?TMP1? = year id 
SET ?TMP2? = [MA_BUILDINGS.YEAR_BUILT] 
IF (TMP1 - TMP2) <= 10 THEN
   RETURN 6;
ELSEIF (TMP1 - TMP2) <= 20 THEN
   RETURN 5;
ELSEIF (TMP1 - TMP2) <= 30 THEN
   RETURN 4;
ELSE
   RETURN 3;
ENDIF

Note: When executing formulas and logical expressions that include 
keywords or database columns, all the applicable functions need to be 
open.

Alternately, you can add a Selection Query to the formula or logical 
expression, in order to retrieve values from database fields. 
SeeSelection Queries on page 216.
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Define and maintain constant values using the Constant Editor form. 
Constants can be used in formulas and logical expressions for values that 
change on a yearly basis. As constants are saved by year, you only need to 
edit the constant definition in order to update your formulas and logical 
expressions.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Constant Editor

Constant Value Editor Command Buttons

Creating a Constant Value: Click New to clear the screen so you can 
enter new information. 

Saving a Constant: Click Save to save a new record or modifications to an 
existing one.

Deleting a Constant: Click Delete button to remove the current record.

Overview
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Browsing Constants: Click Browse to view a list of the constants saved 
for the displayed year. To search records for a different year, you need to 
change the value in the Year field. 

Constant Value Editor Parameters

Year: Constant tables are created by fiscal year. By default, this field displays 
the fiscal year used by your department.

To change this value, for example, at the end of the year, select Set Table 
Year from the Edit menu. The following prompt appears:

Enter the year you want associated with the constant and click OK. 

To copy the values from one year to the following year, select Copy to Next 
Year from the Edit menu. The following warning appears:

It is useful to copy constants from one year to the next. However, if you have 
already created constants in the following year with the same name, these will 
be overwritten. 

Name of Constant: Enter the code for this constant.

Value: Enter a value for the constant. 
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Short Description: Enter a short description. This is used for fast data entry 
and look-ups if space is limited on forms.

Long Description: Enter a long description. This is displayed during look-
ups and on forms and reports.
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SQL Queries

Govern Admin provides two forms for creating and maintaining SQL queries, 
SQL Definition Setup and Queries by SQL Setup:

In order to view, update or delete data, before running a batch process, you 
can create SQL Queries with the Query Generator in Govern Batch 
Processing. See Creating SQL Queries in Govern Batch Processing on 
page 306.

SQL Definition Setup

The SQL Definition Setup form is used for defining queries that can be added 
by a System Administrator or Super User to:

• New, Save and Delete buttons on a Govern function
• User-defined command buttons added to a function
• User-defined formulas and logical expressions
• The customizable Govern CoolBar
• Activity steps linked to a permit, offense or workflow type

Queries by SQL Setup

The Queries by SQL Setup form is used for defining queries for the Search by 
SQL function in Govern. These queries can be selected by the user and are 
typically used for retrieving records.

You can further restrict access to this function, by user and by jurisdiction, as 
follows:

• Grant access to the Query by SQL option for specific users only.
• Restrict user editing rights on this function, so that certain users can select 

and execute pre-defined queries but not modify them, create new ones or 
select other queries from an alternate file. See Disable Editing on Query 

Overview

Note: User with Super User or administrator rights can run Action or 
Selection queries, from this function. Other users can run Selection 
queries only. See Selection Queries and Action Queries on page 216 
for details on queries.
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by SQL on page 63 for more information.
• If you support multiple jurisdictions in your setup, define queries by 

jurisdiction. Only users with access to the jurisdiction can access the 
queries. You can set four types of access rights for jurisdictions 

See User Maintenance on page 60 for more information.

SQL Definition Setup

To access the SQL Definition Setup form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > SQL Definition Setup

Queries by SQL Setup

The Query by SQL search function is used primarily for retrieving records 
through SQL Selection queries. This function also includes a SQL Editor for 
composing new queries or retrieving and modifying existing ones from another 
file.

To access this form, from Govern’s main screen:
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1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select Setup > Queries by SQL Setup...

SQL Definition Setup and the Query by SQL Setup 
Command Buttons

Viewing SQL Query Records: Each query is stored as a separate record. 

Use the right / left navigational arrows to view individual records 
or click Browse to view a list of the records, by query name and definition.

Creating a Query: Click New to clear the form.

Save: Click Save to save a new query or modifications to an existing one.

• Queries created through the SQL Definition Setup form are saved to 
VT_USR_QUERY

• Queries created through the SQL Queries Setup form are saved to 
VT_USR_QUERY2

Note: The Jurisdiction group will only be present when the option for Support 
of Multiple Jurisdiction is selected under the Options tab of the 
System Registry Maintenance form.
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Delete: Click Delete to remove the current record.

Exit / Cancel: When you click New, the Exit button changes to Cancel so 
that you can clear unsaved data without closing the form. If there are any 
unsaved modifications, a confirmation message appears when you click 
Cancel. Click Yes to save the data or No to close the form without saving.

SQL Definition Setup and the Query by SQL Setup 
Parameters

Query Name (Code): Enter a name or code to identify the query.

For the queries that retrieve data and display a value, such as the Coolbar 
Queries, you can add the following characters to the beginning of the name. 
These characters format the value in the result: 

For example, the following query retrieves the appraised value of the property 
and formats it as the Currency without decimals type:

Short Description: Enter a short description. This is used for fast data entry 
and look-ups if space is limited on forms.

Long Description: Enter a long description. This is displayed during look-
ups and on forms and reports.

Character Format Type Example

$ Currency with decimals $2,000.25

@ Currency without decimals $2,000

# Numeric with decimals 2,000.25

. Numeric without decimals 2,000

Query Name:  @GetApp

Query: SELECT appraised_value FROM MA_MASTER WHERE p_id 
= parcel id and frozen_id = frozen id and 
year_id = year id

Result:
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Warning: Enter a message to be displayed before the query is executed, in 
this optional field. For example, if you are linking a query to the Delete button 
of a function, create a message to notify the user that one or more records will 
be deleted. The user can confirm or cancel the action.

Jurisdiction: If you are restricting the query to specific jurisdictions, select 
the jurisdictions from the drop-down list. Leave this field blank to make the 
query accessible in all jurisdictions.

To remove a jurisdiction from the list, highlight the jurisdiction and click R.

Query (SQL): Enter the new SQL Query statement or modify an existing 
one, in this edit box.

Creating Queries

You can compose and store both Action Queries and Selection Queries in the 
edit boxes of the SQL Definition Setup and Query by SQL Setup forms. To 
retrieve or to use a value from the current record; for example, while running a 
query from a function or formula, you can include a keyword. See Using 
Keywords on page 218 for details.

To prompt for user input; for example, to refine a search to records of a 
specific value, you can include variables in a query. See Using Variables on 
page 220 for details.

Note: This field is present on the SQL Definition Setup form only.

Note: This list box is present on the Query by SQL Setup form only. It is 
visible only if the Support of Multiple Jurisdictions option is 
selected on the System Registry Maintenance form. See System 
Registry Maintenance on page 16.

Note: Keywords can be included on the SQL Definition Setup form, only.

Note: Variables can be included on the Queries by SQL Setup form only.

Note: On the Queries by SQL Setup form, you must use SQL syntax for 

Microsoft® Access®.
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Selection Queries

Selection Queries are used to retrieve records from one or more specified 
tables, according to the selection criteria.

The syntax is as follows:

For example, the following query, retrieves the City District name from the 
PC_AREA table for the record matching the current parcel ID, frozen ID and 
year.

Action Queries

Action Queries are used to perform some action, such as updating records in 
one or more tables, adding records to a table, deleting records from a table or 
creating a new table or index.

This section provides simple examples of Update, Append and Delete 
Queries. Since the SQL Definition Setup and Queries by SQL setup forms are 
used for queries that are run multiple times, it is better to compose and run a 
Create Query from outside Govern.

Update Queries

Update Queries are used to modify records in one or more tables, by changing 
values in specified tables and fields, according to certain criteria.

The syntax is as follows:

For example, the following query enters the value abc in the Fire District field 
of the PC_AREA table, wherever the value for this field is null.

SELECT [column] FROM [table] WHERE [criteria]

SELECT DIST_CITY FROM PC_AREA WHERE p_id=parcel id and 
frozen_id=frozen id and year_id = year id

UPDATE table.* SET value WHERE criteria

UPDATE pc_area SET dist_fire = ‘abc’ WHERE dist_fire IS 
NULL
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Update Queries are typically used when you need to change multiple records 
in a table or records in multiple tables.

Append Queries

Append Queries are used to add a single record to one or more table. You 
need to specify the fields to which you are adding values and the value for 
each field. Otherwise, the default value or Null is entered.

The syntax is as follows:

For example, the following query adds a record to the VT_USR_NAMECODE 
table, entering the values ENG, LD, ITR and In Trust in the language, 
department, code, short description fields.

You can also append multiple records to a table, by first selecting the records 
in another table. For this, a Selection Query is added to the Append Query.

Delete Queries

Delete Queries are used to remove records from one or more tables.

The syntax is as follows:

For example, the following query, add records containing the year 2004 are 
deleted from the PC_AREA table.

Tip: You do not obtain a list of results from running this type of query. To 
verify which records will be changed, you can run a Selection Query 
using the same parameters and criteria and view the Results screen.

INSERT INTO table (column list) VALUES (value list)

INSERT INTO vt_usr_namecode (language,dept,code,short_desc) 
VALUES (‘ENG’,’ ’,’ITR’,’In Trust’)

DELETE [table.*] WHERE criteria

DELETE FROM pc_area WHERE year_id = 2004
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Using Keywords

You can include a keyword in a query to retrieve or perform an action on a 
value in the current record, or the record most recently saved and still in 
memory. 

To include a keyword, double-click in SQL Definition Setup form. This displays 
the following list of keywords (Table: VT_SY_BRULE):

Tip: The Delete Query deletes more than the specified fields, it deletes the 
entire record. To delete data from specific fields only, create an update 
query that changes the values to Null.

Code Keyword Description

*date current date Current Date

ac_id aircraft id Identification number of the current 
Aircraft Excise Tax record

ar_id accounts receivable id Identification number of the current 
Account Receivable record

bldg_id building id Identification number of the current 
building

bldg_seq building sequence Identification Sequence Number of 
the current building

br_id bankruptcy id Identification number of the current 
Bankruptcy record

bt_id boat id Identification number of the current 
Boat Excise Tax account 

cc_id cash collection id Identification number of the current 
Cash Collection record

co_id complaint id Identification number of the current 
Complaint, Grievance, Request of 
Services or Workflow record

dept department Department Code

folio_id project folio id Identification number of the current 
Project Folio record

FI
N

AL
 D

R
AF

T



© 2013 MS Govern Page 219

SQL Queries

For example, in the following query, the parcel id, frozen id and year id 
keywords are used to retrieve the appraised property value from the MA_ 
MASTER table, where the P_ID, FROZEN_ID and YEAR_ID fields match the 
values for the current record.

frozen_id frozen id Identification number of the current 
Frozen record

h_id hearing id Identification number of the current 
Hearing record

haz_id hazard id Identification number of the current 
Hazard record

in_id inspection id Identification number of the current 
inspection

key_counter activity id Identification number of the current 
Activity record

land_id land id Identification number of the current 
land

mb_id misc. billing id Identification number of the current 
Miscellaneous Billing record

misc_id miscellaneous id Identification number of the current 
Miscellaneous Billing account

mv_id motor vehicle id Identification number of the current 
Motor Vehicle Account 

na_id name id Identification number of the current 
Name

of_id offence id Identification number of the current 
Offense record

p_id parcel id Identification number of the current 
parcel 

SELECT appraised_value FROM ma_master WHERE p_id=parcel id 
and frozen_id=frozen id and year_id=year id

Code Keyword Description
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Using Variables

You can compose and store queries, on the Query by SQL Setup form, with 
the following variables or parameters. These queries can be used, for 
example, to refine a search to only the records matching the values, or range 
of values, specified by the user:

• [s] for string
• [n] for numeric
• [sl] for string list
• [nl] for numeric list 
• [d] for date

When these parameters are included, the user is prompted to input one or 
more values. For example, in the following query:

the user is prompted to enter the year and the minimum land value:

Note: When including these variables in a query, use lowercase letters.

SELECT * FROM tx_re_assessment WHERE year_id = [n] and 
va_land_value > [n]:
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You can use a comma-separated list in SQL queries and create and save 
queries with variables and use them for retrieving a list of text or numeric 
information:

The following screen shot, illustrates the use of the numeric list in the following 
query:

SELECT * FROM tx_re_assessment WHERE year_id in [nl] and 
va_land_value > [n]:

Similarly, the following screen shot, illustrates the use of the string list in the 
following query:

SELECT * FROM pm_master WHERE pm_type in [sl]:

Note: If you use the numeric list [nl] or sting list [sl] parameters, the user can 
enter more than one parameter. Parameters must be separated by a 
comma.

For example, if the query contained year_id in [nl], the user could 
enter multiple years, as follows: 2001, 2002, 2003, 2004

Similarly, if the query contained pm_type in [sl], the user could 
enter multiple permit types, as follows: Plumbing_Res, Roof, Shed
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Refer to the Property Control guide for more information on this function.

Using Queries in Govern

This section provides examples of how queries can be used throughout 
Govern.

SQL Definition Setup

The SQL Definition Setup edit box is used for creating queries for the following 
forms: Function Setup, New Command Button, CoolBar Queries Setup, 
Formula Editor, Logical Expression Editor and Permit System Activities.

Function Setup

Action Queries can be linked to the New, Save or Delete button of a function, 
in order to perform some action, such as:

• updating records in one or more tables
• adding records to a table
• deleting records from a table

These queries can be applied to both existing and user-defined parameters. 
See Adding Business Rules to a Function on page 126, for more information.
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For example, the following query adds one to the Transponder Identification 
Number in the UB_LK_ACCT_METER table. This query could be added to the 
New button of a UB function.

New Command Button

Action Queries can also be linked to the customized buttons added to a 
function. See New Command Buttons on page 257.

CoolBar Queries Setup

Selection Queries can be linked to the new Govern CoolBar in order to display 
data from the open functions. See CoolBar Queries Setup on page 118.

For example, the following query retrieves the building value for the building, 
parcel, frozen ID and year of the current record.

The result of each query is displayed as a separate item on the CoolBar The 
text and the background color can be modified and the item can be 
repositioned.

Formula Editor

Selection Queries can be included in a formula in order to perform a 
calculation on a retrieved value. See Formula Editor on page 183, for more 
information.

For example, the following formula, rounds the agricultural value, retrieved 
through the AG_VALUE query and divides this by two.

UPDATE ub_lk_acct_meter SET transponder = (SELECT 
MAX(transponder)+1 FROM ub_lk_acct_meter WHERE transponder 
< 10000) WHERE ub_id = utility billing id and transponder is 
null

SELECT BLDG_VALUE FROM ma_master where p_id = parcel id and frozen_id 
= frozen id and year_id = year id

RND({AG_VALUE}/2)
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Logical Expression Block Editor

Both Selection and Action Queries can be included in a logical expression, in 
order to use values, retrieved through queries:

The following conditions apply:

• Only Selection Queries can be used with the IF statement.
• Only Action Queries can be used with the ACTION statement.

See Logical Expression Block Editor on page 191 for more information.

For example, in the following logical expression, the Agricultural Value is 
retrieved through the AG_VALUE query. If this value is positive, it is returned 
by the expression.

Permit System Activities

Both Selection and Action Queries can be linked to an activity through the 
Permit System Activities, Activities (Offense Function) and Activities 
(Workflow Functions) for validating an activity step. Refer to the Administrator 
section of the Permits & Inspections guide for details.

For example, the following query validates the logged in user with the user IDs 
listed in the table, USR_ACT_SECURITY, for the specified activity, 
department and reference number.

IF {AG_VALUE} > 0 THEN
   RETURN |AG_VALUE|;
ELSE
   RETURN 0;
ENDIF

SELECT COUNT (*) FROM usr_act_security WHERE usr_id = user 
id and activity_no = 10 and dept = 'BD' and key_type ='pm'

Note: Queries launched from a System Activity must return a single value, 
either a 0 or 1.
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Queries by SQL Definition Setup

The following queries can be used to retrieve records through the Query by 
SQL search in Govern, with user input.

Refer to the Property Control guide for more information on this search 
function.

SELECT * FROM pc_owner WHERE as_of_date =[d] and info_source= [s] and 
seq_priority=[n]

SELECT * FROM tx_re_assessment WHERE year_id = [n] and va_land_ value 
< [n

SELECT * FROM pc_parcel WHERE tax_map_ufmt >= [s] and tax_map_ ufmt 
<= [s]FI
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File Menu

View and print table data or the table structure using the Show / Print Tables 
feature. 

Show Tables List

Click the Show Tables List option to view a listing of all the database tables. 
You can also view the table structure and properties.

Opening a Database Table

To view a table, highlight it, in the Database Tables section and click Open. 
The selected table appears in a Browsing screen.

Overview
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You can view all the database columns and fields and perform the following 
actions:

• Sort: Click on a column heading and then click Sort to change the order of 
the listed records.

• Copy: Highlight a record, a column or any section of the table and click 
Copy to copy the data to the Windows clipboard.

• Find: Click on a column heading and click Find. Then enter the applicable 
information to search for a record in the list. The first match will be 
highlighted.

• Print: Click the printer icon  to open the Print dialog box and select a 

printer for the record list.

Viewing the Structure Table

Highlight a table and click Show to view the Table Structure.
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The column name, type and length appear in the upper section of the form. 
Information on the table index, or indexes, appears in the lower.

Click Print to print the table structure.

Viewing the Properties of a Specific Table

Highlight the table in the list and click Properties to view a list of the table 
properties.
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Print Table List

To print a list of all the database tables, use the Print Table List option.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select File > Print Table List

To print the list, select your printer, set the preferences and click Print.

Set the Default Year

Change the Govern Admin Default Year, using this feature.

To access this form, from Govern’s main screen:

1. Select Tools > System Administration (Govadm32.exe)

2. In Govern Admin select File > Set Default Year

Saving a New Default Year: Click OK to save the new default year.

Default Year: Enter the Year to process in the Text Box.

Click the year field on the Govern Admin toolbar to access this 
message box, directly.
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Govern Admin Tools Menu

This section describes the options in the Govern Admin Tools menu.

Govern for Windows

Select this option to launch the Govern application. The Govern application 
must be named govern32.exe.

To launch Govern for Windows, click the Govern  icon.

Govern Batch Process

Select this option to Launch the Govern Batch Processing application. This 
application must be named govbat32.exe.

To launch the Govern Batch Processing application for Windows from the 

toolbar, click the GovBatch  icon.

Lockbox Data Entry

Select this option to launch the Lockbox Data Entry application. This 
application must be named lockbx32.exe.

To launch the Lockbox Data Entry application directly from the toolbar, click 

the Lockbox  icon.

Inspector’s Database at the Next Startup

This option is automatically selected after the Export to an Inspector’s 
Database process is run and before the Import from an Inspector’s Database 
is run. The export process creates an extract of the database that the 

Overview

Note: Govern’s suite of applications, Govern Admin, Govern, Lockbox Data 
Entry and Govern Batch Processing must all be located in the same 
directory. Typically, this is Govern / Bin.
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inspector can use while in the field. Exported inspections are locked on the 
master database on the server. Inspections will be unlocked when re-
imported. 

This option is selected to ensure that Govern’s database is not updated before 
the inspector’s changes are uploaded and that the two databases are 
synchronized. Refer to the Permits and Inspections guide for details.

Rebuild .mdb for All Users at Next Logon

Select this option to rebuild the attach and local tables for each user, the next 
time they log on to the system.

Generate Missing Dictionary Entries

Select this option to update the dictionary. This populates SY_DICT_ DESC 
with data from the user validation tables; i.e., the tables beginning with 
VT_USR. Run this process after configuring the system for the first time, after 
updating the database and at anytime data is missing from the user forms.
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CHAPTER 2: USER

This section describes the options for customizing the Govern functions. For 
example, you can add new command buttons, fields and labels, modify, 
rename, or reposition existing ones.

Overview
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Options for Customizing the Govern Functions

These options are accessed through the Setup menu. This menu is visible to 
Super Users and Administrators only.

Object Dragging Mode

Use Object Dragging Mode to change the layout of a function by repositioning 
or removing the existing command buttons, labels and fields. See Object 
Dragging Mode on page 235.

Field Setup Mode

Use Field Setup Mode to modify existing command buttons, labels and fields; 
for example, by modifying the size, changing the names, linking validation 
tables and associating values. See Field Setup Mode on page 237.

New Database Columns

Use the New Database Columns option to define and add new columns to the 
database and to the functions. You can add various types of fields; for 
example, numeric, text, date / time or memo fields and then link a formula or 
logical expression, if required. See New Database Field Creation on 
page 251.

New Labels

Use the New Labels option to add a new label to the function; for example, to 
group customized fields. See New Labels on page 256.

New Command Buttons

Use the New Command Buttons option to add customized command buttons 
to a function. From these command buttons, you can launch another function, 
open a report, run a query or view or modify an FAQ. See New Command 
Buttons on page 257.

Additional Form Dividers

Use the Additional Form Dividers option to add an extra tab to a function; for 
example, for adding customized fields. See Additional Form Dividers on 
page 269.

Note: Modifications made to this menu apply to all users.
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Resetting the Custom Form Layout

Use the Reset Custom Form Layout option to reset a function to its original 
size; to restore the original command buttons and parameters, and to remove 
the customized buttons and parameters. All customized items are positioned 
on the top left corner of the function. See Reset Custom Form Layout on 
page 270.

Browse Setup

Use the Browse Setup option to modify the Browsing screen of the function. 
You can add, remove and reposition the columns. In addition, you can display 
minimum, maximum, average and total values and change the format of 
numeric fields. See Browse Setup on page 271.

Save Current Form Size

Use the Save Current Form Size option to save the size of a function, after 
you change it. Otherwise, the function is reset to its original size when you 
click Save. See Save Current Form Size on page 273.
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Object Dragging Mode

Use Object Dragging Mode to change the layout of a function by repositioning 
or removing the existing command buttons, labels and fields.

You can cancel all your modifications, restore the original command buttons 
and parameters and restore the original setup by selecting Reset Custom 
Form Layout. See Reset Custom Form Layout on page 270.

To access this option:

Open the function, you want to change, and select Setup > Object Dragging 
Mode.

When you are in this mode,  appears on the Govern Status 
Bar and the trash can icon appears on the active function. 

Repositioning Fields

Click on the field you want to reposition and using the mouse, drag the 
selected field object to the location of your choice. You can also move the field 

Overview
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labels and command buttons. Once this is complete, cancel the Object 
Dragging Mode.

Removing Fields

Click on the field you want to remove and using the mouse, drag the selected 
field to the trash can. The trash can icon will then change from green to pink. 
You can also remove the field header. You need to move the header and field 
separately.

Resetting Custom Form Layout

To reset the layout form, cancel the Object Dragging Mode, then select Setup 
> Reset Custom Form Layout. After the reset all the controls return to the 
original position and all user-added controls are placed in the top left corner, at 
position 0, 0.

Cancelling Object Dragging Mode

To return to Standard Mode, select Setup > Cancel Object Dragging Mode.

Note: The fields added on the Form tab of the Permit functions cannot be 
moved or removed through the Object Dragging Mode. Refer to the 
Permit Type Maintenance section in the Permits & Inspections guide 
for details on Adding Columns to Permit Types.
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Field Setup Mode

With Field Setup Mode you can make the following modifications to an existing 
field on a Govern function:

• Modify a label

• Link a validation table to a field
• Modify the size of a field
• Create a default value for a field
• Change the tab sequence of a series of fields
• Link a formula or logical expression to an existing field (See Link Formula / 

Link Logical Expression on page 247) 
• Spell check a field (See under the column Validation Type group on 

page 241)

To access this mode, open the function you are modifying in Govern and 
select Setup > Field Setup Mode.

When you are in this mode, “FIELD SETUP MODE” is displayed in the Status 
Bar in the lower left hand corner of the Govern window.

Overview
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Modifying a Field Label

In order to modify a field in a function, first open the required function.

To modify a field label:

1. Select Setup > Field Setup Mode on the Govern menu.

2. Double-click on the field label requiring the change.

The Field Attribute form appears.

3. Modify the text.

4. Click OK. 

5. Select Setup > Cancel Field Setup Mode.

Changing Field Properties

To change field properties:

1. Open the function you want to edit.

2. Select Setup > Field Setup Mode.

3. Double-click on the field to edit. This opens the Field Setup form.

4. Modify the field by selecting the options described in this section.

Note: If no modification is required, click Cancel to close the Field Attribute 
form without saving any modifications.
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5. Select Setup > Cancel Field Setup Mode.

Field Setup Mode Command Buttons

OK: Select OK to save you modifications and close the form.

Table: Select Table to open the Validation Table Header form, where you can 
create a new table or create new codes for an existing table. See  Validation 
Tables on page 85 for information on this form.

Security: Select Security to access the Group / User Security form.

Cancel: Select Cancel to close the form with saving your modifications.

Field Setup Mode Parameters

The parameters for the Field Setup form are as follows:
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System Field: This option is automatically selected for the System Fields. 
You can modify only a few of the properties of these fields.

Empty Value Accepted: Select the Empty Value Accepted option if the 
parameter can be left blank, by the user. If the field must always contain a 
value, deselect this option.

<TAB>: This field displays the tab sequence number of the selected field. 
This represents the order the cursor moves from to field, as the user select 
Tab on the keyboard. For example, if the field has a tab sequence of 2, the 
cursor is positioned on this field after the user selects Tab twice or after 
entering a value in the field with tab sequence 1 and clicking Tab.

Field Setup Mode Default Value Codes

A default value is a one that will appear in a field of a form prior to a users 
input. Default values can be useful in search forms where a user ID is a 
required entry on the form. The user ID code can be preset to appear by 
default in the field.

In Field Setup Mode you specify any of the following default value codes.

Default Value Code Description

$time Enter this code to set the current time to appear as a 
default. 

$date Enter this code to set the current date as the default 
value that will appear in the field. The date is 
formatted as defined in your Windows environment.

$datetime Enter this code to set the current date and time as 
the default in the field.

$year Enter this code to set the field to the current year.

$userid This code sets the field with the current logged in 
user ID. 

$username This code sets the field with the current logged in 
user name.

$department Entering this code will set the field with the 
department code; this will appear in the field as a two 
(2) character code.
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Default Value: Enter a default value for the field, if applicable. For example, 
in the City field, on the Name & Address function, you can enter your city 
name so that the users do not have to enter it each time.

Width: Enter the width of the field, in Twips or modify the existing value, 
when applicable.

Internet Display Order: This field is used for displaying user-added fields 
on the eGovernment solution Web pages. Enter a value to indicate the order in 
which the selected field is to be displayed on your Web site. Refer to the 
eProfile guide for details.

Column Name: This field displays the name of the selected field. This is for 
informational purposes only and cannot be modified.

Validation Type group

The following Validation Types can be applied to a field. For certain types, you 
need to enter additional information, as described in the Description column:

Note: When entering default value codes in Field Setup Mode, all characters 
MUST be lowercase or the codes will not work.

Tip: 15 Twips = 1 Pixel

Validation Type Description

No Validation Select this option if you do not want to apply a validation to 
the field.

System Table Select this option to link a System validation table to the 
field. Next, select the table in the list box and select a 
display option, under Table Display Type.

User Table Select this option to link a user validation table to the field. 
Next, select the table in the list box and select a display 
option, under Table Display Type
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Date Select this option to set the field as a Date type. Enter 
$date as the default value to add the current date to new 
records. Enter $date + 1 to use the day after the current 
date, $date + 2 to use two days after the current date, etc. 
To apply a range of dates, enter values in the Minimum 
and Maximum fields; for example, Minimum = 1/1/1990, 
Maximum = 12/31/2999. The date is formatted as defined 
in your Windows environment.

Date & Time Select this option to set the field as a Date / Time type. 
Enter $datetime as the default value to add the current 
date and time to new records. To apply a range of dates, 
enter the values in the Minimum and Maximum fields.

Time Select this option to set the field as a Time type. Enter 
$time as the default value to add the current time to new 
records. To apply a range of dates, enter values in the 
Minimum and Maximum fields.

Numeric Select this option to set the field as a Numeric field. The 
user will not be able to enter letters or special characters. 
To apply a range of values, enter the values in the 
Minimum and Maximum fields.

Currency Select this option to set the field as a Currency field. The 
information entered in this field follows the currency model 
defined in your Windows environment.

Currency (no 
decimal)

Select this option to set the field as a Currency field, 
without decimals. The information entered in this field 
follows the currency model defined in your Windows 
environment.

Field Mask Select this option to apply a field mask to the field. Then 
select the mask from the Field Mask drop-down list 

(Table: USR_ FIELDS_MASK). This automatically 
formats the information entered according to a pattern 
defined on the Pattern Name Maintenance form. Use this 
option for phone numbers, postal or ZIP codes, social 
security numbers, etc. See Global Field Validation 
Mask on page 78.

Validation Type Description
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Logical Expression Select this option to apply a Logical Expression to the field. 
Then, select the expression from the list box. 

Note: You can only use a Logical Expression that 
evaluates to true or false; such as the following*:

IF ~textbox valuen~ / 5 > 0 THEN
 RETURN TRUE;
ELSE
 RETURN FALSE;
ENDIF

To use another type of logical expression, select the Link 
Logical Expression option.

* This logical expression is provided as an example, only. 
In this case, it would be easier to use the Minimum 
validation type. However, if you wanted to combine a 
textbox value, from this field, with another database field, 
you could apply a logical expression.

If a logical expression has already been applied and you 
change for another, a warning message appears.

See Logical Expression Block Editor on page 191 for 
details on creating and using logical expressions.

See  Using Keywords on page 218 for details on textbox 
values.

True / False This option is enabled if the selected field is a check box.

Memo Field This option is enabled if the selected field is a notes and 
comments or other memo field. This type of field can 
contain a variable amount of text, depending on your 
setup.

Locked Field The Locked Field feature, for making a field display only, is 
now activated through a check box; so that you select a 
field validation type and lock the field.

Use Spell Check When selected, will apply spell checking to the selected 
notes and comments field. 

Validation Type Description
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Table Display Type group

Select one of the following options for displaying the items from the validation 
table, in the field:

• Code: to display the validation code
• Short Description: to display the short description
• Long Description: to display the long description
• Code & Short: to display both the code and the short description
• Code & Long: to display both the code and the long description
• Long Description Only: This option is enabled only for Text type fields, 

not for the Combo Box type fields. To select an item from a text field, linked 
to a validation code, the Govern user needs to click in the field. A 
secondary screen is displayed:

• For the other Table Display Types, even if the short or long description is 
displayed, on the Validation Code Browse screen, the code is saved to the 
function. However, if Long Description Only is selected, the long 
description is saved to the function.
The following screen shots show the difference between the Table Display 
Types Long Description and Long Description Only.

Long Description
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Long Description Only

The display characteristic of the Long Description Only parameter is different 
from that of the drop down menu. When the user clicks into the parameter, a 
window will open to present the list of items that can then be selected with a 
click.

To link the Country parameter to a system validation table:

1. Launch Govern and select any name and address record.

2. Open the Name and Address Maintenance function.

3. Select Setup > Field Setup Mode, from the Govern menu bar.

For example: You can use the Long Description Only to ensure that 
the country is entered consistently on all name and address records. 
First, create a link to the system validation table, VT_SY_CTRIES.
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4. Select System Table under Validation Type.

5. Select ctries {Countries} from the list of system tables on the right.

6. Select Long Descr. Only from the Table Display Type.

7. Click OK on the Field Setup form.

8. Select Setup > Cancel Field Setup Mode, from the Govern menu bar.

Note: Be sure to select ctries {Countries} and not country {Country}.

Tip: Enter the name of the country that will be entered in the majority of 
records in the Default Value parameter.

X
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Now, when you enter the Country, for a new name and address record, 
the Validation Code Browse screen appears.

9. Select a country and click OK on this screen.

Link Formula / Link Logical Expression: Select one of these options to 
link a formula or logical expression to an existing field. The field may be 
defined as another validation type. For example, the field can be both a date 
field and linked to a logical expression.

1. Select the option on the Field Setup Mode form:
• Link Formula
• Link Logical Expression

Note: This procedure updates new records only. Execute an SQL query to 
change previously created records.
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2. Select the formula from the list box.

3. Click OK.

Executing Formulas and Logical Expressions

Note: You need to create the formula or logical expression through the 
Formula Editor or Logical Expression Block Editor. See Formula 
Editor on page 183 and  Logical Expression Block Editor on page 191 
for details.

Note: When executing formulas and logical expressions that include 
keywords or database columns, all the applicable functions need to be 
open.

Alternately, you can add a Selection Query to the formula or logical 
expression, in order to retrieve values from database fields. See 
Selection Queries on page 216.
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Field Setup User/Group Access Security

There are multiple levels of security that can be applied to a function. It is 
possible to secure specific fields within a function form and limit access to 
existing Users and Groups.

To set User / Group Access security:

1. In Govern, open the function you want to edit.

2. Select Setup > Field Setup Mode.

3. Double-click on the field to edit. This opens the Field Setup form.

4. Select Security at the bottom of the form.

There are three (3) levels of security:

readonly: The field is visible on the form but the data can not be modified

cloaked: The field is visible on the form but the content displays as asterisks 
(*) i.e. not legible.

hidden: The field does not appear on the form.

By default all users and groups will have full access to all fields of the form. 
Full access is an indication that the field is visible on the form and the data can 
be modified.
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To set security access to a selected field:

1. In Govern, open the function form you want to edit.

2. Select Setup > Field Setup Mode.

3. Double-click on the field to edit. This opens the Field Setup form.

4. Click Security at the bottom of the form.

5. At the User / Group Security form, select Groups or Users or both to 
indicate the users that will be restricted.

6. Select the required security.

7. Click Apply to apply the selection.

8. Click OK
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New Database Field Creation

The New Database Field Creation form is used for creating and adding 
customized fields to the Govern functions.

To access this form:

1. Launch Govern.

2. Open the function you are modifying.

3. Select the tab where you are adding the new field.

4. Select Setup > New Database Columns.

When you are in this mode, NEW FIELD SETUP  appears on 
the lower left hand side of the Status Bar.

Overview
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Database Table Name: This field displays the name of the database table 
to which your new fields will be added. It cannot be edited.

In addition to the database table displayed, information on the new field is 
added to the following tables:

• USR_ADDED_FIELDS: Name of the field
• USR_FIELDS_LABEL: Label of the field
• USR_FIELDS_DEF: Position of the field

New Column Name: Enter a name for the field you are creating. This name 
must be unique within the database table. Verify the list of existing fields to 
ensure it does not already exist.

Description: Enter a description. This appears in the system dictionary and 
on the Browsing screens (Table: SY_DICT_DESC).

Create a Label: Select this option if you are adding a label to the field.

Column Label: Enter the text to appear on the label.

User Interface Type: Select a User Interface Type:

• text box
• combo box
• option box

Note: Since there is a limit of 256 columns for each database table, the 
number of fields you can add is equal to 256 minus the number of 
fields already existing in the table.

User-defined fields can be removed from the function, in Object 
Dragging Mode, but cannot be removed from the database.

Note: The unique part of the name must occur within the first 11 characters.
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Column Type: If you select Text Box in the User Interface Type field, you 
need to select one of the following column types:

Column Type Description

Currency Select this option to apply a currency field, formatted 
as defined in your Windows environment, to the field.

Date Select this option to apply a date field, formatted as 
specified on the Registry Information table, in Updata, 
or as defined in your Windows environment (if you are 

using Microsoft® Access®). If you enter $date in the 
default value field, the current date is displayed.

Time Select this option to apply a time field, formatted as 
specified on the Registry Information table, in Updata, 
or as defined in your Windows environment (if you are 

using Microsoft® Access®). If you enter $time in the 
default value field, the current time will be displayed.

Numeric (no decimals) Select this option to apply a numeric field: No 
decimals, letters or special characters will be 
accepted.

Numeric (with decimals) Select this option to apply a numeric field with 
decimals: No letters or special characters will be 
accepted.

Memo Field Select this option to apply a memo field, for notes and 
comments, to the function. You can add multiple 
memo fields to most user functions in Govern, as 
displayed on the following screen shot. Each of these 
fields provides unlimited space for notes and 
comments.

FI
N

AL
 D

R
AF

T



Page 254 © 2013 MS Govern

Super User

Size: Enter the size of the field if this is not entered automatically.

Link Formula: To associate a formula with the field, select Link Formula; 
then, select the formula from the list box.

Link Logical Expression: To associate a logical expression with the field, 
select Link Logical Expression; then, select the logical expression from the 
list box.

OK: Click OK to add your new field to the function. It is added to the top left 
corner of the function.

Note: You cannot specify a default size for a memo field; however, you can 
change the size, after the field is added to the form, using Field Setup 
Mode. See Field Setup Mode on page 237 for details.

Note: You need to create the formulas and logical expressions, beforehand, 
using the Formula Editor or the Logical Expression Editor. See  
Formula Editor on page 183 and  Logical Expression Block Editor on 
page 191 for details.
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Repositioning the Field

Next, you need to reposition your new field using Object Dragging Mode. This 
mode is automatically selected, when the new field is created.

1. Reposition the new field and label by dragging them with your mouse.

2. Select Setup > Cancel Object Dragging Mode from the Govern menu. 
See Object Dragging Mode on page 235 for full details on this mode.

Executing Formulas and Logical Expressions

Note: If you are using Windows 95 / 98 or Millennium, it is highly 
recommended that you limit the number of columns you create. The 
more columns you add, the fewer computer resources you have 
available. The drop-down list uses the most resources, then the text 
box. The option box uses the least. Keep this in mind, for the 
performance of your computer may be severely affected.

Note: When executing formulas and logical expressions that include 
keywords or database columns, all the applicable functions need to be 
open.

Alternately, you can add a Selection Query to the formula or logical 
expression, in order to retrieve values from database fields. See 
Selection Queries on page 216.
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New Labels

The New Labels function is used to add a caption on a function.

To access this function, open the form you are modifying in Govern and select 
Setup > New Labels.

Saving a New Label: Click OK you to save a new label.

Control Name: Enter the new control name.

Caption: Enter the name to display on the label.

Overview
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New Command Buttons

Use the New Command Buttons option to add customized command buttons 
to a function. From these command buttons, you can launch another function; 
open a report; run a query; view or modify an FAQ or launch an external 
application.

To access this option, open the function you are modifying in Govern and 
select Setup > New Command Buttons...

Control Name: Enter a name to be saved to the Control file. You cannot use 
spaces in this name.

Caption: Enter the text that will identify the button.

Tab Sequence: Enter the sequence number for the Tab function.

Type: From a new command button, you can launch another function, open a 
report, run a query, view or modify an FAQ or launch an external application.

Overview
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• Function
• Report Menu
• Single Report 
• Query
• FAQ 
• External Application

Linking a Function to a New Command Button

Select Function to call a function from the new command button. This 
facilitates navigation to another form; for example, if you frequently use the 
Additional Name Information function when completing the Owner Information 
form, create a link. The Govern User can launch the Additional Name 

Information function by clicking the icon , as displayed on the following 

screen shot.

To create a link to a function:

1. In Govern, click Setup > New Command Buttons.

2. Select Function in the Type section of the User Added Command Button 
Setup form.
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3. Select the function you want to call from the Functions List text box.

4. Enter a Control Name. You cannot use spaces in this name.

5. Enter a Caption. This appears on the button, unless you are creating the 
button as an icon.

6. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section. For example, in 
the preceding screen shot, the Additional Name Information icon has been 
added to the Tab section and the Report button has been added to the 
Form section.

7. Select Create as an Icon to use the function icon as the command button.

8. Click OK. A message appears stating that the button has been 
successfully created.

9. Click OK on this message box. The New Command Button is added to the 
top left corner of the current form. Move the button to your preferred 
location by dragging it with the mouse as described under Object Dragging 
Mode on page 235.

10. You can then create a link from the linked function back to the calling 
function. This function is similar to the Back button of your web browser 
and can be very useful.

To create a link back to the calling function:

1. Launch the linked function.

2. Follow the above procedure but in set 2, select Link back to calling 
function.

Linking Reports to a New Command Button

There are two options for adding reports to a function:

• Single Report to open a single report in Quick Open Mode.
• Report Menu to display a list of the reports that are linked to the function.

Adding a Single Report

You can define the parameters to display in the setup for the single report. The 
report is run directly from the selected function without displaying a prompt 
similar to the following.
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To add a single report to your function:

1. In Govern, click Setup > New Command Buttons.

2. Select Single Report under the Type section of the User Added 
Command Button Setup form. 

3. Enter a Control Name. You cannot use spaces in this name.

4. Enter a Caption. This appears on the button, unless you are creating the 
button as an icon.

5. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section. 

Note: For the Quick Open Mode, you can run the reports that contain only 
the General and Recommended Formulas as listed under Report 
Function Setup: Formulas on page 153. If the report contains Read-
only or Conditional formulas, you need to displays the prompt.
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6. Under Report Name, select the report.

7. Under Report Quick Open Mode, select one of the following:
• Standard Report Mode to open the report by its standard parameters.
• Current Parcel ID to display data on the current parcel only.
• Current Name ID to display data on the current name only.
• Current Sub-key to display data on the current sub-key, such as a 

permit ID or building ID, depending on the open function.

8. Click OK.

Adding a Report Menu

To create a new command button that opens a report from the current 
function:

1. In Govern, click Setup > New Command Buttons.

2. Select Report Menu in the Type section of the User Added Command 
Button Setup form. The Reports List text box opens displaying the reports 
that have been linked to the current function, through the Report 
Functions Setup form in Govern Admin. See Lists & Crystal Reports 
Setup on page 140.

3. Highlight the report you want to link and click OK.

4. Enter a Control Name. You cannot use spaces in this name.

5. Enter a Caption. This appears on the button, unless you are creating the 
button as an icon.

Note: You need to repeat this procedure for each report you are linking.
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6. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section. For example, in 
the preceding screen shot, the Additional Name Information icon has been 
added to the Tab section and the Report button has been added to the 
Form section.

7. Click OK. A message appears stating that the button has been 
successfully created.

8. Click OK on this message box. The new command button is added to the 
top left corner of the current form. Move the button to your preferred 
location by dragging it with the mouse as described under Object Dragging 
Mode on page 233.

Linking Queries to a New Command Button

Just as you can link an action query to the Add, Save and Delete buttons on a 
function, you can link a query to a new command button. The query performs 
some action, such as updating records, adding records to a table or deleting 
records from a table and is executed each time the user selects the button. 
See Functions Setup on page 123 for information on linking queries to the 
existing command buttons.

The queries need to be created and saved through the User Defined Queries 
Setup form in Govern Admin. See SQL Queries on page 211.

To execute a query from a new command button:

1. In Govern, select Setup > New Command Buttons.

2. Select Query under the Type section of the User Added Command Button 
Setup function.
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3. Enter a Control Name. You cannot use spaces in this name.

4. Enter a Caption. This appears on the button, unless you are creating the 
button as an icon.

5. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section. For example, in 
the preceding screen shot, the Additional Name Information icon has been 
added to the Tab section and the Report button has been added to the 
Form section.

6. Select the Query you are linking to the command button 

7. Click OK. A message appears stating that the button has been 
successfully created.

8. Click OK on this message box. The New Command Button is added to the 
top left corner of the current form. Move the button to your preferred 
location by dragging it with the mouse as described under Object Dragging 
Mode on page 235.

Note: Only Action Queries appear in the Query Name drop-down list. The 
queries need to be predefined and saved through the SQL Definition 
Setup form. See SQL Queries on page 211 for details.
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FAQ

Select FAQ to add a Frequently Asked Questions (FAQ) button or icon to the 
current form. Users with full access rights can add notes and comments that 
can be viewed by all the users within the department or within the organization 
depending on the setup.

To create a new command button that opens a department FAQ text box:

1. In Govern, click Setup > New Command Buttons.

2. Select FAQ under the Type section of the User Added Command Button 
Setup function.

3. The control name cmd_faq appears automatically in the Control Name 
field. 

4. Enter a Caption. This appears on the button, unless you are creating the 
button as an icon.

5. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section. For example, in 
the preceding screen shot, the Additional Name Information icon has been 

Note: Your FAQ is limited to the department if the FAQ buttons by 
department option is selected on the System Registry Maintenance 
form in Govern. Otherwise, it can be viewed throughout the 
organization.FI
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added to the Tab section and the Report button has been added to the 
Form section.

6. Select Create as an Icon to use the FAQ icon as the command button 

.

7. Click OK. A message appears stating that the button has been 
successfully created.

8. Click OK on this message box. The New Command Button is added to the 
top left corner of the current form. Move the button to your preferred 
location by dragging it with the mouse as described under  Object 
Dragging Mode on page 235.

External Application

Select External Application to add a command button than launches an 
External Application, directly from the current form.

To create a new command button that launches an external application:

1. In Govern, click Setup > New Command Buttons.

2. Select External Application in the Type section of the User Added 
Command Button Setup function.

Note: Before adding the application to a command button, you need to 
configure it for use in Govern, through the External Application Setup 
form. See External Application Setup on page 178.

Once configured, the application is added to the Govern Tools menu.
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3. Enter a control name in the Control Name field. This is saved to the 
Control file. The name cannot contain spaces.

4. Enter a Caption. This appears on the button.

5. Under Container Selection, select Form to add the new button to the 
form section or Tab to add the button to the tab section.

6. Select the application from the External Application drop-down list.

7. Click OK. A message appears stating that the button has been 
successfully created.

8. Click OK on this message box. The New Command Button is added to the 
top left corner of the current form. Move the button to your preferred 
location by dragging it with the mouse as described under Object Dragging 
Mode on page 235.
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Global and Department Messages up to 1000 
Characters Maximum

The Text Message field in the Global and Department message parameters 
now allows for messages that are up to 1000 characters long. This additional 
space allows for more descriptive text messages.

To create new Global and Department messages..

In Govern for Windows...

1. Open a record.

2. Select Edit > Global Flag / Department Flag

Note: The space character is included in the character count of 1000.
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These are the global or department messages that could be attached to a 
P_ID. When configured, these messages will display when the record is 
accessed.

Note: When entering your message, the system will allow you to enter more 
than 1000 characters. Only 1000 characters will be displayed in the 
message window. When the message exceeds the 1000 character 
count, it can be displayed when a report is generated, or by viewing 
the table directly as an administrator.
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Additional Form Dividers

The Additional Form Dividers function is used to add additional tabs or 
dividers to a Govern function.

To access this function:

Open the form you are modifying in Govern and select Setup > Additional 
Form Dividers.

Total Number of Dividers: Enter the total number of dividers, including 
those already present on the form.

Saving a Form Divider Addition: Click OK. The new information is saved 
to the SY_FORM_SIZE system table.

Once you create the additional dividers, you can add new fields. See New 
Database Field Creation on page 251 and  Field Setup Mode on page 237 for 
details.

Overview

Note: This function is not available for all forms.

Note: The original dividers cannot be removed. You can only remove user-
added dividers.
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Reset Custom Form Layout

This function allows you to reset the form to the original design (before adding 
any fields or labels, or before modifying the location of existing fields).

To access this function:

Open the form you are modifying in Govern and select Setup > Reset 
Custom Form Layout.

Overview

Note: All the added fields will be placed in the top left corner of the from, in 
position 0, 0.
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Browse Setup

Use the Browse Setup form to select the field(s) you want to display on the 
Browsing screen for the selected function. For numeric fields, you can select a 
format and display the minimum (<), maximum (>), average (~) or total (#) 
value. This is displayed in the column header of the applicable field.

The Browsing screens automatically expand to the full height and width of 
your Govern window. 

When you are in this mode,  appears on the Status Bar.

Resetting the Browse Screen with Default Settings: Click Reset to 
reset the Browsing screen with the default parameters.

Viewing the Browse Screen (Preview): Click Browse Preview to 
preview the Browsing screen before continuing.

Adding a Column on the Browse Screen: Select a column from the 
Available Columns list box and click -> to move it to the Selected Columns list 
box. The columns will be displayed on the Browsing screen in the order listed 
on this form.

Overview
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Removing a Column from the Browse Screen: Select a column from 
the Selected Columns list box and then click <- to move it to the Available 
Columns list box. The columns displayed in the Available Columns list are not 
displayed on the Browsing screen.

Changing the Display Order of the Columns: Highlight a field and click 
U to move it towards the beginning of the list or D to move it towards the end. 
You need to click once for each space you want to move.

Code: This field displays the code assigned to the function. This is an internal 
number.

Function Description: This field displays the long description of the 
function.

Form Name: This field displays the form number or name. This is displayed 
in the left corner of your computer screen when the function is open.

Available Columns: This list box displays all the fields in the current 
function.

Selected Columns: This list box displays the fields that will appear on the 
Browsing screen.

Options: Select these options to display see the minimum, maximum, 
average or total value for the selected column. If the information is not 
applicable, the option is disabled.

Format:  Select a format for displaying numerical information: ($9,999,99.00) 
for currency, 99.99% for percentage, 9,999,99.00 for decimal  or none for non-
formatted values. If the format is not applicable, the option is disabled.

Note: Do not move or delete the first field from the Selected Columns list: 
P_ID, PM_ID, etc.

Note: The Browsing screens are displayed in the same manner for all users.
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Save Current Form Size

This option allows you to save the new size of the current form if it has been 
changed. If the form has been made larger, you can then add new fields in the 
space created by using one of the editing modes. See Object Dragging 
Mode on page 235.

To save the current form size...

Open the form you are modifying in Govern and select Setup > Save Current 
Form Size.

The current function size is modified when you select this option.

Overview
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CHAPTER 3: BATCH PROCESSING

This section introduces the Govern Batch Processing application and default 
menu options. Detailed descriptions of the processes are provided in the 
reference guides.

Govern Batch Processing Interface

Toolbar Icons

You can launch Govern Admin, Govern and the 
Payment Lockbox applications by clicking the icons 
displayed on the main menu of the Govern Batch 
Processing interface, as well as from the Tools 
menu.

Background

You can change the background of the interfaces for the Govern for Windows 
applications. For details, see Govern for Windows Background on page 15

Overview
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MS Govern Batch (.NET) can be called from 
GovBatch (Govern for Windows Batch)

The MS Govern Batch .NET application can be called from 
GovBatch release 10.7. This will allow for users of GovBatch to 
access new Govern.NET batch processes.  

To configure the link between GovBatch and MS Govern Batch:

In Govern Admin...

1. Select Parameters > Edit the System Registry...

2. In the System Registry Maintenance form, click the Connections tab (A).

3. Locate the DeplyEZ (ClickOnce) Application Batch Shortcut (B) 
parameter.

4. Enter the UNC path to the Govern.NET Batch application, e.g. 
\\MYSERVER\Deployments\DEMO_FOO_SQL\MSGOVBATCH\MsGovB
atch.exe.application.

Users with this functionality will be able to select MS Govern Batch (.NET) 
processes that will appear in any of the GovBatch, i.e. Govern for Windows 
Batch menus. 

Note: This functionality is only available to users that have obtained licenses 
for Govern.NET and have the required applications installed.

NEW
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General Batch Processing Menus Options

This guide describes the File, Import / Export, Tools and Help menus which 
contain the general menu options available throughout Govern Batch 
Processing. 

All other menu options are displayed by subsystem: Accounts Receivable, 
Mass Appraisal, Special Assessment, Miscellaneous Billing, Tax Billing, Tax 
Title and Utility Billing. These menus are available according to the 
subsystems in your setup. These options are described in the reference 
guides.

Audit Trail

An Audit Trail is automatically defined for all processes run through Govern 
Batch Processing. Results are saved to USR_AUDIT_BATCH.

File Menu

The Govern Batch Processing File menu contains processes for setting the 
default date and year, for turning off the display of error messages, as well as 
the Exit command to close the application. All these options are described in 
this section. 

You can also change the default date and year directly from the toolbar. See 
File Menu on page 278 for details.

Import / Export Menu

From this menu, the user can import data from the database file, generate an 
extracted database, export to or import from an inspector’s or appraiser’s 
database, or start the General Ledger interface. See Import / Export Menu on 
page 282 for details.

Tools Menu

The Govern Batch Processing Tools menu contains a number of general 
processes. See Tools Menu on page 290 for details.
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Help Menu

The Help menu provides links to the Govern Batch Processing Help system 
and to the About Box.

Help System: The Help system describes all the processes. To view the 
Help on a specific process, scroll through the Table of Contents or launch the 
process and click F1 on your keyboard. To view context-sensitive Help, right-
click on a specific field or command button.

About Box: The version number of the Govern database has been added to 
the About box for quick reference on all applications Govern Admin, Govern 
and Govern Batch Processing. In addition, the number of licensed users and 
the number of Inquiry Only users are displayed. See User Maintenance on 
page 60 for more details on Inquiry Only access.
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File Menu

The Govern Batch Processing File menu contains processes for setting the 
default date and year, for turning off the display of error messages, as well as 
the Exit command to close the application. All these options are described in 
this section. 

• Setting the Default Year. See page 278.
• Setting the Default Date. See page 279.
• Turning Off the Display of Error Messages. See page 280.
• Exiting Govern’s Batch Processing Application. See page 281.

Setting the Default Date

The Default Date is displayed in the bottom right corner of the screen in 
Govern, Govern Admin and Govern Batch Processing. By default, this is the 
default date. However, you can change this for your batch processes, using 
the default date screen. Double-click in the text box: and select a new default 
date using the pop-up calendar You can also modify the default date directly in 
the Text Box. Click OK to save and continue.

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select File > Set Default Date

Overview
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You can also access this screen by clicking on the default date in the Govern 
toolbar.

Saving a New Default Date: Double-click in the field and select the new 
default date from the pop-up calendar. Then click OK to save.

Click Cancel to close the screen without saving your modification.

Setting the Default Year

You can change the Default Year for all the batch processes with this feature.

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select File > Set Default Year
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You can also access this screen by clicking on the default year in the Govern 
toolbar.

Saving a New Default Year: Enter the default year and click OK to save.

Click Cancel to close the screen without saving your modification.

Turning Off the Display of Error Messages

By default, when errors occur during batch processes, error messages are 
displayed on your screen. To turn off the display of error messages, select the 
Non-interactive Errors (Log Errors to a File) option.

Processes will continue to run regardless of errors. Errors are saved to the log 
file, govbat32.log located in C:\Documents and Settings\User\Local 
Settings\Temp\.

Deselect this option to display errors during batch processing. When this 
option is deselected, a confirmation message appears and the user must 
select an option to continue, when errors occur.

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select File > Non-interactive Errors (Log Errors to a File)

Note: This temporary directory is created for every user who logs into the 
computer.
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Exiting the Application

Click File > Exit or Alt + F, X to close the Govern Batch Processing 
application.
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Import / Export Menu

The Govern Batch Processing Import / Export menu contains processes for 
importing and exporting data and extracted databases to and from Govern.

• Importing Data from a Database File. Refer to the Property Control guide.
• Generating an Extracted Database. See page 283.
• Importing GIS Split / Merge Data to Govern. Refer to the Property Control 

guide.
• Maintaining an Inspector’s Database. Refer to the Permits & Inspections 

guide.
• Maintaining an Appraiser’s Database. Refer to the Mass Appraisal 

General guide.
• Exporting Data to a G/L Interface. Refer to the Accounts Receivable guide.

Importing Data from a Database File

Run the Import Data from a Database File process to import data from an 
external database file to the PC_AREA or PC_LEGAL_INFO database tables. 
For details on this process, refer to the Batch section of the Property Control 
guide.

Overview
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Generating an Extracted Database

Run the Generate an Extracted Database function to create a sample 
database to be used for performing tests or computations. This sample 
database can be created from a range of tax map numbers or a jurisdiction. It 
can be limited further to a year and a number of records. The form varies 
depending on whether you are using Access or ODBC.

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Import/Export > Generate an Extracted Database...
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Generate Data to Database Command Buttons

Process: Click Process to launch the data extraction process.

From External: Select From External to export data from the External 
Recordset only. 

Database Name / Data Source: Click Database Name to indicate the 
MicrosoftDatabase file name that will be created. if the Option for ODBC is 
selected under Server Connection Output, the Database Name button will 
change to Data Source.
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Generate Data to Database Parameters

ODBC / Access: One option is selected by default. This information is read 
from the govern.ini file.

Copy Setup Only: Select Copy setup only to make a copy of a setup.

Generating an Extracted Access Database

If you are using an Access database, the following information appears at the 
top of the form:

Note: If Copy setup only option is selected, all fields below this option will 
disappear. Two (2) drop down fields will appear directly below this 
option: and replaced .FI
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You need to create a database file name for the extracted data.

Creating the Database File Name: To create a Database file name:

1. Click Database Name to open a secondary screen.

2. Navigate to the directory you want to use for the extracted data.

3. Enter a file name.

4. Click Save. 

Generating an Extracted ODBC Database

If you are using Open Database Connectivity (ODBC), the following 
information appears at the top of the form:

You need to select or create the Data Source Name (DSN) for the extracted 
data.

Selecting the DSN: To select a DSN:

1. Click Data Source to open a secondary screen.

2. Select File Data Source if you are using a file DSN or Machine Data 
Source if you are using a system or user DSN.

3. Navigate to the directory where the DSN is saved and select the name or 
create a new DSN and enter the name.

4. Click OK.

Note: If you are using ODBC, you can also create an extracted Access 
Database. See  Generating an Extracted Access Database on 
page 285 for details.

Note: Refer to the online ODBC Help for further details.
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From / To Tax Map Number: Enter the range of Tax Map Numbers for the 
data extraction. Otherwise, to include all properties in the extraction, leave 
these fields blank.

Jurisdiction: To include data from a single jurisdiction only, select the 
jurisdiction, from the drop-down list. Otherwise, leave this field blank.

Year: To include data from a single year only, enter the year in the text box. 
Otherwise, leave this field blank.

Number of Records (empty = all): Enter the number of records you wish 
to retrieve from the boundary Tax Map Numbers entered.

Delete all Previous Data: If selected, this option will delete all previously 
extracted data from the database name you have selected. Otherwise, the 
data extracted is added to the database. Be careful not to duplicate the data.

Restart After Failure: Select this option to automatically restart the process 
after a system failure or time-out.

No Names: Select the No Names option to exclude the following tables from 
the export:

• All tables beginning with NA_, such as:
• NA_NAMES
• NA_MAILING_INDEX
• NA_ACH_INFO
• NA_EXEMPTIONS

• MA_APPRAISERS
• MA_SALES
• PC_GRANTEE
• PC_GRANTOR
• PC_LIEN_NAME
• PC_OCCUPANT
• PC_OWNER
• PC_SALES

Load Data For: The process loads data from the Property Control and 
Name & Address system tables, as well as all validation tables. To load 
additional data, select the applicable subsystems.
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Importing GIS Split / Merge Data to Govern

Run the GIS Split / Merge Import batch process to import parcel split / merge- 
data from an external Geographic Information System (GIS) application into 
Govern. Refer to the Property Control guide for details on this process.

Maintaining an Inspector’s Database

The following batch processes are required for setting up a database that can 
be used by an inspector, while working on site, away from the office and for 
synchronizing data between the exported database and the main network 
database:

• Export to an Inspector’s Database
• Import from an Inspector’s Database
• Inspector’s Database at Next Startup

For details on these processes, refer to the Batch section of the Permits and 
Inspections guide. For details on configuring a laptop computer to use Govern 
off site, refer to the Getting Started guide. 

Maintaining an Appraiser’s Database

The following batch processes are required for setting up a database that can 
be used by an appraiser, while working on site, away from the office and for 
synchronizing data between the exported database and the main network 
database:

• Export to an Appraiser’s Database
• Import from an Appraiser’s Database
• Appraiser’s Database at Next Startup

For details on these processes, refer to the Batch section of the Mass 
Appraisal General guide. For details on configuring a laptop computer to use 
Govern off site, refer to the Getting Started guide. 
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Exporting Data to a G/L Interface

The Export Data to a G/L Interface batch process is used to transfer the 
General Ledger data for use in an external G/L system. The following G/L 
interfaces are supported:

• Govern Unix
• ACS
• Great Plains
• Lawson
• S.F.G.
• Cayenta 

Refer to the Batch section in the Accounts Receivable guide for details on the 
batch processes and to the Appendix for the file layout for each type of 
interface.
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Tools Menu

The Govern Batch Processing Tools menu contains the following processes.

• Launching Govern for Windows. See page 291.
• Launching Govern Admin. See page 291.
• Launching the Payment Lockbox Data Entry. See  Launching the Payment 

Data Entry Lockbox on page 292.
• Assigning User Permissions to Batch Processes. See page 292.
• Initializing Next Year’s Data. Refer to the Property Control guide for 

details.
• Archiving Multimedia Documents. Refer to the Property Control guide for 

details.
• Creating Links to Multimedia Files. Refer to the Permits & Inspections 

guide for details.

Overview
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• Performing Automatic Inspection Rescheduling. Refer to the Permits & 
Inspections guide for details.

• Merging Duplicate Name and Address Data. Refer to the Property Control 
guide for details.

• Formatting Name and Address Data. See page 296.
• Importing / Exporting Name and Address Data. See page 314.
• Formatting Property Location Data. See page 296.
• Generating Internet Accounts. This process generates eProfile accounts. 

Refer to the eProfile guide for details.
• Sending Computations to the Daemon Server. See page 297.
• Purge Entries in Daemon Tables. See page 302.
• Using the Process Flow Wizard.See Process Flow Wizard on page 303.
• Running SQL Queries in Govern Batch Processing. See
• Setting up E-Mail Notification for Batch Processes. See Setting up E-mail 

Notification for Batch Processes on page 310.

Launching Govern for Windows

Select Tools > Govern for Windows to launch the user data entry application, 
Govern for Windows. 

To launch Govern, directly from the toolbar, click the Govern  icon.

Launching Govern Admin

Select Tools > Govern Admin to launch the administrative and configuration 
application, Govern Admin. 

To launch Govern Admin, directly from the, click the Govern Admin  icon.

Note: The full suite of Govern applications must be located in the same 
directory. Typically, this is C:\Govern\Govern 8.5\Bin. The 
Govern for Windows application must be named govern32.exe.

Note: The full suite of Govern applications must be located in the same 
directory. Typically, this is C:\Govern\Govern 8.5\Bin. The 
Govern Admin application must be named govadm32.exe.
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Launching the Payment Data Entry Lockbox

Select Tools > Lockbox Data Entry to launch the Payment Data Entry 
Lockbox. 

You can launch the Payment Data Entry Lockbox, directly from the toolbar, by 
clicking the icon.

Assigning User Permissions to Batch Processes

Govern users that are upgrading from Release 10.6 to 10.7 should 
note that a new method has been implemented to manage the 
menus. As a result of this enhancement, there is greater control of 

user menu access. Administrators are now able to give access to individual 
menu items; previously menu access was granted to all items under the menu. 
From Release 10.7, Administrators or Super Users can give access to specific 
menu items under a Govern Batch Processing (GovBatch) menu (A).

Note: The full suite of Govern applications must be located in the same 
directory. Typically, this is C:\Govern\Govern 8.5\Bin. The 
Lockbox application must be named lockbx32.exe.

NEW
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Select Tools > Menu Security Setup to launch the Menu Security Setup form 
and assign user permissions to Govern’s batch processes.

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Menu Security Setup...

Menu Security Setup Command Buttons

Grant Access to all Menu Items: Click Grant Access to all Menu Items 
to grant the selected users access to all features and processes in Govern 
Batch Processing.

Note: Administrators will need to set access rights for users. By default 
Super Users and Administrators have access to all Govern Admin 
forms, but Users and Inquiry Only users will not have access to any 
menus until access has been granted, See  Access Types on page 64 
for full details about user types.
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Remove Access to all Menu Items: Click Remove Access to all Menu 
Items to block the selected users from all features and processes in Govern 
Batch Processing.

Save: Click Save to save your security settings.

Exit: To close the Menu Security Setup form, click Exit.

Granting and Restricting Access to Batch Processes

To grant or restrict access to a batch process, menu, or menu item:

1. In GovBatch, select Tools > Menu Security Setup...

2. In the Menu Security Setup screen, click to select a user, in the list box.

3. Scroll through the list to locate the menu, or menu items, where the 
processes are contained.

4. Select the process to grant access; if deselected access will be restricted.

Tip: You can select as multiple users at the same time. To select multiple 
consecutively listed users, select the first user, hold down the Shift key 
and select the last name in the list. For non-consecutively listed users, 
press the Ctrl key while selecting. To deselect a user, hold down the Ctrl 
key and reselect the user.
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5. Click Save to save the security settings.

6. Click Exit to close the form.

Initializing Next Year’s Data

Run the Initialize Next Year Data batch process to initialize the Property 
Control subsystem for the new fiscal year. For details on the Initializing Next 
Year’s Data process, refer to the Property Control guide.

Archiving Multimedia Documents 

Run the Archive Multimedia Documents to save the multimedia files to the 
Level 1, 2 or 3 directories as set up in Govern Admin. For details on the 
Archive Multimedia Document process, refer to the Property Control guide.

Note: The user has access to all processes that are selected on the menu. 
When granting access to a menu ensure that the Menu (A) and 
required Menu items (B) are selected.
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Creating Links to Multimedia Files

Run the Link Multimedia Files to Permits function to link multimedia files to 
multiple permits For details on the Link to Multimedia processes, refer to the 
Permits & Inspections guide.

Performing Automatic Inspection Rescheduling

Run the batch Automatic Inspection Rescheduling process to schedule 
inspections that need to be performed periodically. For details on the 
Automatic Inspection Rescheduling process, refer to the Permits & 
Inspections guide.

Merging Duplicate Name and Address Data

Run the Name Merge Utility when you need to combine two or more existing 
name and address records into a single record. For details on the Name 
Merge Utility, refer to the Property Control guide.

Formatting Name and Address Data

Run the Formatting Name and Address Data this process when you need to 
update multiple records that have been added through an import. This process 
formats the name and address data, in NA_NAMES, according to the Country 
Format set on the System Registry Maintenance form in Govern Admin. See 
System Registry Maintenance on page 16 for details on the Country Format 
code.

Formatting Property Location Data

Run the Formatting Name and Address Data this process when you need to 
update multiple records that have been added through an import. Similar to 
the Format Names and Addresses, this process formats the name and 
address data, in PC_ADDRESS, according to the Country Format set on the 
System Registry Maintenance form in Govern Admin. See System Registry 
Maintenance on page 16 for details on the Country Format code.
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Sending Computations to the Daemon 
Server

The Daemon Server

In the Unix world, the term “daemon” is used to refer to a process that 
performs a service in the background. A “server” refers to a computer that is 
dedicated to running a specific application. A “daemon server” in the true 
sense of the meaning, i.e. waits for requests to arrive and automatically 
spawns other “instances” of itself to handle these requests.

Although the Govern Daemon Server tool fits the description of the 
aforementioned definitions, it is not a true “daemon server” in the sense that it 
does not automatically spawn other “instances” of itself to handle requests. 
The Govern Daemon Server is a batch process that can be manually started 
on each server that is running the Govern Batch Processing application. When 
initiated, each running instance is capable of processing a preset number of 
records in the database; this effectively allows you to share any processing 
activities.

Processing Records in Govern

Govern can process records in two (2) ways, Online (Local), and Daemon 
Server. 

Online (Local): An Online (Local) process is one that occurs directly on the 
workstation where Govern is installed. This type of process applies to how 
functions in Govern for Windows, as well as any Govern Batch Processing is 
executed. For example, when you complete parameters on a form and click 

Overview

Note: The term Online in this context should not be confused with the 
current usage of the word that refers to an internet activity; nor is it in 
reference to any of the eGovern solutions.

FI
N

AL
 D

R
AF

T



Page 298 © 2013 MS Govern

Super User

Start, entries are first saved to a table, followed by any required computations; 
this entire process occurs locally, i.e. directly on your workstation.

Daemon Server: When you execute a function in Govern for Windows or 
initiate a batch process in Govern Batch Processing, you have the option to 
request the assistance of the Daemon Server. When a Daemon Server is 
requested, the process automatically becomes a Daemon Server Process, 
and is executed and shared by any instances of the daemon server that are 
running.

When a Daemon Server is started, it immediately begins checking two (2) 
tables to see if any data has been written to them. The tables that are checked 
are USR_DAEMON_ONLINE, which corresponds to Govern for Windows 
online requests for processing, and USR_DAEMON_BATCH which 
corresponds with Govern Batch Processing requests. As soon as data is 
written to one of these tables, the Daemon Server begins processing the 
records.

Why use the Daemon Server

Advantages to using the Daemon Server can be seen in environments where 
extended save times are observed in Govern for Windows. Examples are 
users of the Real Property Tax functions, or Mass Appraisal functions like 
Building Structural Elements (BSE), Mass Appraisal Values Computation and 
the Mass Appraisal Simulation Data Computation. Delays can be due to a 
large number of records being saved, or complexity of computations, i.e. 

Note: In this type of process, system configuration is critical to how fast 
calculations and batch processes are completed. The faster your 
system, i.e. CPU speed, system RAM. Hard disk capacity and access 
speed combination, the better your performance, Refer to Govern’s 
recommended System and Network Requirements in the Getting 
Started guide.

Note: In order for a process to use a Daemon Server, the Daemon Server 
must be running, i.e. manually started. In environments that use a 
Daemon Server, it is customary to have one or more instances of it 
continuously running on a server.

Note: The USR_DAEMON_ONLINE table has a higher processing priority 
than the USR_DAEMON_BATCH table, i.e. all Online (Local) 
processes will be performed before starting any requests from Govern 
Batch.
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multiple formulas, logical expressions, etc. See MA Daemon Server 
Computation in the Mass Apraisal General Information Guide. In addition, 
users of Govern Batch Processing that running Mass Appraisal and Tax Billing 
postings to A/R will also benefit from running a Daemon Server.

In such instances, running the Daemon Server may result in significant 
savings in time. Additional gains are obtained when Daemon Servers are 
running on multiple servers.

Sending Computations to the Daemon Server

To start the Daemon Server, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Start Daemon Server...

Note: In Govern for Windows, when using any of these functions ensure that 
the MA Daemon Server Computation and/or the TX Daemon Server 
Computation options have been selected under the options menu. 
In Govern Batch Processing, ensure that the Send to Daemon Server 
option has been selected in the form of the relevant batch process.
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The Daemon Server application displays the following information from the 
USR_DAEMON_ONLINE table.

Default Settings

The following settings are saved to the SY_REGISTRY table:

Maximum number of records per batch

By default, the maximum number of records per batch is 100. This refers to 
the number of records that can be transferred to a server, at a time. For 
example, if there are ten servers, assigned as Daemon Servers, a maximum 
of 100 records can be transferred to each one; so that, a maximum of 1,000 
records can be processed or in processing queues, at a time, and no server is 
overloaded. When a server has processed one batch of 100, another batch 
can be then be transferred to it.

The parameters for this setting, in the SY_REGISTRY table, are as follows: 
DAEMON_SERVER, BATCH_MAXIMUM_RECORDS, 100

You can define this setting on the System Registry Maintenance form in 
Govern Admin. See Daemon Server group on page 35.
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Delay before startup

By default, the delay between the time a record is saved and then transferred 
to the Daemon Server is ten minutes. This value prevents the same record 
from being processed with different values. This can occur when a user saves 
a record in Govern for Windows, then makes a correction almost immediately 
afterwards.

The parameters for this setting, in the SY_REGISTRY table, are as follows: 
DAEMON_SERVER, ONLINE_START_AFTER, 10.

This setting can be defined on the System Registry Maintenance form in 
Govern Admin. See Daemon Server group on page 35.

Processing

Queue ID: This is automatically assigned to define the position of process in 
the queue. The item with the lowest number is processed first.

Function Description: This field displays the name of the function using 
the Daemon Server.

Tax Map Number: This field displays the tax map number for the record.

Reference ID: This field displays one of the following:

• for a Govern function, it provides a secondary reference for the record; for 
example, the building or land ID.

• for a Govern Batch process, it provides a Batch Number. For example, if 
10,000 records being processed, each batch may include 250 records. 
Each batch could be processed by different servers, at the same time.

Status: This field displays the status of the batch process; such as Online 
Processing or Online Finished.

Error Log

This section displays the queue ID, batch number and error description of any 
failed processes.
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Daemon Server Command Buttons

Pause: Select this option to stop the Daemon Server temporarily. When you 
select this option the Continue button is enabled.

Continue: Select this option to continue the Daemon Server after pausing.

Exit: Select this option to close the form.

Start automatically at next logon: Select this option to start the Daemon 
Server automatically on the computer at the next logon.

Purge Entries in Daemon Tables

Run this process to clear the following tables as well as the Daemon Server 
grid in Govern Batch Processing.

• USR_DAEMON_BATCH
• USR_DAEMON_BA_CTL
• USR_DAEMON_ONLINE
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Process Flow Wizard

An administrator can set up a workflow, using the Process Flow Wizard Setup, 
to define the batch processes that need to be run, administrative procedures 
that need to be performed, and reports that need to generated in order to 
complete a work process. See Process Flow Wizard Setup on page 161.

Use the new Process Flow Wizard to keep track of each task in the workflow. 
The starting and completion date and times are displayed, with the name of 
the user and whether any errors were reported. 

To launch this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Process Flow Wizard...

Overview
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Launching a Workflow 

To start a workflow:

1. Modify the fiscal year in the Year text box, if required.

2. Select the workflow from the Workflow Description drop-down list.

3. Click New Workflow. The workflow is displayed in the grid. Select the first 
step and click Start Process.

4. When the step is completed, highlight the next step and continue, until the 
workflow is completed.

Once a workflow has been started, it is added to the Workflow Summary list 
box. The following details are displayed in the grid, as each step is completed:

• Step Sequence: the step number defined in Govern Admin. The workflow 
must be completed in the order defined by the steps.

• Date Started: the date and time the task was started.
• Batch Process: the Govern batch process, that needs to run to complete 

the step.
• Admin Process: the Govern administrative process, that needs to be 

performed to complete the step:
• Report: the report that needs to be generated to complete the step.
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• Completed On: the date and time the step was completed.
• User: the user ID of the user who started the step.
• Process ID: the Process ID, defined in USR_PROCESS_LOG.
• Errors: the status of the process, displays Yes if there are errors or No if 

there are no errors.

Restarting a Step

You may need to restart a step in the workflow, for example, if an error was 
encountered in the process.

To restart a step:

1. Highlight the step in the grid.

2. Click Restart.An confirmation message is displayed.

3. Click Yes on the confirmation message to continue.

Displaying Errors

Any errors that occur during the workflow are recorded in the Govern Batch 
Processing Error Log. To view the errors, click Error Log on the Process Flow 
Wizard.

Switching from One Workflow to Another

The workflows that have been started are listed in the Workflow Summary in 
the top section of the Process Flow Wizard. You can display a different 
workflow or continue working on steps in a different workflow, by highlighting it 
in this list box.

Note: An administrator can block the Restart on a step. This is done to 
ensure that all required processes are complete before the step is 
restarted, for example, if a calculation needs to be performed before a 
step can be executed. If the Restart has been blocked, a message is 
displayed and you need to restart the workflow, from the step that is 
indicated.
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Creating SQL Queries in Govern Batch 
Processing

Use the Query Generator to view, update or delete data, before running a 
batch process. The Query Generator lists the tables in the database and the 
fields in each table. It has an edit screen, a results grid and a window for 
displaying logged errors. You can execute an SQL query saved to a file or 
build a query selecting the tables and fields, from the list boxes. 

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Query Generator...

Overview
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Creating and Executing an SQL Query

To create an SQL Query on the Query Generator:

1. Compose the query on the Query Editor on the top right of the form.

2. To add a database table, postilion your cursor on the Query Editor and 
double-click on the table in the list box.

3. To add a database field, postilion your cursor on the Query Editor, highlight 
the table and double-click on the field in the list box

4. Click Save SQL to save the query, as an SQL file, to a directory on your 
computer or network.

5. Enter a name for the query and click Save.

6. Enter the maximum number of records to retrieve, in the Max. Rows to 
Retrieve field. 

7. Click Execute SQL.

8. The results of the query are displayed in the Results Grid. 
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The number of records, in the recordset, is displayed in the Rows in 
Recordset field.

The number of records shown in the grid is displayed in the Rows to 
Show in Grid field.

Executing a Query Saved to a File

To execute a query saved to a file:

1. Launch Govern Batch Processing.

2. Select Tools > Query Generator.

3. Click Retrieve SQL.

4. Navigate to the drive and directory and select the file.

5. Click Open.

6. Review the query and make modifications if required.

7. Click Execute SQL.
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For further details on using queries in Govern, see SQL Queries on page 211.
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Setting up E-mail Notification for Batch 
Processes

Use the E-mail Notification process to automatically send e-mail messages 
to an operator when a batch process has been completed. Two types of 
messages can be defined, one for a process that was completed without 
errors the other to notify the operator that errors were encountered during the 
process.

The following information is sent with the e-mail:

• The batch process
• The criteria used in running the process, for example, a range or tax map 

numbers or dates
• The log file, if errors are encountered

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > E-mail Notification...

Overview
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To set up e-mail notification for batch processes:

1. Complete the SMTP Setup on the System Registry Maintenance form, in 
Govern Admin. See SMTP Setup group on page 35, for details.

2. Launch the E-Mail Notification process in Govern Batch Processing. 

3. Enter one or more e-mail addresses for the sender of the e-mail in the 
E-Mail Address text box. If you are entering multiple addresses, separate 
them with a semi-colon (;).

4. Enter a subject to be sent when processes are completed without errors.

5. Compose a message for the successful processes.

6. Enter a subject to be sent when errors are encountered.

7. Compose a message for these e-mails.

8. Select Activate E-mail Notification, when you want to use this feature. 
Deselect the option, if you do not want to use it.
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9. Click Save.

To enable the Audit Trail option for the batch process that you will be running...

1. In Govern Batch Processing select Tools > Audit Trail Setup...

2. In the Audit Trail Setup form, scroll down the list to locate the module with 
the process that you will be running and click under the Audit Trail column 
(A) to select it; a check mark is an indication that the option has been set.

Menus and Submenus

Some headings are colored Pink (Magenta) (B), this is an indication of a main 
menu that contains submenus. To select all submenus under the main menu, 
select the main menu.

WARNING:The E-mail Notification option is directly linked with the Govern 
Batch Processing Audit Trail feature. When configuring E-mail 
Notification, it is important that you also enable the Audit Trail 
option for the process that you will be running.
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3. Click the main menu to automatically select all submenus, or select only 
required individual submenus.

4. Click Save (1).
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Export / Import Names in Mail +4 Format

There are two batch processes for generating tax billing information in Mail +4 
Format:

• Export Names in Mail +4 Format
• Import Names in Mail +4 Format

The Export Names in Mail +4 Format process creates a database with the 
name records for the properties with calculated assessments. Before running 
this process, you need to calculate the billing data and post the information to 
Accounts / Receivable. Once you have the database, run the Melissa Address 
Verification software to update it with the following information for each name 
record:

• SEQUENCE: Mail Distribution Sequence
• CRRT: Carrier Route Code
• DPBC: Delivery Point
• CONTAINER_NUMBER
• PACKAGE_NUMBER

Once the database is updated, run the Import Names in Mail +4 Format to 
update the XX_POST_MASTER table, where XX refers to the module that the 
export is being run for, i.e. AC, BT, MV, PP, TX, or UB. 

Export Names in Mail +4 Format

The Export Names in Mail +4 Format batch process generates a database 
with the computed properties for the names. This is saved to one of the 
following tables, depending on the subsystem selected:

• AC_POST_MASTER, for Aircraft Excise Tax data
• BT_POST_MASTER, for Boat Excise Tax data
• MV_POST_MASTER, for Motor Vehicle Excise Tax data
• PP_POST_MASTER, for Personal Property Tax data
• TX_POST_MASTER, for Real Property Tax data
• UB_POST_MASTER, for Utility Billing data

Overview
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To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR 

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Export Names in Mail +4 Format...

General Parameters for All Subsystems

Sub-system: Select the subsystem from the Subsystem drop-down list.

• Aircraft
• Boat
• Motor Vehicle
• Personal Property
• Real Property
• Utility Billing

Year: By default, this field displays the current fiscal year of your department. 
Modify this field to use a different year.
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A/R Cycle: If you selected Real Property Tax, select the A/R Cycle from the 
drop-down list.

Posting ID: If you selected Utility Billing, select the Posting ID.

Different Sequence for Same Name if Repeated: Select this option to 
generate a new bill sequence number for a name if more than one record 
exists for the name. For example, the same name may be listed for two or 
more subsystems in the POST_MASTER table, once under Real Property Tax 
and again under Motor Vehicle Excise Tax. 

Otherwise, deselect this option to use the same sequence number for all 
records associated with a name.

Bill Criteria Selection for Real Property Tax

To run the Mail +4 Import / Export process, using any of the options in this 
section, you need to complete the following steps in the defined order:

1. Run the Generate Bill Printing Sequence Number batch process. This 
populates the TX_POST_ MASTER table with the required data.

2. Run the Export Mail +4 Process.

3. Run the Import Mail +4 Process.

4. Run the Generate Bill Printing Sequence Number.

Message on Bill: Select this option to copy only the names with an 
associated message; for example, Owner w/ mortgage, TSO Mortgage, 
General or Duplicate Bill. Otherwise, leave this field blank to copy all names, 
regardless of the associated message. Messages are set up on the Bill 
Messages Setup form, in Govern Admin (Table: VT_USR_ MESSBILL). Refer 
to the Super User guide for details.

You can also select one of the following three options:

Note: This field is enabled only if A/R Master by Cycle Code is selected on 
the Accounts Receivable General Parameters form.

Tip: Select criteria for the export database, rather than copying all the names 
from TX_POST_MASTER.
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Export / Import Names in 
Mail +4 Format

Single Bills Only: Select this option to copy only the names that are 
associated with Single Bills. The Single Bill setting is flagged in 
TX_POST_MASTER after an initial posting is made in the fiscal year. This 
indicates that a single property is associated with the name. 

Multiple Bills Only: Select this option to copy only the names that are 
associated with multiple bills. The Multiple Bill field is flagged in 
TX_POST_MASTER after an initial posting is made in the fiscal year. This 
indicates that multiple properties are associated with the name. 

Duplicate Bills Only: Select this option to copy only the names that are 
associated with Duplicate Bills. These are the names selected as the primary 
index, in the Mailing Index, or as the temporary owner(s) if the primary index is 
inactive. This also includes the names for which the Duplicate Bill 
Requested option is selected. 

Database Name and Location for All Subsystems

Drive Name / Folder Name: Select the drive and folder of the export 
database.

UNC Path: You can enter the Universal Naming Convention (UNC) path 
instead of selecting the drive and folder; for example, \\governserver\ 
database. 

Access Database Name: Select the name of the database to which you 
are exporting the names or leave this field blank if you want to create a new 
database.

Start: Click Start to create the export database.

If you have not selected an existing database, the following confirmation 
message is displayed, when you click Start:
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Enter a name for the new export database, or accept the default, and click OK.

Exit: Click Exit to close the form without running the process.

Import Names in Mail +4 Format

The Import Names in Mail +4 Format batch process is run to import a 
database that has been updated with the Mail +4 Format data to the 
NA_NAMES table. 

To access this process, from Govern’s main screen, select Tools > Batch 
Processing (Govbat32.exe) 

OR

Click Applications in the Side Navigation Bar to display Govern applications; 

click  Govern Batch Processing.

In Govern Batch, select Tools > Import Names in Mail +4 Format...

Drive Name / Folder Name: Select the drive and folder where the 
database containing the Mail +4 names is located.

UNC Path: You can enter the Universal Naming Convention (UNC) path 
instead of selecting the drive and folder, such as \\governserver\ 
database\. 
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Access Database Name: Select the database in the list.

Start: Click Start to run the process.

After running the Import process, you need to run the Generate Bill Printing 
Sequence Numbers and Bill Printing processes. 

After this, run the Generate Bill Printing Sequence Numbers batch process 
and select the Use Sequence from Mail +4 Format option. 
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APPENDIX A: STANDARD REPORTS

The following tables list the Standard Reports, provided with Govern:

• Table 1 lists the reports by subsystem
• Table 2 lists the reports alphabetically
• Tables 3 to 6 list the standard reports that are specific to each state

All reports are launched from Govern or Govern Batch Processing and need to 
be linked to a data entry function or batch process, or added to the Report 
Tree View. See Linking Functions and Batch Processes on page 143 and  
Creating a Report Tree View on page 144.

Table 1: Standard Reports by Subsystem

Overview

Note: Before setting up your directory paths to the standard reports, on the 
System Registry Maintenance and User Registry Maintenance forms, 
ensure that you open the directory for your state and copy the reports 
to the Standard Reports directory. See System Registry 
Maintenance on page 16 and  User Registry Maintenance on page 53, 
for details.

Report Name Title pdf Version

Accounts Receivable

ARact1.rpt A/R Activity Report (Effective Date) aract1.pdf

Auxialgl.rpt AR/GL Transaction Auxiliary Ledger auxialgl.pdf

Mass Appraisal

Mainvent.rpt Mass Appraisal Inventory Report mainvent.pdf

Masale.rpt Mass Appraisal Sales Ratio Analysis masale.pdf

masale_cls.rpt Sales: Sales Ratio Analysis, by Class masale_cls.pdf

masale_cls1.rpt Sales Ratio, by Class (Drill Down) masale_cls1.pdf

masale_cls2.rpt Sales Ratio, by Class (Current Values) masale_cls2.pdf
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Miscellaneous Billing

mbRecurring.rpt Miscellaneous Billing: Recurring Entries Edit List mbrecurring.pdf

Motor Vehicle

CompMV.rpt Tax Computation Register (MV) compmv.pdf

Property Control

pcacclbl.rpt Labels (Property Owners with Account) pcacclbl.pdf

Pcownlbl.rpt Owner Labels with Tax Map Number pcownlbl.pdf

Pcownlst.rpt Owner Listing pcownlst.pdf

Permits and Inspections

dash_pm.rpt Land Management Dashboard dash_pm.pdf

PM_restr.rpt Zoning Allowances & Restrictions pm_restr.pdf

Personal Property

CompPP.rpt Personal Property Tax Computation Register comppp.pdf

Ppcompute.rpt Personal Property Computation Register (Summary) ppcompute.pdf

Special Assessment

SAbettlien.rpt Special Assessment Lien Transfer List sabettlien.pdf

System

Audit_trail.rpt Audit Trail Inquiry audit_trail.pdf

process.rpt Processes Log process.pdf

Tax Assessment & Billing

billREstat.rpt Real Estate Bills Printing Statistics billrestat.pdf

CompRE.rpt Real Estate Tax Computation Register compre.pdf

dash_re.rpt Real Estate Tax Dashboard dash_re.pdf

Opencr.rpt Open Credit Report (Refund Report) opencr.pdf

Taxctrld.rpt Tax Receiver Totals: Detailed List taxctrld.pdf

Report Name Title pdf Version
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Table 2: Standard Reports, Listed Alphabetically

Txcompute.rpt Tax Computation Summary txcompute.pdf

txctrdt.rpt Tax Receiver Totals (As of Date) txctrdt.pdf

txctrdt1.rpt Tax Receiver Totals (As of Date: Summary) txctrdt1.pdf

Txsale.rpt Sales Ratio Analysis (Real property) txsale.pdf

Utility Billing

dash_ub.rpt Utility Billing Dashboard dash_ub.pdf

Ublien.rpt Water Lien (Preliminary Detailed) ublien.pdf

Ubliens.rpt Water Lien (Summary) ubliens.pdf

Ublienx.rpt Water Lien (Non Subject to Lien) ublienx.pdf

Ubreadhis.rpt Utility Billing Read History ubreadhis.pdf

Ubreading.rpt Lists all meters and readings attached to an account (Not 
Posted)

ubreading.pdf

UBRegister.rpt Utility Billing Register (Tentative)

Register of the last computation. This report can only be run 
after the Tentative Billing and before the Posting. A running 
parameter lets the user decide whether to print the details or 
only the totals.

ubregister.pdf

Ubregister2.rpt Utility Billing Register (Posted)

Billing Register. This report serves as an audit trail of billed 
records.

ubregister2.pdf

Report Name Title pdf Version

ARact1.rpt A/R Activity Report (Effective Date) aract1.pdf

Auxialgl.rpt AR/GL Transaction Auxiliary Ledger auxialgl.pdf

Report Name Title pdf Version
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Mainvent.rpt Mass Appraisal Inventory Report mainvent.pdf

Masale.rpt Mass Appraisal Sales Ratio Analysis masale.pdf

masale_cls.rpt Sales: Sales Ratio Analysis, by Class masale_cls.pdf

masale_cls1.rpt Sales Ratio, by Class (Drill Down) masale_cls1.pdf

masale_cls2.rpt Sales Ratio, by Class (Current Values) masale_cls2.pdf

mbRecurring.rpt Miscellaneous Billing: Recurring Entries Edit List mbrecurring.pdf

CompMV.rpt Tax Computation Register (MV) compmv.pdf

pcacclbl.rpt Labels (Property Owners with Account) pcacclbl.pdf

Pcownlbl.rpt Owner Labels with Tax Map Number pcownlbl.pdf

Pcownlst.rpt Owner Listing pcownlst.pdf

dash_pm.rpt Land Management Dashboard dash_pm.pdf

PM_restr.rpt Zoning Allowances & Restrictions pm_restr.pdf

CompPP.rpt Personal Property Tax Computation Register comppp.pdf

Ppcompute.rpt Personal Property Computation Register (Summary) ppcompute.pdf

SAbettlien.rpt Special Assessment Lien Transfer List sabettlien.pdf

Audit_trail.rpt Audit Trail Inquiry audit_trail.pdf

process.rpt Processes Log process.pdf

billREstat.rpt Real Estate Bills Printing Statistics billrestat.pdf

CompRE.rpt Real Estate Tax Computation Register compre.pdf

dash_re.rpt Real Estate Tax Dashboard dash_re.pdf

Opencr.rpt Open Credit Report (Refund Report) opencr.pdf

Taxctrld.rpt Tax Receiver Totals: Detailed List taxctrld.pdf

Txcompute.rpt Tax Computation Summary txcompute.pdf

txctrdt.rpt Tax Receiver Totals (As of Date) txctrdt.pdf

txctrdt1.rpt Tax Receiver Totals (As of Date: Summary) txctrdt1.pdf

Report Name Title pdf Version
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Table 3: Standard Reports for Massachusetts

Txsale.rpt Sales Ratio Analysis (Real property) txsale.pdf

dash_ub.rpt Utility Billing Dashboard dash_ub.pdf

Ublien.rpt Water Lien (Preliminary Detailed) ublien.pdf

Ubliens.rpt Water Lien (Summary) ubliens.pdf

Ublienx.rpt Water Lien (Non Subject to Lien) ublienx.pdf

Ubreadhis.rpt Utility Billing Read History ubreadhis.pdf

Ubreading.rpt Lists all meters and readings attached to an account (Not 
Posted)

ubreading.pdf

UBRegister.rpt Utility Billing Register (Tentative)

Register of the last computation. This report can only be run 
after the Tentative Billing and before the Posting. A running 
parameter lets the user decide whether to print the details or 
only the totals.

ubregister.pdf

Ubregister2.rpt Utility Billing Register (Posted)

Billing Register. This report serves as an audit trail of billed 
records.

ubregister2.pdf

Report Name Title pdf Version

MA_LA3.rpt Sales Report (L3)

Property Information including assessed and proposed values 
by sales date

MA_la4.rpt Classification Report (LA4)

MA_TxRollBT.rpt Tax Roll for Boat Excise Tax

MA_TxRollMV.rpt Tax Roll for Motor Vehicle Excise Tax

Report Name Title pdf Version
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Table 4: Standard Reports for New York

MA_TxRollPP.rpt Tax Roll for Personal Property Excise Tax

MA_TxRollRE.rpt Tax Roll for Real Property Excise Tax

revledger.rpt Revenue Ledger revledger

Report Name Title pdf Version

arlm1.rpt Report of Taxable Assessed Values

arlm2.rpt Detailed List of Changes to Locally Assessed Properties

arlm3.rpt Total Assessment Value of Locally Assessed Properties, by 
School District

arlm5.rpt Detailed List of Exempt Properties

arlm6.rpt List of Court-Order Adjustments to Assessments

assfinal.rpt Tax Assessment Roll

assfinals.rpt Tax Assessment Roll (Totals Only)

assnotice.rpt Assessment Increase Notice assnotice.pdf

NY_Opencr.rpt Open Credit Report (Refund Report)

NY_Paydist.rpt Payment Distribution Report

NY_Paydistp.rpt Cash Book (Detailed)

NY_taxctrld.rpt Tax Receiver Collected Totals

sum_arlm1.rpt Summary Alarm Report 

TAXCTRL.RPT Tax Receiver Totals taxctrl.pdf

taxctrlw.rpt Tax Receiver Totals (Weekly) taxctrlw.pdf

Report Name Title pdf Version
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Table 5: Standard Reports for Suffolk County, New York

Table 6: Standard Reports for Rhode Island

Report Name Title pdf Version

taxroll.rpt Final Tax Roll Report taxroll.pdf

txoutbal1.rpt Outstanding Balances (Delinquent Accounts: First Half) taxval1.pdf

txoutbal2.rpt Outstanding Balances (Delinquent Accounts: Second Half) taxval2.pdf

Report Name Title pdf Version

PROppreturn.rpt

PROppsheet.rpt
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Index
A

About
Dataset Source Screens 98

About Dataset Source Screens 98
Access 124
Access to Accounts / Receivable Information 114
Access to the Govern Functions 114
Access Type 125
Active Directory Configuration group 48
Activities

Issues with sending emails 37
Adding a Function to the Accessible Functions List 
115
Adding Business Rules to a Function 126
Adding Columns 91
Administrator 65
Allow Creation of 67
Appraiser database 120
Approved Subdivision 103
Archiving Multimedia Documents 295
Assigning User and Group Access Rights to a 
Function 125
Associating a Fee with a Report 144
Attaching a Message to a Bill 138
Audit Trail 132, 142

Govern Admin 134
Audit Trail and Data Duplication Setup 131
Authentication Type 44
Auto Comments on Memo Fields 133
AutoCAD Viewer 57

B

Barcode Setup for OCR and PostNet Billing 174
Barcodes

Support for USPS Intelligent Mail 2
Batch 274
Batch Processes

Granting and Restricting Access to 294
Bill Fonts and Crystal Reports 40, 174
Bill Fonts group 40
Bill Messages Setup 137
Bill Messages Setup Command Buttons 138
Bill Messages Setup Parameters 137
Bitmap Folder 18, 55, 58

Browse 124
Browsing

Field Mask Records 79
Browsing Bill Messages 139
Browsing Code Records 93
Browsing Department Records 121
Browsing Reports 142
Browsing the Govern Functions 132
Browsing User Records 61
Business Rules 125

C

CCR Configuration 176
CCR Setup 176
CCR Setup group 41
Changing Field Properties 238
Changing the Function Icon 128
Changing the Function Name 127
Code 76, 93, 132
Codes 92
Columns 251
Command Buttons 257

Menu Security Setup 293
Communicating with the Database 120
Computer Name 55
Connections Tab 42
CoolBar Queries 121
Coolbar Queries and Exported Databases 120
CoolBar Queries Setup 118
Create and Modify 109
Creating

a Field Mask 78
a Group 75, 124
a New Bill Message 138
a New Department 121
a New Report 142
a New Validation Table 91
a Query 125
a Report Tree View 144
a User 61
a User Account 124
Codes for the Current Validation Table 91
the Headings 145
User Prompts 147

Creating a New Department 62
Creating a User Group 61
Creating Codes for the Current Validation Table 91
Credit Card 169
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Index

Crystal Report 153
Crystal Reports

Database Connections for 42
Custom Folder 45
Custom Reports Folder 18, 58
Customize Attempts Reached Message 51

D

Daemon Server
Why use the 298

Daemon Server Process 298
Data Duplication 131
Database Connection for SQL Reporting Service 
45
Database Connections for Crystal Reports 42
Dataset

Source Command Buttons 100
Source Parameters 100
Source Setup 98

Dataset Source 10, 70, 98, 100
Access by User and Group 70
Command Buttons 100
Parameters 100
Removing a 70
Removing User or Group Access to 71
Setup 98

Date 279
Default GIS Theme 58
Default Search Form 104
Defining User Access Permissions 142
Delay before query rollback 104
Deleting

a Bill Message 138
a Code 93
a Department 121
a Field Mask 78
a Report 142
a User 61
Validation Tables 91

Deleting a Code 93
Deleting Validation Tables 91
Department 93, 124
Department Code 102
Department Setup 101
Department Setup Command Buttons 121
Department Setup Parameters 102
Departmental Calendar 103

Departments 143
Description 86, 142
Disable Editing on Query by SQL 63
Dividers 269
Do 94
Do Not Show this Code 94
Duplicate Data 132

E

E-Mail Address 62
Enable Outlook Scheduling 63
Encrypt 28
Entering User Registry Maintenance Paths 55
Exit 61, 122, 124
Export 288
Expression Names 198
External Application 178

F

Field Label
Modifying 238

Field Mask 78, 79
Creating 78
Deleting 78
Saving 78

Field Name 147
Field Setup 237
Field Setup Mode Command Buttons 239
Field Setup Mode Parameters 239
Fields 235, 236
Fiscal Year 102
Flags 67
Forms 86
Formula Editor 183
Full Access Rights 76, 110
Full Description 94
Function 124, 132
Function Security 115
Function Setup Command Buttons 124
Functions 143, 184
Functions Setup 123
Functions Setup Parameters 124

G

General Department Information 102
GIS Folder & Scripts 56
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Global and Department Messages 267
Global Field Validation Mask 78
GovBatch

Calling MS Govern Batch for .NET 275
Govern Admin 2
Govern Admin Audit Trail 134
Govern CoolBar 118
Govern Login Settings group 49
Grant Access to all Menu Items 293
Granting and Restricting Access

to the Batch Forms 73
Granting and Restricting Access to Batch Process-
es 294
Group 74
Group Validation Table 75
Groups 70, 124, 143

Selecting 70
Groups of Users 74

I

iAddress Verification 22, 59
ICVerify 168
Image Editor Folder 21, 56
Import from an Appraisers Database 288
Inquiry Only 109
Inspection 296
Inspector Database 120
Issues with sending emails in Activities 37

J

Jurisdiction 68, 75

K

Key Name 119

L

Labels 256
Language 54, 62
Link 110
Linking Functions and Batch Processes 143
Lists & Crystal Reports Setup 140
Lists and Reports Command Buttons 141
Lists and Reports Fields 142
Lite User 63
Lock Parcel Records during DB Export 29
Logical Expression 191

Validate Data Entry 204
Logical Expression Comparison Operators 196
Logical Operators 197
Login setup Tab 48
Long Description 94, 102

M

Manage User Login 51
Menu Security Setup 72
Menu Security Setup Command Buttons 293
Message on Bill 137
Message Types 138
Modifying a Field Label 238
Modifying Functions 127
MS Govern Batch for .NET can be called from Gov-
Batch 275
Multilingual 54
Multimedia 295
Multiple Function selections 116
Multiple Validation Queries 130

N

Name 79, 132
Name & Address Maintenance Security 109
Name & Address Security Grid 107
Name Sharing groups

User access grid 107
Nb records affected before warning 104
Number of Attempts 50
Number of Attempts to Access Govern 49

O

Online (Local) 297
On-Line Help Folder 18, 57
Online Help Folder 57
Option to Use iAddress for Address Verification 22, 
59
Owner as of Month 103

P

Parcel Records Can Be Locked When Exported 29
Parcels 67
Pay Pal Configuration 171
Payment Method 41
Predefine Credentials 44
Primary Department 62
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Index

Privacy / Restrictions for Names 105
Processing Records in Govern 297
Prompt 147
Property Control Validation Tables 97
Providing Access to a Jurisdiction 76

Q

Query Definition Folder 18, 57
Query List 119

R

Remove 124
Remove Access to all Menu Items 294
Removing

a Dataset Source 70
Access Rights from a User or Group 126
User / Group Access to the Dataset 100
User or Group Access to the Dataset Source 71

Removing a Function from the Accessible Func-
tions List 115
Report File Name 142
Report Folder 45
Reports Folder 18, 57
Request password double check 49
Reserved User Validation Tables 87
Restriction Level

No Restrictions 113
Private Names 111
Restricted Names 112
Restricted Names & Addresses 111

Result 119

S

Saving
a Bill Message 138

Saving a Code 93
Saving a Department 121
Saving a Field Mask 78
Saving a New Validation Table 91
Saving a Report 142
Saving a User Record 61
Saving Parameters by Computer Name 54
Scanner 164
Search 110
Selecting Groups 70, 100
Selecting the Headings 146

Selecting Users 70, 100
Server Connection for SQL Reporting group 43
Setting Security Access Rights to a Jurisdiction 76
Setting the Audit Trail and Duplicate Data Parame-
ters 132
Short Description 94, 102
Single Function selection 115
Source

Dataset 70
SQL 212
SQL Administration group 49
SQL Query Example 119
Statements 194
Super User 64
Support for USPS Intelligent Mail Barcodes 2
System 86
System Registry Maintenance

Command Buttons 17
System Registry Maintenance Command Buttons 
17

T

Table Name 75, 86, 93
Table Type 86
Tables 132
Terminal Server PC 55
The Daemon Server 297
Toolbar Queries 121
Tools 230, 290
Transaction 169

U

up to 1000 Characters Maximum 267
Use Active Directory 48
Use Departmental Calendar 103
Use Full Description 87
Use Melissa Data 55
User 65
User Group

Creating a 61
User ID 41, 54

Saving Parameters by 54
User Maintenance 10, 60

Command Buttons 61
Parameters 61

User Registry Maintenance 53
User Tables 87
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Users 70, 74, 100, 124, 142
Selecting 70

V

Valid Masks for all Types of Fields 79
Valid Masks for Tax Map Number Fields Only 80
Validate Data Entry in a Logical Expression 204
Validation Codes 92
Validation Rule 124
Validation Rule Setup for a Function 128
validation table 75
Validation Table Code Command Buttons 93
Validation Table Code Parameters 93
Validation Table Header Command Buttons 90
Validation Table Header Fields 86
Validation Tables 10, 85
Viewing Dataset Source Records 100
Viewing Validation Tables 90

W

warning 104
Why use the Daemon Server 298
Windows Integrated Security 44

Y

Year 75, 93, 229, 280
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