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Disclaimer

MS Govern has taken due care in preparing this manual. However, nothing 
contained herein modifies or alters in any way the standard terms and 
conditions of the purchase, lease, or license agreement by which the product 
was acquired, nor increases in any way the liability of MS Govern to the 
customer. 
© 2013 MS Govern Page i
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Preface
Welcome to Govern for Windows, a comprehensive and fully integrated 
transaction-driven system written exclusively for local governments. Govern 
includes a wide variety of database modules:

Computer-Assisted Mass Appraisal (CAMA)
• Appeals & Grievances
• Appraisals / Property Valuations 
• Comparables Sales Management

Financial Management
• Account Receivable
• Cash Collection 

Land Management
• Business & Individual Licenses
• Complaint Tracking
• Leasing
• Permit Tracking & Inspection Scheduling
• Planing
• Violations

Revenue Management
• Aircraft & Boat Excise Tax
• Miscellaneous Billing
• Personal Property Tax Billing
• Real Property Tax Billing
• Self-Reported Tax Billing
• Special Assessments
• Tax Title / Tax Lien / Tax Sales
• Utility Billing

Since 1980, MS Govern has worked hand-in-hand with State and Local 
Governments to simplify the implementation of software solutions that 
automate the flow of information related to their properties.
Page ii © 2013 MS Govern
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Introduction: Getting Started

The Getting Started guide provides a reference to the setup and installation of 
Govern for Windows™, version 10.8. It lists the system requirements and 
defines the setup, installation, upgrade and third party software configuration 
procedures. It is intended for system administrators and users with Super 
User privileges.

Overview
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General Information

Govern for Windows™ is an integrated client / server system, designed for the 
Windows® environment. It consists of a centralized Property Control 
subsystem for recording and maintaining all parcel and name and address 
data. This can be expanded to include the following subsystems:

• Accounts / Receivable and Cash Collection
• Miscellaneous Billing
• Utility Billing
• Mass Appraisal

• Buildings
• Miscellaneous Structures
• Income
• Sales and Comparable Sales
• Land

• Special Assessment
• Permits & Inspections

• Permits (Building, Electrical, General and Plumbing Permits, Permit to 
Name)

• Animal and Business License, License to Name,
• Approval, Bond, Decision
• Prosecution or Appeal
• Workflows, Complaints, Grievances, Requests for Service
• Offenses
• Public Hearings
• Time Cost Recover

• Tax Assessment & Billing
• Real Estate
• Personal Property
• Motor Vehicle Excise
• Boat Excise
• Aircraft Excise

• Self-Reported Tax

Overview
Page 2 © 2013 MS Govern
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Govern Web and Govern .NET solutions:

• ePermits
• ePayments
• eComplaints

Each subsystem includes administrative forms for defining general 
parameters, codes, SQL queries, etc.; user functions for recording and 
tracking data, performing searches, etc.; as well as, batch processing forms, 
for computing and posting multiple records. The forms and functions are 
installed from three executable files: govadm32.exe, for Govern Admin, 
govern32.exe, for Govern and Govbat.exe, for Govern Batch Processing.

In addition, executable files are used for the Upgrade package, Updata32.exe, 
the Lock Box Tool, lockbox32.exe and the Conversion Tools, cvdata32.exe.

Govern Admin provides the administrative tools to set up the system, define 
the departments, users and groups, set up access permissions to the 
functions, set up the dictionary for each list and report and define parameters 
and codes for the Govern subsystems.

Govern is a centralized system for maintaining and tracking data. It is 
compatible with the following database programs:

• ORACLE
• Microsoft SQL Server
• MySQL
• Microsoft Access

Govern users can perform a search, based on a variety of criteria, and retrieve 
data from any subsystem, to which they have access permissions. For 
example, from an initial property record, the user can open and update the 
Mass Appraisal building information, tax assessment record, utility billing 

Govern Admin (govadm32.exe)

Govern (govern32.exe)
© 2013 MS Govern Page 3
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account and permit application. The user can then add a scanned document, 
view geographical data, on a map, or generate a report. 

Govern Batch Processing, or GovBatch, provides the forms and processes to 
compute and post tax values, compute Mass Appraisal values, post 
payments, post refunds, create Accounts Receivable adjustments, set up and 
perform bill printing, generate an extracted database, import and export a 
database to and from a laptop and much more...

The Upgrade program uploads the database to the server, creates the 
attached and local tables, transfers the database from the server to an Access 
database, upgrades to the latest version and updates the database tables.

The Conversion Tools program creates table interfaces, uploads the data from 
the tables to the Govern database and performs the customized conversions.

The Lock Box Tool program is used to generate a text file containing lock box 
payment information.

Batch Processing (govbat32.exe)

Upgrade (Updata32.exe)

Conversion Tools (cvdata32.exe)

Lock Box Tool (lockbox32.exe)
Page 4 © 2013 MS Govern
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The ArcView Geographic Information System (GIS) software from ESRI is fully 
integrated with Govern. This system can be used to access, display, query, 
analyze and publish your organization’s data, linking maps with traditional data 
analysis tools such as spreadsheets and business graphics. The ArcView 
implementation can be fully customized to meet all your needs.

Arcview® Geographic Information 
System (GIS)

Note: Users that are running Govern with Windows® Vista® will require 
ArcGIS 9.3 for GIS functionality.
© 2013 MS Govern Page 5
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Server and Network Requirements

Note: It is recommended, but not mandatory, to set up three physical 
servers. The first server would be for the Database, the second for the 
Application, and a third would function as, if required, for the Web. If, 
however, you decide to use one physical server for both the 
Application and Web, you will need to revise the minimum 
recommended configuration.

SERVER HARDWARE

Hardware Type Minimum Specifications

DATABASE SERVER

Platform Windows & Unix1

Database Package Oracle2 or Microsoft® SQL Server3 2008 R2

CPU
2 GHz / 1 MB cache, 800 MHz FSB (2.4 GHz Quad-core 1.066 GHz FSB - 
Recommended)

RAM

8 GB DDR24 (16 GB DDR2 - Recommended)
Note that specified memory requirements are for the core Govern Applications 
alone, i.e. without 3rd party application integrations. Third party integrations 
can significantly impact system performance due to their individual require-
ments. A review of requirements of integrated applications should be per-
formed prior to their installation. Also refer to A Note for users of Virtual 
Machines (VM’s) below.

Disk Space
Dependent upon the size of data to be managed; RAID V with a minimum of 
500 GB of hard disk space is a recommended configuration. Note that Disk 
Space is dependent upon Database and Disk Mirroring requirements

Operating System Microsoft® Windows® 2008 or greater

Network 100 Mbit NIC (1 Gbps - Recommended)

Peripherals DVD / CD ROM Drive

WEB SERVER

Platform Microsoft® Windows® 2008 R2 with IIS 7.5
Page 6 © 2013 MS Govern
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A Note for users of Virtual Machines (VM’s)

Users of Virtual Machines (VM’s) should note that when multiple servers are 
being hosted in a Virtual Machine on the same physical servers, the 
requirements for each individual server must be carefully managed as it can 
impact use of system resources. For example, users may decide to host the 
Database Server, Application Server, and an eGovern Web server in a VM 
that is running on the same physical server. In such a situation, as a result of 
the varying requirements of each server, planning is required to address how 
shared system resources are allocated to the individual server, and the VM.

Client and Network Requirements

CPU
3 GHz / 1 MB cache, 800 MHz FSB (2.4 GHz Quad-core 1.066 GHz FSB  - 
Recommended)

RAM 4 GB DDR2 (8 GB - Recommended)

Disk Space
100 MB for each site being maintained. Additional space will be required for 
reports, and temporary space for submitting multimedia documents.

Operating System Microsoft® Windows® Server 2008 or greater

Network 100 Mbit Network Interface Card (NIC) (1 GBit Recommended)

WEB SERVER

Peripherals DVD / CD ROM Drive

Other Redundant power supply and fans

CLIENT HARDWARE

Hardware Type Minimum Specifications

CLIENT WORKSTATIONS

SERVER HARDWARE

Hardware Type Minimum Specifications
© 2013 MS Govern Page 7
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Platform Microsoft® Windows® 

CPU 1.5 GHz (Pentium 3.4 GHz - Recommended)

RAM 2 GB5 (4 GB RAM - Recommended)

Disk Space 40 GB of hard disk space 6

Network 100 Mbit Network Interface Card (NIC) 7 (1 GBit Recommended)

Operating System Microsoft® Windows® XP SP3, Vista, or Windows 7 (32-bit)

Other 17” Display 8  WPF Direct 3D Graphics Card

MOBILE HARDWARE (Laptops / Tablets)

Platform Microsoft® Windows® 

CPU Intel® Core™ i3 Processor 1.33 GHz

RAM
512 MB Internal RAM - 2 GB Recommended
(4 GB recommended for Open Forms Laptop / Tablet)

Operating System
Microsoft® Windows® XP SP3, Windows XP Tablet Edition (32-Bit), Vista (32-

Bit), or Windows® 7 Professional (32-bit) 7

Network 100 Mbit Network Interface Card (NIC) 8

Peripherals Extra Battery, Docking Station in vehicle, plug in keyboard

Other
12.1” (1024 x 768) Display (Recommended 1280 x 1024)

Colors: True Color (32 bit) 9

Disk Space 160 GB of hard disk space

Integrated 
Communications

Optional Integrated Mobile Broadband 

WiFi® 802.11 a/b/g/n

10/100/1000 Ethernet

CLIENT HARDWARE

Hardware Type Minimum Specifications
Page 8 © 2013 MS Govern
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1) The version of UNIX is dependent upon manufacturers recommended version of Oracle.
2) Oracle 11g, and 11g R2 and greater are supported.

3) Microsoft® SQL Server 2005, SQL Server 2008, or SQL Server 2008 R2 are supported.
NOTE: Although these servers are supported, the reference database for the OpenForms Mod-
els is only available as a SQL Server 2008 R2 database.

4) CPU and RAM requirement may vary depending upon the amount of users and the number of 
parcels managed by the application.

5) Minimum - 1 GB (recommended - 2 GB).
6) Govern requires a minimum of 40 GB of temporary storage to be used while running the appli-

cation.
7) Internet Explorer must support HTML 3.0 or higher.
8) Govern’s performance is dependent upon network bandwidth because files, reports, icons, 

images, and data are downloaded from servers.
9) The minimum required resolution for Govern Release 4.0 or greater is 1024 x 768 (1280 x 1024 

Recommended) - Minimum Colors: True Color (32 bit).

THIN CLIENT PC / SERVER

Operating System Microsoft® Windows® 2008 Terminal Server OR Citrix Metaframe 

CLIENT HARDWARE

Hardware Type Minimum Specifications
© 2013 MS Govern Page 9
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CHAPTER 1:  Installing Govern for 
Windows

This chapter describes how to install Govern for Windows™, Release 10.8 
(Govern), on a network, where no previous version of Govern exists. It 
consists of four parts: an overview, followed by procedures for installing the 
software on the network, the client PCs connected to the network and on 
laptop computers that can be used either online or off-line.

Procedures for upgrading to release 10.8 from a previous version are 
described in Chapter 2: Upgrading to Govern for Windows, Release 10.8 on 
page 65. Following this chapter, procedures for installing Crystal Reports and 
Melissa Address Verification third-party software are provided.

Part I: Overview

Part I provides general information on the Govern setup and describes the 
suggested configuration. See Part I: Overview on page 12.

Part II: Installing Govern on the Servers

Part II describes how to install and configure Govern on the servers. It 
includes the following steps:

Step 1: Setting up the servers.

Step 2: Installing the Govern 10.8 dll files.

Step 3: Editing the win.ini file.

Step 4: Uploading the Govern system tables to the database.

Step 5: Defining the Registry Information.

Step 6: Installing the third-party software.

Step 7: Performing the initial setup.

See Part II: Installing Govern on the Servers on page 15.

Overview
Page 10 © 2013 MS Govern 



FI
N

AL
 D

R
AF

T

Part III: Installing Govern on the Client PCs

Part III describes how to install and configure Govern on the Client PCs. It 
includes the following steps:

Step 1: Setting up the Client PCs.

Step 2: Installing the Govern 10.8 dll files.

Step 3: Editing the win.ini file.

Step 4: Creating the Microsoft Access Attach Table.

Step 5: Setting up the database connection.

Step 6: Establishing the ODBC connection.

Step 7: Define the Registry Information.

Step 8: Installing the third-party software.

Step 9: Editing the User Registry.

See Part III: Installing Govern on a Client PC on page 36.

Part IV: Installing Govern on a Laptop

Part IV describes how to install and configure Govern on a laptop computer, 
for an inspector or appraiser, working in the field, disconnected from the 
network. It includes the following steps:

Step 1: Setting up the computer or laptop.

Step 2: Installing the Govern 10.8 dll files.

Step 3: Modifying the win.ini file.

Step 4: Setting up the database connection.

Step 5: Establishing the ODBC connection.

Step 6: Defining the Registry Information.

Step 7: Installing the third-party software.

Step 8: Editing the User Registry.

Step 9: Running the batch program.

See Part IV: Installing Govern on a Stand-Alone Computer or Laptop on 
page 58.
© 2013 MS Govern Page 11
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Part I: Overview

This Overview describes the suggested network configuration for Govern for 
Windows™, release 10.8. This configuration includes two servers, one 
designated as the Database Server and the second designated as the 
Application Server. The Govern reference database is stored on the Database 
Server. The Govern applications and third-party software are installed and 
configured on the Application Server. See Server and Network 
Requirements on page 6 for details on the hardware and software 
requirements for these servers.

A third server can be designated as the Web Server for installations running 
Govern Web and the Govern eComponents, i.e., ePayments, ePermits and 
eComplaints. Refer to Govern’s .NET Toolkits for details on the setting up the 
Web Server.

Govern users run the applications on the Application Server, from Client PCs 
and connect to the Database Server, in order to view and update the data.

There are two types of client / server database connections that are used in 
Govern:

• Direct ODBC Connection - Used for complex queries.
• Microsoft Access Attach Tables Setting - Used for simple queries

Direct ODBC Connection

With this configuration, the application sends a request directly to the 
database server in order to obtain required information. The data definitions 
and the application data are stored on the Database server.

Microsoft Access Attach Tables Setting

With this type of configuration, a Microsoft Access Attach Table is set up on 
each client PC. The Attach Table contains only the data definitions. The 
application data is created and stored on the Database Server. If a change is 
made in the data structure, as a result of an upgrade or if an administrator 
alters the database, an entry is made in a table on the server called SY_ 
ATTACH_TABLE. After this, each time Govern is started on the Client PC, the 

Overview
Page 12 © 2013 MS Govern 
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Microsoft Access database on the Client PC is updated to reflect the new data 
structure on the server.

The .ini File

The database configuration information is stored in an initialization file, 
govern.ini. This information includes the type of database, the database 
or instance name, the Data Source Name (DSN) and the full path to the 
database or to the attach tables.

This file is normally stored on the Application Server. The file path is defined in 
the Windows initialization file, win.ini, on each Client PC, as in the 
following example:

As illustrated in this example, you can change the name of the govern.ini 
file and include more than one in your setup; for example, you may have one 
ini file for the Test database and another for the Production database. If you 
need to reference multiple databases, create an ini file for each one.

To create a new Govern ini file:

1. Copy the govern.ini file.

2. Change the name of this file.

3. Open the new ini file, in Notepad, and make the following modifications:

Note: In this type of configuration, an Attach Table must be set up on each 
client PC. Ensure that the client PCs are not running the Attach table 
from a server.

[GOVERN]
'ini path=C:\Govern\Ini\NFR85.ini
ini path=C:\Govern\Ini\DEMO85.ini
'ini path=C:\Inetpub\wwwroot\GovernWeb\bin\GovernWeb.ini
© 2013 MS Govern Page 13
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4. in the databasename parameter, enter the full path and file name of the 
Microsoft Attach Table,

5. In the DSN and DB parameters, enter the Data Source Name and 
database name.

6. Save your changes.

7. Define the path to each Govern ini file in the win.ini file.

[General]
organization name=DEMO Database 9.0
serial number=150098-18058705920-521969
primary activation key=
secondary activation key=

sql=access
userid prefix=
password=
password suffix=
GLOBAL_USR_ADM=
GLOBAL_PASSWORD_ADM=

[database]
databasename=C:\Govern\Database\demo85.mdb
local name=
DSN=Demo85
DB=DEMO85

[database]
databasename=C:\Govern\Database\demo85.mdb

Note: The Data Source Name (DSN) and Open Database Connectivity 
(ODBC) are the same. 

Note: The paths to the files you are not using can be commented out with an 
apostrophe (‘) or a semi-colon (;), in the wini.ini file.
Page 14 © 2013 MS Govern 
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Part II: Installing Govern on the Servers

This section describes the suggested installation and configuration of Govern 
on the network servers.

The installation and configuration consists of the following steps:

Step 1: Setting up the Database and Application Servers.

Step 2: Installing the Govern 10.8 dll files on the Application Server.

Step 3: Editing the win.ini file.

Step 4: Establishing the ODBC connection.

Step 5: Uploading the Govern system tables to the Database Server.

Step 6: Defining the Registry Information, from the Application Server.

Step 7: Installing the third-party software.

Step 8: Performing the initial Govern setup, from the Application Server.

Step 1: Setting up the Servers

Database Server

To set up the Database Server:

1. Ensure that one of the following database programs is installed and fully 
operational on the server:
• Microsoft® Office Access
• Oracle®
• Microsoft® SQL Server™
• MySQL

Overview

Note: This configuration is suggested, but not mandatory. If, for example, 
you decide to use one physical server, as both the Database and 
Application server, you need to revise the minimum recommended 
requirements and configuration.
© 2013 MS Govern Page 15
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Refer to Server and Network Requirements on page 6 for details on the 
supported versions.

2. Create a new database for the Govern reference database tables and 
fields.

3. Upload the Govern reference database files to this directory, as described 
in Step 6: Establishing an ODBC Connection on page 45.

Application Server

To set up the Application Server:

1. Create a directory called Govern on the Application Server hard drive and 
add the following subdirectories:
• Bin
• Bitmap
• Documentation
• Help
• Install32_90
• StandardReports
• CustomReports
• Scripts

2. Copy the Govern, Govern Admin, Govern Batch Processing and Govern 
Updata exe files, Govadm32.exe, Govern32.exe Govbat32.exe and 
Updata32.exe, as well as the govern.ini file to the MS Govern\Bin 
directory. The exe files are updated periodically and can be downloaded 
from the ftp site.

3. Copy all bitmaps to the Govern \ Bitmap directory. The bitmaps include 
the background images and all the icons for the Govern applications: 
Govern Admin, Govern and Govern Batch Processing.

4. Copy the latest Govern for Windows, release 10.8, documentation to the 
Govern\Documentation directory. This documentation is stored in PDF 
format and updated weekly. It can be downloaded from the ftp site.

5. Copy the latest Help, Tip of the Day and Help image files to the MS 
Govern\Help directory. These files are also updated weekly and can be 
downloaded from the ftp site.

Note: You can replace the background images with images of your choice. 
Refer to the General Information guide for details.
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6. Copy the standard and custom reports, created for your organization to the 
Govern \ Reports directory. 

7. Install the Govern dll files, as described in the next step.

Step 2: Installing the Govern dll files

Complete the following procedure to install the Govern dll files on the 
Application Server:

1. Open the \MS Govern\Install32_90 directory, created in Step 1: Setting 
up the Servers on page 15. 

2. Double-click on the GOV108Setup.exe program.

3. Click Next on the Govern for Windows 10.8 Runtime Setup screen.
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4. Click Install to install Govern to the default location, displayed in the 
Destination Folder text box and proceed to 8. Otherwise, to install Govern 
to an alternate directory, continue with the next step.

5.  To install Govern to an alternate directory, click Browse. 
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6. Navigate to the directory where you want to install Govern and click OK. 
To create a new directory, select Make New Folder and enter the name of 
your new directory. Then, click OK.

7. Verify that the installation path is correct in the Destination Folder text 
box, on the Govern for Windows 10.8 Runtime Setup form and click 
Install.

8. Wait for the Setup program to complete. The progress is displayed on your 
screen.

Note: When installing on the server, it may be necessary to be in the “\bin” 
directory. This is due to the fact that files used by AVAX Control need 
to be in the same location as the executable (.exe) files. 
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9.  Click Finish to complete the installation.

.NET Installer for Govern for Windows Interfaces

The goal of this installer is to consolidate the installation of all previous .NET 
installers under one common Interface.

At the beginning of the installation process, a validation for the version 2.0 and 
4.0 of the .NET Framework is performed. Version 2.0 is required as some 
components are compiled with FrameWork2.0. 

Who should run the Installer?

Users of the following integration interfaces should run the installer.

• Credit Card Helper – Users of IC Verify for Credit Card processing
• Crystal Helper – For users of the Utility Billing eBilling module which 

generates .PDF bills.

Note: If an upgrade is required, you will be presented presented with an error 
requesting that you upgrade to the necessary version of the .NET 
Framework.
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• Email Helper – Used in systems that may have reported issues with email 
integration; this component was a workaround.

• FMS Integration – Users that are using the MS Govern FMS G/L interface
• Great Plains Integration – For users of the Great Plains G/L interface
• iNovah Integration – This is for Govern users with the iNovah payment 

collection and processing interface.
• OneCode Integration – For users of the Intelligent Postal Barcode 

Generator called OneCode.
• Rhode Island DMV Integration – Users of the Integration interface for the 

Rhode Island Department of Motor  Vehicles (DMV)
• Sonrai Systems Integration – Designed for users of the Sonrai Systems 

waste and recycling system management system. 
• SIRE Integration – Any users of the Govern for Windows SIRE Integration 

that allows exchange of multimedia files with the SIRE Document 
Management System.

Running the Installer

To run the installer, obtain the NET108Setup.exe form MS Govern technical 
support:

10. Double-click the NET108Setup.exe file.

11. At the first screen, you will see the list of integration packages that the 
installer will check for and replace; click OK to continue.

Note: This installer must be run on each individual system that will be 
accessing the any of the above listed interfaces.
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Note: Since the installer was previously run, the screen will be different; click 
OK to continue. Running the installer multiple times will in no way 
affect your system.
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12.  At the Welcome screen of the first component to uninstall, click Next.

13. When the component has been removed, i.e. uninstalled, click Finish.

You will repeatedly uninstall any of the interfaces that were discovered by the 
installer. When all components have been completely uninstalled, you will be 
presented with the .NET Component for Govern for Windows Setup screen. 
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14. At the installation Welcome screen, click Install.

During the installation process, all integration interface components will be 
installed.

15. At the completion screen, click Finish.

At the completion of this process, the target system will be updated with the 
latest version of all Govern integration components.

Note:  It will be necessary to have the proper licenses to access these 
interfaces. Contact MS Govern Technical Support for any licensing 
requirements.
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Step 3: Editing the win.ini file

Make the following entry in the win.ini file on the Application Server.

1. Change the directory to \Windows. 

2. Double-click on win.ini file. 

3. At the end of the file, create a section called Govern, and enter the full path 
to the govern.ini file, as in the following example:

Win.ini Editor

Another way to update the win.ini file is to use the Win.ini Editor that is 
included with Govern 10.8. This utility will be located in the \bin subdirectory 
within the Govern install directory.

How to edit the win.ini file with the Govern WinIniEditor utility:

[govern]

ini path=c:\govern\bin\10.8\govern.ini
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1. Navigate to the \bin subdirectory within the Govern install directory and 
locate the WinIniEditor.exe file. Double click to launch the applica-
tion.

2. In the Ini path field, either type the full path to the .ini file that is to be 
inserted, or click “...“ on the right hand side of the field to navigate to the 
file. Click “Next >”

3. At the XML Config Path: enter a path to the XML config file if applicable 
(this information is required for .NET configuration). Click Install.

4. At the Installation Complete window, click Close.

Note: In order to make updates to the Win.ini file under Windows Vista, it is 
necessary to have full Administrator rights. Contact your system 
administrator for further details.
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Step 4: Uploading the Govern Reference 
Database to the Database Server

The Govern System Tables required to run the application are located in the 
reference database file, Govern108.mdb. These tables need to be 
uploaded to the Database Server. 

To upload these tables to the server:

1. On the Application Server, change the directory to \Govern\Bin.

2. Double-click on the Updata32.exe program.

3. In Updata, select Action to Perform > Initial Load of Access Database to 
Server (Upload).

Note: When a new version of a database file is released, a matching 
Updata32.exe utility, designed to work with that database, is also 
released. As a result It is critical when performing updates, that the 
Updata32.exe used is the one that was released with the database. 
For updates, do not use a shortcut to launch Updata32.exe, as the 
shortcut may be pointing to a different location. The Updata32 
program looks for the default initialization file (.ini) in your win.ini file

Note: A validation is performed to ensure that users do not update their 
database with a higher version of Govern.
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4. Select File > Start.

5. Locate the Reference database file, Govern108.mdb, and then select 
Open.

When the Initial upload has finished, the Registry Information Setup screen 
appears.
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Step 5: Defining the Registry Information

This section provides a description of the Registry Information parameters:

Warning on PGM Version Error: Select this option if you want to be 
notified when a more recent release of Govern for Windows™, release 10.8 is 
being used on your network. Otherwise, if this option is left blank, and the 
database and application versions do not match, the Govern Admin, Govern 
and Govern Batch Processing applications will not start. The administrator, 
then, needs to launch the Updata32 application to upgrade the program.

License Information

Organization Name: Enter the license name provided by your Govern rep-
resentative. This creates the link to the database and appears on all 
generated reports.

Serial Number: Enter the Serial Number you received with this release.

Global Password

Password: Enter a password in this optional field, used for automatic logins. 
In this type of login, the same password is assigned to all users connecting to 
the database. For security reasons it is encrypted.
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Re-Enter Password: Re-enter the global password.

General Parameters

User Code: Enter your User Code; this is a mandatory field. This code is 
customized for organizations and will be provided by Govern.

Country/County Code: Enter your County Code in this optional field. This 
is an optional field that is customized for specific organizations, this code will 
be provided by Govern.

State Code: Enter your State Code in this optional field. This is a customized 
field for specific organizations and when required will be provided by Govern.

UserID Prefix: In the optional field, enter a code to add to the beginning of 
the User ID. If the database login is automatic, using a prefix provides 
increased security since the users will never see their real database UserID.

Password Suffix: In this optional field, enter a suffix to append to user 
passwords. This suffix can be encrypted and stored. Since it is appended to 
the password, the user does not need to be aware of it.

Database Date Format: Select one of the three formats for saving dates in 
the database.

SQL Administration

Administrator Password: Use this section to set up the Administrator 
login for Govern. The system uses this password internally to log in.

To set the administrator password:

1. Enter the administrator ID in the User ID field.

2. Enter and confirm the password in the Password and Re-enter 
Password fields.

Note: The User Code, County Code, and State Code are fields that special 
procedure processes may use as filters therefore users should be 
aware of what their requirements are.

Note: If you are using MySQL, the date format must be YYYY/MM/DD.
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3. Select Use this Connection for all Users to make this login the universal 
login for all users. Users still need to log in to Govern using the user ID and 
password assigned to them through the User Maintenance form in Govern 
Admin. Once the login is authenticated, the administrator login is used for 
connection to the database. 

Refer to the Super User guide for details on the User Maintenance form.

Deselect this option to allow all users to log in to Govern, using their own 
user ID and password.

To change the password, the user needs to perform the following procedure:

1. Start the Updata.exe data upgrade application.

2. In the Database Upgrade screen, select File > Update Registry.

Note: If the option is selected, the Change Password screen is not 
accessible in Govern.
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3. In the Registry Information form, ensure that the Administrator Password 
located in the SQL Administration group has been entered (A).

4. Ensure that the Use this Connection for all Users option is NOT 
selected (B).

5. Verify that no passwords have been entered in the Global Password group 
(C).

6. Click Save to save your settings.

7. Close the Updata application; select File > Exit.

8. Start Govern for Windows.

9. In Govern for Windows, select Options > Change Password...

10. The following message appears:

11. Click OK.
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12. Enter your user name.

13. Enter and confirm your new password.

14. Click OK.

Step 6: Installing the Third Party Software

The following third party software is used with Govern:

• Crystal Reports: for creating and running reports. See Installing Crystal 
dll’s on the Network on page 92.

• Melissa Address Verification: for verifying name and address data. See 
Installing the Crystal dll’s Locally on page 92.

• ESRI Arcview Geographical Information System (GIS) Software: Refer 
to the GIS documentation, for Govern for Windows™, version 9.x. Users 
that are running version 10.x will need to install the 10.x runtime.

• Microsoft SQL Reporting Services: Refer to Documentation & 
Standards for SQL Server Reporting Services (SSRS) guide.

Note: Databases will have characters that are allowed for a password or a 
format that these passwords must be in. Refer to your database 
documentation for password formats.

Note: The appearance of the the Change Password option is dependent 
upon conditions that are describwed in the above steps. If the option is 
not available, close down the Govern for Windows application, return 
to the Updata application and review steps 3 to 7 above. 
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Step 7: Creating an Attach Table

Before connecting to a database, you need to create an attach table so that 
you will be able to communicate with the server for the basic setup. The attach 
table stores the data definitions, while data from the application is stored on 
the Database Server.

To create the Attach Tables, complete the following steps.

1. Change the directory to \Govern\Bin. Double-click on the Updata32.exe 
program. 

2. Select Action to Perform, then Create an Access Database of Attach 
Tables.

3. Select File > Start. An information screen appears, listing the source and 
destination databases.

An information screen appears, listing the Destination database.
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4. Verify the database name and click OK to start the process.

Step 8: Performing the Initial Govern Setup

Before running Govern, you need to launch Govern Admin and open the 
System Registry Maintenance parameters and define default settings for the 
following:

• GIS Link Type
• Full Paths to the Multimedia and Multimedia Archive Files
• Full Paths to the Bitmap, Report, Query and Help File Folders

Refer to the Super User guide for details. 

In addition, you need to set up the following:

1. Create the Departments and assign Functions.

2. Create the Users.

3. Define Access Rights for the users.

4. Define User Registry parameters.

5. Create the Validation Tables and Codes.

Note: If a default source name is not displayed, the ODBC connection has 
not been setup correctly.

Note: When you log in to the system for the first time, enter adm in both the 
User ID and Password fields.
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Part III: Installing Govern on a Client PC

The installation on a Client PC, connected to the network, consists of the 
following steps:

Step 1: Setting up the Client PCs.

Step 2: Installing the Govern 10.8 dll files.

Step 3: Editing the win.ini file.

Step 4: Establishing the ODBC connection.

Step 5: Setting up the database connection.

Step 6: Creating the Microsoft Access Attach Table.

Step 7: Defining the Registry Information.

Step 8: Installing the third-party software.

Step 9: Editing the User Registry.

For details on installing Govern on a laptop computer that can be used by an 
appraiser or inspector, either online or off-line, while working in the field, see 
Part IV.

Step 1: Creating an Attach Table

Before running Govern, you need to create an attach table so that the PC can 
communicate with the server. The attach table stores the data definitions, 
while data from the application is stored on the Database Server.

To create the Attach Tables, complete the following steps.

1. Change the directory to \Govern\Bin. Double-click on the Updata32.exe 
program. 

Overview
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2. Select Action to Perform > Create an Access Database of Attach 
Tables.

3. Select File > Start. An information screen appears, listing the source and 
destination databases.

An information screen appears, listing the Destination database.

4. Verify the database name and click OK to start the process.

Step 2: Setting up the Client PCs

To set up the Client PCs:

1. Create a directory called Govern on the hard drive of each Client PC.

Note: If a default source name is not displayed, the ODBC connection has 
not been setup correctly.
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2. Create the following subdirectories for the Govern files:
• Bin: for storing the Updata32.exe files, which is required for creating 

the Attach tables. It is recommended to delete this file after completing 
the installation.

• Database: for storing the Microsoft Access Attach table.

Step 3: Installing the Govern dll files

Complete the following procedure on every client PC running Govern:

1. On the computer hard drive, create a directory called Govern.

2. Copy the Install32_108 directory to this folder.

3. Open the \Govern\Install32_108 directory. 

4. Double-click on the GOV108Setup.exe program and follow the installation 
procedure described in Part II: Installing Govern on the Servers: Step 2: 
Installing the Govern dll files on page 17.

Step 4: Editing the win.ini file

Edit the win.ini file, as follows:

1. Change the directory to \Windows. 

2. Double-click on the win.ini file. 

3. At the end of the file, create a section called Govern, and enter the full path 
to the govern.ini file, as in the following example:

Step 5: Setting up the Database Connection

Complete the following procedure for all database types, Microsoft Access, 
SQL Server, MySQL or Oracle:

1. Change the directory to \Govern\Bin.

2. Double-click on the Updata32.exe program.

[govern]

ini path=GovernServer:\govern\bin\10.8\govern.ini
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If the govern.ini file is not specified in the win.ini file, you need to 
create a new one. A confirmation message appears on the screen:

3. Click Yes, on the confirmation message, to create the govern.ini file. 
It is installed to the same directory as your other executable files, Govern/
Bin by default. 

Once the govern.ini file is created, the Connection Information screen 
appears.

4. From the Type of Database dropdown list, select one of the following and 
proceed with the instructions for the database type you are using:
• Access Server Connection
• SQL Server
• Oracle Server Connection
• MySQL

Access Server Connection 

When you select Access, from the Type of Database field, the following 
screen appears:
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The following table provides a description of the fields required for an Access 
database connection. By default, the definitions for these fields are provided in 
the govern.ini file. Override this information, if required. Then, click OK to 
save your changes.

Field Description

Type of Database This field displays the database type. Valid types include 
Access, Oracle, SQL Server or MySQL. If you are using a 
database type other than Access, select it from the drop-
down list and refer to the applicable section.

DSN This field displays the default Data Source Name (DSN), 
i.e., the device or location where the data are originally 
created and stored. Enter the correct DSN, if this definition 
is not valid.
Note: The DSN and ODBC names are the same.

Database or Instance 
Name

This field displays the name of the database or instance. 
Correct this information, if required.

Database Full Path 
Name

This field displays the full path to the database.
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Microsoft SQL Server and MySQL Users

If you have the Motor Vehicle module, you need to run the script, described in 
Appendix F, after installing the Govern software. See Oracle and SQL 
Scripts on page 140 for details.

SQL Server Connection 

When you select SQL Server in the Type of Database field, the following 
screen appears:

The following table provides a description of the required fields for an SQL 
Server connection. Many of the definitions for these fields are, by default, 
provided in the govern.ini file. Override this information, if required. Then, 
click OK to save your changes.

Field Description

Type of Database This field displays the database type. Valid types include 
Access, Oracle, SQL Server or MySQL. If you are using a 
database type other than SQL Server, select it from the 
drop-down list and refer to the applicable section.
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Oracle Users

If you are using Oracle, you need to perform the following additional 
procedures, before setting up the database connection.

User ID The default User ID (PC UserId) is displayed. If this is not 
valid, enter the correct User ID.

Password You need to enter a password in this field. For increased 
security, the default password is displayed.

DSN This field displays the default Data Source Name (DSN), 
i.e., the device or location where the data are originally 
created and stored. Enter the correct DSN, if this definition 
is not valid.

Database or Instance 
Name

This field displays the name of the database or instance. 
Correct this information, if required.

Attach Table Full 
Path Name

This field displays the full path to the attach table. Correct 
this information, if required.

Grant Access to Role 
Names

Enter the Role names for the groups that will have access 
to the SQL database. If you are entering more than one 
role, separate each name with a comma.

Note: This field is mandatory if you are sharing database 
tables with other users. By default, a database table can 
be accessed only by the person who created it.

In order to provide access to other users, you need to first 
assign them to an SQL or Oracle role. Grant permissions 
to the role; i.e., for creating, modifying, viewing and 
deleting tables. Then enter the name of the role or roles in 
this field. If you are entering more than one role name, 
separate each with a comma.

You can assign users to more than one role. If you grant 
them different access rights in their different roles, they will 
be granted all those rights. However, if you grant a right in 
one role, and deny the same right in another, they will be 
denied that right. A denied access right always overrides a 
granted right.

Field Description
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Additional Procedures

Motor Vehicle or NY RPS Modules

If you have the Motor Vehicle or NY RPS modules, you need to run the scripts, 
listed in Appendix F, after installing the Govern software. See Oracle and SQL 
Scripts on page 140 for details.

Converting to “CLOB”

Description fields in previous versions of Oracle would use a data type of 
Long. For some users this did not offer enough characters for their 
descriptions. A workaround was to use the Character Long OBject (CLOB) 
data type. CLOB data types offer the requirements for longer description 
fields, but databases that use them take longer to backup.

To convert long data types to clob:

1. Launch Updata.

2. Make your connection to the Oracle database.

3. Select Action to Perform > Convert long to Clob.

Note: This procedure requires a long time to run but can be run at any time. 
The Convert Long to Clob menu option will only be displayed when 
accessing an Oracle database.

Note: Oracle users can use varchar2 instead of blob and clob types. To use 
varchar2, select the Do not use clob option on the System Registry 
Maintenance function in Govern Admin. Refer to the Super User guide 
for more information on the System Registry Maintenance form.
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Oracle Connection Information

If you select Oracle, in the Type of Database field, the following screen 
appears:

The following table provides a description of the required fields for an Oracle 
database connection. Many of the definitions for these fields are, by default, 
provided in the govern.ini file. Override this information, if required. Then, 
click OK to save your changes.

Field Description

Type of Database This field displays the database type. Valid types include 
Access, Oracle, SQL Server or MySQL. If you are using a 
database type other than Oracle, select it from the drop-
down list and refer to the applicable section.

User ID The default User ID (PC UserId) is displayed. If this is not 
valid, enter the correct User ID.

Password You need to enter a password in this field. For increased 
security, the default password is displayed.
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Step 6: Establishing an ODBC Connection

The Govern applications communicate with the database using an Open 
DataBase Connectivity (ODBC) connection. You need to have a compatible 
ODBC driver. This is used to establish the connection and to interpret the 
queries sent through Govern. ODBC drivers are provided by Microsoft or 
through your database vendor.

DSN This field displays the default Data Source Name (DSN), 
i.e., the device or location where the data are originally 
created and stored. Verify the information in the DSN field; 
correct if not valid.

Database or Instance 
Name

This field displays the name of the database or instance. 
Correct this information, if required.

Attach Table Full 
Path Name

This field displays the full path to the attach table. Correct 
this information, if required.

Grant Access to Role 
Names

Enter the Role Names for the groups which will have 
access to the Oracle database. If you are entering more 
than one role, separate each name with a comma.

Note: This field is mandatory if you are sharing database 
tables with other users. By default, a database table can 
be accessed only by the person who created it.

In order to provide access to other users, you need to first 
assign them to an SQL or Oracle role. Grant permissions 
to the role; i.e., for creating, modifying, viewing and 
deleting tables. Then enter the name of the role or roles in 
this field. If you are entering more than one role name, 
separate each with a comma.

You can assign users to more than one role. If you grant 
them different access rights in their different roles, they will 
be granted all those rights. However, if you grant a right in 
one role, and deny the same right in another, they will be 
denied that right. A denied access right always overrides a 
granted right.

Data TableSpace 
Name

Enter the name of the device where the data are stored.

Index TableSpace 
Name

Enter the name of the device where the indexes are 
stored.

Field Description
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Complete the following procedure for all database types:

1. Launch Windows Control Panel and select Administrative Tools > Data 
Sources (ODBC).

2. Select the System DSN tab.

3. Click Add.
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4. Select the driver compatible with the database you are connecting to and 
click Finish.

ODBC and 64 bit Operating Systems

Note: Users that are running 64-bit versions of the Windows operating 
system will need to access the 32 bit version of the ODBC 
administrator program (ODBCad32.exe). This file is located in the 
following directory:
%systemdrive%\Windows\SysWoW64
For additional information regarding the ODBC Administrator refer to 
the following Microsoft Support Article at http://support.microsoft.com/
kb/942976.
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Microsoft Access ODBC Connection

1. Enter the DSN name in the Data Source Name field.

2. Enter a description in the Description field, if required.

3. Select Database, under System Database.

4. Select the Drive, Directory and Database Name.

5. Leave the Read Only and Exclusive options blank. Otherwise, Govern 
users will not be able to update the database and it can be opened by only 
one user at a time.

6. Click OK on the Select System Database screen.
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7. Click OK on the ODBC Microsoft Access Setup screen.

For more information, refer to the Microsoft Help files.

SQL Server ODBC Connection

1. Enter the DSN or ODBC name in the Name field.

2. Enter a description in the Description field, if required.

3. Select the SQL Server to which you want to establish a connection in the 
Server field.

4. Click Next.
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5. Click Client Configuration to configure a network library other than the 
default.

6. Select Connect to SQL Server to obtain default settings for the 
additional configuration options to use the SQL Server defaults or 
leave this option blank to use the standard defaults.

7. Click Next.
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8. Select Change the default database to and select the default database 
for the current data source. Otherwise, to make the connection to the 
default database defined for the login ID on the server, leave this field 
blank.

9. Select Attach database filename to attach the database from the file, 
specified in the text box, to the default database, selected in the previous 
file. Then, enter the file name and path.

10. Specify your preferences for stored procedures if you are connecting to an 
older version of SQL Server and this is applicable.

11. Specify your preferences for ANSI quotes, nulls, paddings and warnings, 
using the driver to create temporary stored procedures.

12. Select Use the failover SQL Server if the Primary SQL Server is not 
available to use the failover server, specified in the data source, when the 
driver detects that the primary server is unavailable.

13. Click Next.

Tip: It is recommended to use the default database for the login ID, rather 
than specifying a database on this screen.
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14. Select the language for the SQL Server messages.

15. Select Perform translation for character sets to convert ANSI strings 
sent from the client computer to the server. Otherwise, leave this option 
blank.

16. Leave the Use regional settings when computing, currency, numbers, 
dates and times option blank.

17. Select Save long running queries to the log file to log queries that take 
longer than the specified time. Then, click Browse, select the file and path 
and enter the Long query time in milliseconds in the text box.

18.  Select Log ODBC driver statistics to the log file to log the ODBC driver 
statistics to a specified file. Then, click Browse and select the file and 
path.

19. Click Finish.
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20. Verify the information and select Test Data Source.

21. Click OK.

Oracle ODBC Connection

When configuring an Oracle ODBC connection, please refer to the Notes in 
this section that deal with your specific version of Oracle 10 and associated 
workarounds.

Note: Oracle users should not select the Microsoft ODBC for Oracle drivers. 
This option has presented problems in displaying grids. It is 
recommended that users install the Client package that comes with 
Oracle package.
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When establishing an Oracle ODBC Connection, you need to enter only the 
Data Source Name and the TNS Service Name. In addition, for Govern, you 
need to select the Force Retrieval of Long Columns under the 
Workarounds tab. You can provide the other options, when you run the 
applications.

Note: If you are using Oracle 8i or 9i, you need to select Force Retrieval of 
Long Columns as shown on the following ODBC setup screen. 
Otherwise an error message appears when you use the Activities 
function in the Permits & Inspections subsystem.
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Note: When using Oracle 10g, the Force Retrieval of Long Columns 
option will, be selected, but this option will not be visible for selection.

Note: Users of Oracle 11 should note that the10 g  patch has been 
incorporated within the release..

Note: When using Oracle 10g with the 5731535_10203_winnt patch, the 
Disable RULE Hint option MUST be selected otherwise you may 
experience performance issues with Govern.
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For additional information on installing the Oracle 10g patch, please refer to 
the Oracle 10g update document.

1. Enter the Data Source Name in the Data Source Name field.

2. Enter a description in the Description field, if required.

3. Enter the TNS Service Name. This is the location of the Oracle database. 

4. Enter the user name for the account on the server used to access the data 
in the User ID field.

5. Select the Workarounds tab and select Force Retrieval of Long 
Columns.

6. Click Test Connection. A Connection Login screen appears:

7. Verify the Service Name. Then, enter the User Name and Password for 
the connection.

8. Click OK. A confirmation message appears:

9. Click OK on the Confirmation message.

Note: Users of Oracle 11 should note that the patch in the following section 
has been incorporated within the release.

Note: The option for Force Retrieval of Long Columns is by default 
selected in Oracle 10g, but the option is not visible.
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10. Click OK on the ODBC Oracle Driver Configuration screen.

Step 7: Defining the Registry Information

To define the Registry Information, follow the instructions under Part II: 
Installing Govern on the Servers: Step 5: Defining the Registry Information on 
page 29.

After completing the Registry Information Setup, delete the Updata32.exe 
program from the client PC.

Step 8: Installing the Third Party Software

The following third party software is used with Govern:

• Crystal Reports: for creating and running reports. See Installing Crystal 
Runtime on page 92.

• Melissa Address Verification: for verifying name and address data. See 
Setting up Melissa Data Address Validation on page 96.

• ESRI Arview Geographical Information System (GIS) Software: Refer 
to the GIS documentation, for Govern for Windows™, release 10.8.

Step 9: Editing the User Registry

Before running Govern on a client PC, you need to log in to Govern Admin, 
open the User Registry form and define the following settings:

• GIS Link Type
• Full Paths to the Multimedia and Multimedia Archive Files
• Full Paths to the Bitmap, Report, Query and Help File Folders

Refer to the Super User guide for details. 

Note: Issues have been reported when attempting to execute stored 
procedures (STOREPROC) from Govern over an Oracle ODBC 
connection. See Oracle ODBC Connections and Stored 
Procedures on page 115 for details and a workaround.
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Part IV: Installing Govern on a Stand-
Alone Computer or Laptop

An inspector or appraiser can continue to work in Govern and make updates 
to the database, while working in the field, disconnected from the network. 
Govern provides batch processes for exporting a copy of the database to a 
laptop and then importing the database, with the updates, back to Govern. An 
option is provided to ensure that the inspector or appraiser performs the 
import process, before logging in and making changes to the network 
database.

This section provides the procedure for installing and configuring Govern for 
Windows™, release 10.8, on a laptop that can be used both online, connected 
to the network, or off-line, by an inspector or appraiser working in the field.The 
procedure is similar to that for the Client PC, with the exception that all 
software and supporting files need to be installed on the laptop. It consists of 
the following steps:

Step 1: Setting up the Laptop.

Step 2: Installing the Govern 10.8 dll files.

Step 3: Editing the win.ini file.

Step 4: Creating the Attach table.

Step 5: Setting up the Database Connection.

Step 6: Establishing the ODBC Connection.

Step 7: Defining the Registry Information.

Step 8: Installing the third-party software.

Step 9: Editing the User Registry.

Step 10: Running the batch process.

Overview

Note: If you are running Windows® 2000® or higher on the laptop, you need 
to log in as the administrator of the computer, in order to modify the 
win.ini file and complete the setup.
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To improve offline use, the following new features have been added:

• CoolBar Queries: CoolBar Queries are no longer copied to extracted 
databases, since queries written for SQL databases caused errors when 
run in Microsoft Access.

• Melissa Data Address Verification: You can now enter the path to the 
Melissa Data Address Verification folder on the User Registry 
Maintenance form, to facilitate offline use of this service. See Setting up 
Melissa Data Address Validation on page 96.

Step 1: Setting up the Laptop or Stand-Alone 
Computer

To set up the laptop:

1. Ensure that one of the following database programs is installed and fully 
operational on the server:
• Microsoft® Office Access
• Oracle®
• Microsoft® SQL Server™
• MySQL

See Server and Network Requirements on page 6 for details on the 
supported versions.

2. Create a directory called Govern on the hard drive and add the following 
subdirectories:
• Bin
• Bitmap
• Database
• Documentation
• Help
• Install32_108
• Reports
• Scripts

3. Copy the Govern and Updata exe files, govern32.exe and 
updata32.exe, to the Govern \ Bin directory. The exe files are updated 
periodically and can be downloaded from the ftp site.
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4. Copy all bitmaps to the Govern \ Bitmap directory. The bitmaps include 
the background images and all the icons for Govern Admin, Govern and 
Govern Batch Processing.

5. Copy the Microsoft Access Attach table to the Govern \ Database 
directory. This is used for speeding up access to the Database Server, 
while working online.

6. Copy the latest Govern for Windows, release 10.8, documentation to the 
Govern \ Documentation directory. This documentation is stored in PDF 
format and updated weekly. It can be downloaded from the ftp site.

7. Copy the latest Help, Tip of the Day and Help image files to the Govern \ 
Help directory. These files are also updated weekly and can be 
downloaded from the ftp site.

8. Copy the Govern, GIS and third-party software installation files to the 
Govern \ Install32_108 directory.

9. Copy the standard and custom reports, created for your organization to the 
Govern \ Reports directory. 

Step 2: Installing the dll Files

Complete the following procedure to install the dll files on all stand-alone 
computers and laptops:

1. Open the \Govern\Install32_108 directory, created in Step 1: Setting up 
the Laptop or Stand-Alone Computer on page 59. 

2. Double-click on the GOV108Setup.exe program and follow the installation 
procedure described in Part II: Installing Govern on the Servers: Step 2: 
Installing the Govern dll files on page 17.

Step 3: Editing the win.ini file

Make the following entry in the win.ini file:

1. Change the directory to \ Windows. 

2. Double-click on win.ini file. 

Note: If you are running Windows® 2000® or higher on the laptop, you need 
to log in as the administrator of the computer, in order to modify the 
win.ini file and complete the setup.
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3. At the end of the file, create a section called Govern, and enter the full path 
to the govern.ini file, as in the following example:

Step 4: Creating an Attach Table

You need to create an Attach Table so that the PC can communicate with the 
server, when working online. The attach table stores the data definitions, while 
data from the application is stored on the Database Server.

For details on creating the Attach Tables, see Part III: Installing Govern on a 
Client PC, Step 1: Creating an Attach Table on page 36.

Step 5: Setting up the Database Connection

You need to set up the database connection, as described under Part III: 
Installing Govern on a Client PC, Step 5: Setting up the Database 
Connection on page 38.

[govern]

ini path=c:\govern\bin\10.8\govern.ini
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Step 6: Establishing the ODBC Connection

You need to establish the ODBC connection, as described for the Client PC. 
See Part III: Installing Govern on a Client PC, Step 6: Establishing an ODBC 
Connection on page 45.
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Step 7: Defining the Registry Information

You need to define the Registry Information, as described for the Application 
Server. See Part II: Installing Govern on the Servers, Step 5: Defining the 
Registry Information on page 29.

Step 8: Installing the Third Party Software

The following third party software is used with Govern:

• Crystal Reports: for creating and running reports. See Installing Crystal 
Runtime on page 92.

• Melissa Address Verification: for verifying name and address data. See 
Setting up Melissa Data Address Validation on page 96.

• ESRI Arview Geographical Information System (GIS) Software: Refer 
to the GIS documentation, for Govern for Windows™, release 10.8.

Step 9: Editing the User Registry

Before running Govern, you need to log in to Govern Admin, open the User 
Registry form and define the following settings:

• GIS Link Type
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• Full Paths to the Multimedia and Multimedia Archive Files
• Full Paths to the Bitmap, Report, Query and Help File Folders

Refer to the Super User guide for details. 

Step 10: Running the Batch Process

When the inspector or appraiser needs to take the laptop or computer out in 
the field, you can run the Export a Database Batch Process to extract a copy 
of the database that can be downloaded to the laptop.

• If the database is to be used by an inspector, refer to the Batch Processing 
section in the Permits & Inspections guide.

• If the database is to be used by an appraiser, refer to the Batch Processing 
section in the Mass Appraisal General Information guide.
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CHAPTER 2:  Upgrading to Govern for 
Windows, Release 10.8

This chapter describes the procedures for upgrading Govern for Windows™ 
(Govern) from a previous version to release 10.8.

Upgrade Notes for Oracle Clients

All Oracle users upgrading to 10.8 will need to verify that all uppercase items 
are removed from the following tables:

• USR_VT_CONTROL
• USR_VT_HEADER
• SY_VT_CONTROL
• SY_VT_HEADER

During the upgrade process the same items that exist in the above tables will 
be rein lower case; if the upper case items are not removed, they will be 
duplicated. This will result in program errors.

Notes for Utility Billing Users

All users of the Utility Billing (UB) module will need to check if their UB Crystal 
bills are using the Do not print bill option.

Users of Release 10.8 and earlier will note that when the Do not print bill 
option is selected, during a posting, entries are not created in the 
UB_POST_MASTER and the AR_DETAIL tables even if an account has a 
Primary Mailing Index. This behavior differs from the tax system behavior of 
always creating entries in the UB_POST_MASTER and the AR_DETAIL 
tables if a Primary Mailing Index is found. Some users may have a workflow 
that compensates for the behavior of the Do not print bill option.

Overview
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Posting Behavior as of release 10.7

In Release 10.7, posting behavior was modified to be the same as that of the 
tax system. When a Primary Mailing Index is found, entries will always be 
created in the UB_POST_MASTER and the AR_DETAIL tables, and a bill is 
printed. Deselect the Do not print bill option when you do not want a bill 
printed. 

Upgrade Process

There are three parts to the upgrade:

1. Perform the special procedures that are listed for your configuration.

2. Upgrade the version of the server.

3. Perform an upgrade on each computer that is running the Govern 
software. The required upgrade steps are as follows:

Part I: Special Procedures

Perform any special procedures required for your particular configuration, as 
directed by your Govern representative.

Upgrading Utility Billing

Name and Address Record Validation

Country information is managed by the, VT_SY_CTRIES validation table. 
When completing name and address records, users must select the Country 
rather than entering it manually.

For the name and address records that have already been completed, the 
Country parameter is automatically mapped to this new table, based on the 
user entry. However, for the records with misspellings or other mismatches in 
the Country parameter. See Validation for Countries on page 70.

WARNING: If you are upgrading to release 10.8 from a version earlier than 
8.5 and have the Utility Billing subsystem, ensure that all 
Automated Clearing House (ACH) records are processed, 
otherwise pending records will be lost during the upgrade. See 
ACH Processing on page 69.
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User Menu Security in GovBatch after Upgrade to Release 10.8

Part II: Upgrading Govern on the Network

1. Create a backup.

2. Uninstall your previous version of Govern.

3. Create directories for Govern 10.8 and copy the upgrade files from the ftp 
site or CD to the server hard drive.

4. Install the Govern 10.8 dll files.

5. Upgrade the database.

Part III: Upgrading Govern on each PC

1. Remove the previous version of Govern.

2. If you are installing Crystal Reports 10, 11, or 2008, remove the previous 
installation of Crystal Reports.

3. Create a directory for the Govern 10.8 attach table.

4. Install the Govern dlls.

5. Create the Attach files.

6. Install Crystal Report 10, runtime version. 

Note: Users upgrading to Govern for Windows Release 10.8 will need to 
reconfigure their menu security settings. After the upgrade process, 
users will not have access to any of the Govern Batch Process menus. 
This is a result of a new method of managing menus; Administrators 
will need to reestablish menu access for their users.

Note: It is recommended to install Crystal Reports 10, runtime version on 
every computer running Govern for Windows 10.8. This is used to 
execute reports. You can use Crystal Report Professional version 9.0 
or 8.5 for creating and editing reports. However, these versions are no 
longer supported by Govern Software Inc.

Note: Crystal Reports 10 is not backward compatible with previous versions. 
If you open a Crystal Report created in a previous version; such as 9.0 
or 8.5, in Crystal Reports 10, you are prompted to convert the report. 
After it is converted, you can no longer open it in a previous version.
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Note: As of the time of release of this manual, Crystal reports XI was 
available.
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Part I: Special Procedures

ACH Processing

The Automatic Clearing House (ACH) processing was redefined in Govern for 
Windows™, version 8.2. You can use ACH for all Tax Assessment and Billing 
subsystems, as well as the Utility Billing subsystem. This includes Real 
Property Taxation, Personal Property Taxation, Aircraft Excise Tax, Boat 
Excise Tax and Motor Vehicle Excise Tax. In previous versions of Govern, 
ACH processing could only be used with the Utility Billing subsystem.

A function is available in Govern for setting up the client’s ACH account 
information. Processes are available in Govern Batch Processing to generate 
ACH prenotification files, prepare ACH data, generate the ACH payment file, 
and in release 10.8 and greater ACH for Payment Plans. Refer to the ACH 
Processing section of the Govern for Windows, release 10.8, Accounts 
Receivable guide for details.

Overview

Note: If you are upgrading to version 10.8, from version 8.1 or a version 
previous to this, you need to ensure that all pending ACH records are 
processed. Pending ACH records are not converted to version 10.8. 
The following confirmation message appears before you run the 
upgrade.
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Validation for Countries

With the Validation for Countries form, you can remap the name and address 
records with misspellings or other mismatches in the Country parameter to a 
country in the VT_SY_CTRIES table.

To access the Validation for Countries form:

1. Launch Updata.

2. Enter your connection information.

3. Select Action to Perform > Validation for Countries.

All entries that cannot be mapped to VT_SY_CTRIES are listed on the left. 
The entries in VT_SY_CTRIES are listed on the right.

4. To map an entry on the left to an entry in the validation table, select the 
correct entry, from the right column and drag it under the entry on the left:

5. Continue until you have mapped all entries. 

6. Click Process to perform the remapping; Click Clear to clear all your 
remappings.

7. Click Exit to close the form.

Tip: If you are unsure of a value, you can remap it to the entry, None.
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Part II: Upgrading Govern on the Network

To complete the network upgrade, perform the following five steps:

1. Create a backup.

2. Uninstall your previous version of Govern.

3. Create directories for Govern 10.8 and copy the upgrade files from the ftp 
site or CD to the server hard drive.

4. Install the Govern 10.8 dll files.

5. Upgrade the database.

Step 1: Creating a Backup

Before upgrading to Govern for Windows 10.8, it is recommended that you 
back up the following:

1. All Govern data.

2. Customized icons. If you have defined your own icons for the Govern 
functions, these need to be backed up, before you perform the upgrade.

3. Customized backgrounds. In Govern for Windows, versions 8.5 and 
higher, you can replace the standard background images, for Govern 
Admin, Govern and Govern Batch Processing, with images of your choice. 
If you are using customized images, these need to backed up, before you 
perform the upgrade. Refer to the General Information guide for details on 
creating and saving background images.

4. Modified reports. If you have modified any of the standard reports, you 
need to create a backup. Otherwise, your modifications will be overwritten.

Overview

Note: The function icons and background images are saved to the Govern 
bitmap folder.

Note: Customized reports are not overwritten during the upgrade.
© 2013 MS Govern Page 71



Getting Started

FI
N

AL
 D

R
AF

T

Step 2: Uninstall the previous version of Govern

Before installing Govern for Windows 10.8, you need to uninstall the previous 
version.

To uninstall the previous version:

1. In Windows Control Panel, select Add / Remove Programs.

2. Select Govern (version #) Runtime.

3. Click Change / Remove and follow the instructions on the screen.

Step 3: Creating directories for Govern for 
Windows, release 10.8

Before installing Govern for Windows, release 10.8, perform the following:

1. On the network server, create a directory, called Govern.

2. Copy the Govern 10.8 directories and files, from your ftp site or the CD 
supplied by your representative, to this directory.

The directories include:
• Bin
• Bitmap
• Database
• GIS queries, for GIS applications
• GIS integration, for GIS applications
• Help
• Install 32_108 - Used during installation only, this directory can be 

removed once the Installation is complete.
• StandardReport
• SampleReports

Note: The Bin directory contains the Govern 10.8 executable (.exe) files.
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Step 4: Installing the dll files

To install the Govern 10.8 dll files:

1. Open the \Govern\Install32_108 directory, created in Step 3: Creating 
directories for Govern for Windows, release 10.8. 

2. Double-click on the GOV108Setup.exe program. The Govern  for 
Windows Release 10.8 Runtime Setup screen appears.

3. Click Next on the Govern for Windows 10.8 Runtime Setup screen.
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4. Click Install to install Govern to the default location, displayed in the 
Destination Folder text box and proceed to 8.

5. To install Govern to an alternate directory, click Browse. 
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6. Navigate to the directory where you want to install Govern and click OK. 
To create a new directory, select Make New Folder and enter the name of 
your new directory. Then, click OK.

7. Verify that the installation path is correct in the Destination Folder text 
box, on the Govern for Windows 10.8 Runtime Setup form and click 
Install.

8. Wait for the Setup program to complete. The progress is displayed on your 
screen.

Note: When installing on the server, it may be necessary to be in the “\bin” 
directory. This is due to the fact that files used by AVAX Control need 
to be in the same location as the executable (.exe) files. 

Note:  If you plan to install the ArcView® Geographic Information System 
(GIS) software from ESRI version 3.1 or earlier, the Govern program 
directory name must be eight characters or less and cannot contain 
any spaces or periods.
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9. When the completion screen appears, click Finish. The basic installation 
is complete.

Step 5: Upgrading the Govern Database

To upgrade the Govern database:

1. Change the directory to \Govern\Bin.

2. Double-click on the Updata32.exe program.

Note: Do not use a shortcut. The Updata32 program looks for the default 
initialization file (.ini) in your win.ini file.

Note: You must be the database owner to proceed with this upgrade.
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3. From the Action to Perform menu, select Database Upgrade.

4. From the File menu, select Start.

5. Locate the Reference database file, Govern85.mdb or Govern90.mdb, 
and select Open.

Note: A validation is included that prevents users from updating their 
databases using a higher version of Govern.
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The Table Options screen appears.

6. Verify that the version numbers displayed at the top of this screen are 
different and click OK to start the upgrade. If the version numbers are 
identical, an upgrade is not required.

Note: For some installations, special instructions may be included with the 
Updata32.exe program. Be aware that extra steps may be required.
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7. A prompt appears asking you to confirm the Source and Destination 
databases.

8. Click OK if the information is correct.

Registry Information Setup

Once you have upgraded the database, you need to update the registry 
information.

1. Change directory to \Govern\Bin. 

2. Double-click on the Updata32.exe program. 

3. Select File > Update Govern’s Registry.

The Registry Information screen appears.
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Warning on PGM Version Error: Select this option if you want to be 
notified when a more recent version of the program is available. If this option is 
not selected, and the database and application versions do not match, the 
Govern User, GovAdmin and GovBatch applications will not start. In this case, 
the Administrator needs to launch the Updata32 application to upgrade the 
program.

License Information

Organization Name: Enter the license name provided by Govern to your 
organization. This provides the link to the database and appears on all 
generated reports.

Serial Number: Enter the Serial Number you received with this release.

Global Password

Password: This is an optional field, used for automatic logins. The same 
password is assigned to all users in the SQL database. For security reasons it 
is encrypted.
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Re-Enter Password: Re-enter the global password.

General Parameters

User Code: This is a mandatory field for customized City/Town/Village 
programs.

County Code: This is an optional field for customized County programs.

State Code: This is an optional field for customized State programs.

UserID Prefix: In this optional field, enter a code that will attach to the 
beginning of the User ID. If the database login is automatic, using a prefix 
provides increased security since the users will never see their database 
UserID.

Password Suffix: You can define a password suffix for user passwords. 
This suffix can be encrypted and stored. Since it is appended to the password, 
the user does not need to be aware of it.

Database Date Format: Select one of the three formats for saving dates in 
the database.

SQL Administration

Administrator Password: Use this section to set up the Database 
Administrator login for Govern. The system uses this password internally to 
log in.

To set the database administrator password:

1. Enter the administrator ID in the UserID field.

2. Enter and confirm the password in the Password and Re-enter 
Password fields.

3. Select Use this connection for all users to use this login as a universal 
login for all users. Users still need to login to Govern using the user ID and 
password assigned through the User Maintenance form in Govern Admin.

Once the login is authenticated, the database administrator login is used to 
open Govern. 
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Deselect this option to enable all users to log in to Govern, using their own 
user ID and password.

To change the password, the user needs to perform the following procedure:

1. Log in to Govern.

2. Select Options > Change Password. 

3. Click OK on the confirmation message. The user is automatically logged 
off Govern.

Note: If the option is selected, the Change Password screen will not be 
accessible through Govern.
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4. Enter your user name.

5. Enter and confirm your new password.

6. Click OK.
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Part III: Upgrading Govern on each PC

Perform the following steps on each computer running Govern for Windows.

1. Uninstall the previous version of Govern.

2. If you are installing Crystal Reports 10 or 11, remove the previous version 
of Crystal Reports. This step is strongly recommended.

3. Create a directory for Govern 10.8 attach table.

4. Install the Govern dlls.

5. Create the attach files.

6. Install Crystal Report 10, runtime version. 

Step 1: Uninstalling the Previous Version of 
Govern

Before installing Govern for Windows 10.8, you need to uninstall the previous 
version.

To uninstall the previous version:

1. In Windows Control Panel, select Add > Remove Programs.

2. Select Govern (version #) Runtime.

3. Click Change > Remove and follow the instructions on the screen.

Overview

Note: It is recommended that you install Crystal Reports 10, runtime version 
on every computer running Govern for Windows 10.8. This is used for 
executing reports. You can use Crystal Reports Professional version 
8.5, or 9.0 for creating and editing reports. However, these versions 
are no longer supported by MS Govern Software Inc.

Note: Crystal Reports 10 is not backward compatible with previous versions. 
If you open a crystal report created in a previous version; you are 
prompted to convert the report to version 10. After it is converted, you 
can no longer open it in a previous version.
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Step 2: Uninstalling the previous version of 
Crystal Reports

If you are installing Crystal Reports version 10, you need to uninstall your 
previous version of Crystal Reports.

To uninstall the previous version:

1. In Windows Control Panel, select Add > Remove Programs.

2. Select Crystal Report (version #) for Govern.

3. Click Change > Remove and follow the instructions on the screen.

4. Open the Govern > Bin directory and verify that all dll files have been 
removed. If not, remove the files. 

Step 3: Creating directories for Govern for 
Windows, release 10.8 

Before creating the Govern for Windows, release 10.8, create a directory 
called Govern\Database.

Step 4: Installing the Govern for Windows, 
release 10.8, dll files

To install the Govern 10.8 dll files:

1. Open the \Govern\Install32_108 directory on the server. 

2. Double-click on the GOV108Setup.exe program. The Govern 10.8 
Runtime Setup screen appears.
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3. Click OK. The main Govern Runtime Setup Installation screen appears.

4. Click the installation icon to install Govern to the default directory, then 
proceed to Step 8.
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5. To install Govern to a location of your choice, click Browse. The Browse 
for Folder screen appears

6. Enter or select a destination drive and click OK. If the directory does not 
exist, a prompt appears asking you if you want to create a directory.

Note: If you plan to install the ArcView® Geographic Information System 
(GIS) software from ESRI version 3.1 or earlier, the Govern program 
directory name must be 8 characters or less and must NOT contain 
any spaces or periods.
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7. Click Yes to return to the main installation screen.

8. Govern begins installing the necessary files. Once completed, the 
following message appears.
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9. Click Finish to complete the installation.

Step 5: Creating the Attach Tables for an 
Upgrade

Before running Govern, you need to create an attach table so that the PC can 
communicate with the server.

To create the Attach Tables, complete the following steps.

1. Change the directory on the server to \Govern\Bin. Double-click on the 
Updata32.exe program. This launches the Connection Information form:

2. Enter the full path to the attach table under Database Path Information in 
the Attach Table Full Path Name field.

3. Click OK.

4. Select Action to Perform, then Create an Access Database of Attach 
Tables.
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5. Select File > Start. An information screen appears, listing the source and 
destination databases.

6. Verify the database name and click OK to start the process.

Step 6: Installing Crystal Reports, Runtime 
version

For Govern for Windows versions 8.2 and higher, it is recommended that you 
run the Crystal Reports 10 runtime. As Govern has experienced problems with 
Crystal Reports 9.0, runtime version, previous runtime versions are not 
supported by Govern Software Inc.

Note: If a default source name is not displayed, the ODBC connection has 
not been setup correctly.

Note: Crystal Report 9 and 10 are not backward compatible. If you open a 
crystal report created in a previous version; such as 8.5 or 9, within 
Crystal Report 10, you are prompted to convert the report. After it is 
converted to version 10, you can no longer open it in a previous 
version.
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Read the following procedure carefully as the installation of Crystal Reports 
has changed for version 9.0.

1. Ensure that you have uninstalled your previous version of Crystal Reports 
as described in Step 2: Uninstall the previous version of Govern on 
page 72.

2. Open the Govern Install 32_108 directory, on the PC or server, according 
to your setup. Then open the Crystal 10.5 directory.

3. Double-click on CR10setup.exe and install the program to the Govern / 
Bin directory, by following the directions on your screen.

To set up a test version:

1. Create a new Bin folder on a test computer.

2. Copy the govern.exe file to this directory.

3. Ensure that the client version is completely uninstalled.

4. Install Crystal 10 to this Bin directory.

5. Ensure that all dlls from the previous version are deleted.

6. Ensure that access to the version 10 dlls is granted. Verify permissions in 
Windows Explorer and in REGEDT32.

Troubleshooting Crystal Reports

Crystal Report 9.0 and higher perform differently with Release 10.8 than with 
earlier versions of Govern.

If you get a DLL error message after installation, this is most likely due to an 
obscure dll or component left on the system. In this case:

1. Ensure that the previous version is uninstalled on the server and on the 
client PC.

2. Perform a search for crqe.dll. If this file is found, unregister it and delete it.

3. Once the installation is complete, make sure that all users have read 
access to crqe.dll by running regedt32. If permission is not properly 
granted to this file, verify permissions on all the other Crystal Report dlls 
within the setup.lst file.

Note: It is recommended that if a previous version is installed, you uninstall it 
and ensure that all components and dlls are removed.
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CHAPTER 3:  Installing Third Party 
Software

This section provides procedures for installing Crystal Runtime, Melissa 
Address verification, USPS Intelligent Mail Barcodes (IMB), and 
communication with the Apex Drawing Software.

Installing Crystal Runtime

Installing Crystal dll’s on the Network

These two steps should be performed only once for a network installation.

1. Run the setup program from the Crystal install directory.

2. Change the default directory within the setup program to the network 
directory where Govern is installed. 

Installing the Crystal dll’s Locally 

Perform the following procedure on all client computers.

Overview

Note: Crystal Runtime version 8.5, 10.0, 11, or 2008 must be installed on all 
computers running Govern. Crystal Runtime 8.5 can be installed on 
the local machine or on the network. Versions 10.0, 11.0, and 2008 
only support local installs.

Note: Govern no longer supports Crystal Runtime 9.0.

Note: It is not necessary to install Crystal dll’s on the network if Crystal 
Version 8.5 is already installed on your computer.

Note: It is very important to use the same directory and not a sub-directory, 
as Crystal does not yet support this type of setup.

Note: If Crystal Version 8.5 is already installed on your computer, this step is 
optional.
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1. Run the setup program from the Crystal install directory.

2. Change the default directory within the setup program to the Local 
Windows System32 directory.

Apex Communication

During the installation of Govern, the .DLL required for communication with 
Apex Software is installed. The next step is to enable the communication 
between Govern and Apex.

To enable the communication link between Govern and Apex...

1. In Govern Admin, select Parameters > Mass Appraisal > General Param-
eters... 

Note:  If you have a local installation on your PC and Govern runs on the 
network, the Crystal dll’s from the network override your local dll’s.

Note: Prior to following the procedures for Apex integration with Govern, it is 
mandatory to have obtained a licensed version of the Apex Drawing 
Software. After obtaining the Apex Software license, follow the 
installation instructions provided by Apex Software.
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2. In the Mass Appraisal (General Parameters) form, select the Page 2 (A) 
tab.

3. In the Drawing group, click to select the Use Apex Medina option (B).

Selecting the Use Apex Medina option will enable the communication between 
Govern and Apex. When the user wants to create a drawing, insteading of 
using the Avax drawing tools that are native to Govern, Apex will be loaded.

Batch Import Process for Apex Drawings

The Load Apex Image process is a one time batch import process that allows 
you to import drawings created with Apex and attach them to the drawing 
function. This feature is useful in situations where you have a building already 
in the Govern system, but the drawings of the floorplans are available in the 
stand alone Apex application. Refer to the Load Apex Images section of the 
Mass Appraisal: General Information guide for details.
Page 94 © 2013 MS Govern 



FI
N

AL
 D

R
AF

T

© 2013 MS Govern Page 95



Getting Started

FI
N

AL
 D

R
AF

T

Setting up Melissa Data Address 
Validation

Introduction to Melissa Data

Melissa Data provides automatic verification and correction of inaccurate, 
incomplete and undeliverable addresses in the United States and Canada. If, 
for example, a user enters the wrong street number for a personal property or 
business, Melissa supplies the correct number. Melissa Data also supplies zip 
codes and postal codes where these fields are required. In addition, U.S. 
addresses are standardized according to USPS® specifications and adds the 
ZIP+4 and carrier route codes.

Complete the following procedures on the server and on each client PC that 
will be running the Melissa Data application.

You can include Melissa Data's new Residential Business Delivery Indicator 
(RBDI) add-on with your existing Melissa Address Verification service. This 
needs to be located in the same directory. Contact Melissa Data for 
instructions on installing this service.

Installing Melissa Data on the Server

The Server installation package contains the database and the Melissa Data 
Object or libraries.

To install Melissa Data on the server:

1. Copy the Melissa folder, containing the MDServerSetup.exe file and 
supporting files to the server or to a drive on the network.

2. Open the Melissa folder and double-click on the MDServerSetup.exe 
file to launch the setup program.

Note: The Melissa Data address verification service will not work on 
addresses with no format that are stored in the NA_NAMES table. 
Only formatted addresses, e.g. Individual or Company will work.
A user license is required in order to use this service. Contact MS 
Govern Technical Support for additional details.
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3. Close all open applications and click Next to start the installation.

4. At the Password Validation screen, enter the password that was sent to 
you by e-mail. If you enter an incorrect password, an error message will 
appear; click OK and re-enter the password. If you do not have a 
password, click Cancel to exit the installer.
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5. When a password has been successfully entered, verify that there is 
sufficient space for the installation. Space required and Space available 
information is displayed at the lower left hand side of the setup wizard. If 
required, click Browse to install the program to a destination different from 
the displayed Destination Folder or proceed to step 7.

Note: All provided passwords are case-sensitive so ensure that the Caps 
lock key is not selected.
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6. The Setup Wizard navigates to the default folder. Select an alternate folder 
or create a new one, if required. Then, click OK.

Note: It is recommended that you install the Melissa Data Server application 
under the shared Govern directory on the server. Take a note of this 
directory, it will be used in Configuring Govern for Melissa Data on 
page 103.

Note: Take note of the install dirrectory, it will be required when configuring 
Govern for Melissa Data.
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7. Click Install on the Choose Install Location window.

The progress window displays the file names as the files are extracted and 
installed.
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8. Click Finish when the Completed Installation window is displayed to close 
the wizard.

Installing Melissa Data on Client PCs

The Client installation package includes the Melissa Data Object or libraries, 
only. Users access the Melissa Data address verification database on the 
server.

To install Melissa Data on each PC running the application:

1. Copy the Melissa folder, containing the MDClientSetup.exe file and 
supporting files to the server or to a drive on the network.

2. Open the Melissa folder and double-click on the MDClientSetup.exe 
file to launch the setup program.
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3. Close all open applications and click Install to start the installation. The 
progress window displays the file names as the files are extracted and 
installed.
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4. Click Finish when the Completed Installation window is displayed to close 
the wizard.

Configuring Govern for Melissa Data

To configure Govern for Melissa Data, you need to specify the path to the 
Melissa Data folder, on the System Registry Maintenance form and select the 
Melissa Data option on the User Registry Maintenance form.

1. Launch Govern Admin.

2. Next select Parameters > Edit the System Registry.

3. In the Melissa/iAddress Data Folder field, enter the path to the directory 
where the application is installed; i.e., the Destination Folder displayed in 
Step 5 of procedure for Installing Melissa Data on the Server on page 96.

4. Click Save on the Server Registry Maintenance form.
© 2013 MS Govern Page 103



Getting Started

FI
N

AL
 D

R
AF

T

5. Select Parameters > Edit the User Registry.

6. In the User Registry Maintenance form, click to select the Computer 
Name option (A).

7. Look for the Address Validation drop down menu and select Melissa (B).

8. In the Melissa/iAddress Data Folder field (C), enter the path to the 
directory where the application is installed, if this is different from the path 
entered on the System Registry Maintenance form.

9. Click Save (D) to save your settings.

10. Close the User Registry Maintenance form, click Exit (E).

In order to configure the USPS Barcode refer to the next section of this guide.

Note: If the Melissa Data address verification is to be used offline, enter the 
path in this field.
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Configuration of the USPS Intelligent 
Mail Barcode (IMB)

Introduction

Running the Generate Intelligent Mail Barcode process will result in the 
population of the following fields in (Table: NA_NAMES.IMB_31, and 
NA_NAMES.IMB_65). The resulting data is printed on a bill/letter, or envelope. 
This results in the county being able to take advantage of the USPS bulk 
postal discount mailing rate.

STEP 1 - Install the Intelligent Barcode Font

Before proceeding, you will need to obtain and install the Intelligent Barcode 
font in all systems that will be using the Intelligent Barcode. This font is used to 
generate the USPS barcodes. Fonts can be obtained from the following link 
https://ribbs.usps.gov/onecodesolution/download.cfm, or refer to the 
USPS homepage at www.usps.com.

The “Intelligent Barcode” font (USPSIMBStandard.ttf) must be installed by an 
administrator on all PCs that will use the “Intelligent Barcode”  in a report/bill or 
other output method/form.

STEP 2 - Install Melissa Data or other Address Verfication

Refer to Setting up Melissa Data Address Validation on page 96 for setup and 
configuration instructions for the Melissa Data service. 

STEP 3 - Address Validation Process

Addresses must be validated using the installed address verification service. 
For this example the Melissa Data service is installed and will be used for 
verification.
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For address validation, in Govern Batch Processing (GovBat)...

1. Select Tools > Name and Address formatting, Melissa...

2. At the prompt, click Yes.

The process validates the ‘NAME and ADDRESSES’ fields in (Table: 
NA_NAMES). 
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3. At the end of the process, a dialog window will request that you open the 
error file, FAdress.txt; click Yes, to view  any errors.

This process generates a log file containing errors. You will need to correct 
these errors prior to proceeding to the next step. Some clients will have to 
correct Company Names  (Table: NA_NAMES) that contain special characters 
(e.g. &, /, #), as part of the name that was rejected by the Melissa process. 
These errors must be corrected manually in the (Table: NA_NAMES).

STEP 4 - Installation of the One Code Integration

The next step is to install One Code Integration; contact MS Govern Technical 
Support to obtain the One Code Integration package. This package will 
contain the OneCodeSetup.exe.

1. Locate the OneCodeIntegration folder; in the folder, double click on 
OneCodeSetup.exe 

Note: OneCodeSetup.exe must be run on each User PC that will be running 
the Intelliigent Mail Barcode process.
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2. At the initial setup screen, click Install. 

3. When the installation process is complete, click Finish.
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STEP 5 - Select Barcode Option in System Registry

In the System Registry Maintenance form in Govern Admin you will need to 
ensure that the option for Generate Barcode When Update Name is 
selected. Selecting this option is critical before running the Generate 
Intelligent Mail Barcode process. If the option is not selected the IMB_31 
column of the NA_NAMES tables may not be generated 

In Govern Admin...

1. Select Parameters > Edit the System Registry...

2. In the System Registry Maintenance form, select the Additional Options 
tab.

3. Locate the Intelligent Barcode group and if not selected, select the 
Generate Barcode When Update Name option.

STEP 6 - Update Codes in NA_NAMES Table and 
Generate the Intelligent Mail Barcode (IMB)

The next step is to update the “IMB_31” & “IMB_65” codes in (Table: 
NA_NAMES).
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1. In GovBat select Tools > Generate Intelligent Mail Barcode.

This process only updates the “IMB_31” & “IMB_65” codes if those tables are 
set to NULL (). If the record in the table column is not populated with a NULL, 
the IMB code will not be generated.

When all configuration steps have been followed, after the Generate 
Intelligent Mail Barcode process has been run, the IMB_31 and IMB_65 
columns in the NA_NAMES tables will be populated. 

Note: Immediatealy after the installation of the One Code Integration, if this 
menu option is not available, it may be necessary to restart the Govern 
Batch application.

Best Practices When Generating IMB’s
To minimize errors, it is recommended that a clean start approach be 
taken, i.e. all codes are populated with NULLs, an update query should 
be run on the two (2) tables in (Table: NA_NAMES.IMB_31 and 
NA_NAMES.IMB_65) to populate the fields with NULLS.

Pseudo Code Example:

UPDATE NA_NAMES
SET IMB_31 = NULL, IMB_65 = NULL

The above pseudo code example serves only as a guideline, and should  
be verified for syntax by an administrator that is conversant in SQL.
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Clients Generating Letters/Reports with IMB Codes in 
Crystal Reports

Some Govern Clients have created customized Crystal Report letters or 
reports that contain the IMB_31 and IMB_65 codes. These letters and reports 
can be generated through Govern as long as the USPSIMBStandard 
typeface/font (USPSIMBStandard.ttf) is installed on the PC that is generating 
the letters and reports. The barcode font/typeface should be installed in STEP 
1 - Install the Intelligent Barcode Font on page 105. 

Note: If a City/Town/County has a VB coded TAX/UB/or other bill, Technical 
Support must be advised so that they can modify the bill for the  
“Intelligent Barcode”
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CHAPTER 4:  Troubleshooting

Re-creating Table Indexes

If you find that Govern is not responding correctly, you can run one of the 
following procedures to delete and replace corrupt table indexes.

Use these procedures to re-create the indexes in one or more selected tables 
or in all tables in the database:

Re-creating All Table Indexes

To re-create the table indexes for all tables within the database:

1. Launch Updata.

2. Verify and update the Connection Information, if required.

3. Click OK on the Connection Information form.

4. Select File > Start.

5. Navigate to and select the Govern database.

6. Click Open.

Overview

Note: It is highly recommended to contact Govern’s Technical Support team, 
before running this procedure.
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7. Select Delete all indexes before creating new ones in order to delete 
the existing indexes and create new ones.

8. Click OK. The following warning message appears:

9. Click Yes to continue.

Note: This procedure destroys all indexes; then replaces them, using the 
Govern reference database. This means that all customized indexes, 
as well as all user-defined indexes are destroyed but not replaced. In 
addition indexes from the following tables are not replaced:

• User-defined validation tables; i.e., VT_USR_<XXX>, where <XXX> 
is the table name
• MA_BUILDINGS_2, MA_BUILDINGS_3, and so on, as applicable
• MA_LAND_2, MA_LAND_3, and so on, as applicable
• MA_INCOME_2, MA_INCOME_3, and so on, as applicable
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Re-creating Indexes in Selected Tables

To re-create the table indexes in one or more selected tables:

1. Launch Updata.

2. Verify and update the Connection Information, if required.

3. Click OK on the Connection Information form.

4. Select File > Start.

5. Navigate to and select the Govern database.

6. Click Open.

7. Select Work only with selected files.

8. Select the applicable, from the list in the left. The following fields appear on 
the Table Options form:
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9. Default options are pre-selected. Change these options, as required.

10. Click OK.

Oracle ODBC Connections and Stored 
Procedures

Issues may arise when launching stored procedures (STOREPROC) from 
Govern through an Oracle ODBC connection. The following behavior has 
been observed. 

The syntax used for executing the stored procedure is as follows:
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Oracle Syntax for Stored Procedure

EXEC OWNER.STOREPROC(Param1)

Although the above syntax is correct, the error persists. The following steps 
are a prescribed workaround for executing stored procedures from Govern 
through an Oracle ODBC connection:

Oracle ODBC Stored Procedures Workaround

1. Follow the procedures for establishing an ODBC Connection; see Oracle 
ODBC Connection on page 53.

2. At the Oracle ODBC Driver Configuration screen, select the SQL Server 
Migration tab.

3. Select the Enable EXEC Syntax option; click OK to save the option and 
exit from the form.

Now when you want to execute a stored procedure instead of using Oracle 
syntax, use the syntax for SQL. An example is presented below.

SQL Syntax for Stored Procedure

EXEC OWNER.STOREPROC ‘Param1’

Note: This workaround for executing stored procedures must be repeated for 
every Oracle ODBC connection configured.
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Windows 7 (64-bit) using 32-bit ODBC

Users of Windows 7 64-bit that have installed a 32-bit ODBC driver will 
observe that 32-bit ODBC drivers do not appear in the ODBC Data Source 
Administrator. 

A 64-bit Windows operating system has two odbcad32.exe files:

• %SystemRoot%\system32\odbcad32.exe is used to create and maintain 
data source names for 64-bit applications.

• %SystemRoot%\SysWOW64\odbcad32.exe is used to create and 
maintain data source names for 32-bit applications, including 32-bit 
applications that run on 64-bit operating systems.

RESOLUTION

Running the second of the above will allow the display of all installed 32-bit 
ODBC drivers.

Display 32-bit ODBC drivers in 64-bit Windows 7 install

In a Windows command prompt or in the run screen, enter...

%SYSTEMROOT%\SysWOW64\odbcad32.exe

where ‘%SYSTEMROOT%’ is the Windows install folder, typically ‘C:\Windows\’. 
When executed, you can now use your Data Source Name (DSN) as you 
would with any other system.

WinHelp Workaround for Windows Vista, and 
Windows Server 2008

With the release of Windows Vista and Windows Server 2008, Microsoft no 
longer includes WinHlp32.exe as a component of the Windows operating 
system. With the absence of WinHelp32.exe, an issue has been observed 

Overview

Overview
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with users attempting to open Winhelp files that accompany the Govern for 
Windows suite of applications.

This document offers a workaround that allows users to open WinHelp files on 
Windows Vista, and Windows Server 2008. 

This document is not intended for the general user, but rather for a person with 
system administration experience and full Administrator access privileges.

RESOLUTION

Download and Install

Obtain the download that is appropriate for your system from the Microsoft 
Support site; each download corresponds to the version of Windows that the 
Help file will be accessed from.

Enter this link into your browser: http://support.microsoft.com/kb/917607

When you arrive at the Microsoft Support Web site, scroll down to the tab 
marked Resolution; if the tab is not expanded, click the tab to expand it.

Note: Issues have been observed with Computers that are running 
Windows Vista, or Windows Server 2008.

Note: This document elaborates on key steps that are relevant to Govern for 
Windows; any additional details may be obtained from the Microsoft 
Support site at http://support.microsoft.com/kb/917607.

Note: All steps must be performed on all systems that are running Windows 
Vista, and Windows Server 2008.

Note: You can verify the version of Windows that you are using with the 
following procedure:

1. Click Start > Run..

2. At the prompt, type msinfo32 into the Open: parameter

3. You will be presented with the System Information window;
    determine your version of windows.
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Scroll down to find the version of Winhelp.exe that you require; click the link to 
follow it to the Download Center. You may have to go through the genuine 
Microsoft Windows validation to determine validity of your copy of Vista, if this 
is the case follow the required instructions. Click Continue to proceed.

After completing the download, install the file Winhelp32.exe file.

After the successful installation of Winhelp32.exe, you may receive one of 
several messages.

Macro Error Message

Message: There was a problem running the macro. (1037) 

This message is displayed because macros that the WinHelp file uses are 
now disabled by default in Windows Help for Windows Vista and Windows 
Server 2008.

Registry Key Edit

The solution for this macro error is to make a modification to your registry that 
will enable the required macros. 

There are two (2) ways that the required registry edit can be made:

Method 1

A text file containing the registry entries is created and saved with a .reg file 
extension. When your registry file has been created and saved, you can then 
enter it into your registry.

Note: Issues may exist during the installation, if so refer to the section 
marked “Known issues that may occur while you are installing the 
WinHlp32.exe update” on the Microsoft Support site at http://
support.microsoft.com/kb/917607#kna.

WARNING! The following Registry Key edits are suggestions that will 
allow a workaround to function. The editing of Registry keys, and which 
values are to be edited will vary between organizations. Your IT 
department, or organizational body that determines IT policies is the best 
judge of how to implement these workarounds and assess the risks 
associated with using them.
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To create the registry file, depending on the version of Windows that you are 
running, copy the following into the Windows Textpad editor.

To create a registry file...

1. Open Windows Textpad, copy and paste the text entry that is appropriate 
for you into the document, select File > Save As...

2. Navigate to a location where your registry file will be saved.

3. Under file name enter Winhelp.reg for 32-bit versions of Windows Vista, 
and Windows Server 2008, Winhelpx64.reg for 64-bit versions of 
Windows Vista and Windows Server 2008.

4. Under Save as type: select All Files.

5. Under Encoding: select the Unicode option.

6. Click Save to save the file; close Textpad.

7. Locate your recently created registry file; double-click on the file. You will 
be presented with the following confirmation screen, click Yes to accept.

Entry for 32-bit (Windows Vista / Windows Server 2008)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinHelp]

"AllowProgrammaticMacros"=dword:00000001

"AllowIntranetAccess"=dword:00000001

Entry for 64-bit (Windows Vista / Windows Server 2008)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Micro-
soft\WinHelp]

"AllowProgrammaticMacros"=dword:00000001

"AllowIntranetAccess"=dword:00000001
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8. A confirmation of the entry will appear; click OK.

This entry should now address the macro error message.

Method 2

The second method to make a registry entry is to apply the entries directly to 
the registry using the Windows Registry Editor, RegEdit (regedit.exe).

To access RegEdit...

1. Click Start > Run...

2. At the prompt, type regedit.exe into the Open: parameter

3. In the Registry Editor, locate the HKEY_LOCAL_MACHINE key.

4. Drill down until you locate the SOFTWARE\Wow6432Node\Microsoft.

5. Right click on the Microsoft sub-key and select New > Key.

Entry for 32-bit (Windows Vista / Windows Server 2008)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinHelp]

"AllowProgrammaticMacros"=dword:00000001

"AllowIntranetAccess"=dword:00000001

Entry for 64-bit (Windows Vista / Windows Server 2008)
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Micro-
soft\WinHelp]

"AllowProgrammaticMacros"=dword:00000001

"AllowIntranetAccess"=dword:00000001
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6. A new subkey is created under the Microsoft key; name this key WinHelp.

7. Right click on the WinHelp key and select New > DWORD Value. 
Alternatively you can right click on an open area on the right hand side and 
also select New > DWORD Value.

8. In the New Value field that 
appears on the right hand side, 
enter the appropriate DWORD 
values; repeat this step to create 
the second DWORD value name.

9. Once the DWORD Value name 
has been created, you will need 
to enter a value.

10. On the right hand side, double-
click on the icon for the DWORD 
Value.
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11. A Edit DWORD Value dialog box appears; enter 1 into the Value data: 
parameter

12. Click OK and repeat from step 10 to set the second DWORD Value.

13. Exit from RegEdit.

Configure Internet Properties

After the registry edit, if you are still not able to access the WinHelp file, you 
may need to update Internet properties. Your internet properties will include 
the Server containing the WinHelp File in your Local Intranet Zone.

To update Internet properties:

1. Click Start; select Settings > Control Panel > Internet Properties; click 
the Security tab.

2. Under Select a zone to view or change the security settings., click Local 
Intranet.

WARNING! This workaround may make a computer or a network more 
vulnerable to attack; it is being provided so that you can implement this 
workaround at your discretion.
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3. Click Sites to open the Local Intranet window; 

4. In the Local Intranet form, under Add this website to the zone: enter the 
Server UNC Address into the parameter. 

5. Click Add to add the location to the list of Websites.

6. Click Close.
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Group Policy Update

If previous steps still have not resolved access problems, the following Group 
Policy Update may offer resolution.

To update the machine Group Policy to apply the new Local Intranet zone to 
all user profiles...

1. From the Windows desktop, click Start > Run.

2. Enter gpedit.msc, to launch the Group Policy Editor.

3. Under User Configuration > Windows Settings > Internet Explorer 
Maintenance > Security

4. Click Security Zone and Content Ratings.

5. Under Security Zone and Content Ratings tab select Import the current 
security zones and privacy settings.

6. You can click Modify Settings to display the Internet Properties and 
confirm that the server location is correctly set as a Local Intranet site.

WARNING! The following Group Policy edits are suggestions that will 
allow this workaround to function. The rules for editing of Group Policies 
will vary between organizations. Your IT department, or organizational 
body that determines IT policies is the best judge of how to implement 
these workarounds and assess the risks associated with using them.
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7. Click OK.

Performing the above steps will resolve issues with opening and accessing 
Winhelp files under Windows Vista or Windows Server 2008. that are included 
with Govern for Windows.

WinHelp Missing Search Field

After a successful installation of Govern’s WinHelp files on a Windows XP, or 
Windows Vista operating system, issues with the search tab may be observed. 
This section contains information that may assist in resolving the following 
issue.

Issue:

After running the wizard to create a search index, the Search tab is displayed 
but no search fields are present.

Note: All above actions must be performed on all systems that are running 
Windows Vista, and Windows Server 2008.
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Resolution:

1. Locate the directory that the Winhelp files are located in, ensure that you 
have read/write access privileges.

2. Locate the file titled Govern.DIB; select and delete this file.

With the the .DIB file deleted, a new version will be generated automatically. 
The is done by restarting the help file and selecting the Search tab. When you 
se the Find Setup Wizard, follow the steps to generate a search database. 
Upon completion, the search fields should reappear.

Issues with sending emails in Activities

There is a known issue within the Activities function. This issue is observed 
with users of a combination of Windows 7 / Windows Server 2008 R2 and 
Microsoft Office 2003 / 2007 / 2013 and Microsoft’s Messaging Application 
Programming Interface (MAPI). MAPI enables you to send an email message 
from within an application. When an activity step attempts to send an email via 
MAPI, the message will not be sent. A resolution will involve using an alternate 
method of sending the email.

MANIFESTATION

When an activity step triggers the sending of an email message, the following 
screen is observed:

Overview
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RESOLUTION - Option 1

This issue can be resolved with a Hotfix that is available by request at the 
following link:

http://support.microsoft.com/kb/980681

RESOLUTION - Option 2

An alternative resolution is to request from MS Govern Technical Support the 
NetEmailerSetup.exe patch. Installation of this patch will resolve the issue.

Note: The Hotfix package is by request only; an email contact will have to be 
provided in order to receive it.
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APPENDIX A: Validation Tables
The following tables are printed for informational purposes only:

• VT_USR_STATE: lists American states and Canadian provinces with their 
abbreviations:

• VT_USR_STRDIR: lists street directions and abbreviations
• VT_USR_STRTYPE: lists street types with their abbreviations

Table Name Code Description

VT_USR_STATE AK Alaska

AL Alabama

AR Arkansas

AZ Arizona

CA California

CO Colorado

CT Connecticut

DC District of Columbia

DE Delaware

FL Florida

GA Georgia

HI Hawaii

IA Iowa

ID Idaho

IL Illinois

IN Indiana

KS Kansas

KY Kentucky
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LA Louisiana

MA Massachusetts

MD Maryland

ME Maine

MI Michigan

MN Minnesota

MO Missouri

MS Mississippi

MT Montana

NC North Carolina

ND North Dakota

NE Nebraska

NH New Hampshire

NJ New Jersey

NM New Mexico

NV Nevada

NY New York

OH Ohio

OK Oklahoma

ON Ontario (Canada)

OR Oregon

PA Pennsylvania

QC Quebec (Canada)

RI Rhode Island

SC South Carolina

Table Name Code Description
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SD South Dakota

TN Tennessee

TX Texas

UT Utah

VA Virginia

VT Vermont

WA Washington

WI Wisconsin

WV West Virginia

WY Wyoming

VT_USR_STRDIR E East

N North

NE North East

NW North West

S South

SE South East

SW South West

W West

VT_USR_STRTYPE Aly Alley

Ave Avenue

Bch Beach

Blf Bluff

Blvd Boulevard

Bnd Bend

Byp By Pass

Table Name Code Description
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Cir Circle

Cor Corner

Cors Corners

Crss Crossway

Cswy Causeway

Ct Court

Ctr Center

Cts Courts

Dr Drive

Est Estates

Expy Expressway

Ext Extension

Fwy Freeway

Hts Heights

Hwy Highway

Jct Junction

Lk Lake

Ln Lane

Lndg Landing

Loop Loop

Oval Oval

Path Path

Pk Park

Pky Parkway

Pl Place

Table Name Code Description
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Plz Plaza

Pt Point

R Rural

Rd Road

Rt Route

Run Run

Spur Spur

Sq Square

St Street

Sta Station

Ter Terrace

Tpke Turnpike

Trl Trail

Walk Walk

Way Way

Xing Crossing

Table Name Code Description
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APPENDIX B: New York State Validation 
Tables

The following validation tables are provided only for New York state clients:

• VT_USR_LEVYTYPE
• VT_USR_ROLLSECT

Table Name Code Description

VT_USR_LEVYTYPE am Ambulance District

co County District

ct City / Town District

fd Fire District

hy Highway District

ld Library District

li Light District

ln Lien (Water/Sewer)

oc Other City/Town

ot Other District

pd Police District

pk Park District

pt Police Inside Town

sc School District

sd Special District

sw Sewer District

tx Add. Tax

wa Water district

VT_USR_ROLLSECT 1 Taxable
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3 Taxable State Land

5 Special Franchise

6 Utility, Non-Ceiling Rail

7 Ceiling Railroads

8 Wholly Exempt

Table Name Code Description
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APPENDIX C:Permit Type

Functions

Step Number Activity Yes No Special Restart Fee Status Init.
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APPENDIX D:User ID

Group Functions Access Rights
© 2013 MS Govern Page 137



Getting Started

FI
N

AL
 D

R
AF

T

APPENDIX E:Function Access

Department Code:

Department Description:

Fiscal year:

Name Sharing Group:

Are Names Private?:

Approved Subdivision?

Use Departmental Calendar:

Owner as of Month: + or – Years:

Default Data Source:

Functions Access Rights
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Functions Access Rights
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APPENDIX F:Oracle and SQL Scripts
if you are using Oracle, the following scripts are mandatory for the:

• Motor Vehicle module
• NY RPS

If you are using SQL, the following script is mandatory for the:

• Motor Vehicle module

Oracle and the Motor Vehicle Subsystem

If you are using Oracle, the following script must be run for the Motor Vehicle 
module. 

SQL and the Motor Vehicle Subsystem

If you are using SQL, the following script must be run for the Motor Vehicle 
module.

CREATE SEQUENCE mv_transit_det_tmp_seq START WITH 1 INCREMENT BY 1;

CREATE OR REPLACE TRIGGER mv_transit_det_tmp_trig

BEFORE INSERT ON mv_transit_det_tmp

FOR EACH ROW

DECLARE

 seq_val number;

BEGIN

 SELECT mv_transit_det_tmp_seq.nextval 

INTO seq_val FROM dual;

 :new.auto_field := seq_val;

END;
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Activate the Identity property to Yes with an Identity seed = 1 and an Identity 
Increment = 1 for the following fields:

Oracle and NY RPS

If you are using Oracle, the following three scripts must be run for the NY 
RPS. 

Oracle and NY RPS, Script 1

mv_transit_det_tmp.auto_field (if they have MV module)

tx_ny_rps_trans_t1.auto_field (for NY RPS)

tx_ny_rps_trans_t2.auto_field (for NY RPS)

tx_ny_rps_transit.rps_transit_id (for NY RPS)

// 
***************************************************************************

CREATE SEQUENCE tx_ny_rps_trans_t1_seq START WITH 1 INCREMENT BY 1;

CREATE OR REPLACE TRIGGER tx_ny_rps_trans_t1_trig

BEFORE INSERT ON tx_ny_rps_trans_t1

FOR EACH ROW

DECLARE

 seq_val number;

BEGIN

 SELECT tx_ny_rps_trans_t1_seq.nextval 

INTO seq_val FROM dual;

 :new.auto_field:= seq_val;

END;

// 
****************************************************************************
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Oracle and NY RPS, Script 2

Oracle and NY RPS, Script 3

CREATE SEQUENCE tx_ny_rps_trans_t2_seq START WITH 1 INCREMENT BY 1;

CREATE OR REPLACE TRIGGER tx_ny_rps_trans_t2_trig

BEFORE INSERT ON tx_ny_rps_trans_t2

FOR EACH ROW

DECLARE

 seq_val number;

BEGIN

 SELECT tx_ny_rps_trans_t2_seq.nextval 

 INTO seq_val FROM dual;

 :new.auto_field:= seq_val;

END;

// 
****************************************************************************

CREATE SEQUENCE tx_ny_rps_transit_seq START WITH 1 INCREMENT BY 1;

CREATE OR REPLACE TRIGGER tx_ny_rps_transit_trig

BEFORE INSERT ON tx_ny_rps_transit

FOR EACH ROW

DECLARE

 seq_val number;

BEGIN

 SELECT tx_ny_rps_transit_seq.nextval 

 INTO seq_val FROM dual;

 :new.rps_transit_id:= seq_val;

END;

// *************************************************************************
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