Database Extraction Tool

Database Extraction Tool

Overview

The purpose of the Database Extraction tool is to create a new database that contains only specific, required information. This database is smaller and therefore easier to manage. Performance is better than the original.

The new database is created from data extracted from an existing Govern database. It contains the same schema as the original database but the data, property records, Profiles, and functions it contains are restricted to one or more modules, one or more years, and a saved dataset. A saved dataset is a predefined set of records that is created in Govern. Note that all the dependencies that are required for those records are also copied.

An extracted database can be useful in troubleshooting, testing, or training. For example, you may want to create a demo on a laptop computer and need only the data from the previous assessment year. You may want to test a new tax rate and need all the tax and CAMA tables but only specific property records. You may need to do some troubleshooting and want to send a portion of the database to a team working in a remote office.

The new extracted database is used in a deployment, as any other standalone Govern database. Once it is created, it is independent of the original database. It needs to be updated and maintained separately. It is designed for temporary use. Whenever you run the Database Extraction on it, the existing data are deleted and replaced with the selected data from the source database.

The new extracted database is:

  • Reduced in size
  • Easily transferred to another computer or to another team
  • Contains only the data essential to a specific purpose
  • Provides better performance due to the small size

The database extraction tool:

  • Reduces the time required for creating a new database
  • Reduces downtime over a full backup and restore
  • The source database operates independently of the extracted database.

 

Read More...

 

Documentation

For a comprehensive pdf of this page, see the following document:
103-UT-110-DatabaseExtraction.pdf

Prerequisites

Access to the:

  • Source database and deployment
  • Destination database.
    This can be any SQL database, such as an empty database, or a database from any Govern version.
    All existing data and tables are removed from the destination databae at the beginning of the process.
  • Destination deployment, if one exists
  • Connection keys for both databases

 

Recommendations

  • Complete a successful database verification on the source database.
    For details on running a database verification, refer to the GNA documentation.
  • Back up your source database before beginning.
  • If you need to retain any data in the destination database, back up the database.
    The process clears all data from the destination database.
  • Ensure that a saved dataset exists in the source deployment and that it contains all the required records.
  • All dependencies are copied along with the records in the saved dataset.
    For example, the A/R records that are associated with the tax records in the dataset are copied. These include the property control records that are associated with the CAMA records.The only records extracted are those in the saved dataset and the dependencies of those records.

References

  • For details on creating on a saved dataset, see Saved Dataset
  • For details on creating a new deployment, see Deploy EZ

Extracting a Database

The Database Extraction Tool:

  • Deletes all data in the destination database.
  • Copies the Govern database schema from the source to the destination database.
  • Copies the parameters and settings, for the selected years, from the source database for the following options if they are selected:
  • Billing: All parameter tables beginning with AR_, MB_, or UB.
  • Land Management: All parameter tables beginning with PM_,
  • Mass Appraisal: All parameter tables beginning with MA_ and TX_
  • Tax: All parameter tables beginning with AC_, AR_, BT_, MV_, NA_, PP_, ST_, and TX_
  • Fiscal years
    Data from all tables for the range of years, selected in the From and To drop-down lists for the selected Saved Dataset.
  • Saved Dataset
    All Profiles and user forms required for the records in the dataset, as well as all dependencies, are copied.

A full list of all the tables that are copied can be viewed in the following file:

MSGDatabaseStructMods.xml

This file is accessed from the SystemFiles folder for your deployment.

To create an extracted database from an existing database:

  1. Log on to the server where the source database resides.
  2. Launch GNA.
  3. Select Utilities > Database Extraction.The Database Extraction tool opens:
  4. Select the connection key to the destination database from the Temporary SQL Database Connection Key drop-down list.
  5. Select the saved dataset from the Include Data from Saved Dataset drop-down list.Note: You can select only one dataset.
  6. Select the modules for the parameters that you want to copy from the source to the destination database.
    Tip: If you hover your mouse over the option for the parameter, a tooltip listing all the tables appears.
  7. Select a range of years for the selected parameters from the From and To Years drop-down list
  8. Click the right arrow to start the process.
    A confirmation message appears.
    This message warns you that the process deletes all data in the destination database.
  9. Click Yes to continue.

 

Using the New Database

Once the database extraction process is complete, the newly extracted database is ready to use. You can make it available to a remote team via ftp, or open it in any deployment, with the correct version number. You are ready to begin testing, troubleshooting, or training. The extracted database is the same as the source database.

Maintaining the Extracted Database

Once the procedure is complete, the extracted database is a standalone database that can be used as any other Govern database. You can run ad database verification, update the database or make modifications as you would to any other database.
There is no synchronization between the source and destination databases, once the process is complete.

 

 

 

103-ut-010

 

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this.
Loading...

User Interface

User Interface

Overview

The Govern New Administration (GNA) user interface was redesigned for Release 6.0 and upwards. The interface uses ribbons for quick access to the required areas of the application. Forms are accessible through tabs on the ribbons. Presentation of forms can be changed from the standard multi-window forms that can be overlapped and staggered, to a tabbed layout.

GNA Tools and Utilities are arranged under the tabs that logically groups them by their function. With the exception of the File tab GNA tools are found under one of the following:

  • Options
  • System Parameters
  • Application Configurations
  • Editors
  • Utilities
  • Windows

Change Interface Language

Language

The Govern New Administration (GNA) interface language can be changed as needed; currently the two languages supported are English and French.
To change the interface language:
Select Options > Language > (Select the language of choice)
Additional languages will be supported in future releases.

NOTE: The default language of Govern is determined by the administrator when the deployment is set up in the Deploy EZ™ Publisher.
Text that appears in the GNA interface can be modified with the Govern Resource Editor. Refer to the Resource File Editor

Modify User Interface Language

Under the Options tab are the interface language choices. Selection options are Mutually Exclusive, i.e. when an option has been selected, that option will no longer be displayed as a selection option.

Tile Horizontally / Vertically

Tiling open windows for You can keep all three tools open on your desktop and arrange them to optimize your available space. Windows can be tiled horizontally or vertically by selecting any of the options under the Windows menu in the Govern System Config & Admin application.

Layout (Standard or Tabbed)

The Layout option will control the presentation of any open windows. As with other option selections, they are mutually exclusive. When an option is selected it will not be available in the menu list. For example, when the Standard option is selected, only the Tabbed option will be available in the menu.

 

 

103-UI-All

 

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this.
Loading...

103-UT-001

Active Directory Integration Tool

Overview

Active Directory (AD) is an implementation of the Lightweight Directory Access Protocol (LDAP) directory services by Microsoft. LDAP provides central authentication and authorization services for Windows based computers. AD is available in Windows Server 2000 / 2003 / 2003 R2 / 2014. The Active Directory Govern Integration Tool will allow you to import users from Active Directory into Govern’s user database. This administrative process is unidirectional in that users are copied from Windows™ Active Directory to Govern’s user table (Table: USR_USERFILE); in addition their group designations within Active Directory will be carried over and used to determine which one of the four Govern access groups they will be assigned to. Once imported into Govern, you can then manage which forms and functions users will have access to through Govern’s Administration program. The import Active Directories process can be run periodically for synchronization purposes, e.g. in instances when there have been changes in roles or personnel within the organization.

Managing Import of Multi-role Active Directory users

In the Govern New Administration (GNA), there is a method of processing imported accounts in place to manage Active Directory users with multiple access roles.
In instances where a user being imported is in multiple roles in Active Directory; this could be a user that is in an Administrator group, as well as a Regular group. After this user is imported into Govern, in the Govern USR_USERFILE table, this user will appear once as an Administrator. This the role that they are a member of with the highest permission level.
The Permission hierarchy in Govern, highest to lowest is as follows:

  • Super User
  • Administrator
  • Regular
  • Read Only

To display the Active Directory and MS Govern Integration Tools:

  1. In GNA click to select the Utilities tab on the ribbon, Click Active Directory Integration Tool.

Parameters & Command Buttons

Command Buttons

Process: Click Process to begin importing Active Directory users into Govern.
View Log File: Click View Log File to display the contents of the log file.
Exit: Click Exit to close this window.

Parameters

Active Directory Path: This is the Active Directory path.
Log File Path: This is the path to the Active Directory Integration Tool log file.
Import Active Directory Users into MS Govern Database: Select this option to import Active Directory users into Govern’s database.

 

 

103-ut-001

 

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this.
Loading...

 

103-UT-004

Country Correction in NA_NAMES (Conversion)

Overview

This process is required for cleaning up the text field used in early versions of Govern for Windows. This field was created for users to specify countries in the NA_NAMES table. Since the field for country names is a text field with no validation, errors may have been made during entries, i.e. no standard format or codes were maintained. When this table is to be used on the Web, validation will occur; users must make a selection from a drop-down menu containing pre-defined countries.

This utility is used to “clean up” old codes that exist by allowing you to associate them with existing countries. The data found in this column are usually Postal codes or Zip codes, or non-standard abbreviations.

Making Corrections

For example, under the Erroneous Country column, we may have an entry of a zip code, we could correct this by associating or “mapping” that entry to the United States.
To correct erroneous country codes…

  1. On the GNA ribbon, select Utilities (tab) > Country Corrections in NA_NAMES table…
  2. The Country Name Correction form appears; under the column marked Erroneous Countries, locate an erroneous code.
  3. Click the line that the code appears under the Corrected Countries column.
  4. Select the country code that it should be mapped to from the drop-down menu.
  5. Click Save to Database to save your correction.
  6. If no mapping is required, or no match can be found for the erroneous country codes, click to select the Replace blank corrected countries with null values option.
  7. Click Save to Database to save your changes.

NOTE: Blank corrected countries are replaced with null characters in the database.

The next time you access this tool only the country codes that have not been matched with a correct country code will be displayed.

 

103-UT-004

 

 

103-ub-parm-General

Utility Billing General Parameters

VERSION 6.0 and VERSION 6.1 – (Under Development)

Overview

(Under Development)

 

103-ub-parm-General

 

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this.
Loading...